<!DOCTYPE html>
<html dir='ltr' lang='en-US' xmlns='http://www.w3.org/1999/xhtml' xmlns:b='http://www.google.com/2005/gml/b' xmlns:data='http://www.google.com/2005/gml/data' xmlns:expr='http://www.google.com/2005/gml/expr'>
<head>
<meta charset='utf-8'/>
<meta content='en-us' http-equiv='content-language'/>
<meta content='IE=edge' http-equiv='X-UA-Compatible'/>
<meta content='width=device-width,initial-scale=1.0' name='viewport'/>
<meta content='#f2132d' name='theme-color'/>
<meta content='#f2132d' name='msapplication-TileColor'/>
<link href='https://3.bp.blogspot.com/-_Rvl0I-6PsE/WxqOMWBSvFI/AAAAAAAAAr0/YVpbw6VxjTE0cs2FIG3JGGrzfelqF1AXQCLcBGAs/s1600/apple-icon-180x180.png' rel='apple-touch-icon' sizes='180x180'/>
<link href='https://4.bp.blogspot.com/-C3SXpMZFwoM/WxqOMWPcqBI/AAAAAAAAAr4/q3BlIVZd9BIycvFtwpwee9ho2axmuey1wCLcBGAs/s1600/android-icon-192x192.png' rel='icon' sizes='192x192' type='image/png'/>
<link href='https://fonts.gstatic.com' rel='dns-prefetch'/>
<link crossorigin='anonymous' href='https://fonts.gstatic.com' rel='preconnect'/>
<link as='fetch' crossorigin='anonymous' href='https://fonts.googleapis.com/css?family=Ubuntu:300,300i,400,500,700' rel='preload'/>
<link href='https://cdn.jsdelivr.net' rel='dns-prefetch'/>
<link crossorigin='anonymous' href='https://cdn.jsdelivr.net' rel='preconnect'/>
<link as='fetch' crossorigin='anonymous' href='https://cdn.jsdelivr.net/npm/fork-awesome@1.1.3/css/fork-awesome.min.css' rel='preload'/>
<link crossorigin='crossorigin' href='https://fonts.googleapis.com' rel='preconnect'/>
<link crossorigin='crossorigin' href='https://ajax.googleapis.com' rel='preconnect'/>
<link crossorigin='crossorigin' href='https://apis.google.com' rel='preconnect'/>
<link crossorigin='crossorigin' href='https://cdn.jsdelivr.net' rel='preconnect'/>
<link crossorigin='crossorigin' href='https://lh3.googleusercontent.com' rel='preconnect'/>
<link crossorigin='crossorigin' href='https://fonts.gstatic.com' rel='preconnect'/>
<link crossorigin='crossorigin' href='https://adservice.google.com' rel='preconnect'/>
<link href='//linuxuprising.disqus.com' rel='preconnect'/>
<link href='//disqus.com' rel='dns-prefetch'/>
<link href='//c.disquscdn.com' rel='dns-prefetch'/>
<link href='//referrer.disqus.com' rel='dns-prefetch'/>
<link href='//juggler.services.disqus.com' rel='dns-prefetch'/>
<meta content='text/html; charset=UTF-8' http-equiv='Content-Type'/>
<!-- Chrome, Firefox OS and Opera -->
<meta content='' name='theme-color'/>
<!-- Windows Phone -->
<meta content='' name='msapplication-navbutton-color'/>
<meta content='blogger' name='generator'/>
<link href='https://www.linuxuprising.com/favicon.ico' rel='icon' type='image/x-icon'/>
<link href='https://www.linuxuprising.com/2019/08/default-ubuntu-yaru-theme-rebased-on.html' rel='canonical'/>
<link rel="alternate" type="application/atom+xml" title="Linux Uprising Blog - Atom" href="https://www.linuxuprising.com/feeds/posts/default" />
<link rel="alternate" type="application/rss+xml" title="Linux Uprising Blog - RSS" href="https://www.linuxuprising.com/feeds/posts/default?alt=rss" />
<link rel="service.post" type="application/atom+xml" title="Linux Uprising Blog - Atom" href="https://www.blogger.com/feeds/852161773840707483/posts/default" />

<link rel="alternate" type="application/atom+xml" title="Linux Uprising Blog - Atom" href="https://www.linuxuprising.com/feeds/941578065810547998/comments/default" />
<!--Can't find substitution for tag [blog.ieCssRetrofitLinks]-->
<link href='https://1.bp.blogspot.com/-txs0WHAAYFA/XU1VqolaSKI/AAAAAAAADH4/7XPcpj9Dqu40Ag4jS-0gXS9DKpJb2GGEwCLcBGAs/s640/yaru-rebase-adwaita.png' rel='image_src'/>
<meta content='Yaru, the default Ubuntu 18.10+ theme, was recently rebased on the new Adwaita theme that was released with Gnome 3.32. The target is to have this in Ubuntu 19.10 Eoan Ermine.' name='description'/>
<meta content='https://www.linuxuprising.com/2019/08/default-ubuntu-yaru-theme-rebased-on.html' property='og:url'/>
<meta content='Default Ubuntu Yaru Theme Rebased On Adwaita 3.32' property='og:title'/>
<meta content='Yaru, the default Ubuntu 18.10+ theme, was recently rebased on the new Adwaita theme that was released with Gnome 3.32. The target is to have this in Ubuntu 19.10 Eoan Ermine.' property='og:description'/>
<meta content='https://1.bp.blogspot.com/-txs0WHAAYFA/XU1VqolaSKI/AAAAAAAADH4/7XPcpj9Dqu40Ag4jS-0gXS9DKpJb2GGEwCLcBGAs/w1200-h630-p-k-no-nu/yaru-rebase-adwaita.png' property='og:image'/>
<!--[if IE]> <script> (function() { var html5 = ("abbr,article,aside,audio,canvas,datalist,details," + "figure,footer,header,hgroup,mark,menu,meter,nav,output," + "progress,section,time,video").split(','); for (var i = 0; i < html5.length; i++) { document.createElement(html5[i]); } try { document.execCommand('BackgroundImageCache', false, true); } catch(e) {} })(); </script> <![endif]-->
<meta content='https://www.facebook.com/LinuxUprising' property='article:publisher'/>
<meta content='3F3C1DB7847EE7E64E8A2F6CDC5A5F10' name='msvalidate.01'/>
<meta content='de18aa7b281bff4c' name='yandex-verification'/>
<title>
Default Ubuntu Yaru Theme Rebased On Adwaita 3.32 - Linux Uprising Blog
</title>
<!-- Description and Keywords (start) -->
<meta content='en_US' property='og:locale'/>
<!-- Description and Keywords (end) -->
<meta content='article' property='og:type'/>
<meta content='Linux Uprising Blog' property='og:site_name'/>
<meta content='https://www.linuxuprising.com/' name='twitter:domain'/>
<meta content='Default Ubuntu Yaru Theme Rebased On Adwaita 3.32' name='twitter:title'/>
<meta content='summary_large_image' name='twitter:card'/>
<meta content='https://1.bp.blogspot.com/-txs0WHAAYFA/XU1VqolaSKI/AAAAAAAADH4/7XPcpj9Dqu40Ag4jS-0gXS9DKpJb2GGEwCLcBGAs/s640/yaru-rebase-adwaita.png' name='twitter:image'/>
<meta content='Yaru, the default Ubuntu 18.10+ theme, was recently rebased on the new Adwaita theme that was released with Gnome 3.32. The target is to have this in Ubuntu 19.10 Eoan Ermine.' name='twitter:description'/>
<!-- Social Media meta tag need customer customization -->
<meta content='572203406470374' property='fb:app_id'/>
<meta content='841352899' property='fb:admins'/>
<meta content='@linuxuprising' name='twitter:site'/>
<meta content='@linuxuprising' name='twitter:creator'/>
<!-- Quantcast Choice. Consent Manager Tag -->
<script async='true' type='text/javascript'>
    var elem = document.createElement('script');
    elem.src = 'https://quantcast.mgr.consensu.org/cmp.js';
    elem.async = true;
    elem.type = "text/javascript";
    var scpt = document.getElementsByTagName('script')[0];
    scpt.parentNode.insertBefore(elem, scpt);
    (function() {
    var gdprAppliesGlobally = false;
    function addFrame() {
        if (!window.frames['__cmpLocator']) {
        if (document.body) {
            var body = document.body,
                iframe = document.createElement('iframe');
            iframe.style = 'display:none';
            iframe.name = '__cmpLocator';
            body.appendChild(iframe);
        } else {
            // In the case where this stub is located in the head,
            // this allows us to inject the iframe more quickly than
            // relying on DOMContentLoaded or other events.
            setTimeout(addFrame, 5);
        }
        }
    }
    addFrame();
    function cmpMsgHandler(event) {
        var msgIsString = typeof event.data === "string";
        var json;
        if(msgIsString) {
        json = event.data.indexOf("__cmpCall") != -1 ? JSON.parse(event.data) : {};
        } else {
        json = event.data;
        }
        if (json.__cmpCall) {
        var i = json.__cmpCall;
        window.__cmp(i.command, i.parameter, function(retValue, success) {
            var returnMsg = {"__cmpReturn": {
            "returnValue": retValue,
            "success": success,
            "callId": i.callId
            }};
            event.source.postMessage(msgIsString ?
            JSON.stringify(returnMsg) : returnMsg, '*');
        });
        }
    }
    window.__cmp = function (c) {
        var b = arguments;
        if (!b.length) {
        return __cmp.a;
        }
        else if (b[0] === 'ping') {
        b[2]({"gdprAppliesGlobally": gdprAppliesGlobally,
            "cmpLoaded": false}, true);
        } else if (c == '__cmp')
        return false;
        else {
        if (typeof __cmp.a === 'undefined') {
            __cmp.a = [];
        }
        __cmp.a.push([].slice.apply(b));
        }
    }
    window.__cmp.gdprAppliesGlobally = gdprAppliesGlobally;
    window.__cmp.msgHandler = cmpMsgHandler;
    if (window.addEventListener) {
        window.addEventListener('message', cmpMsgHandler, false);
    }
    else {
        window.attachEvent('onmessage', cmpMsgHandler);
    }
    })();
    window.__cmp('init', {
        'Language': 'en',
    'Initial Screen Reject Button Text': 'I do not accept',
    'Initial Screen Accept Button Text': 'I accept',
    'Purpose Screen Body Text': 'You can set your consent preferences and determine how you want your data to be used based on the purposes below. You may set your preferences for us independently from those of third-party partners. Each purpose has a description so that you know how we and partners use your data.',
    'Vendor Screen Body Text': 'You can set consent preferences for each individual third-party company below. Expand each company list item to see what purposes they use data for to help make your choices. In some cases, companies may disclose that they use your data without asking for your consent, based on their legitimate interests. You can click on their privacy policies for more information and to opt out.',
    'Vendor Screen Accept All Button Text': 'Accept all',
    'Vendor Screen Reject All Button Text': 'Reject all',
    'Initial Screen Body Text': 'We and our partners use technology such as cookies on our site to personalise content and ads, provide social media features, and analyse our traffic. Click below to consent to the use of this technology across the web. You can change your mind and change your consent choices at anytime by returning to this site.',
    'Initial Screen Body Text Option': 1,
    'Publisher Name': 'Linux Uprising',
    'Publisher Logo': 'https://1.bp.blogspot.com/-OQO0AVdTMzg/XUQKnqI4K1I/AAAAAAAADHM/Oy6NjuOQYgMzts8ad4ub85ZMEoF2iZjSQCLcBGAs/s1600/LO_logo.png',
    'Default Value for Toggles': 'on',
    'Initial Screen Title Text': 'We use cookies',
    'Purpose Screen Title Text': 'We use cookies',
    'Vendor Screen Title Text': 'We use cookies', 
    'Display Persistent Consent Link': false,
    'Min Days Between UI Displays': 60,
    'Publisher Purpose IDs': [5],
    'Consent Scope': 'service',
    'No Option': false,
    });
</script>
<!-- &#39;Display Persistent Consent Link&#39;: false, -->
<!-- End Quantcast Choice. Consent Manager Tag -->
<script async='async' src='//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js'></script>
<!-- Disable default blogger Cookie Choice-->
<script type='text/javascript'>
    cookieChoices = {};
</script>
<!-- Set personalized or not for Adsense based on cookie consent info -->
<script type='text/javascript'>

<!-- pause ad requests -->
(adsbygoogle=window.adsbygoogle||[]).pauseAdRequests=1;

var checkUserConsent;

// fetch google personalization consent information
__cmp('getGooglePersonalization', function(consent, isSuccess) {

// do we have a cookie? 
if(!isSuccess) 
 return;

// check for given consent
if(consent.googlePersonalizationData.consentValue) {
  //
  // You have consent from the user: 
  // add your code here to call google&#8217;s admanager or adsense 
  //

  <!-- resume ad requests if cookie exists (user already interacted with consent window) -->
  __cmp('setConsentUiCallback',  (adsbygoogle=window.adsbygoogle||[]).pauseAdRequests=0);  
  (adsbygoogle=window.adsbygoogle||[]).requestNonPersonalizedAds=0;
  checkUserConsent = 'YES';

} else {
  // 
  // No consent for personalized ads from the user:
  // either no call to google&#8217;s admanger / adsense or
  // call admanager and adsense using the appropriate 
  // method to set &#8216;requestNonPersonalizedAds&#8217; accordingly.
  //

  <!-- resume ad requests if cookie exists (user already interacted with consent window) -->
  __cmp('setConsentUiCallback',  (adsbygoogle=window.adsbygoogle||[]).pauseAdRequests=0);
  (adsbygoogle=window.adsbygoogle||[]).requestNonPersonalizedAds=1;
  checkUserConsent = 'NO';

}
});
</script>
<!-- Google Analytics -->
<script type='text/javascript'>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');
  ga('create', 'UA-116578392-1', 'auto');
  if (checkUserConsent == 'NO') {
     ga('set', 'allowAdFeatures', false);
 }
  ga('set', 'anonymizeIp', true);
  ga('send', 'pageview');
</script>
<style id='page-skin-1' type='text/css'>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</style>
<style id='template-skin-1' type='text/css'><!--
/*------Layout (No Edit)----------*/
body#layout .row {width: 900px;}
body#layout #outer-wrapper{padding:0;width:900px}
body#layout .section h4{color:#333!important}
body#layout .theme-opt{overflow:hidden;     display: block!important;}
body#layout #option{overflow:hidden; display:block}
body#layout #option h4{font-size:16px;padding:4px 0 7px}
body#layout #option .widget{float:left;width:20%}
body#layout #option .widget.locked-widget .widget-content{background-color: #ff7575 !important;
border-color: #840000 !important;
color: #fff !important;}
body#layout #option .widget.locked-widget .widget-content a.editlink{color:#fff!important;border:1px solid;border-radius:2px;padding:2px 5px}
body#layout #topnav,body#layout .tm-head{height:auto}
body#layout .tm-menu{margin:0;width:70%}
body#layout .social-area{margin:0;width:30%}
body#layout .header-content,body#layout #header-blog{height:160px}
body#layout .header-logo{float:left;width:30%;margin:0;padding:0}
body#layout .header-ads{width:70%;margin:0}
body#layout .header-menu li.home-child{display:none}
body#layout .header-search,body#layout .m-rec{display:none}
body#layout .header-menu{float:left;width:100%;margin:4px 0 0;padding:0}
body#layout #content-wrapper{margin:0 auto}
body#layout .feat-layout .widget-content,body#layout .feat-layout h2.title,body#layout #ads-blog{display:block}
body#layout #main-wrapper{float:left;width:70%;margin:0;padding:0}
body#layout #ads-post10{display:block}
body#layout .sidebar-wrapper{float:right;width:30%;margin:0;padding:0}
body#layout #footer-wrapper{overflow:hidden}
body#layout .sect-left{width:28.3%;float:left}
body#layout #social-footer{width:30%;float:right}
/*------Layout (end)----------*/
--></style>
<style type='text/css'>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</style>
<noscript>
<style>
        #HTML1, #HTML2, #HTML3, #adsense-top-horiz {display:none;}
    </style>
</noscript>
<script>
if (window.innerWidth < 1000) {
     (adsbygoogle = window.adsbygoogle || []).push({
          google_ad_client: "ca-pub-1997822342415050",
          enable_page_level_ads: true
     });
}    
</script>
<script type='text/javascript'> 
//<![CDATA[
var text_month = [, "Jan", "Feb", "Mar", "Apr", "May", "Jun", "Jul", "Aug", "Sept", "Oct", "Nov", "Dec"];
var no_image_url = "https://1.bp.blogspot.com/-dUVHHKr63sw/WrjkLAm4OkI/AAAAAAAAABU/SNBN1gIB8E0vLNWf41AGwudNCH1Q9hYYwCLcBGAs/s1600-r/nothumb.jpg";
var feat1_number = 3;
var related_number = 4;
//]]>
</script>
<script>
        (function () {
            var done = false;
            var script = document.createElement("script"),
            head = document.getElementsByTagName("head")[0] || document.documentElement;
            script.src = 'https://ajax.googleapis.com/ajax/libs/webfont/1.6.26/webfont.js';
            script.async = true;
            script.onload = script.onreadystatechange = function() {
                if ( ! done && ( ! this.readyState || this.readyState === "loaded" || this.readyState === "complete" ) ) {
                    done = true;
                    WebFont.load({
                        google: {
                            families: ['Ubuntu:300,300i,500,700&display=swap']
                        }
                    });
                    script.onload = script.onreadystatechange = null;
                }
            };
            head.insertBefore(script, head.firstChild);
        })();
    </script>
<noscript><link href='https://fonts.googleapis.com/css?family=Ubuntu:300,300i,500,700&display=swap' rel='stylesheet'/></noscript>

-<!--<link href='https://www.blogger.com/dyn-css/authorization.css?targetBlogID=852161773840707483&amp;zx=a2559254-84d1-4abb-a5fb-1a2ea3f20103' media='none' onload='if(media!=&#39;all&#39;)media=&#39;all&#39;' rel='stylesheet'/><noscript><link href='https://www.blogger.com/dyn-css/authorization.css?targetBlogID=852161773840707483&amp;zx=a2559254-84d1-4abb-a5fb-1a2ea3f20103' rel='stylesheet'/></noscript>

</head>--></head>

    <body class='item'>
<div class='theme-opt' style='display:none'>
<div class='option section' id='option' name='Theme Option'><div class='widget HTML' data-version='1' id='HTML103'>

<script type='text/javascript'> 
          //<![CDATA[
          var recentposts_number = 5;
          //]]>
         </script>
         
</div><div class='widget HTML' data-version='1' id='HTML104'>
<script type='text/javascript'> 
          //<![CDATA[
          var randomposts_number = 4;
          //]]>
         </script>
</div><div class='widget HTML' data-version='1' id='HTML105'>

         <script type='text/javascript'>
          var postperpage=12;
         </script>
         
</div><div class='widget HTML' data-version='1' id='HTML106'>
</div><div class='widget HTML' data-version='1' id='HTML851'>
<script src='https://ajax.googleapis.com/ajax/libs/jquery/2.2.4/jquery.min.js' type='text/javascript'></script>
<script type='text/javascript'> 
            //<![CDATA[

            // Plugin: Sticky jQuery ~ BY: https://stickyjs.com
            (function(e){var t={topSpacing:0,bottomSpacing:0,className:"is-sticky",wrapperClassName:"sticky-wrapper",center:false,getWidthFrom:"",responsiveWidth:false},n=e(window),r=e(document),i=[],s=n.height(),o=function(){var t=n.scrollTop(),o=r.height(),u=o-s,a=t>u?u-t:0;for(var f=0;f<i.length;f++){var l=i[f],c=l.stickyWrapper.offset().top,h=c-l.topSpacing-a;if(t<=h){if(l.currentTop!==null){l.stickyElement.css("width","").css("position","").css("top","");l.stickyElement.trigger("sticky-end",[l]).parent().removeClass(l.className);l.currentTop=null}}else{var p=o-l.stickyElement.outerHeight()-l.topSpacing-l.bottomSpacing-t-a;if(p<0){p=p+l.topSpacing}else{p=l.topSpacing}if(l.currentTop!=p){l.stickyElement.css("width",l.stickyElement.width()).css("position","fixed").css("top",p);if(typeof l.getWidthFrom!=="undefined"){l.stickyElement.css("width",e(l.getWidthFrom).width())}l.stickyElement.trigger("sticky-start",[l]).parent().addClass(l.className);l.currentTop=p}}}},u=function(){s=n.height();for(var t=0;t<i.length;t++){var r=i[t];if(typeof r.getWidthFrom!=="undefined"&&r.responsiveWidth===true){r.stickyElement.css("width",e(r.getWidthFrom).width())}}},a={init:function(n){var r=e.extend({},t,n);return this.each((function(){var n=e(this);var s=n.attr("id");var o=s?s+"-"+t.wrapperClassName:t.wrapperClassName;var u=e("<div></div>").attr("id",s+"-sticky-wrapper").addClass(r.wrapperClassName);n.wrapAll(u);if(r.center){n.parent().css({width:n.outerWidth(),marginLeft:"auto",marginRight:"auto"})}if(n.css("float")=="right"){n.css({"float":"none"}).parent().css({"float":"right"})}var a=n.parent();a.css("height",n.outerHeight());i.push({topSpacing:r.topSpacing,bottomSpacing:r.bottomSpacing,stickyElement:n,currentTop:null,stickyWrapper:a,className:r.className,getWidthFrom:r.getWidthFrom,responsiveWidth:r.responsiveWidth})}))},update:o,unstick:function(t){return this.each((function(){var t=e(this);var n=-1;for(var r=0;r<i.length;r++){if(i[r].stickyElement.get(0)==t.get(0)){n=r}}if(n!=-1){i.splice(n,1);t.unwrap();t.removeAttr("style")}}))}};if(window.addEventListener){window.addEventListener("scroll",o,false);window.addEventListener("resize",u,false)}else if(window.attachEvent){window.attachEvent("onscroll",o);window.attachEvent("onresize",u)}e.fn.sticky=function(t){if(a[t]){return a[t].apply(this,Array.prototype.slice.call(arguments,1))}else if(typeof t==="object"||!t){return a.init.apply(this,arguments)}else{e.error("Method "+t+" does not exist on jQuery.sticky")}};e.fn.unstick=function(t){if(a[t]){return a[t].apply(this,Array.prototype.slice.call(arguments,1))}else if(typeof t==="object"||!t){return a.unstick.apply(this,arguments)}else{e.error("Method "+t+" does not exist on jQuery.sticky")}};e((function(){setTimeout(o,0)}))})(jQuery);
            //]]>
          </script>
          <script type='text/javascript'> 
            //<![CDATA[
              $(document).ready(function(){$("#header-navigation").sticky({topSpacing:0});});
            //]]>
          </script>
        </div></div>
</div>

<div id="pages-wrap" class="item">

<div id='outer-wrapper'>
<div id='topnav'>
<div class='tm-head row'>
<div class='tm-menu'>
<div class='menu1 section' id='menu1' name='Top Navigation'><div class='widget LinkList' data-version='1' id='LinkList210'>
<div class='widget-content'>
<ul id='nav1'>
<li><a href='https://www.linuxuprising.com/p/about.html'>About</a></li>
<li><a href='https://www.linuxuprising.com/p/contact.html'>Contact</a></li>
<li><a href='https://www.reddit.com/r/LinuxUprising/' rel='noreferrer' target='_blank'>Submit A Tip</a></li>
</ul>
</div>
</div></div>
</div>
<!-- Top Social -->
<div class='social-area'>
<div class='social-top section' id='social-top' name='Social Top'><div class='widget LinkList' data-version='1' id='LinkList50'>
<div class='widget-content'>
<ul>
<li><a class='rss' href='https://feeds.feedburner.com/LinuxUprising' rel='noreferrer' target='_blank' title='rss'></a></li>
<li><a class='friendica' href='https://libranet.de/profile/linuxuprising' rel='noreferrer' target='_blank' title='friendica'></a></li>
<li><a class='twitter' href='https://twitter.com/linuxuprising' rel='noreferrer' target='_blank' title='twitter'></a></li>
<li><a class='telegram' href='https://t.me/LinuxUprising' rel='noreferrer' target='_blank' title='telegram'></a></li>
<li><a class='facebook' href='https://www.facebook.com/LinuxUprising/' rel='noreferrer' target='_blank' title='facebook'></a></li>
<li><a class='reddit' href='https://www.reddit.com/r/LinuxUprising/' rel='noreferrer' target='_blank' title='reddit'></a></li>
</ul>
</div>
</div></div>
</div>
</div>
</div>
<div id='header-blog'>
<div class='header-content row'>
<div class='header-logo'>
<div class='section' id='logo_blog' name='Logo'><div class='widget Header' data-version='1' id='Header1'>
<div id='header-inner'>
<h2 class='logo'>
<a href='https://www.linuxuprising.com/' style='display: block'>
<img alt='Linux Uprising Blog' height='23px; ' id='Header1_headerimg' src='https://cdn.rawgit.com/logix2/6fb43ed0a1979f24c50857fadc6de3ac/raw/24571f5df3fa6fadeeb0937ffd40ea38c380075f/logo2.svg' style='display: block' width='455px; '/>
</a>
<span class='alt-logo'>Linux Uprising blog</span>
</h2>
</div>
</div></div>
</div>
<!-- <div class='header-ads'> <b:section id='ads-content' maxwidgets='1' name='Ads 728x90' showaddelement='yes'> <b:widget id='HTML1' locked='false' title='' type='HTML'> <b:includable id='main'> <b:if cond='data:title != &quot;&quot;'> <h2 class='title'><data:title/></h2> </b:if> <div class='widget-content'> <data:content/> </div> </b:includable> </b:widget> </b:section> </div> -->
</div>
</div>
<nav class='row' id='header-navigation'>
<div class='nav-wrapper'>
<div class='nav-menu'>
<div class='header-search'>
<ul>
<li>
<a class='search' id='search'>
<form action='/search/max-results=12' method='get'>
<input id='s' name='q' placeholder='Type and hit enter...' type='text'/>
</form>
</a>
</li>
</ul>
</div>
<div class='header-menu'>
<ul>
<li class='home-child'><a href='https://www.linuxuprising.com/'>Home</a></li>
</ul>
<div class='menu section' id='menu' name='Main Menu'><div class='widget LinkList' data-version='1' id='LinkList110'>
<div class='widget-content'>
<ul id='nav' itemscope='' itemtype='https://schema.org/SiteNavigationElement'>
<li itemprop='name'><a href='https://www.linuxuprising.com/search/label/news?max-results=12' itemprop='url'>News</a></li>
<li itemprop='name'><a href='https://www.linuxuprising.com/search/label/apps?max-results=12' itemprop='url'>Applications</a></li>
<li itemprop='name'><a href='https://www.linuxuprising.com/search/label/how-to?max-results=12' itemprop='url'>How To</a></li>
<li itemprop='name'><a href='https://www.linuxuprising.com/search/label/tweaks?max-results=12' itemprop='url'>Tweaks</a></li>
<li itemprop='name'><a href='https://www.linuxuprising.com/search/label/customization?max-results=12' itemprop='url'>Themes & More</a></li>
<li itemprop='name'><a href='https://www.linuxuprising.com/search/label/console?max-results=12' itemprop='url'>Console</a></li>
</ul>
</div>
</div></div>
</div>
</div>
</div>
</nav>
<div class='clear'></div>
<div class='row' id='content-wrapper'>
<div id='main-wrapper'>
<div id='ads-blog'>
<div class='home-ad no-items section' id='ads-home' name='Ads Home/Post (728x90)'>
</div>
</div>
<div class='main section' id='main' name='Main Wrapper'><div class='widget Blog' data-version='1' id='Blog1'>
<div class='blog-posts hfeed'>
<div class='post-outer' id='post-outer'>
<div class='post' id='post-article'>

    <div itemprop='blogPost' itemscope='itemscope' itemtype='https://schema.org/Article'>
            <meta content='data:post.link : data:post.url' itemType='https://schema.org/WebPage' itemid='' itemprop='mainEntityOfPage' itemscope='itemscope'/>
<div itemprop='publisher' itemscope='itemscope' itemtype='https://schema.org/Organization'>
<div itemprop='logo' itemscope='itemscope' itemtype='https://schema.org/ImageObject'>
<meta content='https://4.bp.blogspot.com/-OlFvIO7s2mM/WrzEk1hCVZI/AAAAAAAAAE0/H4meMs7XreskNd_mTgVtNREkBX08-O1CACK4BGAYYCw/s590/LUR_logo1.png' itemprop='url'/>
<meta content='455' itemprop='width'/>
<meta content='48' itemprop='height'/>
</div>
<meta content='Linux Uprising Blog' itemprop='name'/>
</div>
<meta content='https://1.bp.blogspot.com/-txs0WHAAYFA/XU1VqolaSKI/AAAAAAAADH4/7XPcpj9Dqu40Ag4jS-0gXS9DKpJb2GGEwCLcBGAs/s640/yaru-rebase-adwaita.png' itemprop='image'/>
<div class='post-header'>
<div id='adsense-top-horiz'>
<ins class='adsbygoogle responsive_1' data-ad-client='ca-pub-1997822342415050' data-ad-slot='5867515603' style='display:inline-block;'></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
<br/><br/>
</div>
<div class='post-head'><h1 class='post-title entry-title' id='entry-title' itemprop='name headline'>
Default Ubuntu Yaru Theme Rebased On Adwaita 3.32
</h1></div>
<div class='post-meta'>
<span class='post-author vcard'>
<i class='fa fa-user'></i>
<span class='fn' itemprop='author' itemscope='itemscope' itemtype='https://schema.org/Person'>
<meta content='https://www.blogger.com/profile/03026963810377267607' itemprop='url'/>
<a class='g-profile' href='https://www.blogger.com/profile/03026963810377267607' rel='author' title='Logix'>
<span itemprop='name'>Logix</span>
</a>
</span>
</span>
<span class='post-timestamp'>
<i class='fa fa-clock-o'></i>
<meta content='https://www.linuxuprising.com/2019/08/default-ubuntu-yaru-theme-rebased-on.html' itemprop='url'/>
          Updated on <a class='timestamp-link' href='https://www.linuxuprising.com/2019/08/default-ubuntu-yaru-theme-rebased-on.html' rel='bookmark' title='permanent link'><time class='updated timeago' datetime='2019-08-09T18:09:38Z' title='2019-08-09T18:09:38Z'><span id='updatedateinfo'>2019-08-09T18:09:38Z</span></time></a>
<script>
            var dates = "2019-08-09T18:09:38Z"
            var dateu = new Date(dates);
            var months = ["January","February","March","April","May","June","July","August","September","October","November","December"];
            document.getElementById("updatedateinfo").innerHTML = months[dateu.getMonth()] + " " + dateu.getDate() + ", " + dateu.getFullYear();
        </script>
<meta content='2019-08-09T18:09:38Z' itemprop='dateModified'/>
<meta content='2019-08-09T12:47:00+01:00' itemprop='datePublished'/>
</span>
<span class='label-head'>
<i class='fa fa-folder-open-o'></i>
<a href='https://www.linuxuprising.com/search/label/customization?max-results=12' rel='tag'>customization</a>,
<a href='https://www.linuxuprising.com/search/label/news?max-results=12' rel='tag'>news</a>,
<a href='https://www.linuxuprising.com/search/label/ubuntu?max-results=12' rel='tag'>ubuntu</a>,
<a href='https://www.linuxuprising.com/search/label/Yaru?max-results=12' rel='tag'>Yaru</a>
</span>
</div>
<div class='ads-posting'>
<a name='ad-post'></a>
</div>
</div>
<article>
<div class='post-body entry-content' id='post-body-941578065810547998' itemprop='articleBody'>
<meta content='  The latest Yaru theme master branch (rebased on Adwaita 3.32)   Yaru , the default Ubuntu 18.10+ theme, was recently rebased on the new Ad...' name='twitter:description'/>
<table align="center" cellpadding="0" cellspacing="0" class="tr-caption-container" style="margin-left: auto; margin-right: auto; text-align: center;"><tbody>
<tr><td style="text-align: center;"><a href="https://1.bp.blogspot.com/-txs0WHAAYFA/XU1VqolaSKI/AAAAAAAADH4/7XPcpj9Dqu40Ag4jS-0gXS9DKpJb2GGEwCLcBGAs/s1600/yaru-rebase-adwaita.png" imageanchor="1" style="margin-left: auto; margin-right: auto;"><img border="0" data-original-height="900" data-original-width="1600" height="360" src="https://1.bp.blogspot.com/-txs0WHAAYFA/XU1VqolaSKI/AAAAAAAADH4/7XPcpj9Dqu40Ag4jS-0gXS9DKpJb2GGEwCLcBGAs/s640/yaru-rebase-adwaita.png" width="640" /></a></td></tr>
<tr><td class="tr-caption" style="text-align: center;">The latest Yaru theme master branch (rebased on Adwaita 3.32)</td></tr>
</tbody></table><br />
<b><a href="https://github.com/ubuntu/yaru" target="_blank">Yaru</a>, the default Ubuntu 18.10+ theme, was recently <a href="https://discourse.ubuntu.com/t/yaru-next-move/12155" target="_blank">rebased on the new Adwaita</a> theme that was released with <a href="https://www.linuxuprising.com/2019/03/features-and-improvements-in-gnome-332.html">Gnome 3.32</a>. The target is to have this in Ubuntu 19.10 Eoan Ermine.</b><br />
<br />
In the official announcement, Carlo Lobrano says the rebase of Yaru theme on the newest Adwaita was born out of the acknowledgement that "<i>some application developers had serious problems developing for too many variants</i>", and the desire to make use of the "<i>great work upstream is doing</i>". <br />
<a name='more'></a><br />
<blockquote class="tr_bq">"The Yaru team (but mostly Frederik, who did a great job) took a new, more upstream oriented, contribution approach, proposing some of its solutions and ideas to GNOME developers, that - as always stated - have been quite open to consider, discuss and in some cases accept.<br />
<br />
This was fundamental to reduce the customization needed for Yaru and other theme variations and allowed us to work internally developing and testing a huge rebase on the newest Adwaita."</blockquote><br />
You won't notice massive differences between the old and new Yaru though, because there are only a few visible changes:<br />
<br />
<ul><li><b>headerbar is no longer flat and buttons have borders</b></li>
<li><b>switches are round</b></li>
<li><b>menu hover is orange</b></li>
<li><b>Gnome Shell now has a full light and a full dark theme (we just miss the switch to toggle this)</b></li>
<li><b>the Gnome Shell theme menus are now light in current master</b></li>
</ul><br />
<b>The updated <a href="https://github.com/ubuntu/yaru" target="_blank">Yaru theme</a> landed in the master branch at the beginning of this week, and the target is to have it available with Ubuntu 19.10 Eoan Ermine, which will be released on&nbsp;October 17, 2019.</b><br />
<br />
This are the widgets of the updated Yaru theme (in both regular - light, and dark colors):<br />
<br />
<div class="separator" style="clear: both; text-align: center;"><a href="https://1.bp.blogspot.com/-AxYaeZaKdX8/XU1V8-Xye7I/AAAAAAAADIE/xU9VCUE2ahcSHGnFhFGmpyuqVpCb5ydrQCLcBGAs/s1600/yaru-rebase-adwaita-gtk3-twf.png" imageanchor="1" style="margin-left: 1em; margin-right: 1em;"><img alt="New Yaru theme rabased on Adwaita 3.32" border="0" data-original-height="762" data-original-width="1401" height="348" src="https://1.bp.blogspot.com/-AxYaeZaKdX8/XU1V8-Xye7I/AAAAAAAADIE/xU9VCUE2ahcSHGnFhFGmpyuqVpCb5ydrQCLcBGAs/s640/yaru-rebase-adwaita-gtk3-twf.png" title="New Yaru theme rabased on Adwaita 3.32" width="640" /></a></div><br />
<div class="separator" style="clear: both; text-align: center;"><a href="https://1.bp.blogspot.com/-wPrgm4UMsMk/XU1V89T01SI/AAAAAAAADIA/VDvopyTDbHYyiQUXdWHG39LteHNQZt3IgCLcBGAs/s1600/yaru-rebase-adwaita-gtk3-twf-dark.png" imageanchor="1" style="margin-left: 1em; margin-right: 1em;"><img alt="New Yaru theme rabased on Adwaita 3.32" border="0" data-original-height="762" data-original-width="1401" height="348" src="https://1.bp.blogspot.com/-wPrgm4UMsMk/XU1V89T01SI/AAAAAAAADIA/VDvopyTDbHYyiQUXdWHG39LteHNQZt3IgCLcBGAs/s640/yaru-rebase-adwaita-gtk3-twf-dark.png" title="New Yaru theme rabased on Adwaita 3.32" width="640" /></a></div><br />
<div class="separator" style="clear: both; text-align: center;"><a href="https://1.bp.blogspot.com/-LAH3hUw_Vyk/XU1chZiyLBI/AAAAAAAADIc/QBOtCvhHOIM9mlT1Ta25ypNTbfRE5b5gACLcBGAs/s1600/yaru-updated-dark.png" imageanchor="1" style="margin-left: 1em; margin-right: 1em;"><img alt="Yaru Ubuntu 19.10" border="0" data-original-height="900" data-original-width="1600" height="360" src="https://1.bp.blogspot.com/-LAH3hUw_Vyk/XU1chZiyLBI/AAAAAAAADIc/QBOtCvhHOIM9mlT1Ta25ypNTbfRE5b5gACLcBGAs/s640/yaru-updated-dark.png" title="Yaru Ubuntu 19.10" width="640" /></a></div><br />
<div class="separator" style="clear: both; text-align: center;"><a href="https://1.bp.blogspot.com/-ENjdVmoJP0k/XU1chcUs04I/AAAAAAAADIY/KxOSSGFsEkQYMMbxfK0fMvuS4xhnFt1qwCLcBGAs/s1600/yaru-updated_2.png" imageanchor="1" style="margin-left: 1em; margin-right: 1em;"><img alt="Yaru Ubuntu 19.10" border="0" data-original-height="900" data-original-width="1600" height="360" src="https://1.bp.blogspot.com/-ENjdVmoJP0k/XU1chcUs04I/AAAAAAAADIY/KxOSSGFsEkQYMMbxfK0fMvuS4xhnFt1qwCLcBGAs/s640/yaru-updated_2.png" title="Yaru Ubuntu 19.10" width="640" /></a></div><br />
And this is the Yaru theme shat ships with Ubuntu 19.04, for comparison:<br />
<br />
<div class="separator" style="clear: both; text-align: center;"><a href="https://1.bp.blogspot.com/-jpK6Ot85t54/XU1WHOkMixI/AAAAAAAADII/iNRvBDGFY04zNJRYn8sVCbF9QPdUHgZMACLcBGAs/s1600/original-yaru-theme.png" imageanchor="1" style="margin-left: 1em; margin-right: 1em;"><img alt="Yaru theme Ubuntu 19.04" border="0" data-original-height="758" data-original-width="1391" height="348" src="https://1.bp.blogspot.com/-jpK6Ot85t54/XU1WHOkMixI/AAAAAAAADII/iNRvBDGFY04zNJRYn8sVCbF9QPdUHgZMACLcBGAs/s640/original-yaru-theme.png" title="Yaru theme Ubuntu 19.04" width="640" /></a></div><br />
You can read more about the updated Yaru theme in the official announcement on the <a href="https://discourse.ubuntu.com/t/yaru-next-move/12155" target="_blank">Ubuntu Discourse</a>, where you'll also find Yaru team members answering questions.<br />
<br />
<h2>Try the updated Yaru theme</h2><br />
Want to try the updated Yaru theme on your Linux desktop? This is how to install it from source. <br />
<br />
<b>Note that following these instructions will replace the Yaru theme you may already have installed on your system in <span class="codeblock2"><code>/usr/share/themes</code></span>. On Ubuntu though, you can easily revert this if you want, by reinstalling the Yaru theme package. What's more, if you have Yaru installed under <span class="codeblock2"><code>~/.themes</code></span>, remove it before proceeding.</b><br />
<br />
1. Install Git (to get the latest master branch), libglib2.0, xmllint, sassc and meson (to build the theme).<br />
<br />
E.g. on Debian/Ubuntu, install them using:<br />
<br />
<pre class="cssterm"><code>sudo apt install git meson sassc libglib2.0-dev libxml2-utils</code></pre><br />
2. Grab the latest <a href="https://github.com/ubuntu/yaru" target="_blank">Yaru master branch</a> from git, build and install the theme:<br />
<br />
<pre class="cssterm"><code>git clone https://github.com/ubuntu/yaru
cd yaru
meson build
cd build
sudo ninja install</code></pre><br />
You can now change the Gtk, icon and Gnome Shell theme using the Tweaks app. See <a href="https://www.linuxuprising.com/2018/04/how-to-change-gtk-icon-or-gnome-shell.html">How To Change The GTK, Icon Or GNOME Shell Theme In GNOME</a>. If you were already using Yaru, you may need to switch to a different theme, then back to Yaru.<br />
<br />
If you don't use Ubuntu 18.10+ and its default "Ubuntu" session, the recommended way to use it is to logout, and choose "Yaru session" from the login screen.<br />
<br />
<br />
<b>Those using Ubuntu and wanting to revert to the initial Yaru theme version (installed from the repositories) they had installed on their system, can reinstall the theme:</b><br />
<br />
<pre class="cssterm"><code>sudo apt install --reinstall yaru-theme-gnome-shell yaru-theme-gtk</code></pre><br />
And switch to a different theme, then back to Yaru to see the changes.<br />
<br />
<i>I took the screenshots from this post in Ubuntu 19.04 with the latest Yaru (as of August 9, 2019) built from the master git branch.</i>
</div>
</article>
<div style='clear:both'></div>
<div class='post-footer'>
<div class='share-box'>
<h8 class='share-title'>Share This:</h8>
<div class='share-art'>
<a class='fac-art' href='https://www.facebook.com/sharer.php?u=https://www.linuxuprising.com/2019/08/default-ubuntu-yaru-theme-rebased-on.html&title=Default Ubuntu Yaru Theme Rebased On Adwaita 3.32' onclick='window.open(this.href, &#39;windowName&#39;, &#39;width=600, height=400, left=24, top=24, scrollbars, resizable&#39;); return false;' rel='nofollow noreferrer' target='_blank' title='Facebppl'><i class='fa fa-facebook'></i><span class='resp_del'> Facebook</span></a>
<a class='twi-art' href='https://twitter.com/share?url=https://www.linuxuprising.com/2019/08/default-ubuntu-yaru-theme-rebased-on.html&title=Default Ubuntu Yaru Theme Rebased On Adwaita 3.32' onclick='window.open(this.href, &#39;windowName&#39;, &#39;width=600, height=400, left=24, top=24, scrollbars, resizable&#39;); return false;' rel='nofollow noreferrer' target='_blank' title='Twitter'><i class='fa fa-twitter'></i><span class='resp_del2'> Twitter</span></a>
<a class='dis-art' href='https://sharetodiaspora.github.io/?url=https://www.linuxuprising.com/2019/08/default-ubuntu-yaru-theme-rebased-on.html&title=Default Ubuntu Yaru Theme Rebased On Adwaita 3.32' onclick='window.open(this.href, &#39;windowName&#39;, &#39;width=770, height=500, left=24, top=24, scrollbars, resizable&#39;); return false;' rel='nofollow noreferrer' target='_blank' title='Diaspora'><i class='fa fa-diaspora'></i><span class='resp_del3'> Diaspora</span></a>
<a class='redd-art' href='https://www.reddit.com/submit?url=https://www.linuxuprising.com/2019/08/default-ubuntu-yaru-theme-rebased-on.html&title=Default Ubuntu Yaru Theme Rebased On Adwaita 3.32' onclick='window.open(this.href, &#39;windowName&#39;); return false;' rel='nofollow noreferrer' target='_blank' title='Reddit'><i class='fa fa-reddit-alien'></i><span class='resp_del4'> Reddit</span></a>
<a class='tel-art' href='https://telegram.me/share/url?text=Default Ubuntu Yaru Theme Rebased On Adwaita 3.32&tags=&url=https://www.linuxuprising.com/2019/08/default-ubuntu-yaru-theme-rebased-on.html' onclick='window.open(this.href, &#39;windowName&#39;, &#39;width=600, height=400, left=24, top=24, scrollbars, resizable&#39;); return false;' rel='nofollow noreferrer' target='_blank' title='Telegram'><i class='fa fa-telegram'></i><span class='resp_del5'> Telegram</span></a>
<a class='wat-art' data-action='share/whatsapp/share' href='whatsapp://send?text=Default Ubuntu Yaru Theme Rebased On Adwaita 3.32 https://www.linuxuprising.com/2019/08/default-ubuntu-yaru-theme-rebased-on.html' onclick='window.open(this.href, &#39;windowName&#39;, &#39;width=600, height=400, left=24, top=24, scrollbars, resizable&#39;); return false;' rel='nofollow noreferrer' target='_blank' title='WhatsApp'><i class='fa fa-whatsapp'></i><span class='resp_del6'> WhatsApp</span></a>
</div>
</div>
<div style='clear:both'></div>
<div class='ads-post'>
<a name='ads-post-in'></a>
</div>
<div id='related-posts'>
Yaru
</div>
<div class='clear'></div>
<div class='comment-notif-box'>Please post civil and on-topic comments. <a href='https://www.linuxuprising.com/p/commenting-guidelines.html' rel='nofollow' target='_blank'>Commenting guidelines</a>.</div>
</div>
<div id='disqus_thread_load_on_scroll'>
<div id='disqus_empty' style='display: none'>Empty</div>
</div>

      </div>
    
</div>
<div class='comments' id='comments'>
<a name='comments'></a>
<div id='backlinks-container'>
<div id='Blog1_backlinks-container'>
</div>
</div>
</div>
</div>
</div>
<div class='post-feeds'>
</div>
</div></div>
<div id='ads-post10'>
<div class='no-items section' id='ads-post-468' name='ADS Inner Footer 728x90'>
</div>
</div>
</div>
<div class='sidebar-wrapper' id='sidebar-wrapper'>
<div class='sidebar section' id='sidebar' name='Sidebar Right'><div class='widget HTML' data-version='1' id='HTML6'>
<script type='text/javascript'>
var disqus_shortname = 'linuxuprising';
var disqus_blogger_current_url = "https://www.linuxuprising.com/2019/08/default-ubuntu-yaru-theme-rebased-on.html";
var disqus_title = "Default Ubuntu Yaru Theme Rebased On Adwaita 3.32 - Linux Uprising Blog"; 
if (!disqus_blogger_current_url.length) {
disqus_blogger_current_url = "https://www.linuxuprising.com/2019/08/default-ubuntu-yaru-theme-rebased-on.html";
}
var disqus_blogger_homepage_url = "https://www.linuxuprising.com/";
var disqus_blogger_canonical_homepage_url = "https://www.linuxuprising.com/";
</script>
<script>
var disqus_loaded = false;
function load_disqus( disqus_shortname ) {
  // Prepare the trigger and target

  var is_disqus_empty = document.getElementById('disqus_empty'),
      disqus_target   = document.getElementById('disqus_thread_load_on_scroll'),
      disqus_embed    = document.createElement('script'),
      disqus_hook     = (document.getElementsByTagName('head')[0] || document.getElementsByTagName('body')[0]);

  // Load script asynchronously only when the trigger and target exist
  if( disqus_target && is_disqus_empty ) {
    disqus_loaded = true;
    disqus_embed.type = 'text/javascript';
    disqus_embed.async = true;
    disqus_embed.src = '//' + disqus_shortname + '.disqus.com/blogger_item.js';
    disqus_hook.appendChild(disqus_embed);
    is_disqus_empty.remove();
  }
}

window.addEventListener('scroll', function(e) {
  var currentScroll = document.scrollingElement.scrollTop;
  var disqus_target = document.getElementById('disqus_thread_load_on_scroll');

  if( currentScroll > disqus_target.getBoundingClientRect().top - 150 ) {
    if (disqus_loaded==false) {
      load_disqus('linuxuprising');
    };
  }
}, false);

(function($){
    setInterval(() => {
        $.each($('iframe'), (arr,x) => {
            let src = $(x).attr('src');
            if (src && src.match(/(ads-iframe)|(disqusads)/gi)) {
                $(x).remove();
            }
        });
    }, 300);
})(jQuery);
</script>
</div><div class='widget HTML' data-version='1' id='HTML1'>
<div class='widget-content'>
<div class="imagehere"><!-- Top Right Sidebar 300x250 -->
<ins class="adsbygoogle"
     style="display:inline-block;width:300px;height:250px"
     data-ad-client="ca-pub-1997822342415050"
     data-ad-slot="8358301820"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div>

<script type="text/javascript">
//<![CDATA[
$(window).load(function(){null==document.getElementsByTagName("iframe").item(ga.length-1)&&$("div.imagehere").html("<a href='https://www.linuxuprising.com/2019/04/join-uprising.html' rel='nofollow noopener'><img src='https://4.bp.blogspot.com/-RM33YT7JTCw/XOVA0YwyKxI/AAAAAAAACyo/lA22C-cphP87WD39N4_9SJ-qG5b21IORgCLcBGAs/s1600/join-the-uprising.png' alt='Join the Uprising'/></a><br/>")});
//]]> 
</script>
</div>
</div><div class='widget HTML' data-version='1' id='HTML2'>
<h2 class='title'>Recent Posts</h2>
<div id='RecentPosts'>
<div class='widget-content'>
recentposts
</div>
</div>
</div><div class='widget HTML' data-version='1' id='HTML3'>
<div class='widget-content'>
<!-- Sidebar right 300x600 -->
<ins class="adsbygoogle"
     style="display:inline-block;width:300px;height:600px"
     data-ad-client="ca-pub-1997822342415050"
     data-ad-slot="6174183113"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
</div><div class='widget ContactForm' data-version='1' id='ContactForm1'>
</div><div class='widget LinkList' data-version='1' id='LinkList2'>
<h2>Editor's Picks</h2>
<div class='widget-content'>
<ul>
<li><a href='https://www.linuxuprising.com/2018/07/anbox-how-to-install-google-play-store.html'>Anbox: How To Install Google Play Store And Enable ARM (libhoudini) Support, The Easy Way</a></li>
<li><a href='https://www.linuxuprising.com/2018/07/how-to-mount-onedrive-in-linux-using.html'>How To Mount OneDrive In Linux Using Rclone (Supports Business And Personal Accounts)</a></li>
<li><a href='https://www.linuxuprising.com/2018/06/how-to-install-davinci-resolve-15-in.html'>How To Install DaVinci Resolve 16 Or 15 In Ubuntu, Linux Mint Or Debian (Generate DEB Package)</a></li>
<li><a href='https://www.linuxuprising.com/2019/03/control-android-devices-from-your.html'>Control Android Devices From A Desktop With scrcpy (Ubuntu, Fedora, Debian, Linux Mint Installation)</a></li>
<li><a href='https://www.linuxuprising.com/2019/02/how-to-create-fillable-pdf-forms-with.html'>How To Create Fillable PDF Forms With LibreOffice Writer</a></li>
<li><a href='https://www.linuxuprising.com/2019/05/how-to-convert-pdf-to-text-on-linux-gui.html'>How To Convert PDF To Text On Linux (GUI And Command Line)</a></li>
<li><a href='https://www.linuxuprising.com/2018/12/pdfarranger-merge-split-rotate-crop-or.html'>PDFArranger: Merge, Split, Rotate, Crop Or Rearrange PDF Documents (PDF-Shuffler Fork)</a></li>
<li><a href='https://www.linuxuprising.com/2019/03/how-to-install-oracle-java-12-jdk-12-in.html'>How To Install Oracle Java 12 (JDK 12) In Ubuntu, Linux Mint Or Debian (Using PPA)</a></li>
<li><a href='https://www.linuxuprising.com/2019/03/create-persistent-storage-live-usb-with.html'>Create A Persistent Storage Live USB With Ubuntu, Linux Mint Or Debian (UEFI, >4GB Persistance Support)</a></li>
</ul>
</div>
</div></div>
</div>
<div class='clear'></div>
</div>
<!-- end content-wrapper -->
<div class='clear'></div><!-- Footer wrapper -->
<div id='footer-wrapper'>
<div id='footer'>
<div class='footer-sections row' id='footer-sections'>
<div class='sect-left section' id='footer-sec1' name='Widget 1'><div class='widget LinkList' data-version='1' id='LinkList1'>
<h2>Linux Uprising</h2>
<div class='widget-content'>
<ul>
<li><a href='https://www.linuxuprising.com/p/contact.html'>Contact</a></li>
<li><a href='https://www.linuxuprising.com/p/about.html'>About</a></li>
<li><a href='https://www.linuxuprising.com/p/terms-of-use.html'>Terms of Service</a></li>
<li><a href='https://www.linuxuprising.com/p/cookie-policy.html'>Cookie Information</a></li>
<li><a href='https://www.linuxuprising.com/p/privacy-policy.html'>Privacy Policy</a></li>
</ul>
</div>
</div><div class='widget HTML' data-version='2' id='HTML47'>
<div class='widget-content'>
<a class="change-consent" onclick="window.__cmp('displayConsentUi');">Cookie Settings</a>
</div>
</div></div>
<div class='sect-left section' id='footer-sec2' name='Widget 2'><div class='widget FollowByEmail' data-version='1' id='FollowByEmail1'>
<h2 class='title'>Follow by Email</h2>
<div class='widget-content'>
<div class='follow-by-email-inner'>
<form action='https://feedburner.google.com/fb/a/mailverify' method='post' onsubmit='window.open("https://feedburner.google.com/fb/a/mailverify?uri=LinuxUprising", "popupwindow", "scrollbars=yes,width=550,height=520"); return true' target='popupwindow'>
<table width='100%'>
<tr>
<td>
<label for='email'><input aria-label='email' class='follow-by-email-address' id='email' name='email' placeholder='Email address...' type='text'/></label>
</td>
<td width='64px'>
<input class='follow-by-email-submit' type='submit' value='Submit'/>
</td>
</tr>
</table>
<input name='uri' type='hidden' value='LinuxUprising'/>
<input name='loc' type='hidden' value='en_US'/>
</form>
</div>
</div>
<span class='item-control blog-admin'>
</span>
</div></div>
<div class='sect-left section' id='footer-sec3' name='Widget 3'><div class='widget BlogArchive' data-version='1' id='BlogArchive2'>
<h2>Blog Archive</h2>
<div class='widget-content'>
<div id='ArchiveList'>
<div id='BlogArchive2_ArchiveList'>
<label aria-label='archive-menu' for='BlogArchive2_ArchiveMenu'>
<select id='BlogArchive2_ArchiveMenu'>
<option value=''>Blog Archive</option>
<option value='https://www.linuxuprising.com/2019/08/'>August 2019 (2)</option>
<option value='https://www.linuxuprising.com/2019/07/'>July 2019 (22)</option>
<option value='https://www.linuxuprising.com/2019/06/'>June 2019 (18)</option>
<option value='https://www.linuxuprising.com/2019/05/'>May 2019 (19)</option>
<option value='https://www.linuxuprising.com/2019/04/'>April 2019 (20)</option>
<option value='https://www.linuxuprising.com/2019/03/'>March 2019 (16)</option>
<option value='https://www.linuxuprising.com/2019/02/'>February 2019 (17)</option>
<option value='https://www.linuxuprising.com/2019/01/'>January 2019 (21)</option>
<option value='https://www.linuxuprising.com/2018/12/'>December 2018 (15)</option>
<option value='https://www.linuxuprising.com/2018/11/'>November 2018 (24)</option>
<option value='https://www.linuxuprising.com/2018/10/'>October 2018 (22)</option>
<option value='https://www.linuxuprising.com/2018/09/'>September 2018 (15)</option>
<option value='https://www.linuxuprising.com/2018/08/'>August 2018 (27)</option>
<option value='https://www.linuxuprising.com/2018/07/'>July 2018 (26)</option>
<option value='https://www.linuxuprising.com/2018/06/'>June 2018 (21)</option>
<option value='https://www.linuxuprising.com/2018/05/'>May 2018 (31)</option>
<option value='https://www.linuxuprising.com/2018/04/'>April 2018 (25)</option>
<option value='https://www.linuxuprising.com/2018/03/'>March 2018 (1)</option>
</select>
</label>
</div>
</div>
</div>
</div></div>
</div>
</div>
<div class='clear'></div>
<div class='footer-wrapper'>
<div class='footer-sec row'>
<!-- Footer Social -->
<div class='social-footer section' id='social-footer' name='Social Footer'><div class='widget LinkList' data-version='1' id='LinkList20'>
<div class='widget-content'>
<ul>
<li><a class='rss' href='https://feeds.feedburner.com/LinuxUprising' rel='noreferrer' target='_blank' title='rss'></a></li>
<li><a class='friendica' href='https://libranet.de/profile/linuxuprising' rel='noreferrer' target='_blank' title='friendica'></a></li>
<li><a class='twitter' href='https://twitter.com/linuxuprising' rel='noreferrer' target='_blank' title='twitter'></a></li>
<li><a class='telegram' href='https://t.me/LinuxUprising' rel='noreferrer' target='_blank' title='telegram'></a></li>
<li><a class='facebook' href='https://www.facebook.com/LinuxUprising/' rel='noreferrer' target='_blank' title='facebook'></a></li>
<li><a class='reddit' href='https://www.reddit.com/r/LinuxUprising/' rel='noreferrer' target='_blank' title='reddit'></a></li>
</ul>
</div>
</div></div>
<!-- Footer Copyright -->
<div class='copyright'>
License: <a href='https://creativecommons.org/licenses/by-nc/4.0/' rel='license nofollow noreferrer' target='_blank'>CC BY-NC 4.0</a>
<a href='https://www.linuxuprising.com'>Linux Uprising</a>. <br/>The registered trademark Linux&#174; is used pursuant to a sublicense from the Linux Foundation, the exclusive licensee of Linus Torvalds, owner of the mark on a world&#173;wide basis.
</div>
</div>
</div>
</div>
<script type='text/javascript'>    
//<![CDATA[

$(document).ready((function() {
    $('pre.cssterm','#post-article').each((function() {
        $(this).attr('title','Triple click to select a complete line!');
    }));
}));

            // Lazyload
            (function(a){a.fn.lazyload=function(b){var c={threshold:0,failurelimit:0,event:"scroll",effect:"show",container:window};if(b){a.extend(c,b)}var d=this;if("scroll"==c.event){a(c.container).bind("scroll",function(b){var e=0;d.each(function(){if(a.abovethetop(this,c)||a.leftofbegin(this,c)){}else if(!a.belowthefold(this,c)&&!a.rightoffold(this,c)){a(this).trigger("appear")}else{if(e++>c.failurelimit){return false}}});var f=a.grep(d,function(a){return!a.loaded});d=a(f)})}this.each(function(){var b=this;if(undefined==a(b).attr("original")){a(b).attr("original",a(b).attr("src"))}if("scroll"!=c.event||undefined==a(b).attr("src")||c.placeholder==a(b).attr("src")||a.abovethetop(b,c)||a.leftofbegin(b,c)||a.belowthefold(b,c)||a.rightoffold(b,c)){if(c.placeholder){a(b).attr("src",c.placeholder)}else{a(b).removeAttr("src")}b.loaded=false}else{b.loaded=true}a(b).one("appear",function(){if(!this.loaded){a("<img />").bind("load",function(){a(b).hide().attr("src",a(b).attr("original"))[c.effect](c.effectspeed);b.loaded=true}).attr("src",a(b).attr("original"))}});if("scroll"!=c.event){a(b).bind(c.event,function(c){if(!b.loaded){a(b).trigger("appear")}})}});a(c.container).trigger(c.event);return this};a.belowthefold=function(b,c){if(c.container===undefined||c.container===window){var d=a(window).height()+a(window).scrollTop()}else{var d=a(c.container).offset().top+a(c.container).height()}return d<=a(b).offset().top-c.threshold};a.rightoffold=function(b,c){if(c.container===undefined||c.container===window){var d=a(window).width()+a(window).scrollLeft()}else{var d=a(c.container).offset().left+a(c.container).width()}return d<=a(b).offset().left-c.threshold};a.abovethetop=function(b,c){if(c.container===undefined||c.container===window){var d=a(window).scrollTop()}else{var d=a(c.container).offset().top}return d>=a(b).offset().top+c.threshold+a(b).height()};a.leftofbegin=function(b,c){if(c.container===undefined||c.container===window){var d=a(window).scrollLeft()}else{var d=a(c.container).offset().left}return d>=a(b).offset().left+c.threshold+a(b).width()};a.extend(a.expr[":"],{"below-the-fold":"$.belowthefold(a, {threshold : 0, container: window})","above-the-fold":"!$.belowthefold(a, {threshold : 0, container: window})","right-of-fold":"$.rightoffold(a, {threshold : 0, container: window})","left-of-fold":"!$.rightoffold(a, {threshold : 0, container: window})"})})(jQuery);$(function(){$("img").lazyload({placeholder:"https://1.bp.blogspot.com/-zfTgNA4ZsX0/XR0aQA2GyiI/AAAAAAAADAA/JOjs9ZVsMvA7aIt4bXkH5AqiJK_xkIDUwCLcBGAs/s1600/pixel.gif",effect:"fadeIn",threshold:"-50"})});

$("#related-posts").each((function() {
    var g = $(this).html();
    var title = $("#entry-title").text().trim();
    $.ajax({
        url: "/feeds/posts/default/-/" + g + "?alt=json-in-script&max-results=" + related_number,
        type: 'get',
        cache: true,
        dataType: "jsonp",
        success: function(data) {
            var posturl = "";
            var htmlcode = '<div class="related"><ul>';
            for (var i = 0; i < data.feed.entry.length; i++) {
              var s = data.feed.entry[i].title.$t.trim();
              if (s !== title) {
                for (var j = 0; j < data.feed.entry[i].link.length; j++) {
                    if (data.feed.entry[i].link[j].rel == "alternate") {
                            posturl = data.feed.entry[i].link[j].href;
                            break
                    }
                }

                var posttitle = data.feed.entry[i].title.$t;

                if (!data.feed.entry[i].media$thumbnail) {
                    var thumb = '<a title="' + posttitle +'" class="related-img" href="' + posturl + '" style="background:url(' + no_image_url + ') no-repeat center center;background-size: cover"/>'                
                } else {
                    var src = data.feed.entry[i].media$thumbnail.url.split(/s72-c/).join("s320");
                    var thumb = '<a title="' + posttitle +'" class="related-img" href="' + posturl + '" style="background:url(' + src + ') no-repeat center center;background-size: cover"/>'                
                }

                htmlcode += '<li><div class="related-thumb">' + thumb + '</div><h3 class="related-title"><a href="' + posturl + '">' + posttitle + '</a></h3></li>'
            }
            }
            htmlcode += '</ul></div><div class="clear"/>';
            $("#related-posts").html(htmlcode);


        }
    })
}));

//]]>
</script>
<script type='text/javascript'>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</script>
</div>
<script type='text/javascript'>
!function(e,n,t){"use strict";var o="https://cdn.jsdelivr.net/npm/fork-awesome@1.1.3/css/fork-awesome.min.css",r="__3perf_googleFonts_dcfa3";function c(e){(n.head||n.body).appendChild(e)}function a(){var e=n.createElement("link");e.href=o,e.rel="stylesheet",c(e)}function f(e){if(!n.getElementById(r)){var t=n.createElement("style");t.id=r,c(t)}n.getElementById(r).innerHTML=e}e.FontFace&&e.FontFace.prototype.hasOwnProperty("display")?(t[r]&&f(t[r]),fetch(o).then(function(e){return e.text()}).then(function(e){return e.replace(/@font-face{/g,"@font-face{font-display:swap;")}).then(function(e){return e.replace(/\.\.\/fonts\//g,"https:\/\/cdn\.jsdelivr\.net\/npm\/fork-awesome@1\.1\.3\/fonts\/")}).then(function(e){return t[r]=e}).then(f).catch(a)):a()}(window,document,localStorage);
</script>
<noscript><link href='https://cdn.jsdelivr.net/npm/fork-awesome@1.1.3/css/fork-awesome.min.css' rel='stylesheet'/></noscript>
<div class='back-to-top'>
<a href='#' id='back-to-top' title='back to top'>
<i class='fa fa-long-arrow-up'></i>
</a>
</div>

<script type="text/javascript" src="https://www.blogger.com/static/v1/widgets/3680708148-widgets.js"></script>
<script type='text/javascript'>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</script>
</body>
</html>