<!DOCTYPE html>
<html dir='ltr' lang='en-US' xmlns='http://www.w3.org/1999/xhtml' xmlns:b='http://www.google.com/2005/gml/b' xmlns:data='http://www.google.com/2005/gml/data' xmlns:expr='http://www.google.com/2005/gml/expr'>
<head><meta charset='utf-8'/>
<script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>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</script><script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>__ez.pel=(function(){var pixels=[],pxURL="/porpoiseant/army.gif";function AddAndFirePixel(adSlot,pixelData){AddPixel(adSlot,pixelData,0,0,0,0,0);Fire();}
function AddAndFireOrigPixel(adSlot,pixelData){AddPixel(adSlot,pixelData,0,0,0,0,0,true);Fire();}
function GetCurrentPixels(){return pixels;}
function AddPixel(adSlot,pixelData,revenue,est_revenue,bid_floor_filled,bid_floor_prev,stat_source_id,isOrig){if(!__ez.dot.isDefined(adSlot)||__ez.dot.isAnyDefined(adSlot.getSlotElementId,adSlot.ElementId)==false){return;}
var ad_position_id=parseInt(__ez.dot.getTargeting(adSlot,'ap'));var impId=__ez.dot.getSlotIID(adSlot),adUnit=__ez.dot.getAdUnit(adSlot,isOrig);var compId=parseInt(__ez.dot.getTargeting(adSlot,"compid"));var lineItemId=0;var creativeId=0;var ezimData=getEzimData(adSlot);if(typeof ezimData=='object'){if(ezimData.creative_id!==undefined){creativeId=ezimData.creative_id;}
if(ezimData.line_item_id!==undefined){lineItemId=ezimData.line_item_id;}}
if(__ez.dot.isDefined(impId,adUnit)&&__ez.dot.isValid(pixelData)){pixels.push({type:"impression",impression_id:impId,domain_id:__ez.dot.getDID(),unit:adUnit,t_epoch:__ez.dot.getEpoch(0),revenue:revenue,est_revenue:est_revenue,ad_position:ad_position_id,ad_size:"",bid_floor_filled:bid_floor_filled,bid_floor_prev:bid_floor_prev,stat_source_id:stat_source_id,country_code:__ez.dot.getCC(),pageview_id:__ez.dot.getPageviewId(),comp_id:compId,line_item_id:lineItemId,creative_id:creativeId,data:__ez.dot.dataToStr(pixelData),is_orig:isOrig||__ez.template.isOrig,});}}
function AddPixelById(impFullId,pixelData,isOrig){var vals=impFullId.split('/');if(__ez.dot.isDefined(impFullId)&&vals.length===3&&__ez.dot.isValid(pixelData)){var adUnit=vals[0],impId=vals[2];pixels.push({type:"impression",impression_id:impId,domain_id:__ez.dot.getDID(),unit:adUnit,t_epoch:__ez.dot.getEpoch(0),pageview_id:__ez.dot.getPageviewId(),data:__ez.dot.dataToStr(pixelData),is_orig:isOrig||__ez.template.isOrig});}}
function Fire(){if(typeof document.visibilityState!=='undefined'&&document.visibilityState==="prerender")return;if(__ez.dot.isDefined(pixels)&&pixels.length>0){var allPixels=[pixels.filter(pixel=>pixel.is_orig),pixels.filter(pixel=>!pixel.is_orig)];allPixels.forEach(pixels=>{while(pixels.length>0){var isOrig=pixels[0].is_orig||false;var j=5;if(j>pixels.length){j=pixels.length;}
var pushPixels=pixels.splice(0,j);var pixelURL=__ez.dot.getURL(pxURL)+"?orig="+(isOrig===true?1:0)+"&sts="+btoa(JSON.stringify(pushPixels));if(typeof window.isAmp!=='undefined'&&isAmp&&typeof window._ezaq!=='undefined'&&_ezaq.hasOwnProperty("domain_id")){pixelURL+="&visit_uuid="+_ezaq['visit_uuid'];}
(new Image()).src=pixelURL;}})}
pixels=[];}
function getEzimData(adSlot){if(typeof _ezim_d=="undefined"){return false}
var adUnitName=__ez.dot.getAdUnitPath(adSlot).split('/').pop();if(typeof _ezim_d==='object'&&_ezim_d.hasOwnProperty(adUnitName)){return _ezim_d[adUnitName];}
for(var ezimKey in _ezim_d){if(ezimKey.split('/').pop()===adUnitName){return _ezim_d[ezimKey];}}
return false;}
return{Add:AddPixel,AddAndFire:AddAndFirePixel,AddAndFireOrig:AddAndFireOrigPixel,AddById:AddPixelById,Fire:Fire,GetPixels:GetCurrentPixels,};})();__ez.queue.addFile('/detroitchicago/raleigh.js', '/detroitchicago/raleigh.js?gcb=191-0&cb=2', false, [], true, false, true, false);__ez.queue.addFile('/detroitchicago/tampa.js', '/detroitchicago/tampa.js?gcb=191-0&cb=1', false, [], true, false, true, false);</script>
<script data-ezscrex="false" data-cfasync="false">(function(){if("function"===typeof window.CustomEvent)return!1;window.CustomEvent=function(c,a){a=a||{bubbles:!1,cancelable:!1,detail:null};var b=document.createEvent("CustomEvent");b.initCustomEvent(c,a.bubbles,a.cancelable,a.detail);return b}})();</script><script data-ezscrex="false" data-cfasync="false">__ez.queue.addFile('/detroitchicago/tulsa.js', '/detroitchicago/tulsa.js?gcb=191-0&cb=2', false, [], true, false, true, false);</script>

<meta content='en-us' http-equiv='content-language'/>
<meta content='IE=edge' http-equiv='X-UA-Compatible'/>
<meta content='width=device-width,initial-scale=1.0' name='viewport'/>
<meta content='#f2132d' name='theme-color'/>
<meta content='#f2132d' name='msapplication-TileColor'/>
<meta content='#f2132d' name='msapplication-navbutton-color'/>
<link href='https://3.bp.blogspot.com/-_Rvl0I-6PsE/WxqOMWBSvFI/AAAAAAAAAr0/YVpbw6VxjTE0cs2FIG3JGGrzfelqF1AXQCLcBGAs/s1600-e120/apple-icon-180x180.png' rel='apple-touch-icon' sizes='180x180'/>
<link href='https://4.bp.blogspot.com/-C3SXpMZFwoM/WxqOMWPcqBI/AAAAAAAAAr4/q3BlIVZd9BIycvFtwpwee9ho2axmuey1wCLcBGAs/s1600-e120/android-icon-192x192.png' rel='icon' sizes='192x192' type='image/png'/>
<link href='https://1.bp.blogspot.com/-Rt0ksgLeHY8/XfJ5aMpjzZI/AAAAAAAADts/utsNBkpMNgoN82UZoo9EjfGponnDWZLIACLcBGAsYHQ/s1600-e120/favicon-large_32x32.png' rel='icon' sizes='32x32' type='image/png'/>
<meta content='text/html; charset=UTF-8' http-equiv='Content-Type'/>
<!-- Chrome, Firefox OS and Opera -->
<meta content='' name='theme-color'/>
<!-- Windows Phone -->
<meta content='' name='msapplication-navbutton-color'/>
<meta content='blogger' name='generator'/>
<link href='https://www.linuxuprising.com/favicon.ico' rel='icon' type='image/x-icon'/>
<link href='https://www.linuxuprising.com/2020/11/configure-logitech-steelseries-and.html' rel='canonical'/>
<link rel="alternate" type="application/atom+xml" title="Linux Uprising Blog - Atom" href="https://www.linuxuprising.com/feeds/posts/default" />
<link rel="alternate" type="application/rss+xml" title="Linux Uprising Blog - RSS" href="https://www.linuxuprising.com/feeds/posts/default?alt=rss" />
<link rel="service.post" type="application/atom+xml" title="Linux Uprising Blog - Atom" href="https://www.blogger.com/feeds/852161773840707483/posts/default" />

<link rel="alternate" type="application/atom+xml" title="Linux Uprising Blog - Atom" href="https://www.linuxuprising.com/feeds/6153335275471631874/comments/default" />
<!--Can't find substitution for tag [blog.ieCssRetrofitLinks]-->
<link href='https://1.bp.blogspot.com/-vX0D40OfMOE/X6U9FIGQ2PI/AAAAAAAAE4Q/THjP3Ay-QxYBtg_FT-ugYKL5cc9iqjteQCLcBGAsYHQ/s640/piper-configure-gaming-mice-linux.png' rel='image_src'/>
<meta content='Piper is a GTK application to configure some gaming mice on Linux. It allows changing the mouse resolution (DPI) and sensitivity (report rate), set wh' name='description'/>
<meta content='https://www.linuxuprising.com/2020/11/configure-logitech-steelseries-and.html' property='og:url'/>
<meta content='Configure Logitech, Steelseries And Other Gaming Mice On Linux Using Piper' property='og:title'/>
<meta content='Piper is a GTK application to configure some gaming mice on Linux. It allows changing the mouse resolution (DPI) and sensitivity (report rate), set wh' property='og:description'/>
<meta content='https://1.bp.blogspot.com/-vX0D40OfMOE/X6U9FIGQ2PI/AAAAAAAAE4Q/THjP3Ay-QxYBtg_FT-ugYKL5cc9iqjteQCLcBGAsYHQ/w1200-h630-p-k-no-nu/piper-configure-gaming-mice-linux.png' property='og:image'/>
<!--[if IE]> <script> (function() { var html5 = ("abbr,article,aside,audio,canvas,datalist,details," + "figure,footer,header,hgroup,mark,menu,meter,nav,output," + "progress,section,time,video").split(','); for (var i = 0; i < html5.length; i++) { document.createElement(html5[i]); } try { document.execCommand('BackgroundImageCache', false, true); } catch(e) {} })(); </script> <![endif]-->
<link href='https://fonts.gstatic.com' rel='dns-prefetch'/>
<link crossorigin='anonymous' href='https://fonts.gstatic.com' rel='preconnect'/>
<link href='https://cdn.jsdelivr.net' rel='dns-prefetch'/>
<link crossorigin='anonymous' href='https://cdn.jsdelivr.net' rel='preconnect'/>
<link crossorigin='crossorigin' href='https://fonts.googleapis.com' rel='preconnect'/>
<link crossorigin='crossorigin' href='https://ajax.googleapis.com' rel='preconnect'/>
<link crossorigin='crossorigin' href='https://www.google-analytics.com' rel='preconnect'/>
<link crossorigin='crossorigin' href='https://ssl.google-analytics.com' rel='preconnect'/>
<link crossorigin='crossorigin' href='https://apis.google.com' rel='preconnect'/>
<link crossorigin='crossorigin' href='https://googleads.g.doubleclick.net' rel='preconnect'/>
<link crossorigin='crossorigin' href='https://cdn.jsdelivr.net' rel='preconnect'/>
<link crossorigin='crossorigin' href='https://lh3.googleusercontent.com' rel='preconnect'/>
<link crossorigin='crossorigin' href='https://fonts.gstatic.com' rel='preconnect'/>
<link crossorigin='crossorigin' href='https://adservice.google.com' rel='preconnect'/>
<link crossorigin='crossorigin' href='https://www.googletagservices.com' rel='preconnect'/>
<link crossorigin='crossorigin' href='https://tpc.googlesyndication.com' rel='preconnect'/>
<link crossorigin='crossorigin' href='https://partner.googleadservices.com' rel='preconnect'/>
<link crossorigin='crossorigin' href='https://vendorlist.consensu.org' rel='preconnect'/>
<link crossorigin='crossorigin' href='https://cdnjs.cloudflare.com' rel='preconnect'/>
<link crossorigin='crossorigin' href='https://1.bp.blogspot.com' rel='preconnect'/>
<link crossorigin='crossorigin' href='https://2.bp.blogspot.com' rel='preconnect'/>
<link crossorigin='crossorigin' href='https://3.bp.blogspot.com' rel='preconnect'/>
<link crossorigin='crossorigin' href='https://4.bp.blogspot.com' rel='preconnect'/>
<link crossorigin='crossorigin' href='https://ib.adnxs.com' rel='preconnect'/>
<link crossorigin='crossorigin' href='https://bidder.criteo.com' rel='preconnect'/>
<link crossorigin='crossorigin' href='https://g.ezoic.net' rel='preconnect'/>
<link href='//linuxuprising.disqus.com' rel='preconnect'/>
<link href='//disqus.com' rel='dns-prefetch'/>
<link href='//c.disquscdn.com' rel='dns-prefetch'/>
<link href='//referrer.disqus.com' rel='dns-prefetch'/>
<link href='//juggler.services.disqus.com' rel='dns-prefetch'/>
<meta content='https://www.facebook.com/LinuxUprising' property='article:publisher'/>
<meta content='3F3C1DB7847EE7E64E8A2F6CDC5A5F10' name='msvalidate.01'/>
<meta content='de18aa7b281bff4c' name='yandex-verification'/>
<title>
Configure Logitech, Steelseries And Other Gaming Mice On Linux Using Piper - Linux Uprising Blog
</title>
<!-- Description and Keywords (start) -->
<meta content='en_US' property='og:locale'/>
<!-- Description and Keywords (end) -->
<meta content='article' property='og:type'/>
<meta content='Linux Uprising Blog' property='og:site_name'/>
<meta content='https://www.linuxuprising.com/' name='twitter:domain'/>
<meta content='Configure Logitech, Steelseries And Other Gaming Mice On Linux Using Piper' name='twitter:title'/>
<meta content='summary_large_image' name='twitter:card'/>
<meta content='https://1.bp.blogspot.com/-vX0D40OfMOE/X6U9FIGQ2PI/AAAAAAAAE4Q/THjP3Ay-QxYBtg_FT-ugYKL5cc9iqjteQCLcBGAsYHQ/s640/piper-configure-gaming-mice-linux.png' name='twitter:image'/>
<meta content='Piper is a GTK application to configure some gaming mice on Linux. It allows changing the mouse resolution (DPI) and sensitivity (report rate), set wh' name='twitter:description'/>
<!-- Social Media meta tag need customer customization -->
<meta content='572203406470374' property='fb:app_id'/>
<meta content='841352899' property='fb:admins'/>
<meta content='@linuxuprising' name='twitter:site'/>
<meta content='@linuxuprising' name='twitter:creator'/>
<!-- Disable default blogger Cookie Choice-->
<script type='text/javascript'>
    cookieChoices = {};
</script>
<!-- Set personalized or not for ads based on cookie consent info -->
<script>
var checkUserConsent;

    // fetch consent information
    function EzConsentCallback(consent) {
        // consent contains the necessary, preferences, statistics, and marketing properties with boolean values 
        if(consent.marketing) {
            // Consent given
            // Ezoic handles the requestNonPersonalizedAds thingy itself
            // (adsbygoogle=window.adsbygoogle||[]).requestNonPersonalizedAds=0;
            checkUserConsent = 'YES'; 
        } else {
            // No consent for personalized ads
            // (adsbygoogle=window.adsbygoogle||[]).requestNonPersonalizedAds=1;
            checkUserConsent = 'NO';
        }
    }
</script>
<!-- Google Analytics -->
<script type='text/javascript'>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');
  ga('create', 'UA-116578392-1', 'auto');
  if (checkUserConsent == 'NO') {
     ga('set', 'allowAdFeatures', false);
  }
  ga('set', 'anonymizeIp', true);
  ga('send', 'pageview');
</script>
<style id='page-skin-1' type='text/css'>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</style>
<style id='template-skin-1' type='text/css'><!--
/*------Layout (No Edit)----------*/
body#layout .row {width: 900px;}
body#layout #outer-wrapper{padding:0;width:900px}
body#layout .section h4{color:#333!important}
body#layout .theme-opt{overflow:hidden;     display: block!important;}
body#layout #option{overflow:hidden; display:block}
body#layout #option h4{font-size:16px;padding:4px 0 7px}
body#layout #option .widget{float:left;width:20%}
body#layout #option .widget.locked-widget .widget-content{background-color: #ff7575 !important;
border-color: #840000 !important;
color: #fff !important;}
body#layout #option .widget.locked-widget .widget-content a.editlink{color:#fff!important;border:1px solid;border-radius:2px;padding:2px 5px}
body#layout #topnav,body#layout .tm-head{height:auto}
body#layout .tm-menu{margin:0;width:70%}
body#layout .social-area{margin:0;width:30%}
body#layout .header-content,body#layout #header-blog{height:160px}
body#layout .header-logo{float:left;width:30%;margin:0;padding:0}
body#layout .header-ads{width:70%;margin:0}
body#layout .header-menu li.home-child{display:none}
body#layout .header-search,body#layout .m-rec{display:none}
body#layout .header-menu{float:left;width:100%;margin:4px 0 0;padding:0}
body#layout #content-wrapper{margin:0 auto}
body#layout .feat-layout .widget-content,body#layout .feat-layout h2.title,body#layout #ads-blog{display:block}
body#layout #main-wrapper{float:left;width:70%;margin:0;padding:0}
body#layout #ads-post10{display:block}
body#layout .sidebar-wrapper{float:right;width:30%;margin:0;padding:0}
body#layout #footer-wrapper{overflow:hidden}
body#layout .sect-left{width:28.3%;float:left}
body#layout #social-footer{width:30%;float:right}
/*------Layout (end)----------*/
--></style>
<style type='text/css'>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</style>
<noscript>
<style>
        #HTML1, #HTML2, #HTML3, #adsense-top-horiz {display:none;}
    </style>
</noscript>
<script type='text/javascript'> 
//<![CDATA[
var text_month = [, "Jan", "Feb", "Mar", "Apr", "May", "Jun", "Jul", "Aug", "Sept", "Oct", "Nov", "Dec"];
var no_image_url = "https://1.bp.blogspot.com/-dUVHHKr63sw/WrjkLAm4OkI/AAAAAAAAABU/SNBN1gIB8E0vLNWf41AGwudNCH1Q9hYYwCLcBGAs/s1600-r/nothumb.jpg";
var feat1_number = 3;
var related_number = 4;
//]]>
</script>
<script>
        (function () {
            var done = false;
            var script = document.createElement("script"),
            head = document.getElementsByTagName("head")[0] || document.documentElement;
            script.src = 'https://ajax.googleapis.com/ajax/libs/webfont/1.6.26/webfont.js';
            script.async = true;
            script.onload = script.onreadystatechange = function() {
                if ( ! done && ( ! this.readyState || this.readyState === "loaded" || this.readyState === "complete" ) ) {
                    done = true;
                    WebFont.load({
                        google: {
                            families: ['Ubuntu:300,300i,500,700&display=swap']
                        }
                    });
                    script.onload = script.onreadystatechange = null;
                }
            };
            head.insertBefore(script, head.firstChild);
        })();
    </script>
<noscript><link href='https://fonts.googleapis.com/css?family=Ubuntu:300,300i,500,700&display=swap' rel='stylesheet'/></noscript>
<script type='text/javascript'>
!function(e,n,t){"use strict";var o="https://cdn.jsdelivr.net/npm/fork-awesome@1.1.3/css/fork-awesome.min.css",r="__3perf_googleFonts_dcfa3";function c(e){(n.head||n.body).appendChild(e)}function a(){var e=n.createElement("link");e.href=o,e.rel="stylesheet",c(e)}function f(e){if(!n.getElementById(r)){var t=n.createElement("style");t.id=r,c(t)}n.getElementById(r).innerHTML=e}e.FontFace&&e.FontFace.prototype.hasOwnProperty("display")?(t[r]&&f(t[r]),fetch(o).then(function(e){return e.text()}).then(function(e){return e.replace(/@font-face{/g,"@font-face{font-display:swap;")}).then(function(e){return e.replace(/\.\.\/fonts\//g,"https:\/\/cdn\.jsdelivr\.net\/npm\/fork-awesome@1\.1\.3\/fonts\/")}).then(function(e){return t[r]=e}).then(f).catch(a)):a()}(window,document,localStorage);
</script>
<noscript><link href='https://cdn.jsdelivr.net/npm/fork-awesome@1.1.3/css/fork-awesome.min.css' rel='stylesheet'/></noscript>
<link href='https://www.blogger.com/dyn-css/authorization.css?targetBlogID=852161773840707483&amp;zx=e49db8bc-70b7-46a5-88ff-16820f5fce87' media='none' onload='if(media!=&#39;all&#39;)media=&#39;all&#39;' rel='stylesheet'/><noscript><link href='https://www.blogger.com/dyn-css/authorization.css?targetBlogID=852161773840707483&amp;zx=e49db8bc-70b7-46a5-88ff-16820f5fce87' rel='stylesheet'/></noscript>

<!-- data-ad-client=ca-pub-1997822342415050 -->


<script data-ezscrex="false" data-cfasync="false" type="text/javascript">window.google_analytics_uacct = "UA-124339592-32";</script>
<script data-ezscrex="false" data-cfasync="false" type="text/javascript">
var _gaq = _gaq || [];
_gaq.push(function(){
	_gat._createTracker('UA-124339592-32', 'e');
});
_gaq.push(function(){
	_gat._createTracker('UA-38339005-1', 'f');
});
_gaq.push(['e._setDomainName', 'linuxuprising.com']);
_gaq.push(['f._setDomainName', 'linuxuprising.com']);
_gaq.push(['e._setCustomVar',1,'template','old_site_gc',3]);
_gaq.push(['e._setCustomVar',2,'t','126',3]);
_gaq.push(['e._setCustomVar',3,'rid','0',2]);
_gaq.push(['e._setCustomVar',4,'bra','mod1',3]);
_gaq.push(['e._setAllowAnchor',true]);
_gaq.push(['e._setSiteSpeedSampleRate', 10]);
_gaq.push(['f._setCustomVar',1,'template','old_site_gc',3]);
_gaq.push(['f._setCustomVar',2,'domain','linuxuprising.com',3]);
_gaq.push(['f._setSiteSpeedSampleRate', 20]);
_gaq.push(['e._trackPageview']);
_gaq.push(['f._trackPageview']);


(function() {
 var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
 ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
 var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
})();
</script>
<script type="text/javascript">var ezouid = "1";</script><base href="https://www.linuxuprising.com/2020/11/configure-logitech-steelseries-and.html"><script type='text/javascript'>
var ezoTemplate = 'old_site_gc';
if(typeof ezouid == 'undefined')
{
    var ezouid = 'none';
}
var ezoFormfactor = '1';
var ezo_elements_to_check = Array();
</script><!-- START EZHEAD -->
<script data-ezscrex="false" type='text/javascript'>
var soc_app_id = '0';
var did = 131660;
var ezdomain = 'linuxuprising.com';
var ezoicSearchable = 1;
</script>
<!--{jquery}-->
<!-- END EZHEAD -->
<script data-ezscrex="false" type="text/javascript" data-cfasync="false">var _ezaq = {"ad_cache_level":0,"ad_lazyload_version":0,"city":"Ashburn","country":"US","days_since_last_visit":-1,"domain_id":131660,"domain_test_group":20200402,"engaged_time_visit":0,"ezcache_level":0,"forensiq_score":-1,"form_factor_id":1,"framework_id":1,"is_return_visitor":false,"is_sitespeed":0,"last_page_load":"","last_pageview_id":"","lt_cache_level":0,"metro_code":511,"page_ad_positions":"","page_view_count":0,"page_view_id":"f3729338-c40c-4086-4847-bf3f27726c88","position_selection_id":0,"postal_code":"20149","pv_event_count":0,"response_time_orig":178,"serverid":"3.235.226.138:11712","state":"VA","t_epoch":1604687646,"template_id":126,"time_on_site_visit":0,"url":"https://www.linuxuprising.com/2020/11/configure-logitech-steelseries-and.html","user_id":0,"word_count":1208,"worst_bad_word_level":0};var _ezExtraQueries = "&ez_orig=1";</script><script data-ezscrex='false' data-cfasync='false' type="text/javascript" src="/detroitchicago/rochester.js?cb=191-0&v=9" async></script>
<script data-ezscrex='false' data-pagespeed-no-defer data-cfasync='false'>
function create_ezolpl(pvID, rv) {
    var d = new Date();
    d.setTime(d.getTime() + (365*24*60*60*1000));
    var expires = "expires="+d.toUTCString();
    __ez.ck.setByCat("ezux_lpl_131660=" + new Date().getTime() + "|" + pvID + "|" + rv + "; " + expires, 3);
}
function attach_ezolpl(pvID, rv) {
    if (document.readyState === "complete") {
        create_ezolpl(pvID, rv);
    }
    if(window.attachEvent) {
        window.attachEvent("onload", create_ezolpl, pvID, rv);
    } else {
        if(window.onload) {
            var curronload = window.onload;
            var newonload = function(evt) {
                curronload(evt);
                create_ezolpl(pvID, rv);
            };
            window.onload = newonload;
        } else {
            window.onload = create_ezolpl.bind(null, pvID, rv);
        }
    }
}

__ez.queue.addFunc("attach_ezolpl", "attach_ezolpl", ["f3729338-c40c-4086-4847-bf3f27726c88", "false"], false, ['/detroitchicago/boise.js'], true, false, false, false);
</script></head>
<body class='item'>
<div class='theme-opt' style='display:none'>
<div class='option section' id='option' name='Theme Option'><div class='widget HTML' data-version='1' id='HTML103'>

<script type='text/javascript'> 
          //<![CDATA[
          var recentposts_number = 5;
          //]]>
         </script>
         
</div><div class='widget HTML' data-version='1' id='HTML104'>
<script type='text/javascript'> 
          //<![CDATA[
          var randomposts_number = 4;
          //]]>
         </script>
</div><div class='widget HTML' data-version='1' id='HTML105'>

         <script type='text/javascript'>
          var postperpage=12;
         </script>
         
</div><div class='widget HTML' data-version='1' id='HTML106'>
</div><div class='widget HTML' data-version='1' id='HTML851'>
<script src='https://ajax.googleapis.com/ajax/libs/jquery/2.2.4/jquery.min.js' type='text/javascript'></script>
<script type='text/javascript'> 
            //<![CDATA[

            // Plugin: Sticky jQuery ~ BY: https://stickyjs.com
            (function(e){var t={topSpacing:0,bottomSpacing:0,className:"is-sticky",wrapperClassName:"sticky-wrapper",center:false,getWidthFrom:"",responsiveWidth:false},n=e(window),r=e(document),i=[],s=n.height(),o=function(){var t=n.scrollTop(),o=r.height(),u=o-s,a=t>u?u-t:0;for(var f=0;f<i.length;f++){var l=i[f],c=l.stickyWrapper.offset().top,h=c-l.topSpacing-a;if(t<=h){if(l.currentTop!==null){l.stickyElement.css("width","").css("position","").css("top","");l.stickyElement.trigger("sticky-end",[l]).parent().removeClass(l.className);l.currentTop=null}}else{var p=o-l.stickyElement.outerHeight()-l.topSpacing-l.bottomSpacing-t-a;if(p<0){p=p+l.topSpacing}else{p=l.topSpacing}if(l.currentTop!=p){l.stickyElement.css("width",l.stickyElement.width()).css("position","fixed").css("top",p);if(typeof l.getWidthFrom!=="undefined"){l.stickyElement.css("width",e(l.getWidthFrom).width())}l.stickyElement.trigger("sticky-start",[l]).parent().addClass(l.className);l.currentTop=p}}}},u=function(){s=n.height();for(var t=0;t<i.length;t++){var r=i[t];if(typeof r.getWidthFrom!=="undefined"&&r.responsiveWidth===true){r.stickyElement.css("width",e(r.getWidthFrom).width())}}},a={init:function(n){var r=e.extend({},t,n);return this.each((function(){var n=e(this);var s=n.attr("id");var o=s?s+"-"+t.wrapperClassName:t.wrapperClassName;var u=e("<div></div>").attr("id",s+"-sticky-wrapper").addClass(r.wrapperClassName);n.wrapAll(u);if(r.center){n.parent().css({width:n.outerWidth(),marginLeft:"auto",marginRight:"auto"})}if(n.css("float")=="right"){n.css({"float":"none"}).parent().css({"float":"right"})}var a=n.parent();a.css("height",n.outerHeight());i.push({topSpacing:r.topSpacing,bottomSpacing:r.bottomSpacing,stickyElement:n,currentTop:null,stickyWrapper:a,className:r.className,getWidthFrom:r.getWidthFrom,responsiveWidth:r.responsiveWidth})}))},update:o,unstick:function(t){return this.each((function(){var t=e(this);var n=-1;for(var r=0;r<i.length;r++){if(i[r].stickyElement.get(0)==t.get(0)){n=r}}if(n!=-1){i.splice(n,1);t.unwrap();t.removeAttr("style")}}))}};if(window.addEventListener){window.addEventListener("scroll",o,false);window.addEventListener("resize",u,false)}else if(window.attachEvent){window.attachEvent("onscroll",o);window.attachEvent("onresize",u)}e.fn.sticky=function(t){if(a[t]){return a[t].apply(this,Array.prototype.slice.call(arguments,1))}else if(typeof t==="object"||!t){return a.init.apply(this,arguments)}else{e.error("Method "+t+" does not exist on jQuery.sticky")}};e.fn.unstick=function(t){if(a[t]){return a[t].apply(this,Array.prototype.slice.call(arguments,1))}else if(typeof t==="object"||!t){return a.unstick.apply(this,arguments)}else{e.error("Method "+t+" does not exist on jQuery.sticky")}};e((function(){setTimeout(o,0)}))})(jQuery);
            //]]>
          </script>
          <script type='text/javascript'> 
            //<![CDATA[
              $(document).ready(function(){$("#header-navigation").sticky({topSpacing:0});});
            //]]>
          </script>
        </div></div>
</div>

<div id="pages-wrap" class="item">

<div id='outer-wrapper'>
<div id='topnav'>
<div class='tm-head row'>
<div class='tm-menu'>
<div class='menu1 section' id='menu1' name='Top Navigation'><div class='widget LinkList' data-version='1' id='LinkList210'>
<div class='widget-content'>
<ul id='nav1'>
<li><a href='https://www.linuxuprising.com/p/about.html'>About</a></li>
<li><a href='https://www.reddit.com/r/LinuxUprising/' rel='noreferrer' target='_blank'>Submit A Tip</a></li>
</ul>
</div>
</div></div>
</div>
<!-- Top Social -->
<div class='social-area'>
<div class='social-top section' id='social-top' name='Social Top'><div class='widget LinkList' data-version='1' id='LinkList50'>
<div class='widget-content'>
<ul>
<li><a class='rss' href='https://feeds.feedburner.com/LinuxUprising' rel='noreferrer' target='_blank' title='rss'></a></li>
<li><a class='friendica' href='https://libranet.de/profile/linuxuprising' rel='noreferrer' target='_blank' title='friendica'></a></li>
<li><a class='twitter' href='https://twitter.com/linuxuprising' rel='noreferrer' target='_blank' title='twitter'></a></li>
<li><a class='telegram' href='https://t.me/LinuxUprising' rel='noreferrer' target='_blank' title='telegram'></a></li>
<li><a class='facebook' href='https://www.facebook.com/LinuxUprising/' rel='noreferrer' target='_blank' title='facebook'></a></li>
<li><a class='reddit' href='https://www.reddit.com/r/LinuxUprising/' rel='noreferrer' target='_blank' title='reddit'></a></li>
</ul>
</div>
</div></div>
</div>
</div>
</div>
<div id='header-blog'>
<div class='header-content row'>
<div class='header-logo'>
<div class='section' id='logo_blog' name='Logo'><div class='widget Header' data-version='1' id='Header1'>
<div id='header-inner'>
<h2 class='logo'>
<a href='https://www.linuxuprising.com/' style='display: block'>
<img alt='Linux Uprising Blog' height='23px; ' id='Header1_headerimg' src='https://cdn.rawgit.com/logix2/6fb43ed0a1979f24c50857fadc6de3ac/raw/24571f5df3fa6fadeeb0937ffd40ea38c380075f/logo2.svg' style='display: block' width='455px; '/>
</a>
<span class='alt-logo'>Linux Uprising blog</span>
</h2>
</div>
</div></div>
</div>
<!-- <div class='header-ads'> <b:section id='ads-content' maxwidgets='1' name='Ads 728x90' showaddelement='yes'> <b:widget id='HTML1' locked='false' title='' type='HTML'> <b:includable id='main'> <b:if cond='data:title != &quot;&quot;'> <h2 class='title'><data:title/></h2> </b:if> <div class='widget-content'> <data:content/> </div> </b:includable> </b:widget> </b:section> </div> -->
</div>
</div>
<nav class='row' id='header-navigation'>
<div class='nav-wrapper'>
<div class='nav-menu'>
<div class='header-search'>
<ul>
<li>
<a class='search' id='search'>
<form action='/search/max-results=12' method='get'>
<input id='s' name='q' placeholder='Type and hit enter...' type='text'/>
</form>
</a>
</li>
</ul>
</div>
<div class='header-menu'>
<ul>
<li class='home-child'><a href='https://www.linuxuprising.com/'>Home</a></li>
</ul>
<div class='menu section' id='menu' name='Main Menu'><div class='widget LinkList' data-version='1' id='LinkList110'>
<div class='widget-content'>
<ul id='nav' itemscope='' itemtype='https://schema.org/SiteNavigationElement'>
<li itemprop='name'><a href='https://www.linuxuprising.com/search/label/news?max-results=12' itemprop='url'>News</a></li>
<li itemprop='name'><a href='https://www.linuxuprising.com/search/label/apps?max-results=12' itemprop='url'>Applications</a></li>
<li itemprop='name'><a href='https://www.linuxuprising.com/search/label/how-to?max-results=12' itemprop='url'>Tutorials</a></li>
<li itemprop='name'><a href='https://www.linuxuprising.com/search/label/tweaks?max-results=12' itemprop='url'>Tweaks</a></li>
<li itemprop='name'><a href='https://www.linuxuprising.com/search/label/customization?max-results=12' itemprop='url'>Themes & More</a></li>
<li itemprop='name'><a href='https://www.linuxuprising.com/search/label/console?max-results=12' itemprop='url'>Console</a></li>
</ul>
</div>
</div></div>
</div>
</div>
</div>
</nav>
<div class='clear'></div>
<div class='row' id='content-wrapper'>
<div id='main-wrapper'>
<div id='ads-blog'>
<div class='home-ad no-items section' id='ads-home' name='Ads Home/Post (728x90)'>
</div>
</div>
<div class='main section' id='main' name='Main Wrapper'><div class='widget Blog' data-version='1' id='Blog1'>
<div class='blog-posts hfeed'>
<div class='post-outer' id='post-outer'>
<div class='post' id='post-article'>

    <div itemprop='blogPost' itemscope='itemscope' itemtype='https://schema.org/Article'>
            <meta content='data:post.link : data:post.url' itemType='https://schema.org/WebPage' itemid='' itemprop='mainEntityOfPage' itemscope='itemscope'/>
<div itemprop='publisher' itemscope='itemscope' itemtype='https://schema.org/Organization'>
<div itemprop='logo' itemscope='itemscope' itemtype='https://schema.org/ImageObject'>
<meta content='https://4.bp.blogspot.com/-OlFvIO7s2mM/WrzEk1hCVZI/AAAAAAAAAE0/H4meMs7XreskNd_mTgVtNREkBX08-O1CACK4BGAYYCw/s590-e120/LUR_logo1.png' itemprop='url'/>
<meta content='455' itemprop='width'/>
<meta content='48' itemprop='height'/>
</div>
<meta content='Linux Uprising Blog' itemprop='name'/>
</div>
<meta content='https://1.bp.blogspot.com/-vX0D40OfMOE/X6U9FIGQ2PI/AAAAAAAAE4Q/THjP3Ay-QxYBtg_FT-ugYKL5cc9iqjteQCLcBGAsYHQ/s640/piper-configure-gaming-mice-linux.png' itemprop='image'/>
<div class='post-header'>
<div id='adsense-top-horiz'>
<div id='ezoic-pub-ad-placeholder-103'>
</div>
</div>
<div class='post-head'><h1 class='post-title entry-title' id='entry-title' itemprop='name headline'>
Configure Logitech, Steelseries And Other Gaming Mice On Linux Using Piper
</h1></div>
<div class='post-meta'>
<span class='post-author vcard'>
<i class='fa fa-user'></i>
<span class='fn' itemprop='author' itemscope='itemscope' itemtype='https://schema.org/Person'>
<meta content='https://www.blogger.com/profile/03026963810377267607' itemprop='url'/>
<a class='g-profile' href='https://www.blogger.com/profile/03026963810377267607' rel='author' title='Logix'>
<span itemprop='name'>Logix</span>
</a>
</span>
</span>
<span class='post-timestamp'>
<i class='fa fa-clock-o'></i>
<meta content='https://www.linuxuprising.com/2020/11/configure-logitech-steelseries-and.html' itemprop='url'/>
          Updated on <a class='timestamp-link' href='https://www.linuxuprising.com/2020/11/configure-logitech-steelseries-and.html' rel='bookmark' title='permanent link'><time class='updated timeago' datetime='2020-11-06T12:53:03Z' title='2020-11-06T12:53:03Z'><span id='updatedateinfo'>2020-11-06T12:53:03Z</span></time></a>
<script>
            var dates = "2020-11-06T12:53:03Z"
            var dateu = new Date(dates);
            var months = ["January","February","March","April","May","June","July","August","September","October","November","December"];
            document.getElementById("updatedateinfo").innerHTML = months[dateu.getMonth()] + " " + dateu.getDate() + ", " + dateu.getFullYear();
        </script>
<meta content='2020-11-06T12:53:03Z' itemprop='dateModified'/>
<meta content='2020-11-06T12:44:00Z' itemprop='datePublished'/>
</span>
<span class='label-head'>
<i class='fa fa-folder-open-o'></i>
<a href='https://www.linuxuprising.com/search/label/apps?max-results=12' rel='tag'>apps</a>
</span>
</div>
<div class='ads-posting'>
<div id='ezoic-pub-ad-placeholder-107'></div>
</div>
</div>
<article>
<div class='post-body entry-content' id='post-body-6153335275471631874' itemprop='articleBody'>
<meta content='I recently got a new mouse, and I searched for a way to configure it under Linux. The mouse is a Logitech G102. In most places, Solaar  is t...' name='twitter:description'/>
<p>I recently got a new mouse, and I searched for a way to configure it under Linux. The mouse is a Logitech G102. In most places, <a href="https://pwr-solaar.github.io/Solaar/" target="_blank">Solaar</a> is the recommended go-to software to configure Logitech mice (and other Logitech devices like keyboards or trackpads) on Linux, but it doesn't seem to support my G102, as I'm getting an error saying&nbsp; "No Logitech receiver found".</p><p>After some digging I discovered that "Solaar will detect all devices paired with your Unifying, Lightspeed, or Nano receiver, and at the very least display some basic information about them. Solaar will detect some Logitech devices that connect via a USB cable or Bluetooth". So it seems that Solaar is <i>mostly</i> for Logitech devices that use a USB receiver.</p><table align="center" cellpadding="0" cellspacing="0" class="tr-caption-container" style="margin-left: auto; margin-right: auto;"><tbody><tr><td style="text-align: center;"><a href="https://1.bp.blogspot.com/-vX0D40OfMOE/X6U9FIGQ2PI/AAAAAAAAE4Q/THjP3Ay-QxYBtg_FT-ugYKL5cc9iqjteQCLcBGAsYHQ/s1012/piper-configure-gaming-mice-linux.png" style="margin-left: auto; margin-right: auto;"><img alt="Piper configure gaming mice Linux" border="0" data-original-height="687" data-original-width="1012" height="434" src="https://1.bp.blogspot.com/-vX0D40OfMOE/X6U9FIGQ2PI/AAAAAAAAE4Q/THjP3Ay-QxYBtg_FT-ugYKL5cc9iqjteQCLcBGAsYHQ/s640/piper-configure-gaming-mice-linux.png" title="Piper configure gaming mice Linux" width="640" /></a></td></tr><tr><td class="tr-caption" style="text-align: center;">Piper<br /></td></tr></tbody></table><br /><p><b>So I had to look elsewhere, and that's how I <a href="https://www.reddit.com/r/linux/comments/fl32cv/configure_mouse_rgb_buttons_and_dpi_in_linux_with/" rel="nofollow" target="_blank">found</a> out about <a href="https://github.com/libratbag/piper" target="_blank">Piper</a>, a GTK application to configure gaming mice on Linux (using <a href="https://github.com/libratbag/libratbag" target="_blank">libratbag</a>,&nbsp;a DBus daemon to configure input devices, mainly gaming mice). It supports devices from Logitech,&nbsp;Etekcity, G.Skill, Roccat, Nubwo and Steelseries, like:</b></p><p></p><ul style="text-align: left;"><li><span><a name='more'></a></span>Logitech G602, G502 Hero / Hero Wireless / Proteus Core / Proteus Spectrum, G903, G903 Hero, G Pro, G Pro Wireless, G102, G204, G300, G3002, G303, G402, G403, G403 Hero / Wireless and many more</li><li>Roccat Kone Pure and Kone XTD</li><li>Steelseries Kinzu v2, Kinzu v2 Pro, Kinzu v3, Rival, Rival 310 / 600 and Sensei Raw / 310</li><li>Etekcity Scroll Alpha</li><li>Nubwo X7 Spectrum</li><li>Glorious Model D and Model O</li><li>G.Skill MX780</li></ul><p><b>The list of supported mice is constantly growing, so check out the <a href="https://github.com/libratbag/libratbag/tree/master/data/devices" rel="nofollow" target="_blank">complete list</a>.</b></p><p>Feature-wise, Piper supports the following:</p><p></p><ul style="text-align: left;"><li><b>set the mouse sensitivity (report rate) and resolutions (DPI)</b></li><li><b>configure mouse buttons (including macros, if supported by the device)</b></li><li><b>configure LED colors</b></li><li><b>custom mouse profiles</b></li></ul><p></p><p>I only know about the profiles feature from the Piper screenshots available on its project page, because that button is missing in my case (I'm using the latest Piper, so I guess it's due to my mouse not supporting it).</p><p>Here are some screenshots with the Piper Buttons and LEDs settings:</p><div class="separator" style="clear: both; text-align: center;"><a href="https://1.bp.blogspot.com/-y9XyweYAm0k/X6U9WhtFcHI/AAAAAAAAE4c/NsVztuE94AIUNkwuoUvJKvVuqOXGAMdyACLcBGAsYHQ/s1206/piper-macros.png" style="margin-left: 1em; margin-right: 1em;"><img alt="Piper configure Logitech mouse macros Linux" border="0" data-original-height="780" data-original-width="1206" height="414" src="https://1.bp.blogspot.com/-y9XyweYAm0k/X6U9WhtFcHI/AAAAAAAAE4c/NsVztuE94AIUNkwuoUvJKvVuqOXGAMdyACLcBGAsYHQ/w640-h414/piper-macros.png" title="Piper configure Logitech mouse macros Linux" width="640" /></a></div><br /><div class="separator" style="clear: both; text-align: center;"><a href="https://1.bp.blogspot.com/-3rlmxqRIvmc/X6U9WniI2GI/AAAAAAAAE4Y/3_jRAMVMe1w3EW4v4d7ZkF4rFHwzRg98gCLcBGAsYHQ/s1012/piper-leds.png" style="margin-left: 1em; margin-right: 1em;"><img alt="Piper configure mouse LEDs Linux" border="0" data-original-height="687" data-original-width="1012" height="434" src="https://1.bp.blogspot.com/-3rlmxqRIvmc/X6U9WniI2GI/AAAAAAAAE4Y/3_jRAMVMe1w3EW4v4d7ZkF4rFHwzRg98gCLcBGAsYHQ/w640-h434/piper-leds.png" title="Piper configure mouse LEDs Linux" width="640" /></a></div><br /><p>So far the application has worked great to tweak my Logitech G102 mouse on my Ubuntu 20.10 desktop, but I do have some complaints. For starters, it doesn't have a tray icon, which could be very helpful to see the current DPI for example, or change profiles (if I could use those).&nbsp;</p><p>Piper also doesn't notify you in any way when changing the DPI using the assigned mouse button(s). What's more, the Piper user interface doesn't correctly show the active DPI when changing it using the assigned mouse button, even after restarting the application.</p><p>By the way, if you have a gaming mouse on Linux, you'll want to disable mouse acceleration, especially if you play FPS games. See <a href="https://www.linuxuprising.com/2018/09/how-to-disable-mouse-acceleration-in.html">this article</a> for how to disable mouse acceleration in Ubuntu / GNOME.</p><br /><h2>Install Piper to configure gaming mice on Linux</h2><br /><p>Piper should be available in the official repositories for most Linux distributions. Install it using:</p><p></p><ul style="text-align: left;"><li><b>Debian buster (backports), bullseye and sid / Ubuntu 20.04 and 20.10 / Linux Mint 20 / Pop!_OS 20.04 and 20.10 / Zorin OS and other Debian or Ubuntu-based Linux distributions:</b></li></ul><pre class="cssterm"><code>sudo apt install piper</code></pre><p></p><ul style="text-align: left;"><li><b>Fedora:</b></li></ul><pre class="cssterm"><code>sudo dnf install piper</code></pre><p></p><ul style="text-align: left;"><li><b>Arch Linux / Manjaro:</b></li></ul><pre class="cssterm"><code>sudo pacman -S piper</code></pre><p></p><ul style="text-align: left;"><li><b>openSUSE:</b></li></ul><pre class="cssterm"><code>sudo zypper install piper</code></pre><p></p><p>For Ubuntu, Linux Mint and Pop!_OS users there's also a <a href="https://launchpad.net/~libratbag-piper/+archive/ubuntu/piper-libratbag-git" rel="nofollow" target="_blank">PPA</a> that has the latest Piper and libratbag from Git, in case you need to use a version newer than the one available in the repositories. The PPA also has packages for older Ubuntu versions, like 18.04 (Bionic).</p><p>I can't list every single Linux distribution here, so if you use some other distro, search for Piper in the repositories and install it from there.</p><p><b>Piper is also <a href="https://flathub.org/apps/details/org.freedesktop.Piper" rel="nofollow" target="_blank">available to install from Flathub</a>, and from there you can install it on most Linux distributions. </b>In case Piper / libratbag added support for your mouse only recently (see the list of <a href="https://github.com/libratbag/libratbag/tree/master/data/devices" rel="nofollow" target="_blank">supported mice</a>), and you're using an old version of Piper / libratbag, install the Piper Flahub package.</p><p>To install Piper from Flathub&nbsp;you'll need to install Flatpak and add the Flathub repository. You can find instructions for how to do this on the Flathub <a href="https://flatpak.org/setup/" rel="nofollow" target="_blank">quick setup</a> page. You only need to setup Flatpak and Flathub once. After that you'll be able to take advantage of the large application database it offers for installation with minor effort.</p><p>After setting up Flatpak and Flathub, head to the <a href="https://flathub.org/apps/details/org.freedesktop.Piper" rel="nofollow" target="_blank">Piper Flathub page</a> and click the install button. If you're a Gnome user, you can also search for it on Gnome Software / Ubuntu Software and install it from there.&nbsp;If you're a Gnome user, you can also search for it on Gnome Software and install it from there.</p><p>You may also install Piper from Flathub on Linux by using this command:</p><pre class="cssterm"><code>flatpak install flathub org.freedesktop.Piper</code></pre><br /><p>You might like:</p><ul style="text-align: left;"><li><a href="https://www.linuxuprising.com/2020/03/how-to-record-and-play-mouse-and.html"><b>How To Record And Play Mouse And Keyboard Events Using Atbswp Macro Recorder (GUI)</b></a></li><li><a href="https://www.linuxuprising.com/2019/11/how-to-bind-mouse-buttons-to-keyboard.html"><b>How To Bind Mouse Buttons To Keyboard Keys Or Commands (Linux Using X11)</b></a></li></ul>
</div>
</article>
<div style='clear:both'></div>
<div class='post-footer'>
<div class='share-box'>
<h8 class='share-title'>Share This:</h8>
<div class='share-art'>
<a class='fac-art' href='https://www.facebook.com/sharer.php?u=https://www.linuxuprising.com/2020/11/configure-logitech-steelseries-and.html&title=Configure Logitech, Steelseries And Other Gaming Mice On Linux Using Piper' onclick='window.open(this.href, &#39;windowName&#39;, &#39;width=600, height=400, left=24, top=24, scrollbars, resizable&#39;); return false;' rel='nofollow noreferrer' target='_blank' title='Facebook'><i class='fa fa-facebook'></i><span class='resp_del'> Facebook</span></a>
<a class='twi-art' href='https://twitter.com/share?url=https://www.linuxuprising.com/2020/11/configure-logitech-steelseries-and.html&title=Configure Logitech, Steelseries And Other Gaming Mice On Linux Using Piper' onclick='window.open(this.href, &#39;windowName&#39;, &#39;width=600, height=400, left=24, top=24, scrollbars, resizable&#39;); return false;' rel='nofollow noreferrer' target='_blank' title='Twitter'><i class='fa fa-twitter'></i><span class='resp_del2'> Twitter</span></a>
<a class='dis-art' href='https://sharetodiaspora.github.io/?url=https://www.linuxuprising.com/2020/11/configure-logitech-steelseries-and.html&title=Configure Logitech, Steelseries And Other Gaming Mice On Linux Using Piper' onclick='window.open(this.href, &#39;windowName&#39;, &#39;width=770, height=500, left=24, top=24, scrollbars, resizable&#39;); return false;' rel='nofollow noreferrer' target='_blank' title='Diaspora'><i class='fa fa-diaspora'></i><span class='resp_del3'> Diaspora</span></a>
<a class='redd-art' href='https://www.reddit.com/submit?url=https://www.linuxuprising.com/2020/11/configure-logitech-steelseries-and.html&title=Configure Logitech, Steelseries And Other Gaming Mice On Linux Using Piper' onclick='window.open(this.href, &#39;windowName&#39;); return false;' rel='nofollow noreferrer' target='_blank' title='Reddit'><i class='fa fa-reddit-alien'></i><span class='resp_del4'> Reddit</span></a>
<a class='tel-art' href='https://telegram.me/share/url?text=Configure Logitech, Steelseries And Other Gaming Mice On Linux Using Piper&tags=&url=https://www.linuxuprising.com/2020/11/configure-logitech-steelseries-and.html' onclick='window.open(this.href, &#39;windowName&#39;, &#39;width=600, height=400, left=24, top=24, scrollbars, resizable&#39;); return false;' rel='nofollow noreferrer' target='_blank' title='Telegram'><i class='fa fa-telegram'></i><span class='resp_del5'> Telegram</span></a>
<a class='wat-art' data-action='share/whatsapp/share' href='whatsapp://send?text=Configure Logitech, Steelseries And Other Gaming Mice On Linux Using Piper https://www.linuxuprising.com/2020/11/configure-logitech-steelseries-and.html' onclick='window.open(this.href, &#39;windowName&#39;, &#39;width=600, height=400, left=24, top=24, scrollbars, resizable&#39;); return false;' rel='nofollow noreferrer' target='_blank' title='WhatsApp'><i class='fa fa-whatsapp'></i><span class='resp_del6'> WhatsApp</span></a>
</div>
</div>
<div style='clear:both'></div>
<div class='ads-post'>
<a name='ads-post-in'></a>
</div>
<div id='related-posts'>
apps
</div>
<div class='under-related'>
<div id='ezoic-pub-ad-placeholder-105'></div>
</div>
<div class='clear'></div>
<div class='comment-notif-box'>Please post civil and on-topic comments. <a href='https://www.linuxuprising.com/p/commenting-guidelines.html' rel='nofollow'>Commenting guidelines</a>.</div>
</div>
<div id='disqus_thread_load_on_scroll'>
<div id='disqus_empty' style='display: none'>Empty</div>
</div>

      </div>
    
</div>
<div class='comments' id='comments'>
<a name='comments'></a>
<div id='backlinks-container'>
<div id='Blog1_backlinks-container'>
</div>
</div>
</div>
</div>
</div>
<div class='post-feeds'>
</div>
</div></div>
<div id='ads-post10'>
<div class='no-items section' id='ads-post-468' name='ADS Inner Footer 728x90'>
</div>
</div>
</div>
<div class='sidebar-wrapper' id='sidebar-wrapper'>
<div class='sidebar section' id='sidebar' name='Sidebar Right'><div class='widget HTML' data-version='1' id='HTML1'>
<div class='widget-content'>
<div class="imagehere"><!-- Top Right Sidebar 300x250 -->
<!-- Ezoic - 300x250 top right - sidebar -->
<div id="ezoic-pub-ad-placeholder-102">            
<!-- <ins class="adsbygoogle"
     style="display:inline-block;width:300px;height:250px"
     data-ad-client="ca-pub-1997822342415050"
     data-ad-slot="8358301820"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script> -->
</div>
<!-- End Ezoic - 300x250 top right - sidebar -->
</div>

<script type="text/javascript">
//<![CDATA[
$(window).load(function(){null==document.getElementsByTagName("iframe").item(ga.length-1)&&$("div.imagehere").html("<a href='https://www.linuxuprising.com/2019/04/join-uprising.html' rel='nofollow noopener'><img src='https://4.bp.blogspot.com/-RM33YT7JTCw/XOVA0YwyKxI/AAAAAAAACyo/lA22C-cphP87WD39N4_9SJ-qG5b21IORgCLcBGAs/s1600-e120/join-the-uprising.png' alt='Join the Uprising'/></a><br/>")});
//]]> 
</script>
</div>
</div><div class='widget HTML' data-version='1' id='HTML2'>
<h2 class='title'>Recent Posts</h2>
<div id='RecentPosts'>
<div class='widget-content'>
recentposts
</div>
</div>
</div><div class='widget HTML' data-version='1' id='HTML3'>
<div class='widget-content'>
<div style="margin:0 auto;">
<a target="_blank" rel="noopener nofollow" href="https://t.me/LinuxUprising"><img src="https://1.bp.blogspot.com/-fCC0RyOv2Ts/XcVRcqh6LxI/AAAAAAAADhQ/v-meoJy6TnUe9642hYTzRM1a9q1VQ7seQCLcBGAsYHQ/s1600-e120/telegram-320.png" alt="Join us on Telegram" title="Join us on Telegram"/></a>
</div>
<br/>
<div style="margin:0 auto;">
<a target="_blank" rel="noopener nofollow" href="https://twitter.com/LinuxUprising"><img src="https://1.bp.blogspot.com/-LKFL-Vu_G8w/XfJ0DAfbXcI/AAAAAAAADtc/9nhpwKOKez4EOawDSsDVQe_le3D0Gu-1gCLcBGAsYHQ/s320-e120/twitter.png" alt="Follow us on Twitter" title="Follow us on Twitter"/></a>
</div>
<br/>
<!-- Ezoic - Sidebar middle - sidebar_middle -->
<div id="ezoic-pub-ad-placeholder-104">
</div>
<!-- End Ezoic - Sidebar middle - sidebar_middle -->
</div>
</div><div class='widget LinkList' data-version='1' id='LinkList2'>
<h2>Editor's Picks</h2>
<div class='widget-content'>
<ul>
<li><a href='https://www.linuxuprising.com/2020/04/top-things-to-do-after-installing.html'>Top Things To Do After Installing Ubuntu 20.04 Focal Fossa To Make The Most Of It</a></li>
<li><a href='https://www.linuxuprising.com/2020/03/opensnitch-linux-application-firewall.html'>OpenSnitch Linux Application Firewall Fork With Improvements And Bug Fixes</a></li>
<li><a href='https://www.linuxuprising.com/2020/01/4-tools-to-record-your-linux-desktop.html'>4 Tools To Record Your Linux Desktop (Screencast) In 2020</a></li>
<li><a href='https://www.linuxuprising.com/2020/01/how-to-boot-to-console-text-mode-in.html'>How To Boot To Console (Text) Mode Using Debian / Ubuntu, Fedora, Arch Linux / Manjaro And More</a></li>
<li><a href='https://www.linuxuprising.com/2019/11/ffmpeg-extract-audio-from-video-in.html'>FFmpeg: Extract Audio From Video In Original Format Or Converting It To MP3 Or Ogg Vorbis</a></li>
<li><a href='https://www.linuxuprising.com/2018/06/how-to-install-davinci-resolve-15-in.html'>How To Install DaVinci Resolve 16.2 In Ubuntu, Linux Mint Or Debian (Generate DEB Package)</a></li>
<li><a href='https://www.linuxuprising.com/2018/12/how-to-change-grub-boot-order-or.html'>How To Change The GRUB Boot Order Or Default Boot Entry In Ubuntu, Linux Mint, Debian, Or Fedora With Grub Customizer</a></li>
<li><a href='https://www.linuxuprising.com/2019/06/new-oracle-java-11-installer-for-ubuntu.html'>New Oracle Java 11 Installer For Ubuntu Or Linux Mint (Using Local Oracle Java .tar.gz)</a></li>
<li><a href='https://www.linuxuprising.com/2018/07/how-to-fix-could-not-get-lock.html'>How To Fix `Could not get lock /var/lib/dpkg/lock - open (11 Resource temporarily unavailable)` Errors</a></li>
<li><a href='https://www.linuxuprising.com/2018/07/how-to-mount-onedrive-in-linux-using.html'>How To Mount OneDrive In Linux Using Rclone (Supports Business And Personal Accounts)</a></li>
</ul>
</div>
</div><div class='widget HTML' data-version='2' id='HTML5'>
<div class='widget-content'>
<!-- Ezoic - Sidebar bottom - sidebar_bottom -->
<div id="ezoic-pub-ad-placeholder-106"></div>
<!-- End Ezoic - Sidebar bottom - sidebar_bottom -->
</div>
</div><div class='widget HTML' data-version='1' id='HTML6'>
<script type='text/javascript'>
var disqus_shortname = 'linuxuprising';
var disqus_blogger_current_url = "https://www.linuxuprising.com/2020/11/configure-logitech-steelseries-and.html";
var disqus_title = "Configure Logitech, Steelseries And Other Gaming Mice On Linux Using Piper - Linux Uprising Blog";
if (!disqus_blogger_current_url.length) {
disqus_blogger_current_url = "https://www.linuxuprising.com/2020/11/configure-logitech-steelseries-and.html";
}
var disqus_blogger_homepage_url = "https://www.linuxuprising.com/";
var disqus_blogger_canonical_homepage_url = "https://www.linuxuprising.com/";
</script>
<script>
var disqus_loaded = false;
function load_disqus( disqus_shortname ) {
  // Prepare the trigger and target

  var is_disqus_empty = document.getElementById('disqus_empty'),
      disqus_target   = document.getElementById('disqus_thread_load_on_scroll'),
      disqus_embed    = document.createElement('script'),
      disqus_hook     = (document.getElementsByTagName('head')[0] || document.getElementsByTagName('body')[0]);

  // Load script asynchronously only when the trigger and target exist
  if( disqus_target && is_disqus_empty ) {
    disqus_loaded = true;
    disqus_embed.type = 'text/javascript';
    disqus_embed.async = true;
    disqus_embed.src = '//' + disqus_shortname + '.disqus.com/blogger_item.js';
    disqus_hook.appendChild(disqus_embed);
    is_disqus_empty.remove();
  }
}

window.addEventListener('scroll', function(e) {
  var currentScroll = document.scrollingElement.scrollTop;
  var disqus_target = document.getElementById('disqus_thread_load_on_scroll');

  if( currentScroll > disqus_target.getBoundingClientRect().top - 150 ) {
    if (disqus_loaded==false) {
      load_disqus('linuxuprising');
    };
  }
}, false);
</script>
</div></div>
</div>
<div class='clear'></div>
</div>
<!-- end content-wrapper -->
<div class='clear'></div><!-- Footer wrapper -->
<div id='footer-wrapper'>
<div id='footer'>
<div class='footer-sections row' id='footer-sections'>
<div class='sect-left section' id='footer-sec1' name='Widget 1'><div class='widget LinkList' data-version='1' id='LinkList1'>
<h2>Linux Uprising</h2>
<div class='widget-content'>
<ul>
<li><a href='https://www.linuxuprising.com/p/about.html'>About</a></li>
<li><a href='https://www.linuxuprising.com/p/privacy-policy.html'>Privacy Policy</a></li>
<li><a href='https://www.linuxuprising.com/p/terms-of-use.html'>Terms of Service</a></li>
<li><a href='https://www.linuxuprising.com/p/cookie-policy.html'>Cookie Information</a></li>
<li><a href='https://www.linuxuprising.com/?ez_force_cookie_consent=1'>Cookie Settings</a></li>
</ul>
</div>
</div></div>
<div class='sect-left section' id='footer-sec2' name='Widget 2'><div class='widget FollowByEmail' data-version='1' id='FollowByEmail1'>
<h2 class='title'>Follow by Email</h2>
<div class='widget-content'>
<div class='follow-by-email-inner'>
<form action='https://feedburner.google.com/fb/a/mailverify' method='post' onsubmit='window.open("https://feedburner.google.com/fb/a/mailverify?uri=LinuxUprising", "popupwindow", "scrollbars=yes,width=550,height=520"); return true' target='popupwindow'>
<table width='100%'>
<tr>
<td>
<label for='email'><input aria-label='email' class='follow-by-email-address' id='email' name='email' placeholder='Email address...' type='text'/></label>
</td>
<td width='64px'>
<input class='follow-by-email-submit' type='submit' value='Submit'/>
</td>
</tr>
</table>
<input name='uri' type='hidden' value='LinuxUprising'/>
<input name='loc' type='hidden' value='en_US'/>
</form>
</div>
</div>
<span class='item-control blog-admin'>
</span>
</div></div>
<div class='sect-left section' id='footer-sec3' name='Widget 3'><div class='widget BlogArchive' data-version='1' id='BlogArchive2'>
<h2>Blog Archive</h2>
<div class='widget-content'>
<div id='ArchiveList'>
<div id='BlogArchive2_ArchiveList'>
<label aria-label='archive-menu' for='BlogArchive2_ArchiveMenu'>
<select id='BlogArchive2_ArchiveMenu'>
<option value=''>Blog Archive</option>
<option value='https://www.linuxuprising.com/2020/11/'>November 2020 (3)</option>
<option value='https://www.linuxuprising.com/2020/10/'>October 2020 (13)</option>
<option value='https://www.linuxuprising.com/2020/09/'>September 2020 (6)</option>
<option value='https://www.linuxuprising.com/2020/07/'>July 2020 (8)</option>
<option value='https://www.linuxuprising.com/2020/06/'>June 2020 (8)</option>
<option value='https://www.linuxuprising.com/2020/05/'>May 2020 (7)</option>
<option value='https://www.linuxuprising.com/2020/04/'>April 2020 (13)</option>
<option value='https://www.linuxuprising.com/2020/03/'>March 2020 (12)</option>
<option value='https://www.linuxuprising.com/2020/02/'>February 2020 (14)</option>
<option value='https://www.linuxuprising.com/2020/01/'>January 2020 (13)</option>
<option value='https://www.linuxuprising.com/2019/12/'>December 2019 (14)</option>
<option value='https://www.linuxuprising.com/2019/11/'>November 2019 (18)</option>
<option value='https://www.linuxuprising.com/2019/10/'>October 2019 (13)</option>
<option value='https://www.linuxuprising.com/2019/09/'>September 2019 (17)</option>
<option value='https://www.linuxuprising.com/2019/08/'>August 2019 (11)</option>
<option value='https://www.linuxuprising.com/2019/07/'>July 2019 (22)</option>
<option value='https://www.linuxuprising.com/2019/06/'>June 2019 (18)</option>
<option value='https://www.linuxuprising.com/2019/05/'>May 2019 (19)</option>
<option value='https://www.linuxuprising.com/2019/04/'>April 2019 (20)</option>
<option value='https://www.linuxuprising.com/2019/03/'>March 2019 (16)</option>
<option value='https://www.linuxuprising.com/2019/02/'>February 2019 (17)</option>
<option value='https://www.linuxuprising.com/2019/01/'>January 2019 (21)</option>
<option value='https://www.linuxuprising.com/2018/12/'>December 2018 (15)</option>
<option value='https://www.linuxuprising.com/2018/11/'>November 2018 (24)</option>
<option value='https://www.linuxuprising.com/2018/10/'>October 2018 (22)</option>
<option value='https://www.linuxuprising.com/2018/09/'>September 2018 (15)</option>
<option value='https://www.linuxuprising.com/2018/08/'>August 2018 (27)</option>
<option value='https://www.linuxuprising.com/2018/07/'>July 2018 (26)</option>
<option value='https://www.linuxuprising.com/2018/06/'>June 2018 (21)</option>
<option value='https://www.linuxuprising.com/2018/05/'>May 2018 (31)</option>
<option value='https://www.linuxuprising.com/2018/04/'>April 2018 (25)</option>
<option value='https://www.linuxuprising.com/2018/03/'>March 2018 (1)</option>
</select>
</label>
</div>
</div>
</div>
</div></div>
</div>
</div>
<div class='clear'></div>
<div class='footer-wrapper'>
<div class='footer-sec row'>
<!-- Footer Social -->
<div class='social-footer section' id='social-footer' name='Social Footer'><div class='widget LinkList' data-version='1' id='LinkList20'>
<div class='widget-content'>
<ul>
<li><a class='rss' href='https://feeds.feedburner.com/LinuxUprising' rel='noreferrer' target='_blank' title='rss'></a></li>
<li><a class='friendica' href='https://libranet.de/profile/linuxuprising' rel='noreferrer' target='_blank' title='friendica'></a></li>
<li><a class='twitter' href='https://twitter.com/linuxuprising' rel='noreferrer' target='_blank' title='twitter'></a></li>
<li><a class='telegram' href='https://t.me/LinuxUprising' rel='noreferrer' target='_blank' title='telegram'></a></li>
<li><a class='facebook' href='https://www.facebook.com/LinuxUprising/' rel='noreferrer' target='_blank' title='facebook'></a></li>
<li><a class='reddit' href='https://www.reddit.com/r/LinuxUprising/' rel='noreferrer' target='_blank' title='reddit'></a></li>
</ul>
</div>
</div></div>
<!-- Footer Copyright -->
<div class='copyright'>
License: <a href='https://creativecommons.org/licenses/by-sa/4.0/' rel='license nofollow noreferrer' target='_blank'>Creative Commons Attribution 4.0 International License</a>
<a href='https://www.linuxuprising.com'>Linux Uprising</a>. <br/>The registered trademark Linux&#174; is used pursuant to a sublicense from the Linux Foundation, the exclusive licensee of Linus Torvalds, owner of the mark on a world&#173;wide basis.
</div>
</div>
</div>
</div>
</div>
<script type='text/javascript'>
if (!('IntersectionObserver' in window)) {
    var script = document.createElement("script");
    script.src = "https://cdn.jsdelivr.net/npm/intersection-observer@0.7.0/intersection-observer.js";
    document.getElementsByTagName('head')[0].appendChild(script);
}
</script>
<script src='https://cdnjs.cloudflare.com/ajax/libs/vanilla-lazyload/12.3.0/lazyload.min.js'></script>
<script type='text/javascript'>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</script>
<script type='text/javascript'>    
//<![CDATA[

$(document).ready((function() {
    $('pre.cssterm','#post-article').each((function() {
        $(this).attr('title','Triple click to select a complete line!');
    }));
}));


// Lazyload
            (function(a){a.fn.lazyload=function(b){var c={threshold:0,failurelimit:0,event:"scroll",effect:"show",container:window};if(b){a.extend(c,b)}var d=this;if("scroll"==c.event){a(c.container).bind("scroll",function(b){var e=0;d.each(function(){if(a.abovethetop(this,c)||a.leftofbegin(this,c)){}else if(!a.belowthefold(this,c)&&!a.rightoffold(this,c)){a(this).trigger("appear")}else{if(e++>c.failurelimit){return false}}});var f=a.grep(d,function(a){return!a.loaded});d=a(f)})}this.each(function(){var b=this;if(undefined==a(b).attr("original")){a(b).attr("original",a(b).attr("src"))}if("scroll"!=c.event||undefined==a(b).attr("src")||c.placeholder==a(b).attr("src")||a.abovethetop(b,c)||a.leftofbegin(b,c)||a.belowthefold(b,c)||a.rightoffold(b,c)){if(c.placeholder){a(b).attr("src",c.placeholder)}else{a(b).removeAttr("src")}b.loaded=false}else{b.loaded=true}a(b).one("appear",function(){if(!this.loaded){a("<img />").bind("load",function(){a(b).hide().attr("src",a(b).attr("original"))[c.effect](c.effectspeed);b.loaded=true}).attr("src",a(b).attr("original"))}});if("scroll"!=c.event){a(b).bind(c.event,function(c){if(!b.loaded){a(b).trigger("appear")}})}});a(c.container).trigger(c.event);return this};a.belowthefold=function(b,c){if(c.container===undefined||c.container===window){var d=a(window).height()+a(window).scrollTop()}else{var d=a(c.container).offset().top+a(c.container).height()}return d<=a(b).offset().top-c.threshold};a.rightoffold=function(b,c){if(c.container===undefined||c.container===window){var d=a(window).width()+a(window).scrollLeft()}else{var d=a(c.container).offset().left+a(c.container).width()}return d<=a(b).offset().left-c.threshold};a.abovethetop=function(b,c){if(c.container===undefined||c.container===window){var d=a(window).scrollTop()}else{var d=a(c.container).offset().top}return d>=a(b).offset().top+c.threshold+a(b).height()};a.leftofbegin=function(b,c){if(c.container===undefined||c.container===window){var d=a(window).scrollLeft()}else{var d=a(c.container).offset().left}return d>=a(b).offset().left+c.threshold+a(b).width()};a.extend(a.expr[":"],{"below-the-fold":"$.belowthefold(a, {threshold : 0, container: window})","above-the-fold":"!$.belowthefold(a, {threshold : 0, container: window})","right-of-fold":"$.rightoffold(a, {threshold : 0, container: window})","left-of-fold":"!$.rightoffold(a, {threshold : 0, container: window})"})})(jQuery);$(function(){$("img").lazyload({placeholder:"https://1.bp.blogspot.com/-zfTgNA4ZsX0/XR0aQA2GyiI/AAAAAAAADAA/JOjs9ZVsMvA7aIt4bXkH5AqiJK_xkIDUwCLcBGAs/s1600-e120/pixel.gif",effect:"fadeIn",threshold:"1"})});

$("#related-posts").each((function() {
    var g = $(this).html();
    var title = $("#entry-title").text().trim();
    $.ajax({
        url: "/feeds/posts/default/-/" + g + "?alt=json-in-script&max-results=" + related_number,
        type: 'get',
        cache: true,
        dataType: "jsonp",
        success: function(data) {
            var posturl = "";
            var htmlcode = '<div class="related"><ul>';
            for (var i = 0; i < data.feed.entry.length; i++) {
              var s = data.feed.entry[i].title.$t.trim();
              if (s !== title) {
                for (var j = 0; j < data.feed.entry[i].link.length; j++) {
                    if (data.feed.entry[i].link[j].rel == "alternate") {
                            posturl = data.feed.entry[i].link[j].href;
                            break
                    }
                }

                var posttitle = data.feed.entry[i].title.$t;

                if (!data.feed.entry[i].media$thumbnail) {
                    var thumb = '<a title="' + posttitle +'" class="related-img" href="' + posturl + '"' + 'data-bg="url(' + no_image_url + ')" />'                 
                } else {
                    var src = data.feed.entry[i].media$thumbnail.url.split(/s72-c/).join("s320");
                    var thumb = '<a title="' + posttitle +'" class="related-img" href="' + posturl + '"' + 'data-bg="url(' + src + ')" />'                
                }

                htmlcode += '<li><div class="related-thumb">' + thumb + '</div><h3 class="related-title"><a href="' + posturl + '">' + posttitle + '</a></h3></li>'
            }
            }
            htmlcode += '</ul></div><div class="clear"/>';
            $("#related-posts").html(htmlcode);
            LL.update();

        }
    })
}));


//]]>
</script>
<div class='back-to-top'>
<a href='#' id='back-to-top' title='back to top'>
<i class='fa fa-long-arrow-up'></i>
</a>
</div>

<script type='text/javascript' style='display:none;' async>
__ez.queue.addFile('edmonton.php', '/detroitchicago/edmonton.webp?a=a&cb=0&shcb=34', true, ['/detroitchicago/minneapolis.js'], true, false, false, false);
__ez.queue.addFile('jellyfish.php', '/porpoiseant/jellyfish.webp?a=a&cb=0&shcb=34', false, [], true, false, false, false);
</script>

<script>var _audins_dom="linuxuprising_com",_audins_did=131660;__ez.queue.addDelayFunc("audins.js","__ez.script.add", "//go.ezoic.net/detroitchicago/audins.js?cb=191-0");</script><noscript><div style="display:none;"><img src="//pixel.quantserve.com/pixel/p-31iz6hfFutd16.gif?labels=Domain.linuxuprising_com,DomainId.131660" border="0" height="1" width="1" alt="Quantcast"/></div></noscript><noscript><img src="https://sb.scorecardresearch.com/p?c1=2&c2=20015427&cv=2.0&cj=1"/></noscript>
<script type='text/javascript' data-cfasync='false'></script><script type="text/javascript" onload="__ezcl.handle(true);" async src="/utilcave_com/inc/ezcl.webp?cb=4"></script></body>
</html>