<!DOCTYPE html><html dir="ltr" lang="en-US" xmlns="http://www.w3.org/1999/xhtml" xmlns:b="http://www.google.com/2005/gml/b" xmlns:data="http://www.google.com/2005/gml/data" xmlns:expr="http://www.google.com/2005/gml/expr"><head><meta charset="utf-8"/>
<script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>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</script><script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>__ez.pel=(function(){var pixels=[],pxURL="/porpoiseant/army.gif";function AddAndFirePixel(adSlot,pixelData){AddPixel(adSlot,pixelData,0,0,0,0,0);Fire();}
function AddAndFireOrigPixel(adSlot,pixelData){AddPixel(adSlot,pixelData,0,0,0,0,0,true);Fire();}
function GetCurrentPixels(){return pixels;}
function AddPixel(adSlot,pixelData,revenue,est_revenue,bid_floor_filled,bid_floor_prev,stat_source_id,isOrig){if(!__ez.dot.isDefined(adSlot)||__ez.dot.isAnyDefined(adSlot.getSlotElementId,adSlot.ElementId)==false){return;}
var ad_position_id=parseInt(__ez.dot.getTargeting(adSlot,'ap'));var impId=__ez.dot.getSlotIID(adSlot),adUnit=__ez.dot.getAdUnit(adSlot,isOrig);var compId=parseInt(__ez.dot.getTargeting(adSlot,"compid"));var lineItemId=0;var creativeId=0;var ezimData=getEzimData(adSlot);if(typeof ezimData=='object'){if(ezimData.creative_id!==undefined){creativeId=ezimData.creative_id;}
if(ezimData.line_item_id!==undefined){lineItemId=ezimData.line_item_id;}}
if(__ez.dot.isDefined(impId,adUnit)&&__ez.dot.isValid(pixelData)){pixels.push({type:"impression",impression_id:impId,domain_id:__ez.dot.getDID(),unit:adUnit,t_epoch:__ez.dot.getEpoch(0),revenue:revenue,est_revenue:est_revenue,ad_position:ad_position_id,ad_size:"",bid_floor_filled:bid_floor_filled,bid_floor_prev:bid_floor_prev,stat_source_id:stat_source_id,country_code:__ez.dot.getCC(),pageview_id:__ez.dot.getPageviewId(),comp_id:compId,line_item_id:lineItemId,creative_id:creativeId,data:__ez.dot.dataToStr(pixelData),is_orig:isOrig||__ez.template.isOrig,});}}
function AddPixelById(impFullId,pixelData,isOrig){var vals=impFullId.split('/');if(__ez.dot.isDefined(impFullId)&&vals.length===3&&__ez.dot.isValid(pixelData)){var adUnit=vals[0],impId=vals[2];pixels.push({type:"impression",impression_id:impId,domain_id:__ez.dot.getDID(),unit:adUnit,t_epoch:__ez.dot.getEpoch(0),pageview_id:__ez.dot.getPageviewId(),data:__ez.dot.dataToStr(pixelData),is_orig:isOrig||__ez.template.isOrig});}}
function Fire(){if(typeof document.visibilityState!=='undefined'&&document.visibilityState==="prerender")return;if(__ez.dot.isDefined(pixels)&&pixels.length>0){var allPixels=[pixels.filter(function(pixel){return pixel.is_orig}),pixels.filter(function(pixel){return!pixel.is_orig})];allPixels.forEach(function(pixels){while(pixels.length>0){var isOrig=pixels[0].is_orig||false;var j=5;if(j>pixels.length){j=pixels.length;}
var pushPixels=pixels.splice(0,j);var pixelURL=__ez.dot.getURL(pxURL)+"?orig="+(isOrig===true?1:0)+"&sts="+btoa(JSON.stringify(pushPixels));if(typeof window.isAmp!=='undefined'&&isAmp&&typeof window._ezaq!=='undefined'&&_ezaq.hasOwnProperty("domain_id")){pixelURL+="&visit_uuid="+_ezaq['visit_uuid'];}
__ez.dot.Fire(pixelURL);}})}
pixels=[];}
function getEzimData(adSlot){if(typeof _ezim_d=="undefined"){return false}
var adUnitName=__ez.dot.getAdUnitPath(adSlot).split('/').pop();if(typeof _ezim_d==='object'&&_ezim_d.hasOwnProperty(adUnitName)){return _ezim_d[adUnitName];}
for(var ezimKey in _ezim_d){if(ezimKey.split('/').pop()===adUnitName){return _ezim_d[ezimKey];}}
return false;}
return{Add:AddPixel,AddAndFire:AddAndFirePixel,AddAndFireOrig:AddAndFireOrigPixel,AddById:AddPixelById,Fire:Fire,GetPixels:GetCurrentPixels,};})();__ez.queue.addFile('/detroitchicago/raleigh.js', '/detroitchicago/raleigh.js?gcb=195-0&cb=5', false, [], true, false, true, false);__ez.queue.addFile('/detroitchicago/tampa.js', '/detroitchicago/tampa.js?gcb=195-0&cb=4', false, [], true, false, true, false);</script>
<script data-ezscrex="false" data-cfasync="false">(function(){if("function"===typeof window.CustomEvent)return!1;window.CustomEvent=function(c,a){a=a||{bubbles:!1,cancelable:!1,detail:null};var b=document.createEvent("CustomEvent");b.initCustomEvent(c,a.bubbles,a.cancelable,a.detail);return b}})();</script><script data-ezscrex="false" data-cfasync="false">__ez.queue.addFile('/detroitchicago/tulsa.js', '/detroitchicago/tulsa.js?gcb=195-0&cb=5', false, [], true, false, true, false);</script>

<meta content="en-us" http-equiv="content-language"/>
<meta content="IE=edge" http-equiv="X-UA-Compatible"/>
<meta content="width=device-width,initial-scale=1.0" name="viewport"/>
<meta content="#f2132d" name="theme-color"/>
<meta content="#f2132d" name="msapplication-TileColor"/>
<meta content="#f2132d" name="msapplication-navbutton-color"/>
<link href="https://3.bp.blogspot.com/-_Rvl0I-6PsE/WxqOMWBSvFI/AAAAAAAAAr0/YVpbw6VxjTE0cs2FIG3JGGrzfelqF1AXQCLcBGAs/s1600-rw/apple-icon-180x180.png" rel="apple-touch-icon" sizes="180x180"/>
<link href="https://4.bp.blogspot.com/-C3SXpMZFwoM/WxqOMWPcqBI/AAAAAAAAAr4/q3BlIVZd9BIycvFtwpwee9ho2axmuey1wCLcBGAs/s1600-rw/android-icon-192x192.png" rel="icon" sizes="192x192" type="image/png"/>
<link href="https://1.bp.blogspot.com/-Rt0ksgLeHY8/XfJ5aMpjzZI/AAAAAAAADts/utsNBkpMNgoN82UZoo9EjfGponnDWZLIACLcBGAsYHQ/s1600-rw/favicon-large_32x32.png" rel="icon" sizes="32x32" type="image/png"/>
<meta content="text/html; charset=UTF-8" http-equiv="Content-Type"/>
<!-- Chrome, Firefox OS and Opera -->
<meta content="" name="theme-color"/>
<!-- Windows Phone -->
<meta content="" name="msapplication-navbutton-color"/>
<meta content="blogger" name="generator"/>
<link href="https://www.linuxuprising.com/favicon.ico" rel="icon" type="image/x-icon"/>
<link href="https://www.linuxuprising.com/2021/09/plocate-is-much-faster-locate-drop-in.html" rel="canonical"/>
<link rel="alternate" type="application/atom+xml" title="Linux Uprising Blog - Atom" href="https://www.linuxuprising.com/feeds/posts/default"/>
<link rel="alternate" type="application/rss+xml" title="Linux Uprising Blog - RSS" href="https://www.linuxuprising.com/feeds/posts/default?alt=rss"/>
<link rel="service.post" type="application/atom+xml" title="Linux Uprising Blog - Atom" href="https://www.blogger.com/feeds/852161773840707483/posts/default"/>

<link rel="alternate" type="application/atom+xml" title="Linux Uprising Blog - Atom" href="https://www.linuxuprising.com/feeds/3892020352571529214/comments/default"/>
<!--Can't find substitution for tag [blog.ieCssRetrofitLinks]-->
<link href="https://1.bp.blogspot.com/-CdQitrWkHqY/YTnlyMLV7bI/AAAAAAAAFyQ/9LaOtu04AxsG318h5Vb3kfgv1iVVHPENQCLcBGAsYHQ/w640-h440/plocate-linux.png" rel="image_src"/>
<meta content="plocate is a newer, much faster locate (tool to find files on the command-line). it&#39;s a drop-in replacement for mlocate in nearly all aspects, includi" name="description"/>
<meta content="https://www.linuxuprising.com/2021/09/plocate-is-much-faster-locate-drop-in.html" property="og:url"/>
<meta content="plocate Is A Much Faster locate (Drop-In Replacement For mlocate)" property="og:title"/>
<meta content="plocate is a newer, much faster locate (tool to find files on the command-line). it&#39;s a drop-in replacement for mlocate in nearly all aspects, includi" property="og:description"/>
<meta content="https://1.bp.blogspot.com/-CdQitrWkHqY/YTnlyMLV7bI/AAAAAAAAFyQ/9LaOtu04AxsG318h5Vb3kfgv1iVVHPENQCLcBGAsYHQ/w1200-h630-p-k-no-nu/plocate-linux.png" property="og:image"/>
<!--[if IE]> <script> (function() { var html5 = ("abbr,article,aside,audio,canvas,datalist,details," + "figure,footer,header,hgroup,mark,menu,meter,nav,output," + "progress,section,time,video").split(','); for (var i = 0; i < html5.length; i++) { document.createElement(html5[i]); } try { document.execCommand('BackgroundImageCache', false, true); } catch(e) {} })(); </script> <![endif]-->
<link href="https://fonts.gstatic.com" rel="dns-prefetch"/>
<link crossorigin="anonymous" href="https://fonts.gstatic.com" rel="preconnect"/>
<link href="https://cdn.jsdelivr.net" rel="dns-prefetch"/>
<link crossorigin="anonymous" href="https://cdn.jsdelivr.net" rel="preconnect"/>
<link crossorigin="crossorigin" href="https://fonts.googleapis.com" rel="preconnect"/>
<link crossorigin="crossorigin" href="https://ajax.googleapis.com" rel="preconnect"/>
<link crossorigin="crossorigin" href="https://www.google-analytics.com" rel="preconnect"/>
<link crossorigin="crossorigin" href="https://ssl.google-analytics.com" rel="preconnect"/>
<link crossorigin="crossorigin" href="https://apis.google.com" rel="preconnect"/>
<link crossorigin="crossorigin" href="https://googleads.g.doubleclick.net" rel="preconnect"/>
<link crossorigin="crossorigin" href="https://cdn.jsdelivr.net" rel="preconnect"/>
<link crossorigin="crossorigin" href="https://lh3.googleusercontent.com" rel="preconnect"/>
<link crossorigin="crossorigin" href="https://fonts.gstatic.com" rel="preconnect"/>
<link crossorigin="crossorigin" href="https://adservice.google.com" rel="preconnect"/>
<link crossorigin="crossorigin" href="https://www.googletagservices.com" rel="preconnect"/>
<link crossorigin="crossorigin" href="https://tpc.googlesyndication.com" rel="preconnect"/>
<link crossorigin="crossorigin" href="https://partner.googleadservices.com" rel="preconnect"/>
<link crossorigin="crossorigin" href="https://vendorlist.consensu.org" rel="preconnect"/>
<link crossorigin="crossorigin" href="https://cdnjs.cloudflare.com" rel="preconnect"/>
<link crossorigin="crossorigin" href="https://1.bp.blogspot.com" rel="preconnect"/>
<link crossorigin="crossorigin" href="https://2.bp.blogspot.com" rel="preconnect"/>
<link crossorigin="crossorigin" href="https://3.bp.blogspot.com" rel="preconnect"/>
<link crossorigin="crossorigin" href="https://4.bp.blogspot.com" rel="preconnect"/>
<link crossorigin="crossorigin" href="https://ib.adnxs.com" rel="preconnect"/>
<link crossorigin="crossorigin" href="https://bidder.criteo.com" rel="preconnect"/>
<link crossorigin="crossorigin" href="https://g.ezoic.net" rel="preconnect"/>
<link href="//linuxuprising.disqus.com" rel="preconnect"/>
<link href="//disqus.com" rel="dns-prefetch"/>
<link href="//c.disquscdn.com" rel="dns-prefetch"/>
<link href="//referrer.disqus.com" rel="dns-prefetch"/>
<link href="//juggler.services.disqus.com" rel="dns-prefetch"/>
<meta content="https://www.facebook.com/LinuxUprising" property="article:publisher"/>
<meta content="3F3C1DB7847EE7E64E8A2F6CDC5A5F10" name="msvalidate.01"/>
<meta content="de18aa7b281bff4c" name="yandex-verification"/>
<title>
plocate Is A Much Faster locate (Drop-In Replacement For mlocate) - Linux Uprising Blog
</title>
<!-- Description and Keywords (start) -->
<meta content="en_US" property="og:locale"/>
<!-- Description and Keywords (end) -->
<meta content="article" property="og:type"/>
<meta content="Linux Uprising Blog" property="og:site_name"/>
<meta content="https://www.linuxuprising.com/" name="twitter:domain"/>
<meta content="plocate Is A Much Faster locate (Drop-In Replacement For mlocate)" name="twitter:title"/>
<meta content="summary_large_image" name="twitter:card"/>
<meta content="https://1.bp.blogspot.com/-CdQitrWkHqY/YTnlyMLV7bI/AAAAAAAAFyQ/9LaOtu04AxsG318h5Vb3kfgv1iVVHPENQCLcBGAsYHQ/w640-h440/plocate-linux.png" name="twitter:image"/>
<meta content="plocate is a newer, much faster locate (tool to find files on the command-line). it&#39;s a drop-in replacement for mlocate in nearly all aspects, includi" name="twitter:description"/>
<!-- Social Media meta tag need customer customization -->
<meta content="572203406470374" property="fb:app_id"/>
<meta content="841352899" property="fb:admins"/>
<meta content="@linuxuprising" name="twitter:site"/>
<meta content="@linuxuprising" name="twitter:creator"/>
<!-- Disable default blogger Cookie Choice-->
<script type="text/javascript">
    cookieChoices = {};
</script>
<!-- Google Analytics -->
<script type="text/javascript">
  <!-- Set personalized or not for ads based on cookie consent info -->    
  var checkUserConsent;

    // fetch consent information
    function EzConsentCallback(consent) {
        // consent contains the necessary, preferences, statistics, and marketing properties with boolean values 
        if(consent.marketing) {
            // Consent given
            // Ezoic handles the requestNonPersonalizedAds thingy itself
            // (adsbygoogle=window.adsbygoogle||[]).requestNonPersonalizedAds=0;
            checkUserConsent = 'YES'; 
        } else {
            // No consent for personalized ads
            // (adsbygoogle=window.adsbygoogle||[]).requestNonPersonalizedAds=1;
            checkUserConsent = 'NO';
        }
    }

  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');
  ga('create', 'UA-116578392-1', 'auto');
  if (checkUserConsent == 'NO') {
     ga('set', 'allowAdFeatures', false);
  }
  ga('set', 'anonymizeIp', true);
  ga('send', 'pageview');
</script>
<style id="page-skin-1" type="text/css">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</style>
<style type="text/css">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</style>
<noscript>
<style>
        #HTML1, #HTML2, #HTML3, #adsense-top-horiz {display:none;}
    </style>
<link href='https://fonts.googleapis.com/css2?family=Ubuntu:ital,wght@0,300;0,500;0,700;1,300&display=swap' rel='stylesheet'/>
<link href='https://cdn.jsdelivr.net/npm/fork-awesome@1.1.3/css/fork-awesome.min.css' rel='stylesheet'/>
</noscript>
<link href="https://www.blogger.com/dyn-css/authorization.css?targetBlogID=852161773840707483&amp;zx=15058bce-b505-4f49-bc4e-f5c8b4395a84" media="none" onload="if(media!=&#39;all&#39;)media=&#39;all&#39;" rel="stylesheet"/><noscript><link href='https://www.blogger.com/dyn-css/authorization.css?targetBlogID=852161773840707483&amp;zx=15058bce-b505-4f49-bc4e-f5c8b4395a84' rel='stylesheet'/></noscript>
<meta name="google-adsense-platform-account" content="ca-host-pub-1556223355139109"/>
<meta name="google-adsense-platform-domain" content="blogspot.com"/>

<!-- data-ad-client=ca-pub-1997822342415050 -->

<script type="text/javascript">var ezouid = "1";</script><base href="https://www.linuxuprising.com/2021/09/plocate-is-much-faster-locate-drop-in.html"><script type='text/javascript'>
var ezoTemplate = 'old_site_gc';
if(typeof ezouid == 'undefined')
{
    var ezouid = 'none';
}
var ezoFormfactor = '1';
var ezo_elements_to_check = Array();
</script><!-- START EZHEAD -->
<script data-ezscrex="false" type='text/javascript'>
var soc_app_id = '0';
var did = 131660;
var ezdomain = 'linuxuprising.com';
var ezoicSearchable = 1;
</script>
<!--{jquery}-->
<!-- END EZHEAD -->
<script data-ezscrex="false" type="text/javascript" data-cfasync="false">var _ezaq = {"ad_cache_level":0,"ad_lazyload_version":0,"ad_load_version":0,"city":"Ashburn","country":"US","days_since_last_visit":-1,"domain_id":131660,"domain_test_group":20210308,"engaged_time_visit":0,"ezcache_level":2,"ezcache_skip_code":0,"form_factor_id":1,"framework_id":1,"is_return_visitor":false,"is_sitespeed":0,"last_page_load":"","last_pageview_id":"","lt_cache_level":0,"metro_code":511,"page_ad_positions":"","page_view_count":0,"page_view_id":"7601e16b-8046-4931-46da-8a7d9f3ee0d5","position_selection_id":0,"postal_code":"20149","pv_event_count":0,"response_size_orig":91749,"response_time_orig":4,"serverid":"18.206.87.246:6458","state":"VA","t_epoch":1631322708,"template_id":126,"time_on_site_visit":0,"url":"https://www.linuxuprising.com/2021/09/plocate-is-much-faster-locate-drop-in.html","user_id":0,"word_count":1186,"worst_bad_word_level":0};var _ezExtraQueries = "&ez_orig=1";</script>
<script data-ezscrex='false' data-pagespeed-no-defer data-cfasync='false'>
function create_ezolpl(pvID, rv) {
    var d = new Date();
    d.setTime(d.getTime() + (365*24*60*60*1000));
    var expires = "expires="+d.toUTCString();
    __ez.ck.setByCat("ezux_lpl_131660=" + new Date().getTime() + "|" + pvID + "|" + rv + "; " + expires, 3);
}
function attach_ezolpl(pvID, rv) {
    if (document.readyState === "complete") {
        create_ezolpl(pvID, rv);
    }
    if(window.attachEvent) {
        window.attachEvent("onload", create_ezolpl, pvID, rv);
    } else {
        if(window.onload) {
            var curronload = window.onload;
            var newonload = function(evt) {
                curronload(evt);
                create_ezolpl(pvID, rv);
            };
            window.onload = newonload;
        } else {
            window.onload = create_ezolpl.bind(null, pvID, rv);
        }
    }
}

__ez.queue.addFunc("attach_ezolpl", "attach_ezolpl", ["7601e16b-8046-4931-46da-8a7d9f3ee0d5", "false"], false, ['/detroitchicago/boise.js'], true, false, false, false);
</script></head>
<body class="item">
<div class="theme-opt" style="display:none">
<div class="option section" id="option" name="Theme Option"><div class="widget HTML" data-version="1" id="HTML103">

<script type="text/javascript"> 
          //<![CDATA[
          var recentposts_number = 5;
          //]]>
         </script>
         
</div><div class="widget HTML" data-version="1" id="HTML104">
<script type="text/javascript"> 
          //<![CDATA[
          var randomposts_number = 4;
          //]]>
         </script>
</div><div class="widget HTML" data-version="1" id="HTML105">

         <script type="text/javascript">
          var postperpage=12;
         </script>
         
</div><div class="widget HTML" data-version="1" id="HTML106">
</div><div class="widget HTML" data-version="1" id="HTML851">
</div></div>
</div>

<div id="pages-wrap" class="item">

<div id="outer-wrapper">
<div id="topnav">
<div class="tm-head row">
<div class="tm-menu">
<div class="menu1 section" id="menu1" name="Top Navigation"><div class="widget LinkList" data-version="1" id="LinkList210">
<div class="widget-content">
<ul id="nav1">
<li><a href="https://www.linuxuprising.com/p/about.html">About</a></li>
<li><a href="https://www.reddit.com/r/LinuxUprising/" rel="noreferrer" target="_blank">Submit A Tip</a></li>
</ul>
</div>
</div></div>
</div>
<!-- Top Social -->
<div class="social-area">
<div class="social-top section" id="social-top" name="Social Top"><div class="widget LinkList" data-version="1" id="LinkList50">
<div class="widget-content">
<ul>
<li><a class="rss" href="https://www.linuxuprising.com/feeds/posts/default" rel="noreferrer" target="_blank" title="rss"></a></li>
<li><a class="friendica" href="https://libranet.de/profile/linuxuprising" rel="noreferrer" target="_blank" title="friendica"></a></li>
<li><a class="twitter" href="https://twitter.com/linuxuprising" rel="noreferrer" target="_blank" title="twitter"></a></li>
<li><a class="telegram" href="https://t.me/LinuxUprising" rel="noreferrer" target="_blank" title="telegram"></a></li>
<li><a class="reddit" href="https://www.reddit.com/r/LinuxUprising/" rel="noreferrer" target="_blank" title="reddit"></a></li>
</ul>
</div>
</div></div>
</div>
</div>
</div>
<div id="header-blog">
<div class="header-content row">
<div class="header-logo">
<div class="section" id="logo_blog" name="Logo"><div class="widget Header" data-version="1" id="Header1">
<div id="header-inner">
<h2 class="logo">
<a href="https://www.linuxuprising.com/" style="display: block">
<img alt="Linux Uprising Blog" height="23px; " id="Header1_headerimg" src="https://cdn.rawgit.com/logix2/6fb43ed0a1979f24c50857fadc6de3ac/raw/24571f5df3fa6fadeeb0937ffd40ea38c380075f/logo2.svg" style="display: block" width="455px; "/>
</a>
<span class="alt-logo">Linux Uprising blog</span>
</h2>
</div>
</div></div>
</div>
<!-- <div class='header-ads'> <b:section id='ads-content' maxwidgets='1' name='Ads 728x90' showaddelement='yes'> <b:widget id='HTML1' locked='false' title='' type='HTML'> <b:includable id='main'> <b:if cond='data:title != ""'> <h2 class='title'><data:title/></h2> </b:if> <div class='widget-content'> <data:content/> </div> </b:includable> </b:widget> </b:section> </div> -->
</div>
</div>
<nav class="row" id="header-navigation">
<div class="nav-wrapper">
<div class="nav-menu">
<div class="header-search">
<ul>
<li>
<a class="search" id="search" title="Search">
<form action="/search/max-results=14" method="get">
<input id="s" name="q" placeholder="Type and hit enter..." type="text"/>
</form>
</a>
</li>
</ul>
</div>
<div class="header-menu">
<ul>
<li class="home-child"><a href="https://www.linuxuprising.com/">Home</a></li>
</ul>
<div class="menu section" id="menu" name="Main Menu"><div class="widget LinkList" data-version="1" id="LinkList110">
<div class="widget-content">
<ul id="nav" itemscope="" itemtype="https://schema.org/SiteNavigationElement">
<li itemprop="name"><a href="https://www.linuxuprising.com/search/label/news?max-results=14" itemprop="url">News</a></li>
<li itemprop="name"><a href="https://www.linuxuprising.com/search/label/apps?max-results=14" itemprop="url">Applications</a></li>
<li itemprop="name"><a href="https://www.linuxuprising.com/search/label/how-to?max-results=14" itemprop="url">Tutorials</a></li>
<li itemprop="name"><a href="https://www.linuxuprising.com/search/label/tweaks?max-results=14" itemprop="url">Tweaks</a></li>
<li itemprop="name"><a href="https://www.linuxuprising.com/search/label/customization?max-results=14" itemprop="url">Themes &amp; More</a></li>
<li itemprop="name"><a href="https://www.linuxuprising.com/search/label/console?max-results=14" itemprop="url">Console</a></li>
</ul>
</div>
</div></div>
</div>
</div>
</div>
</nav>
<div class="clear"></div>
<div class="row content-all" id="content-wrapper">
<div id="main-wrapper">
<div id="ads-blog">
<div class="home-ad no-items section" id="ads-home" name="Ads Home/Post (728x90)">
</div>
</div>
<div class="main section" id="main" name="Main Wrapper"><div class="widget Blog" data-version="1" id="Blog1">
<div class="blog-posts hfeed">
<div class="post-outer" id="post-outer">
<div class="post" id="post-article">

    <div itemprop="blogPost" itemscope="itemscope" itemtype="https://schema.org/Article">
            <meta content="data:post.link : data:post.url" itemtype="https://schema.org/WebPage" itemid="" itemprop="mainEntityOfPage" itemscope="itemscope"/>
<div itemprop="publisher" itemscope="itemscope" itemtype="https://schema.org/Organization">
<div itemprop="logo" itemscope="itemscope" itemtype="https://schema.org/ImageObject">
<meta content="https://4.bp.blogspot.com/-OlFvIO7s2mM/WrzEk1hCVZI/AAAAAAAAAE0/H4meMs7XreskNd_mTgVtNREkBX08-O1CACK4BGAYYCw/s590/LUR_logo1.png" itemprop="url"/>
<meta content="455" itemprop="width"/>
<meta content="48" itemprop="height"/>
</div>
<meta content="Linux Uprising Blog" itemprop="name"/>
</div>
<meta content="https://1.bp.blogspot.com/-CdQitrWkHqY/YTnlyMLV7bI/AAAAAAAAFyQ/9LaOtu04AxsG318h5Vb3kfgv1iVVHPENQCLcBGAsYHQ/w640-h440/plocate-linux.png" itemprop="image"/>
<div class="post-header">
<div id="adsense-top-horiz">
<div id="ezoic-pub-ad-placeholder-103">
</div>
</div>
<div class="post-head"><h1 class="post-title entry-title" id="entry-title" itemprop="name headline">
plocate Is A Much Faster locate (Drop-In Replacement For mlocate)
</h1></div>
<div class="post-meta">
<span class="post-author vcard">
<i class="fa fa-user"></i>
<span class="fn" itemprop="author" itemscope="itemscope" itemtype="https://schema.org/Person">
<meta content="https://www.blogger.com/profile/03026963810377267607" itemprop="url"/>
<a class="g-profile" href="https://www.blogger.com/profile/03026963810377267607" rel="author" title="Logix">
                   <span itemprop="name">Logix</span>
</a>
</span>
</span>
<span class="post-timestamp">
<i class="fa fa-clock-o"></i>
<meta content="https://www.linuxuprising.com/2021/09/plocate-is-much-faster-locate-drop-in.html" itemprop="url"/>
           Updated on <a class="timestamp-link" href="https://www.linuxuprising.com/2021/09/plocate-is-much-faster-locate-drop-in.html" rel="bookmark" title="permanent link"><time class="updated timeago" datetime="2021-09-09T10:48:29Z" title="2021-09-09T10:48:29Z"><span id="updatedateinfo">2021-09-09T10:48:29Z</span></time></a>
<script data-pagespeed-no-defer="data-pagespeed-no-defer" type="text/javascript">
            var dates = "2021-09-09T10:48:29Z"
            var dateu = new Date(dates);
            var months = ["January","February","March","April","May","June","July","August","September","October","November","December"];
            document.getElementById("updatedateinfo").innerHTML = months[dateu.getMonth()] + " " + dateu.getDate() + ", " + dateu.getFullYear();
        </script>
<meta content="2021-09-09T10:48:29Z" itemprop="dateModified"/>
<meta content="2021-09-09T11:48:00+01:00" itemprop="datePublished"/>
</span>
<span class="label-head">
<i class="fa fa-folder-open-o"></i>
<a href="https://www.linuxuprising.com/search/label/console?max-results=14" rel="tag">console</a>
</span>
</div>
<div class="ads-posting">
<div id="ezoic-pub-ad-placeholder-107"></div>
</div>
</div>
<article>
<div class="post-body entry-content" id="post-body-3892020352571529214" itemprop="articleBody">
<meta content="locate  is a Unix tool used to find files by name on the filesystem, which uses a prebuilt database of generated files (created using update..." name="twitter:description"/>
<div class="separator" style="clear: both; text-align: center;"><a href="https://1.bp.blogspot.com/-CdQitrWkHqY/YTnlyMLV7bI/AAAAAAAAFyQ/9LaOtu04AxsG318h5Vb3kfgv1iVVHPENQCLcBGAsYHQ/s905/plocate-linux.png" style="margin-left: 1em; margin-right: 1em;"><img alt="plocate find files command line" border="0" data-original-height="621" data-original-width="905" height="440" src="https://1.bp.blogspot.com/-CdQitrWkHqY/YTnlyMLV7bI/AAAAAAAAFyQ/9LaOtu04AxsG318h5Vb3kfgv1iVVHPENQCLcBGAsYHQ/w640-h440/plocate-linux.png" title="plocate find files command line" width="640"/></a></div><p></p><p><span class="codeblock2"><code>locate</code></span> is a Unix tool used to find files by name on the filesystem, which uses a prebuilt database of generated files (created using <span class="codeblock2"><code>updatedb</code></span>). Using <span class="codeblock2"><code>locate</code></span> is faster than <span class="codeblock2"><code>find</code></span>, but it requires having the database updated to find newly added files.</p><p><span class="codeblock2"><code>locate</code></span> was created in 1982, with the BSD and GNU Findutils versions deriving from the original implementation.</p><p><b><a href="https://plocate.sesse.net/" target="_blank">plocate</a> is a newer (the first stable release was less than a year ago), much faster <span class="codeblock2"><code>locate</code></span>. It&#39;s based on posting lists, giving much faster searches on a much smaller index. </b></p><p>The command-line tool is a drop-in replacement for <span class="codeblock2"><code>mlocate</code></span> (Merging Locate; a restricted-access database, only showing filenames accessible to the user) in nearly all aspects, including reusing the <span class="codeblock2"><code>mlocate</code></span> database (plocate creates its own index using <span class="codeblock2"><code>plocate-build</code></span> which reads the database made by <span class="codeblock2"><code>updatedb</code></span>), and <b>is fast on SSDs and HDDs alike</b>.<span></span></p><a name="more"></a><p></p><p></p><blockquote>plocate works by creating an inverted index over trigrams (combinations of three bytes) in the search strings, which allows it to rapidly narrow down the set of candidates to a very small list, instead of linearly scanning through every entry. It does nearly all I/O asynchronously using io_uring if available (Linux 5.1+), which reduces the impact of seek latency on systems without SSDs.</blockquote><p></p><p><b><i>You might also like: <a href="https://www.linuxuprising.com/2020/09/how-to-find-files-modified-in-last-n.html">How To Find Files Modified In The Last N Days Or Minutes Using find</a></i></b></p><p>To show how fast plocate is compared to mlocate, the plocate developer shows this benchmark on the tool&#39;s homepage in which plocate is able to find 2 files out of 27 million in just a few milliseconds:</p><div class="separator" style="clear: both; text-align: center;"><a href="https://1.bp.blogspot.com/-EdTxJ8TWdHc/YTnfChAsboI/AAAAAAAAFyI/GlL80C2vZDgsB-65XDsuvXkgamVhsCUdQCLcBGAsYHQ/s642/plocate.png" style="margin-left: 1em; margin-right: 1em;"><img alt="plocate performance" border="0" data-original-height="331" data-original-width="642" src="https://1.bp.blogspot.com/-EdTxJ8TWdHc/YTnfChAsboI/AAAAAAAAFyI/GlL80C2vZDgsB-65XDsuvXkgamVhsCUdQCLcBGAsYHQ/s16000/plocate.png" title="plocate performance"/></a></div><br/><p>Also, like <span class="codeblock2"><code>mlocate</code></span>, plocate shows all the files matching the search query only if they are visible to the user running the command, skipping all restricted files.</p><br/><h2 style="text-align: left;">How to install and use plocate</h2><br/><p><b>plocate is available in the official repositories of a few Linux distributions, including Arch Linux / Manjaro and Debian</b> (Bullseye and newer, as well as the Buster backports) / <b>Ubuntu</b> (21.04 and newer). You can install it using:</p><p></p><ul style="text-align: left;"><li><b>Arch Linux / Manjaro:</b></li></ul><pre class="cssterm"><code>sudo pacman -S plocate</code></pre><p></p><p></p><ul style="text-align: left;"><li><b>Debian (Bullseye and newer, as well as the Buster backports) / Ubuntu (21.04 and newer):</b></li></ul><pre class="cssterm"><code>plocate find files command linesudo apt install plocate</code></pre><p></p><p><b>To build it on other Linux distributions</b> you&#39;ll need a C++17 compiler, Zstd (development headers) and Meson. In my test on Fedora I also had to install <span class="codeblock2"><code>libatomic</code></span> to get the program to build. Optionally, you&#39;ll also want <span class="codeblock2"><code>liburing</code></span> and a kernel supporting <span class="codeblock2"><code>io_uring</code></span> (Linux 5.1 or newer) for best performance, especially if you&#39;re not using a SSD. Another optional dependency is systemd, which can be used to run the built-in plocate database update timer.</p><p><b>To install the plocate build-dependencies on Fedora (including the optional <span class="codeblock2"><code>liburing</code></span>), use:</b></p><p></p><pre class="cssterm"><code>sudo dnf install libzstd-devel liburing-devel libatomic gcc-c++ meson</code></pre><p></p><p><b>Or to build it on e.g. Ubuntu 20.04 (note that Ubuntu 20.04 doesn&#39;t have <span class="codeblock2"><code>liburing</code></span> in its repositories so plocate will not use all of its power if you&#39;re using a regular HDD), you&#39;ll need these dependencies:</b></p><p></p><pre class="cssterm"><code>sudo apt install libzstd-dev meson build-essential</code></pre><p></p><p><b>Once you have the build-dependencies installed, <a href="https://plocate.sesse.net/" rel="nofollow" target="_blank">download</a> and extract plocate, and use the terminal to navigate to its folder. Now </b><b>you can proceed to build and install plocate on your system:</b></p><pre class="cssterm"><code><p>meson obj</p><p>cd obj</p><p>ninja</p><p>sudo groupadd --system plocate</p><p>sudo ninja install</p>sudo systemctl enable plocate-updatedb.timer</code></pre><p></p><p><b>Now you can start using plocate.</b> Before using it for the first time, create its database (file index) using the following command:</p><p></p><pre class="cssterm"><code>sudo updatedb</code></pre><p></p><p>The first time you run <span class="codeblock2"><code>updatedb</code></span>, it scans the entire filesystem, and it may take a while. Subsequent runs should be much faster.</p><p>Now use <span class="codeblock2"><code>plocate</code></span> like you would use <span class="codeblock2"><code>locate</code></span>. <b>Search for a file using plocate:</b></p><p></p><pre class="cssterm"><code>locate &lt;MY_FILE.EXT&gt;</code></pre><p></p><p>Replacing <span class="codeblock2"><code>MY_FILE.EXT</code></span> with the file you want to find.</p><p>For more options like ignore case, regex search, etc., see the tool&#39;s help and man page.</p><p><b><i>You might like: <a href="https://www.linuxuprising.com/2019/09/how-to-delete-files-older-or-newer-than.html">How To Delete Files Older Or Newer Than N Days Using find (With Extra Examples)</a></i></b></p>
</div>
</article>
<div style="clear:both"></div>
<div class="post-footer">
<div class="share-box">
<h8 class="share-title">Share This:</h8>
<div class="share-art">
<a class="mast-art" href="https://sharetomastodon.github.io/?url=https://www.linuxuprising.com/2021/09/plocate-is-much-faster-locate-drop-in.html&amp;title=plocate Is A Much Faster locate (Drop-In Replacement For mlocate)" rel="nofollow noreferrer" target="_blank" title="Mastodon"><i class="fa fa-mastodon"></i><span class="resp_del">Mastodon</span></a>
<a class="twi-art" href="https://twitter.com/share?url=https://www.linuxuprising.com/2021/09/plocate-is-much-faster-locate-drop-in.html&amp;title=plocate Is A Much Faster locate (Drop-In Replacement For mlocate)" rel="nofollow noreferrer" target="_blank" title="Twitter"><i class="fa fa-twitter"></i><span class="resp_del2"> Twitter</span></a>
<a class="dis-art" href="https://sharetodiaspora.github.io/?url=https://www.linuxuprising.com/2021/09/plocate-is-much-faster-locate-drop-in.html&amp;title=plocate Is A Much Faster locate (Drop-In Replacement For mlocate)" rel="nofollow noreferrer" target="_blank" title="Diaspora"><i class="fa fa-diaspora"></i><span class="resp_del3">Diaspora</span></a>
<a class="redd-art" href="https://www.reddit.com/submit?url=https://www.linuxuprising.com/2021/09/plocate-is-much-faster-locate-drop-in.html&amp;title=plocate Is A Much Faster locate (Drop-In Replacement For mlocate)" rel="nofollow noreferrer" target="_blank" title="Reddit"><i class="fa fa-reddit-alien"></i><span class="resp_del4"> Reddit</span></a>
<a class="tel-art" href="https://telegram.me/share/url?text=plocate Is A Much Faster locate (Drop-In Replacement For mlocate)&amp;tags=&amp;url=https://www.linuxuprising.com/2021/09/plocate-is-much-faster-locate-drop-in.html" rel="nofollow noreferrer" target="_blank" title="Telegram"><i class="fa fa-telegram"></i><span class="resp_del5">Telegram</span></a>
<a class="wat-art" data-action="share/whatsapp/share" href="whatsapp://send?text=plocate Is A Much Faster locate (Drop-In Replacement For mlocate) https://www.linuxuprising.com/2021/09/plocate-is-much-faster-locate-drop-in.html" rel="nofollow noreferrer" target="_blank" title="WhatsApp"><i class="fa fa-whatsapp"></i><span class="resp_del6">WhatsApp</span></a>
</div>
</div>
<div style="clear:both"></div>
<div class="ads-post">
<a name="ads-post-in"></a>
</div>
<div id="related-posts">
<div class="related"><ul>
<li><div class="related-thumb"><a class="related-img" href="https://www.linuxuprising.com/2021/04/zellij-is-new-terminal-multiplexer.html" style="background:url(https://1.bp.blogspot.com/-RSybkbP90Y8/YIlO7olDssI/AAAAAAAAFfI/Jc7EDNf49_wqFw5T-xI3LgyG3kxQXEeMgCLcBGAsYHQ/s320/zellij.png) no-repeat center center;background-size: cover;" title="Zellij Is A New Terminal Multiplexer Written In Rust"></a></div><h3 class="related-title"><a href="https://www.linuxuprising.com/2021/04/zellij-is-new-terminal-multiplexer.html">Zellij Is A New Terminal Multiplexer Written In Rust</a></h3></li>
<li><div class="related-thumb"><a class="related-img" href="https://www.linuxuprising.com/2021/03/ytfzf-search-with-thumbnails-and-play.html" style="background:url(https://1.bp.blogspot.com/-23FYy8NjoMU/YEIm2dVpSII/AAAAAAAAFU4/PBlVIZievak2IPBQtIKo04Md3qZZvQmVwCLcBGAsYHQ/s320/ytfzf-thumbnails-search-play-youtube-terminal.png) no-repeat center center;background-size: cover;" title="ytfzf - Search (With Thumbnails) And Play YouTube Videos From A Terminal"></a></div><h3 class="related-title"><a href="https://www.linuxuprising.com/2021/03/ytfzf-search-with-thumbnails-and-play.html">ytfzf - Search (With Thumbnails) And Play YouTube Videos From A Terminal</a></h3></li>
<li><div class="related-thumb"><a class="related-img" href="https://www.linuxuprising.com/2021/02/archbox-makes-it-easy-to-install.html" style="background:url(https://1.bp.blogspot.com/-6et2yhSlhKU/YC0wMNXz2xI/AAAAAAAAFOU/9iVsBNu3qIMqBxqqNC5ixbjkDlqtcj35ACLcBGAsYHQ/s320/archbox-arch-linux-mint.png) no-repeat center center;background-size: cover;" title="Archbox Makes It Easy To Install Software From Arch Linux On Other Linux Distributions (Using A Chroot Environment)"></a></div><h3 class="related-title"><a href="https://www.linuxuprising.com/2021/02/archbox-makes-it-easy-to-install.html">Archbox Makes It Easy To Install Software From Arch Linux On Other Linux Distributions (Using A Chroot Environment)</a></h3></li>
</ul></div><div class="clear"></div>
</div>
<div class="under-related">
<div id="ezoic-pub-ad-placeholder-105"></div>
</div>
<div class="clear"></div>
<div class="comment-notif-box">Please post civil and on-topic comments. <a href="https://www.linuxuprising.com/p/commenting-guidelines.html" rel="nofollow">Commenting guidelines</a>.</div>
</div>
<div id="disqus_thread_load_on_scroll">
<div id="disqus_empty" style="display: none">Empty</div>
</div>

      </div>
    
</div>
<div class="comments" id="comments">
<a name="comments"></a>
<div id="backlinks-container">
<div id="Blog1_backlinks-container">
</div>
</div>
</div>
</div>
</div>
<div class="post-feeds">
</div>
</div></div>
<div id="ads-post10">
<div class="no-items section" id="ads-post-468" name="ADS Inner Footer 728x90">
</div>
</div>
</div>
<div class="sidebar-wrapper" id="sidebar-wrapper">
<div class="sidebar section" id="sidebar" name="Sidebar Right"><div class="widget HTML" data-version="1" id="HTML1">
<div class="widget-content">
<div id="imagehere" class="imagehere"><!-- Top Right Sidebar 300x250 -->
<!-- Ezoic - 300x250 top right - sidebar -->
<div id="ezoic-pub-ad-placeholder-102">            
<!-- <ins class="adsbygoogle"
     style="display:inline-block;width:300px;height:250px"
     data-ad-client="ca-pub-1997822342415050"
     data-ad-slot="8358301820"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script> -->
</div>
<!-- End Ezoic - 300x250 top right - sidebar -->
</div>

<script type="text/javascript">

window.addEventListener("load", function(){null==document.getElementsByTagName("iframe").item(ga.length-1)&&(document.getElementById("imagehere").innerHTML = "<a href='https://www.linuxuprising.com/2019/04/join-uprising.html' rel='nofollow noopener'><img src='https://4.bp.blogspot.com/-RM33YT7JTCw/XOVA0YwyKxI/AAAAAAAACyo/lA22C-cphP87WD39N4_9SJ-qG5b21IORgCLcBGAs/s1600/join-the-uprising.png' width='300' height='250' alt='Join the Uprising'/></a><br/>");});

</script>
</div>
</div><div class="widget HTML" data-version="1" id="HTML2">
<div class="widget-title"><h2 class="title">Recent Posts</h2></div>
<div id="RecentPosts">
<div class="widget-content">
<ul class="roma-widget">
<li><div class="wid-thumb"><a title="OpenSnitch Application Firewall 1.4.0 Adds eBPF And nftables Support, Allow/Block Lists" class="mag-thumb" href="https://www.linuxuprising.com/2021/09/opensnitch-application-firewall-140.html" style="background:url(https://1.bp.blogspot.com/-4QvsYaHtzyk/YTsj_cqhFpI/AAAAAAAAFyY/gOTxDLm4DxwKayu_OpX-JYxfGu3RN5xAQCLcBGAsYHQ/s135/opensnitch-140.png)"></a></div><div class="p-head"><h3 class="wrp-titulo"><a href="https://www.linuxuprising.com/2021/09/opensnitch-application-firewall-140.html">OpenSnitch Application Firewall 1.4.0 Adds eBPF And nftables Support, Allow/Block Lists</a></h3></div></li>              
<li><div class="wid-thumb"><a title="plocate Is A Much Faster locate (Drop-In Replacement For mlocate)" class="mag-thumb" href="https://www.linuxuprising.com/2021/09/plocate-is-much-faster-locate-drop-in.html" style="background:url(https://1.bp.blogspot.com/-CdQitrWkHqY/YTnlyMLV7bI/AAAAAAAAFyQ/9LaOtu04AxsG318h5Vb3kfgv1iVVHPENQCLcBGAsYHQ/s135/plocate-linux.png)"></a></div><div class="p-head"><h3 class="wrp-titulo"><a href="https://www.linuxuprising.com/2021/09/plocate-is-much-faster-locate-drop-in.html">plocate Is A Much Faster locate (Drop-In Replacement For mlocate)</a></h3></div></li>               
<li><div class="wid-thumb"><a title="Ubuntu&#39;s Yaru Theme Gets Official Support For Xfce" class="mag-thumb" href="https://www.linuxuprising.com/2021/09/ubuntus-yaru-theme-gets-official.html" style="background:url(https://1.bp.blogspot.com/-q0FSoIfEXiw/YTiHQ7qm3AI/AAAAAAAAFxs/iF4DDKft418ndVeNEYIdUa-fN_xTfANEACLcBGAsYHQ/s135/yaru-xfce-xubuntu.png)"></a></div><div class="p-head"><h3 class="wrp-titulo"><a href="https://www.linuxuprising.com/2021/09/ubuntus-yaru-theme-gets-official.html">Ubuntu&#39;s Yaru Theme Gets Official Support For Xfce</a></h3></div></li>   
<li><div class="wid-thumb"><a title="Draw Using Your Laptop Touchpad To Sign PDFs And More With FingerPaint" class="mag-thumb" href="https://www.linuxuprising.com/2021/09/draw-using-your-laptop-touchpad-to-sign.html" style="background:url(https://1.bp.blogspot.com/-5V1s5ym6NoE/YSYXpBgNlAI/AAAAAAAAFv8/FjJ0nys_3w0qiezgY8GPRQkDUzdLtXmXQCLcBGAsYHQ/s135/fingerpaint.png)"></a></div><div class="p-head"><h3 class="wrp-titulo"><a href="https://www.linuxuprising.com/2021/09/show-webp-thumbnails-in-gtk.html">Draw Using Your Laptop Touchpad To Sign PDFs And More With FingerPaint</a></h3></div></li>            
<li><div class="wid-thumb"><a title="Show WebP Thumbnails In GTK Applications (Nautilus, Thunar, Etc) Using WebP GDK Pixbuf Loader Library" class="mag-thumb" href="https://www.linuxuprising.com/2021/09/show-webp-thumbnails-in-gtk.html" style="background:url(https://1.bp.blogspot.com/-xSTYvxdDcxg/YS9lQ8OfByI/AAAAAAAAFxg/vvYT-oGs1Cglrm7sdT4eI8ixozhgjjK4ACLcBGAsYHQ/s135/webp-image-thumbnail-nautilus-gnome.png)"></a></div><div class="p-head"><h3 class="wrp-titulo"><a href="https://www.linuxuprising.com/2021/09/show-webp-thumbnails-in-gtk.html">Show WebP Thumbnails In GTK Applications (Nautilus, Thunar, Etc) Using WebP GDK Pixbuf Loader Library</a></h3></div></li>               
<li><div class="wid-thumb"><a title="exatorrent Is A New Self-Hostable BitTorrent Client Featuring A Responsive Web Interface, Streamable Torrents" class="mag-thumb" href="https://www.linuxuprising.com/2021/08/exatorrent-is-new-self-hostable.html" style="background:url(https://1.bp.blogspot.com/-G7TUVb6xaUM/YSdma_1GeHI/AAAAAAAAFw8/1Mo8xdSpDVwZi9AK30xRBMF3_3zoWbbmgCLcBGAsYHQ/s135/exatorrent.png)"></a></div><div class="p-head"><h3 class="wrp-titulo"><a href="https://www.linuxuprising.com/2021/08/exatorrent-is-new-self-hostable.html">exatorrent Is A New Self-Hostable BitTorrent Client Featuring A Responsive Web Interface, Streamable Torrents</a></h3></div></li>                                       
</ul>
</div>
</div>
</div><div class="widget HTML" data-version="1" id="HTML3">
<div class="widget-content">
<div style="margin:0 auto;">
<a target="_blank" rel="noopener nofollow" href="https://t.me/LinuxUprising"><img src="https://1.bp.blogspot.com/-fCC0RyOv2Ts/XcVRcqh6LxI/AAAAAAAADhQ/v-meoJy6TnUe9642hYTzRM1a9q1VQ7seQCLcBGAsYHQ/s1600/telegram-320.png" height="160" width="320" alt="Join us on Telegram" title="Join us on Telegram"/></a>
</div>
<br/>
<div style="margin:0 auto;">
<a target="_blank" rel="noopener nofollow" href="https://twitter.com/LinuxUprising"><img src="https://1.bp.blogspot.com/-LKFL-Vu_G8w/XfJ0DAfbXcI/AAAAAAAADtc/9nhpwKOKez4EOawDSsDVQe_le3D0Gu-1gCLcBGAsYHQ/s1600/twitter.png" height="160" width="320" alt="Follow us on Twitter" title="Follow us on Twitter"/></a>
</div>
<br/>
<!-- Ezoic - Sidebar middle - sidebar_middle -->
<div id="ezoic-pub-ad-placeholder-104">
</div>
<!-- End Ezoic - Sidebar middle - sidebar_middle -->
</div>
</div><div class="widget LinkList" data-version="1" id="LinkList2">
<div class="widget-title"><h2>Editor&#39;s Picks</h2></div>
<div class="widget-content">
<ul>
<li><a href="https://www.linuxuprising.com/2021/01/how-to-enable-hardware-accelerated.html">How To Enable Hardware Accelerated Video Decode In Google Chrome, Brave, Vivaldi And Opera Browsers On Debian, Ubuntu Or Linux Mint</a></li>
<li><a href="https://www.linuxuprising.com/2021/03/install-macos-big-sur-or-catalina-in.html">Install macOS Big Sur Or Catalina In A Virtual Machine Using Docker-OSX</a></li>
<li><a href="https://www.linuxuprising.com/2020/06/create-bootable-usb-drive-by-simply.html">Create A Bootable USB Drive By Simply Copying The ISO To The USB With Ventoy (Linux And Windows)</a></li>
<li><a href="https://www.linuxuprising.com/2020/01/how-to-boot-to-console-text-mode-in.html">How To Boot To Console (Text) Mode Using Debian / Ubuntu, Fedora, Arch Linux / Manjaro And More</a></li>
<li><a href="https://www.linuxuprising.com/2019/11/ffmpeg-extract-audio-from-video-in.html">FFmpeg: Extract Audio From Video In Original Format Or Converting It To MP3 Or Ogg Vorbis</a></li>
<li><a href="https://www.linuxuprising.com/2018/06/how-to-install-davinci-resolve-15-in.html">How To Install DaVinci Resolve 16.2 In Ubuntu, Linux Mint Or Debian (Generate DEB Package)</a></li>
<li><a href="https://www.linuxuprising.com/2018/12/how-to-change-grub-boot-order-or.html">How To Change The GRUB Boot Order Or Default Boot Entry In Ubuntu, Linux Mint, Debian, Or Fedora With Grub Customizer</a></li>
<li><a href="https://www.linuxuprising.com/2019/06/new-oracle-java-11-installer-for-ubuntu.html">New Oracle Java 11 Installer For Ubuntu Or Linux Mint (Using Local Oracle Java .tar.gz)</a></li>
<li><a href="https://www.linuxuprising.com/2018/07/how-to-fix-could-not-get-lock.html">How To Fix `Could not get lock /var/lib/dpkg/lock - open (11 Resource temporarily unavailable)` Errors</a></li>
<li><a href="https://www.linuxuprising.com/2018/07/how-to-mount-onedrive-in-linux-using.html">How To Mount OneDrive In Linux Using Rclone (Supports Business And Personal Accounts)</a></li>
</ul>
</div>
</div><div class="widget HTML" data-version="2" id="HTML5">
<div class="widget-content">
<!-- Ezoic - Sidebar bottom - sidebar_bottom -->
<div id="ezoic-pub-ad-placeholder-106"></div>
<!-- End Ezoic - Sidebar bottom - sidebar_bottom -->
</div>
</div><div class="widget HTML" data-version="1" id="HTML6">
<script type="text/javascript">
var disqus_shortname = 'linuxuprising';
var disqus_blogger_current_url = "https://www.linuxuprising.com/2021/09/plocate-is-much-faster-locate-drop-in.html";
var disqus_title = "plocate Is A Much Faster locate (Drop-In Replacement For mlocate) - Linux Uprising Blog";
if (!disqus_blogger_current_url.length) {
disqus_blogger_current_url = "https://www.linuxuprising.com/2021/09/plocate-is-much-faster-locate-drop-in.html";
}
var disqus_blogger_homepage_url = "https://www.linuxuprising.com/";
var disqus_blogger_canonical_homepage_url = "https://www.linuxuprising.com/";
</script>
<script>
var disqus_loaded = false;
function load_disqus( disqus_shortname ) {
  // Prepare the trigger and target

  var is_disqus_empty = document.getElementById('disqus_empty'),
      disqus_target   = document.getElementById('disqus_thread_load_on_scroll'),
      disqus_embed    = document.createElement('script'),
      disqus_hook     = (document.getElementsByTagName('head')[0] || document.getElementsByTagName('body')[0]);

  // Load script asynchronously only when the trigger and target exist
  if( disqus_target && is_disqus_empty ) {
    disqus_loaded = true;
    disqus_embed.type = 'text/javascript';
    disqus_embed.async = true;
    disqus_embed.src = '//linuxuprising.disqus.com/blogger_item.js';
    disqus_hook.appendChild(disqus_embed);
    is_disqus_empty.remove();

    var existCondition = setInterval(function() {
        if (document.querySelector('#disqus_thread iframe:first-child')) {
        clearInterval(existCondition);
        document.querySelector('#disqus_thread iframe:first-child').style.display = 'none';
        }
    }, 100);

  }
}

window.addEventListener('scroll', function(e) {
  var currentScroll = document.scrollingElement.scrollTop;
  var disqus_target = document.getElementById('disqus_thread_load_on_scroll');

  if( currentScroll > disqus_target.getBoundingClientRect().top - 150 ) {
    if (disqus_loaded==false) {
      load_disqus('linuxuprising');
    };
  }
}, false);
</script>
</div></div>
</div>
<div class="clear"></div>
</div>
<!-- end content-wrapper -->
<div class="clear"></div><!-- Footer wrapper -->
<div id="footer-wrapper">
<div id="footer">
<div class="footer-sections row" id="footer-sections">
<div class="sect-left section" id="footer-sec1" name="Widget 1"><div class="widget LinkList" data-version="1" id="LinkList1">
<div class="widget-title"><h2>Linux Uprising</h2></div>
<div class="widget-content">
<ul>
<li><a href="https://www.linuxuprising.com/p/about.html">About</a></li>
<li><a href="https://www.linuxuprising.com/p/privacy-policy.html">Privacy Policy</a></li>
<li><a href="https://www.linuxuprising.com/p/terms-of-use.html">Terms of Service</a></li>
<li><a href="https://www.linuxuprising.com/p/cookie-policy.html">Cookie Information</a></li>
<li><a href="https://www.linuxuprising.com/?ez_force_cookie_consent=1">Cookie Settings</a></li>
</ul>
</div>
</div></div>
<div class="sect-left section" id="footer-sec2" name="Widget 2"><div class="widget HTML" data-version="1" id="HTML199">
<div class="widget-title"><h2 class="title">License</h2></div>
<div class="widget-content">
<div id="license"><a href="https://creativecommons.org/licenses/by-sa/4.0/">Creative Commons Attribution 4.0 International License</a> <br/><br/>The registered trademark Linux® is used pursuant to a sublicense from the Linux Foundation, the exclusive licensee of Linus Torvalds, owner of the mark on a world-wide basis.</div>
</div>
</div></div>
<div class="sect-left section" id="footer-sec3" name="Widget 3"><div class="widget BlogArchive" data-version="1" id="BlogArchive2">
<div class="widget-title"><h2>Blog Archive</h2></div>
<div class="widget-content">
<div id="ArchiveList">
<div id="BlogArchive2_ArchiveList">
<label aria-label="archive-menu" for="BlogArchive2_ArchiveMenu">
<select id="BlogArchive2_ArchiveMenu">
<option value="">Blog Archive</option>
<option value="https://www.linuxuprising.com/2021/09/">September 2021 (5)</option>
<option value="https://www.linuxuprising.com/2021/08/">August 2021 (9)</option>
<option value="https://www.linuxuprising.com/2021/07/">July 2021 (4)</option>
<option value="https://www.linuxuprising.com/2021/06/">June 2021 (6)</option>
<option value="https://www.linuxuprising.com/2021/05/">May 2021 (13)</option>
<option value="https://www.linuxuprising.com/2021/04/">April 2021 (11)</option>
<option value="https://www.linuxuprising.com/2021/03/">March 2021 (13)</option>
<option value="https://www.linuxuprising.com/2021/02/">February 2021 (21)</option>
<option value="https://www.linuxuprising.com/2021/01/">January 2021 (11)</option>
<option value="https://www.linuxuprising.com/2020/12/">December 2020 (10)</option>
<option value="https://www.linuxuprising.com/2020/11/">November 2020 (12)</option>
<option value="https://www.linuxuprising.com/2020/10/">October 2020 (13)</option>
<option value="https://www.linuxuprising.com/2020/09/">September 2020 (6)</option>
<option value="https://www.linuxuprising.com/2020/07/">July 2020 (8)</option>
<option value="https://www.linuxuprising.com/2020/06/">June 2020 (8)</option>
<option value="https://www.linuxuprising.com/2020/05/">May 2020 (7)</option>
<option value="https://www.linuxuprising.com/2020/04/">April 2020 (13)</option>
<option value="https://www.linuxuprising.com/2020/03/">March 2020 (12)</option>
<option value="https://www.linuxuprising.com/2020/02/">February 2020 (14)</option>
<option value="https://www.linuxuprising.com/2020/01/">January 2020 (13)</option>
<option value="https://www.linuxuprising.com/2019/12/">December 2019 (14)</option>
<option value="https://www.linuxuprising.com/2019/11/">November 2019 (18)</option>
<option value="https://www.linuxuprising.com/2019/10/">October 2019 (13)</option>
<option value="https://www.linuxuprising.com/2019/09/">September 2019 (17)</option>
<option value="https://www.linuxuprising.com/2019/08/">August 2019 (11)</option>
<option value="https://www.linuxuprising.com/2019/07/">July 2019 (22)</option>
<option value="https://www.linuxuprising.com/2019/06/">June 2019 (18)</option>
<option value="https://www.linuxuprising.com/2019/05/">May 2019 (19)</option>
<option value="https://www.linuxuprising.com/2019/04/">April 2019 (20)</option>
<option value="https://www.linuxuprising.com/2019/03/">March 2019 (16)</option>
<option value="https://www.linuxuprising.com/2019/02/">February 2019 (17)</option>
<option value="https://www.linuxuprising.com/2019/01/">January 2019 (21)</option>
<option value="https://www.linuxuprising.com/2018/12/">December 2018 (15)</option>
<option value="https://www.linuxuprising.com/2018/11/">November 2018 (24)</option>
<option value="https://www.linuxuprising.com/2018/10/">October 2018 (22)</option>
<option value="https://www.linuxuprising.com/2018/09/">September 2018 (15)</option>
<option value="https://www.linuxuprising.com/2018/08/">August 2018 (27)</option>
<option value="https://www.linuxuprising.com/2018/07/">July 2018 (26)</option>
<option value="https://www.linuxuprising.com/2018/06/">June 2018 (21)</option>
<option value="https://www.linuxuprising.com/2018/05/">May 2018 (31)</option>
<option value="https://www.linuxuprising.com/2018/04/">April 2018 (25)</option>
<option value="https://www.linuxuprising.com/2018/03/">March 2018 (1)</option>
</select>
</label>
</div>
</div>
</div>
</div></div>
</div>
</div>
<div class="clear"></div>
<div class="footer-wrapper">
<div class="footer-sec row">
<!-- Footer Social -->
<div class="social-footer section" id="social-footer" name="Social Footer"><div class="widget LinkList" data-version="1" id="LinkList20">
<div class="widget-content">
<ul>
<li><a class="rss" href="https://www.linuxuprising.com/feeds/posts/default" rel="noreferrer" target="_blank" title="rss"></a></li>
<li><a class="friendica" href="https://libranet.de/profile/linuxuprising" rel="noreferrer" target="_blank" title="friendica"></a></li>
<li><a class="twitter" href="https://twitter.com/linuxuprising" rel="noreferrer" target="_blank" title="twitter"></a></li>
<li><a class="telegram" href="https://t.me/LinuxUprising" rel="noreferrer" target="_blank" title="telegram"></a></li>
<li><a class="reddit" href="https://www.reddit.com/r/LinuxUprising/" rel="noreferrer" target="_blank" title="reddit"></a></li>
</ul>
</div>
</div></div>
<!-- Footer Text -->
<div class="footertext">
Blog focused on Linux and FOSS.
</div>
</div>
</div>
</div>
</div>
<script type="text/javascript">

//<![CDATA[


// SelectNav.js - by: https://github.com/lukaszfiszer/selectnav.js - Adaptado por https://www.ideiasblog.com
window.selectnav=(function(){"use strict";var e=function(e,t){function c(e){var t;if(!e)e=window.event;if(e.target)t=e.target;else if(e.srcElement)t=e.srcElement;if(t.nodeType===3)t=t.parentNode;if(t.value)window.location.href=t.value}function h(e){var t=e.nodeName.toLowerCase();return t==="ul"||t==="ol"}function p(e){for(var t=1;document.getElementById("selectnav"+t);t++);return e?"selectnav"+t:"selectnav"+(t-1)}function d(e){a++;var t=e.children.length,n="",l="",c=a-1;if(!t){return}if(c){while(c--){l+=o}l+=" "}for(var v=0;v<t;v++){var m=e.children[v].children[0];if(typeof m!=="undefined"){var g=m.innerText||m.textContent;var y="";if(r){y=m.className.search(r)!==-1||m.parentNode.className.search(r)!==-1?f:""}if(i&&!y){y=m.href===document.URL?f:""}n+='<option value="'+m.href+'" '+y+">"+l+g+"</option>";if(s){var b=e.children[v].children[1];if(b&&h(b)){n+=d(b)}}}}if(a===1&&u){n='<option value="">'+u+"</option>"+n}if(a===1){n='<select class="selectnav" aria-label="menu" id="'+p(true)+'">'+n+"</select>"}a--;return n}e=document.getElementById(e);if(!e){return}if(!h(e)){return}if(!("insertAdjacentHTML"in window.document.documentElement)){return}document.documentElement.className+=" js";var n=t||{},r=n.activeclass||"active",i=typeof n.autoselect==="boolean"?n.autoselect:true,s=typeof n.nested==="boolean"?n.nested:true,o=n.indent||"→",u=n.label||"Menu",a=0,f=" selected ";e.insertAdjacentHTML("afterend",d(e));var l=document.getElementById(p());if(l.addEventListener){l.addEventListener("change",c)}if(l.attachEvent){l.attachEvent("onchange",c)}return l};return function(t,n){e(t,n)}})();

// Main Scripts 

//no need for a sub-menu now, only top level menus used right now
//$(document).ready(function() {
//    $("ul#sub-menu").parent("li").addClass("hasSub");
//    (jQuery)
//});

//$(document).ready(function() {
//    $('a[name="ads-post-in"]').before($('#ads-post10').html());
//    $('#ads-post10').html('')
//});

document.addEventListener("DOMContentLoaded", function(event) {
    //load menu
    selectnav('nav');selectnav('nav1');



    //$("#sidebar-wrapper").find(".widget h2").wrap("<div class='widget-title'/>");
    //$("#footer-sections").find(".widget h2").wrap("<div class='widget-title'/>");
    //var Posts = $("#post-outer")
    //Posts.each((function() {
    //    $(this).find(".block-image .thumb a").attr("style", (function(e, t) {
    //        return t.replace(/s72.*?\//, "s524-rw/")
    //    }))
    //})); 

    //$(window).scroll((function() {
    //    if ($(this).scrollTop() > 200) {
    //        $('#back-to-top').fadeIn()
    //    } else {
    //       $('#back-to-top').fadeOut()
    //    }
    //}));
    //$('#back-to-top').hide().click((function() {
    //    $('html, body').animate({
    //        scrollTop: 0
    //    }, 1000);
    //    return false
    //}));
    var search = document.querySelector('#search');
    search.addEventListener('click', function(e) {
        e.preventDefault();
        if (search.classList.contains('.active') && $(e.target).is(search)) {
            search.classList.remove('active')
        } else {
            search.classList.add('active');
            search.querySelector('input').focus()
        }
    });
});

//]]>
</script>
<script type="text/javascript">    
//<![CDATA[

document.addEventListener("DOMContentLoaded", function(event) {
        const termblocks = document.querySelectorAll('pre.cssterm');
        termblocks.forEach(function(userItem) {
            userItem.setAttribute('title', 'Triple click to select a complete line!');
        });
});

//]]>
</script>
<script type="text/javascript"> 
            //<![CDATA[

            window.onscroll = function() {myFunction()};

            // Get the navbar
            var navbar = document.getElementById("header-navigation");

            // Get the offset position of the navbar
            var sticky = navbar.offsetTop;

            // Add the sticky class to the navbar when you reach its scroll position. Remove "sticky" when you leave the scroll position
            function myFunction() {
                if (window.pageYOffset >= sticky) {
                    navbar.classList.add("sticky")
                } else {
                    navbar.classList.remove("sticky");
                }
            } 

            //]]>
          </script>
<script data-pagespeed-no-defer="data-pagespeed-no-defer" type="text/javascript">
!function(e,n,t){"use strict";var o="https://cdn.jsdelivr.net/npm/fork-awesome@1.1.3/css/fork-awesome.min.css",r="__3perf_googleFonts_dcfa3";function c(e){(n.head||n.body).appendChild(e)}function a(){var e=n.createElement("link");e.href=o,e.rel="stylesheet",c(e)}function f(e){if(!n.getElementById(r)){var t=n.createElement("style");t.id=r,c(t)}n.getElementById(r).innerHTML=e}e.FontFace&&e.FontFace.prototype.hasOwnProperty("display")?(t[r]&&f(t[r]),fetch(o).then(function(e){return e.text()}).then(function(e){return e.replace(/@font-face{/g,"@font-face{font-display:swap;")}).then(function(e){return e.replace(/\.\.\/fonts\//g,"https:\/\/cdn\.jsdelivr\.net\/npm\/fork-awesome@1\.1\.3\/fonts\/")}).then(function(e){return t[r]=e}).then(f).catch(a)):a()}(window,document,localStorage);
</script>
<script type="text/javascript">
        (function () {
            var done = false;
            var script = document.createElement("script"),
            head = document.getElementsByTagName("head")[0] || document.documentElement;
            script.src = 'https://ajax.googleapis.com/ajax/libs/webfont/1.6.26/webfont.js';
            script.async = true;
            script.onload = script.onreadystatechange = function() {
                if ( ! done && ( ! this.readyState || this.readyState === "loaded" || this.readyState === "complete" ) ) {
                    done = true;
                    WebFont.load({
                        google: {
                            families: ['Ubuntu:ital,wght@0,300;0,500;0,700;1,300&display=swap']
                        }
                    });
                    script.onload = script.onreadystatechange = null;
                }
            };
            head.insertBefore(script, head.firstChild);
        })();
    </script>
<div class="back-to-top">
<a href="#" id="back-to-top" title="back to top">
<i class="fa fa-long-arrow-up"></i>
</a>
</div>


</div><script type='text/javascript' style='display:none;' async>
__ez.queue.addFile('/detroitchicago/edmonton.webp', '/detroitchicago/edmonton.webp?a=a&cb=0&shcb=34', true, ['/detroitchicago/minneapolis.js'], true, false, false, false);
__ez.queue.addFile('/porpoiseant/jellyfish.webp', '/porpoiseant/jellyfish.webp?a=a&cb=0&shcb=34', false, [], true, false, false, false);
</script>

<script>var _audins_dom="linuxuprising_com",_audins_did=131660;__ez.queue.addDelayFunc("audins.js","__ez.script.add", "//go.ezoic.net/detroitchicago/audins.js?cb=195-0");</script><noscript><div style="display:none;"><img src="//pixel.quantserve.com/pixel/p-31iz6hfFutd16.gif?labels=Domain.linuxuprising_com,DomainId.131660" border="0" height="1" width="1" alt="Quantcast"/></div></noscript>
<script type="text/javascript" data-cfasync="false"></script>
<script>__ez.queue.addFile('/tardisrocinante/vitals.js', '/tardisrocinante/vitals.js?gcb=0&cb=3', false, ['/detroitchicago/minneapolis.js'], true, false, true, false);</script></body></html>