<!DOCTYPE html>
<html dir='ltr' lang='en-US' xmlns='http://www.w3.org/1999/xhtml' xmlns:b='http://www.google.com/2005/gml/b' xmlns:data='http://www.google.com/2005/gml/data' xmlns:expr='http://www.google.com/2005/gml/expr'>
<head><meta charset='utf-8'/>
<script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>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</script><script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>__ez.pel=(function(){var pixels=[],pxURL="/porpoiseant/army.gif";function AddAndFirePixel(adSlot,pixelData){AddPixel(adSlot,pixelData,0,0,0,0,0);Fire();}
function AddAndFireOrigPixel(adSlot,pixelData){AddPixel(adSlot,pixelData,0,0,0,0,0,true);Fire();}
function GetCurrentPixels(){return pixels;}
function AddPixel(adSlot,pixelData,revenue,est_revenue,bid_floor_filled,bid_floor_prev,stat_source_id,isOrig){if(!__ez.dot.isDefined(adSlot)||__ez.dot.isAnyDefined(adSlot.getSlotElementId,adSlot.ElementId)==false){return;}
var ad_position_id=parseInt(__ez.dot.getTargeting(adSlot,'ap'));var impId=__ez.dot.getSlotIID(adSlot),adUnit=__ez.dot.getAdUnit(adSlot,isOrig);var compId=parseInt(__ez.dot.getTargeting(adSlot,"compid"));var lineItemId=0;var creativeId=0;var ezimData=getEzimData(adSlot);if(typeof ezimData=='object'){if(ezimData.creative_id!==undefined){creativeId=ezimData.creative_id;}
if(ezimData.line_item_id!==undefined){lineItemId=ezimData.line_item_id;}}
if(__ez.dot.isDefined(impId,adUnit)&&__ez.dot.isValid(pixelData)){pixels.push({type:"impression",impression_id:impId,domain_id:__ez.dot.getDID(),unit:adUnit,t_epoch:__ez.dot.getEpoch(0),revenue:revenue,est_revenue:est_revenue,ad_position:ad_position_id,ad_size:"",bid_floor_filled:bid_floor_filled,bid_floor_prev:bid_floor_prev,stat_source_id:stat_source_id,country_code:__ez.dot.getCC(),pageview_id:__ez.dot.getPageviewId(),comp_id:compId,line_item_id:lineItemId,creative_id:creativeId,data:__ez.dot.dataToStr(pixelData),is_orig:isOrig||__ez.template.isOrig,});}}
function AddPixelById(impFullId,pixelData,isOrig){var vals=impFullId.split('/');if(__ez.dot.isDefined(impFullId)&&vals.length===3&&__ez.dot.isValid(pixelData)){var adUnit=vals[0],impId=vals[2];pixels.push({type:"impression",impression_id:impId,domain_id:__ez.dot.getDID(),unit:adUnit,t_epoch:__ez.dot.getEpoch(0),pageview_id:__ez.dot.getPageviewId(),data:__ez.dot.dataToStr(pixelData),is_orig:isOrig||__ez.template.isOrig});}}
function Fire(){if(typeof document.visibilityState!=='undefined'&&document.visibilityState==="prerender")return;if(__ez.dot.isDefined(pixels)&&pixels.length>0){var allPixels=[pixels.filter(function(pixel){return pixel.is_orig}),pixels.filter(function(pixel){return!pixel.is_orig})];allPixels.forEach(function(pixels){while(pixels.length>0){var isOrig=pixels[0].is_orig||false;var j=5;if(j>pixels.length){j=pixels.length;}
var pushPixels=pixels.splice(0,j);var pixelURL=__ez.dot.getURL(pxURL)+"?orig="+(isOrig===true?1:0)+"&sts="+btoa(JSON.stringify(pushPixels));if(typeof window.isAmp!=='undefined'&&isAmp&&typeof window._ezaq!=='undefined'&&_ezaq.hasOwnProperty("domain_id")){pixelURL+="&visit_uuid="+_ezaq['visit_uuid'];}
__ez.dot.Fire(pixelURL);}})}
pixels=[];}
function getEzimData(adSlot){if(typeof _ezim_d=="undefined"){return false}
var adUnitName=__ez.dot.getAdUnitPath(adSlot).split('/').pop();if(typeof _ezim_d==='object'&&_ezim_d.hasOwnProperty(adUnitName)){return _ezim_d[adUnitName];}
for(var ezimKey in _ezim_d){if(ezimKey.split('/').pop()===adUnitName){return _ezim_d[ezimKey];}}
return false;}
return{Add:AddPixel,AddAndFire:AddAndFirePixel,AddAndFireOrig:AddAndFireOrigPixel,AddById:AddPixelById,Fire:Fire,GetPixels:GetCurrentPixels,};})();__ez.queue.addFile('/detroitchicago/raleigh.js', '/detroitchicago/raleigh.js?gcb=192-0&cb=5', false, [], true, false, true, false);__ez.queue.addFile('/detroitchicago/tampa.js', '/detroitchicago/tampa.js?gcb=192-0&cb=3', false, [], true, false, true, false);</script>
<script data-ezscrex="false" data-cfasync="false">(function(){if("function"===typeof window.CustomEvent)return!1;window.CustomEvent=function(c,a){a=a||{bubbles:!1,cancelable:!1,detail:null};var b=document.createEvent("CustomEvent");b.initCustomEvent(c,a.bubbles,a.cancelable,a.detail);return b}})();</script><script data-ezscrex="false" data-cfasync="false">__ez.queue.addFile('/detroitchicago/tulsa.js', '/detroitchicago/tulsa.js?gcb=192-0&cb=5', false, [], true, false, true, false);</script>

<meta content='en-us' http-equiv='content-language'/>
<meta content='IE=edge' http-equiv='X-UA-Compatible'/>
<meta content='width=device-width,initial-scale=1.0' name='viewport'/>
<meta content='#f2132d' name='theme-color'/>
<meta content='#f2132d' name='msapplication-TileColor'/>
<meta content='#f2132d' name='msapplication-navbutton-color'/>
<link href='https://3.bp.blogspot.com/-_Rvl0I-6PsE/WxqOMWBSvFI/AAAAAAAAAr0/YVpbw6VxjTE0cs2FIG3JGGrzfelqF1AXQCLcBGAs/s1600-rw/apple-icon-180x180.png' rel='apple-touch-icon' sizes='180x180'/>
<link href='https://4.bp.blogspot.com/-C3SXpMZFwoM/WxqOMWPcqBI/AAAAAAAAAr4/q3BlIVZd9BIycvFtwpwee9ho2axmuey1wCLcBGAs/s1600-rw/android-icon-192x192.png' rel='icon' sizes='192x192' type='image/png'/>
<link href='https://1.bp.blogspot.com/-Rt0ksgLeHY8/XfJ5aMpjzZI/AAAAAAAADts/utsNBkpMNgoN82UZoo9EjfGponnDWZLIACLcBGAsYHQ/s1600-rw/favicon-large_32x32.png' rel='icon' sizes='32x32' type='image/png'/>
<meta content='text/html; charset=UTF-8' http-equiv='Content-Type'/>
<!-- Chrome, Firefox OS and Opera -->
<meta content='' name='theme-color'/>
<!-- Windows Phone -->
<meta content='' name='msapplication-navbutton-color'/>
<meta content='blogger' name='generator'/>
<link href='https://www.linuxuprising.com/favicon.ico' rel='icon' type='image/x-icon'/>
<link href='https://www.linuxuprising.com/2021/02/free-and-open-source-rts-game-0-ad.html' rel='canonical'/>
<link rel="alternate" type="application/atom+xml" title="Linux Uprising Blog - Atom" href="https://www.linuxuprising.com/feeds/posts/default" />
<link rel="alternate" type="application/rss+xml" title="Linux Uprising Blog - RSS" href="https://www.linuxuprising.com/feeds/posts/default?alt=rss" />
<link rel="service.post" type="application/atom+xml" title="Linux Uprising Blog - Atom" href="https://www.blogger.com/feeds/852161773840707483/posts/default" />

<link rel="alternate" type="application/atom+xml" title="Linux Uprising Blog - Atom" href="https://www.linuxuprising.com/feeds/4863265105667344662/comments/default" />
<!--Can't find substitution for tag [blog.ieCssRetrofitLinks]-->
<link href='https://1.bp.blogspot.com/-44vbUspyBZQ/YDON7vY8deI/AAAAAAAAFQU/nyjc62wr73soTuExqlpIuuS8NSK1OsYTACLcBGAsYHQ/s640/0ad-alpha24.png' rel='image_src'/>
<meta content='0 A.D. Alpha 24 "Xšayāršā" has been released over the weekend, after almost 3 years since the previous release.' name='description'/>
<meta content='https://www.linuxuprising.com/2021/02/free-and-open-source-rts-game-0-ad.html' property='og:url'/>
<meta content='Free And Open Source RTS Game 0 A.D. Alpha 24 Xšayāršā Released' property='og:title'/>
<meta content='0 A.D. Alpha 24 &quot;Xšayāršā&quot; has been released over the weekend, after almost 3 years since the previous release.' property='og:description'/>
<meta content='https://1.bp.blogspot.com/-44vbUspyBZQ/YDON7vY8deI/AAAAAAAAFQU/nyjc62wr73soTuExqlpIuuS8NSK1OsYTACLcBGAsYHQ/w1200-h630-p-k-no-nu/0ad-alpha24.png' property='og:image'/>
<!--[if IE]> <script> (function() { var html5 = ("abbr,article,aside,audio,canvas,datalist,details," + "figure,footer,header,hgroup,mark,menu,meter,nav,output," + "progress,section,time,video").split(','); for (var i = 0; i < html5.length; i++) { document.createElement(html5[i]); } try { document.execCommand('BackgroundImageCache', false, true); } catch(e) {} })(); </script> <![endif]-->
<link href='https://fonts.gstatic.com' rel='dns-prefetch'/>
<link crossorigin='anonymous' href='https://fonts.gstatic.com' rel='preconnect'/>
<link href='https://cdn.jsdelivr.net' rel='dns-prefetch'/>
<link crossorigin='anonymous' href='https://cdn.jsdelivr.net' rel='preconnect'/>
<link crossorigin='crossorigin' href='https://fonts.googleapis.com' rel='preconnect'/>
<link crossorigin='crossorigin' href='https://ajax.googleapis.com' rel='preconnect'/>
<link crossorigin='crossorigin' href='https://www.google-analytics.com' rel='preconnect'/>
<link crossorigin='crossorigin' href='https://ssl.google-analytics.com' rel='preconnect'/>
<link crossorigin='crossorigin' href='https://apis.google.com' rel='preconnect'/>
<link crossorigin='crossorigin' href='https://googleads.g.doubleclick.net' rel='preconnect'/>
<link crossorigin='crossorigin' href='https://cdn.jsdelivr.net' rel='preconnect'/>
<link crossorigin='crossorigin' href='https://lh3.googleusercontent.com' rel='preconnect'/>
<link crossorigin='crossorigin' href='https://fonts.gstatic.com' rel='preconnect'/>
<link crossorigin='crossorigin' href='https://adservice.google.com' rel='preconnect'/>
<link crossorigin='crossorigin' href='https://www.googletagservices.com' rel='preconnect'/>
<link crossorigin='crossorigin' href='https://tpc.googlesyndication.com' rel='preconnect'/>
<link crossorigin='crossorigin' href='https://partner.googleadservices.com' rel='preconnect'/>
<link crossorigin='crossorigin' href='https://vendorlist.consensu.org' rel='preconnect'/>
<link crossorigin='crossorigin' href='https://cdnjs.cloudflare.com' rel='preconnect'/>
<link crossorigin='crossorigin' href='https://1.bp.blogspot.com' rel='preconnect'/>
<link crossorigin='crossorigin' href='https://2.bp.blogspot.com' rel='preconnect'/>
<link crossorigin='crossorigin' href='https://3.bp.blogspot.com' rel='preconnect'/>
<link crossorigin='crossorigin' href='https://4.bp.blogspot.com' rel='preconnect'/>
<link crossorigin='crossorigin' href='https://ib.adnxs.com' rel='preconnect'/>
<link crossorigin='crossorigin' href='https://bidder.criteo.com' rel='preconnect'/>
<link crossorigin='crossorigin' href='https://g.ezoic.net' rel='preconnect'/>
<link href='//linuxuprising.disqus.com' rel='preconnect'/>
<link href='//disqus.com' rel='dns-prefetch'/>
<link href='//c.disquscdn.com' rel='dns-prefetch'/>
<link href='//referrer.disqus.com' rel='dns-prefetch'/>
<link href='//juggler.services.disqus.com' rel='dns-prefetch'/>
<meta content='https://www.facebook.com/LinuxUprising' property='article:publisher'/>
<meta content='3F3C1DB7847EE7E64E8A2F6CDC5A5F10' name='msvalidate.01'/>
<meta content='de18aa7b281bff4c' name='yandex-verification'/>
<title>
Free And Open Source RTS Game 0 A.D. Alpha 24 Xšayāršā Released - Linux Uprising Blog
</title>
<!-- Description and Keywords (start) -->
<meta content='en_US' property='og:locale'/>
<!-- Description and Keywords (end) -->
<meta content='article' property='og:type'/>
<meta content='Linux Uprising Blog' property='og:site_name'/>
<meta content='https://www.linuxuprising.com/' name='twitter:domain'/>
<meta content='Free And Open Source RTS Game 0 A.D. Alpha 24 Xšayāršā Released' name='twitter:title'/>
<meta content='summary_large_image' name='twitter:card'/>
<meta content='https://1.bp.blogspot.com/-44vbUspyBZQ/YDON7vY8deI/AAAAAAAAFQU/nyjc62wr73soTuExqlpIuuS8NSK1OsYTACLcBGAsYHQ/s640/0ad-alpha24.png' name='twitter:image'/>
<meta content='0 A.D. Alpha 24 "Xšayāršā" has been released over the weekend, after almost 3 years since the previous release.' name='twitter:description'/>
<!-- Social Media meta tag need customer customization -->
<meta content='572203406470374' property='fb:app_id'/>
<meta content='841352899' property='fb:admins'/>
<meta content='@linuxuprising' name='twitter:site'/>
<meta content='@linuxuprising' name='twitter:creator'/>
<!-- Disable default blogger Cookie Choice-->
<script type='text/javascript'>
    cookieChoices = {};
</script>
<!-- Google Analytics -->
<script type='text/javascript'>
  <!-- Set personalized or not for ads based on cookie consent info -->    
  var checkUserConsent;

    // fetch consent information
    function EzConsentCallback(consent) {
        // consent contains the necessary, preferences, statistics, and marketing properties with boolean values 
        if(consent.marketing) {
            // Consent given
            // Ezoic handles the requestNonPersonalizedAds thingy itself
            // (adsbygoogle=window.adsbygoogle||[]).requestNonPersonalizedAds=0;
            checkUserConsent = 'YES'; 
        } else {
            // No consent for personalized ads
            // (adsbygoogle=window.adsbygoogle||[]).requestNonPersonalizedAds=1;
            checkUserConsent = 'NO';
        }
    }

  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');
  ga('create', 'UA-116578392-1', 'auto');
  if (checkUserConsent == 'NO') {
     ga('set', 'allowAdFeatures', false);
  }
  ga('set', 'anonymizeIp', true);
  ga('send', 'pageview');
</script>
<style id='page-skin-1' type='text/css'>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</style>
<style type='text/css'>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</style>
<noscript>
<style>
        #HTML1, #HTML2, #HTML3, #adsense-top-horiz {display:none;}
    </style>
</noscript>
<script type='text/javascript'> 
//<![CDATA[
var text_month = [, "Jan", "Feb", "Mar", "Apr", "May", "Jun", "Jul", "Aug", "Sept", "Oct", "Nov", "Dec"];
var no_image_url = "https://1.bp.blogspot.com/-dUVHHKr63sw/WrjkLAm4OkI/AAAAAAAAABU/SNBN1gIB8E0vLNWf41AGwudNCH1Q9hYYwCLcBGAs/s1600-rw/nothumb.jpg";
var feat1_number = 3;
var related_number = 4;
//]]>
</script>
<script>
        (function () {
            var done = false;
            var script = document.createElement("script"),
            head = document.getElementsByTagName("head")[0] || document.documentElement;
            script.src = 'https://ajax.googleapis.com/ajax/libs/webfont/1.6.26/webfont.js';
            script.async = true;
            script.onload = script.onreadystatechange = function() {
                if ( ! done && ( ! this.readyState || this.readyState === "loaded" || this.readyState === "complete" ) ) {
                    done = true;
                    WebFont.load({
                        google: {
                            families: ['Ubuntu:ital,wght@0,300;0,500;0,700;1,300&display=swap']
                        }
                    });
                    script.onload = script.onreadystatechange = null;
                }
            };
            head.insertBefore(script, head.firstChild);
        })();
    </script>
<noscript><link href='https://fonts.googleapis.com/css?family=Ubuntu:300,300i,500,700&display=swap' rel='stylesheet'/></noscript>
<script type='text/javascript'>
!function(e,n,t){"use strict";var o="https://cdn.jsdelivr.net/npm/fork-awesome@1.1.3/css/fork-awesome.min.css",r="__3perf_googleFonts_dcfa3";function c(e){(n.head||n.body).appendChild(e)}function a(){var e=n.createElement("link");e.href=o,e.rel="stylesheet",c(e)}function f(e){if(!n.getElementById(r)){var t=n.createElement("style");t.id=r,c(t)}n.getElementById(r).innerHTML=e}e.FontFace&&e.FontFace.prototype.hasOwnProperty("display")?(t[r]&&f(t[r]),fetch(o).then(function(e){return e.text()}).then(function(e){return e.replace(/@font-face{/g,"@font-face{font-display:swap;")}).then(function(e){return e.replace(/\.\.\/fonts\//g,"https:\/\/cdn\.jsdelivr\.net\/npm\/fork-awesome@1\.1\.3\/fonts\/")}).then(function(e){return t[r]=e}).then(f).catch(a)):a()}(window,document,localStorage);
</script>
<noscript><link href='https://cdn.jsdelivr.net/npm/fork-awesome@1.1.3/css/fork-awesome.min.css' rel='stylesheet'/></noscript>
<link href='https://www.blogger.com/dyn-css/authorization.css?targetBlogID=852161773840707483&amp;zx=814ebc41-d2ed-424e-b2a9-cb71d19f5858' media='none' onload='if(media!=&#39;all&#39;)media=&#39;all&#39;' rel='stylesheet'/><noscript><link href='https://www.blogger.com/dyn-css/authorization.css?targetBlogID=852161773840707483&amp;zx=814ebc41-d2ed-424e-b2a9-cb71d19f5858' rel='stylesheet'/></noscript>

<!-- data-ad-client=ca-pub-1997822342415050 -->

<script type="text/javascript">var ezouid = "1";</script><base href="https://www.linuxuprising.com/2021/02/free-and-open-source-rts-game-0-ad.html"><script type='text/javascript'>
var ezoTemplate = 'old_site_gc';
if(typeof ezouid == 'undefined')
{
    var ezouid = 'none';
}
var ezoFormfactor = '1';
var ezo_elements_to_check = Array();
</script><!-- START EZHEAD -->
<script data-ezscrex="false" type='text/javascript'>
var soc_app_id = '0';
var did = 131660;
var ezdomain = 'linuxuprising.com';
var ezoicSearchable = 1;
</script>
<!--{jquery}-->
<!-- END EZHEAD -->
<script data-ezscrex="false" type="text/javascript" data-cfasync="false">var _ezaq = {"ad_cache_level":0,"ad_lazyload_version":0,"city":"Ashburn","country":"US","days_since_last_visit":-1,"domain_id":131660,"domain_test_group":20200402,"engaged_time_visit":0,"ezcache_level":0,"ezcache_skip_code":0,"form_factor_id":1,"framework_id":1,"is_return_visitor":false,"is_sitespeed":0,"last_page_load":"","last_pageview_id":"","lt_cache_level":0,"metro_code":511,"page_ad_positions":"","page_view_count":0,"page_view_id":"cf8acc4c-5810-4386-54b7-599997364d74","position_selection_id":0,"postal_code":"20149","pv_event_count":0,"response_size_orig":103735,"response_time_orig":111,"serverid":"54.165.91.255:1727","state":"VA","t_epoch":1614460908,"template_id":126,"time_on_site_visit":0,"url":"https://www.linuxuprising.com/2021/02/free-and-open-source-rts-game-0-ad.html","user_id":0,"word_count":884,"worst_bad_word_level":0};var _ezExtraQueries = "&ez_orig=1";</script><script data-ezscrex='false' data-cfasync='false' type="text/javascript" src="/detroitchicago/rochester.js?dcb=192-0&cb=2&v=9" async></script>
<script data-ezscrex='false' data-pagespeed-no-defer data-cfasync='false'>
function create_ezolpl(pvID, rv) {
    var d = new Date();
    d.setTime(d.getTime() + (365*24*60*60*1000));
    var expires = "expires="+d.toUTCString();
    __ez.ck.setByCat("ezux_lpl_131660=" + new Date().getTime() + "|" + pvID + "|" + rv + "; " + expires, 3);
}
function attach_ezolpl(pvID, rv) {
    if (document.readyState === "complete") {
        create_ezolpl(pvID, rv);
    }
    if(window.attachEvent) {
        window.attachEvent("onload", create_ezolpl, pvID, rv);
    } else {
        if(window.onload) {
            var curronload = window.onload;
            var newonload = function(evt) {
                curronload(evt);
                create_ezolpl(pvID, rv);
            };
            window.onload = newonload;
        } else {
            window.onload = create_ezolpl.bind(null, pvID, rv);
        }
    }
}

__ez.queue.addFunc("attach_ezolpl", "attach_ezolpl", ["cf8acc4c-5810-4386-54b7-599997364d74", "false"], false, ['/detroitchicago/boise.js'], true, false, false, false);
</script></head>
<body class='item'>
<div class='theme-opt' style='display:none'>
<div class='option section' id='option' name='Theme Option'><div class='widget HTML' data-version='1' id='HTML103'>

<script type='text/javascript'> 
          //<![CDATA[
          var recentposts_number = 5;
          //]]>
         </script>
         
</div><div class='widget HTML' data-version='1' id='HTML104'>
<script type='text/javascript'> 
          //<![CDATA[
          var randomposts_number = 4;
          //]]>
         </script>
</div><div class='widget HTML' data-version='1' id='HTML105'>

         <script type='text/javascript'>
          var postperpage=12;
         </script>
         
</div><div class='widget HTML' data-version='1' id='HTML106'>
</div><div class='widget HTML' data-version='1' id='HTML851'>
<script src='https://ajax.googleapis.com/ajax/libs/jquery/3.5.1/jquery.min.js' type='text/javascript'></script>
<script type='text/javascript'> 
            //<![CDATA[

            // Plugin: Sticky jQuery ~ BY: https://stickyjs.com
            (function(e){var t={topSpacing:0,bottomSpacing:0,className:"is-sticky",wrapperClassName:"sticky-wrapper",center:false,getWidthFrom:"",responsiveWidth:false},n=e(window),r=e(document),i=[],s=n.height(),o=function(){var t=n.scrollTop(),o=r.height(),u=o-s,a=t>u?u-t:0;for(var f=0;f<i.length;f++){var l=i[f],c=l.stickyWrapper.offset().top,h=c-l.topSpacing-a;if(t<=h){if(l.currentTop!==null){l.stickyElement.css("width","").css("position","").css("top","");l.stickyElement.trigger("sticky-end",[l]).parent().removeClass(l.className);l.currentTop=null}}else{var p=o-l.stickyElement.outerHeight()-l.topSpacing-l.bottomSpacing-t-a;if(p<0){p=p+l.topSpacing}else{p=l.topSpacing}if(l.currentTop!=p){l.stickyElement.css("width",l.stickyElement.width()).css("position","fixed").css("top",p);if(typeof l.getWidthFrom!=="undefined"){l.stickyElement.css("width",e(l.getWidthFrom).width())}l.stickyElement.trigger("sticky-start",[l]).parent().addClass(l.className);l.currentTop=p}}}},u=function(){s=n.height();for(var t=0;t<i.length;t++){var r=i[t];if(typeof r.getWidthFrom!=="undefined"&&r.responsiveWidth===true){r.stickyElement.css("width",e(r.getWidthFrom).width())}}},a={init:function(n){var r=e.extend({},t,n);return this.each((function(){var n=e(this);var s=n.attr("id");var o=s?s+"-"+t.wrapperClassName:t.wrapperClassName;var u=e("<div></div>").attr("id",s+"-sticky-wrapper").addClass(r.wrapperClassName);n.wrapAll(u);if(r.center){n.parent().css({width:n.outerWidth(),marginLeft:"auto",marginRight:"auto"})}if(n.css("float")=="right"){n.css({"float":"none"}).parent().css({"float":"right"})}var a=n.parent();a.css("height",n.outerHeight());i.push({topSpacing:r.topSpacing,bottomSpacing:r.bottomSpacing,stickyElement:n,currentTop:null,stickyWrapper:a,className:r.className,getWidthFrom:r.getWidthFrom,responsiveWidth:r.responsiveWidth})}))},update:o,unstick:function(t){return this.each((function(){var t=e(this);var n=-1;for(var r=0;r<i.length;r++){if(i[r].stickyElement.get(0)==t.get(0)){n=r}}if(n!=-1){i.splice(n,1);t.unwrap();t.removeAttr("style")}}))}};if(window.addEventListener){window.addEventListener("scroll",o,false);window.addEventListener("resize",u,false)}else if(window.attachEvent){window.attachEvent("onscroll",o);window.attachEvent("onresize",u)}e.fn.sticky=function(t){if(a[t]){return a[t].apply(this,Array.prototype.slice.call(arguments,1))}else if(typeof t==="object"||!t){return a.init.apply(this,arguments)}else{e.error("Method "+t+" does not exist on jQuery.sticky")}};e.fn.unstick=function(t){if(a[t]){return a[t].apply(this,Array.prototype.slice.call(arguments,1))}else if(typeof t==="object"||!t){return a.unstick.apply(this,arguments)}else{e.error("Method "+t+" does not exist on jQuery.sticky")}};e((function(){setTimeout(o,0)}))})(jQuery);
            //]]>
          </script>
          <script type='text/javascript'> 
            //<![CDATA[
              $(document).ready(function(){$("#header-navigation").sticky({topSpacing:0});});
            //]]>
          </script>
        </div></div>
</div>

<div id="pages-wrap" class="item">

<div id='outer-wrapper'>
<div id='topnav'>
<div class='tm-head row'>
<div class='tm-menu'>
<div class='menu1 section' id='menu1' name='Top Navigation'><div class='widget LinkList' data-version='1' id='LinkList210'>
<div class='widget-content'>
<ul id='nav1'>
<li><a href='https://www.linuxuprising.com/p/about.html'>About</a></li>
<li><a href='https://www.reddit.com/r/LinuxUprising/' rel='noreferrer' target='_blank'>Submit A Tip</a></li>
</ul>
</div>
</div></div>
</div>
<!-- Top Social -->
<div class='social-area'>
<div class='social-top section' id='social-top' name='Social Top'><div class='widget LinkList' data-version='1' id='LinkList50'>
<div class='widget-content'>
<ul>
<li><a class='rss' href='https://feeds.feedburner.com/LinuxUprising' rel='noreferrer' target='_blank' title='rss'></a></li>
<li><a class='friendica' href='https://libranet.de/profile/linuxuprising' rel='noreferrer' target='_blank' title='friendica'></a></li>
<li><a class='twitter' href='https://twitter.com/linuxuprising' rel='noreferrer' target='_blank' title='twitter'></a></li>
<li><a class='telegram' href='https://t.me/LinuxUprising' rel='noreferrer' target='_blank' title='telegram'></a></li>
<li><a class='facebook' href='https://www.facebook.com/LinuxUprising/' rel='noreferrer' target='_blank' title='facebook'></a></li>
<li><a class='reddit' href='https://www.reddit.com/r/LinuxUprising/' rel='noreferrer' target='_blank' title='reddit'></a></li>
</ul>
</div>
</div></div>
</div>
</div>
</div>
<div id='header-blog'>
<div class='header-content row'>
<div class='header-logo'>
<div class='section' id='logo_blog' name='Logo'><div class='widget Header' data-version='1' id='Header1'>
<div id='header-inner'>
<h2 class='logo'>
<a href='https://www.linuxuprising.com/' style='display: block'>
<img alt='Linux Uprising Blog' height='23px; ' id='Header1_headerimg' src='https://cdn.rawgit.com/logix2/6fb43ed0a1979f24c50857fadc6de3ac/raw/24571f5df3fa6fadeeb0937ffd40ea38c380075f/logo2.svg' style='display: block' width='455px; '/>
</a>
<span class='alt-logo'>Linux Uprising blog</span>
</h2>
</div>
</div></div>
</div>
<!-- <div class='header-ads'> <b:section id='ads-content' maxwidgets='1' name='Ads 728x90' showaddelement='yes'> <b:widget id='HTML1' locked='false' title='' type='HTML'> <b:includable id='main'> <b:if cond='data:title != &quot;&quot;'> <h2 class='title'><data:title/></h2> </b:if> <div class='widget-content'> <data:content/> </div> </b:includable> </b:widget> </b:section> </div> -->
</div>
</div>
<nav class='row' id='header-navigation'>
<div class='nav-wrapper'>
<div class='nav-menu'>
<div class='header-search'>
<ul>
<li>
<a class='search' id='search'>
<form action='/search/max-results=12' method='get'>
<input id='s' name='q' placeholder='Type and hit enter...' type='text'/>
</form>
</a>
</li>
</ul>
</div>
<div class='header-menu'>
<ul>
<li class='home-child'><a href='https://www.linuxuprising.com/'>Home</a></li>
</ul>
<div class='menu section' id='menu' name='Main Menu'><div class='widget LinkList' data-version='1' id='LinkList110'>
<div class='widget-content'>
<ul id='nav' itemscope='' itemtype='https://schema.org/SiteNavigationElement'>
<li itemprop='name'><a href='https://www.linuxuprising.com/search/label/news?max-results=12' itemprop='url'>News</a></li>
<li itemprop='name'><a href='https://www.linuxuprising.com/search/label/apps?max-results=12' itemprop='url'>Applications</a></li>
<li itemprop='name'><a href='https://www.linuxuprising.com/search/label/how-to?max-results=12' itemprop='url'>Tutorials</a></li>
<li itemprop='name'><a href='https://www.linuxuprising.com/search/label/tweaks?max-results=12' itemprop='url'>Tweaks</a></li>
<li itemprop='name'><a href='https://www.linuxuprising.com/search/label/customization?max-results=12' itemprop='url'>Themes & More</a></li>
<li itemprop='name'><a href='https://www.linuxuprising.com/search/label/console?max-results=12' itemprop='url'>Console</a></li>
</ul>
</div>
</div></div>
</div>
</div>
</div>
</nav>
<div class='clear'></div>
<div class='row' id='content-wrapper'>
<div id='main-wrapper'>
<div id='ads-blog'>
<div class='home-ad no-items section' id='ads-home' name='Ads Home/Post (728x90)'>
</div>
</div>
<div class='main section' id='main' name='Main Wrapper'><div class='widget Blog' data-version='1' id='Blog1'>
<div class='blog-posts hfeed'>
<div class='post-outer' id='post-outer'>
<div class='post' id='post-article'>

    <div itemprop='blogPost' itemscope='itemscope' itemtype='https://schema.org/Article'>
            <meta content='data:post.link : data:post.url' itemType='https://schema.org/WebPage' itemid='' itemprop='mainEntityOfPage' itemscope='itemscope'/>
<div itemprop='publisher' itemscope='itemscope' itemtype='https://schema.org/Organization'>
<div itemprop='logo' itemscope='itemscope' itemtype='https://schema.org/ImageObject'>
<meta content='https://4.bp.blogspot.com/-OlFvIO7s2mM/WrzEk1hCVZI/AAAAAAAAAE0/H4meMs7XreskNd_mTgVtNREkBX08-O1CACK4BGAYYCw/s590-rw/LUR_logo1.png' itemprop='url'/>
<meta content='455' itemprop='width'/>
<meta content='48' itemprop='height'/>
</div>
<meta content='Linux Uprising Blog' itemprop='name'/>
</div>
<meta content='https://1.bp.blogspot.com/-44vbUspyBZQ/YDON7vY8deI/AAAAAAAAFQU/nyjc62wr73soTuExqlpIuuS8NSK1OsYTACLcBGAsYHQ/s640/0ad-alpha24.png' itemprop='image'/>
<div class='post-header'>
<div id='adsense-top-horiz'>
<div id='ezoic-pub-ad-placeholder-103'>
</div>
</div>
<div class='post-head'><h1 class='post-title entry-title' id='entry-title' itemprop='name headline'>
Free And Open Source RTS Game 0 A.D. Alpha 24 Xšayāršā Released
</h1></div>
<div class='post-meta'>
<span class='post-author vcard'>
<i class='fa fa-user'></i>
<span class='fn' itemprop='author' itemscope='itemscope' itemtype='https://schema.org/Person'>
<meta content='https://www.blogger.com/profile/03026963810377267607' itemprop='url'/>
<a class='g-profile' href='https://www.blogger.com/profile/03026963810377267607' rel='author' title='Logix'>
                  &nbsp;<span itemprop='name'>Logix</span>
</a>
</span>
</span>
<span class='post-timestamp'>
<i class='fa fa-clock-o'></i>
<meta content='https://www.linuxuprising.com/2021/02/free-and-open-source-rts-game-0-ad.html' itemprop='url'/>
          &nbsp;Updated on <a class='timestamp-link' href='https://www.linuxuprising.com/2021/02/free-and-open-source-rts-game-0-ad.html' rel='bookmark' title='permanent link'><time class='updated timeago' datetime='2021-02-22T12:30:43Z' title='2021-02-22T12:30:43Z'><span id='updatedateinfo'>2021-02-22T12:30:43Z</span></time></a>
<script>
            var dates = "2021-02-22T12:30:43Z"
            var dateu = new Date(dates);
            var months = ["January","February","March","April","May","June","July","August","September","October","November","December"];
            document.getElementById("updatedateinfo").innerHTML = months[dateu.getMonth()] + " " + dateu.getDate() + ", " + dateu.getFullYear();
        </script>
<meta content='2021-02-22T12:30:43Z' itemprop='dateModified'/>
<meta content='2021-02-22T11:01:00Z' itemprop='datePublished'/>
</span>
<span class='label-head'>
<i class='fa fa-folder-open-o'></i>
<a href='https://www.linuxuprising.com/search/label/games?max-results=12' rel='tag'>games</a>,
<a href='https://www.linuxuprising.com/search/label/news?max-results=12' rel='tag'>news</a>
</span>
</div>
<div class='ads-posting'>
<div id='ezoic-pub-ad-placeholder-107'></div>
</div>
</div>
<article>
<div class='post-body entry-content' id='post-body-4863265105667344662' itemprop='articleBody'>
<meta content='0 A.D.  Alpha 24 &quot;Xšayāršā&quot; has been released over the weekend, after almost 3 years since the previous release. This is a free an...' name='twitter:description'/>
<div class="separator" style="clear: both; text-align: center;"><a href="https://1.bp.blogspot.com/-44vbUspyBZQ/YDON7vY8deI/AAAAAAAAFQU/nyjc62wr73soTuExqlpIuuS8NSK1OsYTACLcBGAsYHQ/s1580/0ad-alpha24.png" style="margin-left: 1em; margin-right: 1em;"><img alt="0 a.d. alpha 24" border="0" data-original-height="949" data-original-width="1580" height="384" src="https://1.bp.blogspot.com/-44vbUspyBZQ/YDON7vY8deI/AAAAAAAAFQU/nyjc62wr73soTuExqlpIuuS8NSK1OsYTACLcBGAsYHQ/s640/0ad-alpha24.png" title="0 a.d. alpha 24" width="640" /></a></div><p></p><p><b><a href="https://play0ad.com/" target="_blank">0 A.D.</a> Alpha 24 "Xšayāršā" has been released over the weekend, after almost 3 years since the previous release.</b></p><p>This is a free and open source&nbsp;historical real time strategy (RTS) game that runs on Microsoft Windows, macOS, Linux,&nbsp;FreeBSD, and OpenBSD. It features the real-time strategy gameplay components of building a base, economic development, training an army, combat, and technology research. The game&nbsp; has both single and multiplayer functionality.</p><p>0 A.D. was originally started as a&nbsp;total conversion mod concept for Age of Empires II: The Age of Kings. The developers then decided that making a mod was too limiting, so an in-house engine was created. For more about the game, check out <a href="https://play0ad.com/game-info/project-overview/" rel="nofollow" target="_blank">this page</a>.</p><p><span></span></p><a name='more'></a>It's worth noting that 0 A.D. is still considered alpha software mainly because it's not yet feature complete (for example, new civilizations are added with most releases), but the game is playable. However, several bugs still exist according to the game downloads page, like some lag when moving many units, large maps can cause issues, and formations are disabled.<p></p><p>There is no official release date set for the stable version.</p><table align="center" cellpadding="0" cellspacing="0" class="tr-caption-container" style="margin-left: auto; margin-right: auto;"><tbody><tr><td style="text-align: center;"><a href="https://1.bp.blogspot.com/-Ts8pstpBPwY/YDOLhK4-XKI/AAAAAAAAFQA/fAq4O-2e_b0Nl0lMgjkDhHa0Z_yckSS0gCLcBGAsYHQ/s1920/0ad-alpha24-textures.jpg" style="margin-left: auto; margin-right: auto;"><img alt="0 A.D. alpha 24 textures" border="0" data-original-height="1080" data-original-width="1920" height="360" src="https://1.bp.blogspot.com/-Ts8pstpBPwY/YDOLhK4-XKI/AAAAAAAAFQA/fAq4O-2e_b0Nl0lMgjkDhHa0Z_yckSS0gCLcBGAsYHQ/w640-h360/0ad-alpha24-textures.jpg" title="0 A.D. alpha 24 textures" width="640" /></a></td></tr><tr><td class="tr-caption" style="text-align: center;">Cavalry models and textures comparison between 0 A.D. alpha 23 and 24. Image via play0ad.com</td></tr></tbody></table><p></p><p>0 A.D. alpha 24 changes include:</p><p></p><ul style="text-align: left;"><li><b>Important artwork improvements: reworked meshes, animations (including new idle, attack, defence and gather animations), textures and materials for many units, as well as new models</b></li><li><b>9 new&nbsp;skirmish maps as well as a new map browser</b></li><li><b>Hundreds of balance tweaks</b></li><li><b>You can now easily place buildings next to each other with snapping</b></li><li><b>Unit behaviour improvements</b></li><li><b>World population settings</b></li><li><b>Anti-aliasing renderer: you can choose between no anti-aliasing, FXAA and various levels of MSAA. A Contrast Adaptive Sharpening filter has also been added to the engine</b></li><li><b>New in-game hotkey editor</b></li><li><b>You can now host password-protected games in the lobby</b></li><li><b>User interface improvements like showing the&nbsp;number of active gatherers under the resource count,&nbsp;an overlay with ceasefire time, and improved tooltips</b></li><li><b>Reinforcement-learning interface,&nbsp;a Machine Learning technique that can be used to train AI to play games</b></li><li><b>More</b></li></ul><p>The developers also note that while 0 A.D. alpha 24 was the version that took the longest to release,&nbsp;they are hoping to "get back to a more regular schedule".</p><p>You may also want to check out the 0 A.D. alpha 24&nbsp;<a href="https://videos.pair2jeux.tube/videos/watch/862b06e3-7e6b-44b3-9a9a-86222623d9d7" rel="nofollow" target="_blank">trailer</a>:</p><p></p><div style="height: 0px; padding-bottom: 64.765%; position: relative; width: 100%;"><iframe allowfullscreen="" frameborder="0" height="315" sandbox="allow-same-origin allow-scripts allow-popups" src="https://videos.pair2jeux.tube/videos/embed/862b06e3-7e6b-44b3-9a9a-86222623d9d7?start=27s" style="height: 100%; position: absolute; width: 100%;" width="560"></iframe></div><br /><p>Head to the <a href="http://play0ad.com" rel="nofollow" target="_blank">play0ad.com</a> website to read the complete 0 A.D. alpha 24 release announcement.</p><p><b><i>You may also like: <a href="https://www.linuxuprising.com/2018/09/how-to-use-lutris-to-play-windows-games.html">How To Use Lutris To Play Windows Games On Linux (Quick Start Guide)</a></i></b></p><br /><h2 style="text-align: left;">Download 0 A.D.</h2><br /><div style="text-align: center;">
  <a href="https://play0ad.com/download/" rel="noopener" target="_blank"><input class="install" title="Download 0 A.D." type="button" value="Download 0 A.D." /></a></div><br /><p></p><p>On Linux, 0 A.D. is available on many Linux distributions, including Arch Linux / Manjaro, Debian / Ubuntu (including stable and development PPAs), Fedora, Gentoo, openSUSE, etc. The game is also available using genric packages: AppImage, Flatpak and Snap. However, at the time I'm writing this article, 0 A.D. has not yet been updated to the latest alpha 24 version in most cases.</p><p><b><i>Related: <a href="https://www.linuxuprising.com/2020/02/add-overlay-with-gpu-cpu-usage-and.html">Add An Overlay With GPU / CPU Usage And Temperature (And More) To Any Vulkan Game With MangoHud</a></i></b></p>
</div>
</article>
<div style='clear:both'></div>
<div class='post-footer'>
<div class='share-box'>
<h8 class='share-title'>Share This:</h8>
<div class='share-art'>
<a class='fac-art' href='https://www.facebook.com/sharer.php?u=https://www.linuxuprising.com/2021/02/free-and-open-source-rts-game-0-ad.html&title=Free And Open Source RTS Game 0 A.D. Alpha 24 Xšayāršā Released' onclick='window.open(this.href, &#39;windowName&#39;, &#39;width=600, height=400, left=24, top=24, scrollbars, resizable&#39;); return false;' rel='nofollow noreferrer' target='_blank' title='Facebook'><i class='fa fa-facebook'></i><span class='resp_del'> Facebook</span></a>
<a class='twi-art' href='https://twitter.com/share?url=https://www.linuxuprising.com/2021/02/free-and-open-source-rts-game-0-ad.html&title=Free And Open Source RTS Game 0 A.D. Alpha 24 Xšayāršā Released' onclick='window.open(this.href, &#39;windowName&#39;, &#39;width=600, height=400, left=24, top=24, scrollbars, resizable&#39;); return false;' rel='nofollow noreferrer' target='_blank' title='Twitter'><i class='fa fa-twitter'></i><span class='resp_del2'> Twitter</span></a>
<a class='dis-art' href='https://sharetodiaspora.github.io/?url=https://www.linuxuprising.com/2021/02/free-and-open-source-rts-game-0-ad.html&title=Free And Open Source RTS Game 0 A.D. Alpha 24 Xšayāršā Released' onclick='window.open(this.href, &#39;windowName&#39;, &#39;width=770, height=500, left=24, top=24, scrollbars, resizable&#39;); return false;' rel='nofollow noreferrer' target='_blank' title='Diaspora'><i class='fa fa-diaspora'></i><span class='resp_del3'> Diaspora</span></a>
<a class='redd-art' href='https://www.reddit.com/submit?url=https://www.linuxuprising.com/2021/02/free-and-open-source-rts-game-0-ad.html&title=Free And Open Source RTS Game 0 A.D. Alpha 24 Xšayāršā Released' onclick='window.open(this.href, &#39;windowName&#39;); return false;' rel='nofollow noreferrer' target='_blank' title='Reddit'><i class='fa fa-reddit-alien'></i><span class='resp_del4'> Reddit</span></a>
<a class='tel-art' href='https://telegram.me/share/url?text=Free And Open Source RTS Game 0 A.D. Alpha 24 Xšayāršā Released&tags=&url=https://www.linuxuprising.com/2021/02/free-and-open-source-rts-game-0-ad.html' onclick='window.open(this.href, &#39;windowName&#39;, &#39;width=600, height=400, left=24, top=24, scrollbars, resizable&#39;); return false;' rel='nofollow noreferrer' target='_blank' title='Telegram'><i class='fa fa-telegram'></i><span class='resp_del5'> Telegram</span></a>
<a class='wat-art' data-action='share/whatsapp/share' href='whatsapp://send?text=Free And Open Source RTS Game 0 A.D. Alpha 24 Xšayāršā Released https://www.linuxuprising.com/2021/02/free-and-open-source-rts-game-0-ad.html' onclick='window.open(this.href, &#39;windowName&#39;, &#39;width=600, height=400, left=24, top=24, scrollbars, resizable&#39;); return false;' rel='nofollow noreferrer' target='_blank' title='WhatsApp'><i class='fa fa-whatsapp'></i><span class='resp_del6'> WhatsApp</span></a>
</div>
</div>
<div style='clear:both'></div>
<div class='ads-post'>
<a name='ads-post-in'></a>
</div>
<div id='related-posts'>
news
</div>
<div class='under-related'>
<div id='ezoic-pub-ad-placeholder-105'></div>
</div>
<div class='clear'></div>
<div class='comment-notif-box'>Please post civil and on-topic comments. <a href='https://www.linuxuprising.com/p/commenting-guidelines.html' rel='nofollow'>Commenting guidelines</a>.</div>
</div>
<div id='disqus_thread_load_on_scroll'>
<div id='disqus_empty' style='display: none'>Empty</div>
</div>

      </div>
    
</div>
<div class='comments' id='comments'>
<a name='comments'></a>
<div id='backlinks-container'>
<div id='Blog1_backlinks-container'>
</div>
</div>
</div>
</div>
</div>
<div class='post-feeds'>
</div>
</div></div>
<div id='ads-post10'>
<div class='no-items section' id='ads-post-468' name='ADS Inner Footer 728x90'>
</div>
</div>
</div>
<div class='sidebar-wrapper' id='sidebar-wrapper'>
<div class='sidebar section' id='sidebar' name='Sidebar Right'><div class='widget HTML' data-version='1' id='HTML1'>
<div class='widget-content'>
<div id="imagehere" class="imagehere"><!-- Top Right Sidebar 300x250 -->
<!-- Ezoic - 300x250 top right - sidebar -->
<div id="ezoic-pub-ad-placeholder-102">            
<!-- <ins class="adsbygoogle"
     style="display:inline-block;width:300px;height:250px"
     data-ad-client="ca-pub-1997822342415050"
     data-ad-slot="8358301820"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script> -->
</div>
<!-- End Ezoic - 300x250 top right - sidebar -->
</div>

<script type="text/javascript">
//<![CDATA[
$(window).on("load", function(){null==document.getElementsByTagName("iframe").item(ga.length-1)&&$("div#imagehere").html("<a href='https://www.linuxuprising.com/2019/04/join-uprising.html' rel='nofollow noopener'><img src='https://4.bp.blogspot.com/-RM33YT7JTCw/XOVA0YwyKxI/AAAAAAAACyo/lA22C-cphP87WD39N4_9SJ-qG5b21IORgCLcBGAs/s1600-rw/join-the-uprising.png' alt='Join the Uprising'/></a><br/>")});
//]]> 
</script>
</div>
</div><div class='widget HTML' data-version='1' id='HTML2'>
<h2 class='title'>Recent Posts</h2>
<div id='RecentPosts'>
<div class='widget-content'>
recentposts
</div>
</div>
</div><div class='widget HTML' data-version='1' id='HTML3'>
<div class='widget-content'>
<div style="margin:0 auto;">
<a target="_blank" rel="noopener nofollow" href="https://t.me/LinuxUprising"><img src="https://1.bp.blogspot.com/-fCC0RyOv2Ts/XcVRcqh6LxI/AAAAAAAADhQ/v-meoJy6TnUe9642hYTzRM1a9q1VQ7seQCLcBGAsYHQ/s1600-rw/telegram-320.png" height="160" width="320" alt="Join us on Telegram" title="Join us on Telegram"/></a>
</div>
<br/>
<div style="margin:0 auto;">
<a target="_blank" rel="noopener nofollow" href="https://twitter.com/LinuxUprising"><img src="https://1.bp.blogspot.com/-LKFL-Vu_G8w/XfJ0DAfbXcI/AAAAAAAADtc/9nhpwKOKez4EOawDSsDVQe_le3D0Gu-1gCLcBGAsYHQ/s1600-rw/twitter.png" height="160" width="320" alt="Follow us on Twitter" title="Follow us on Twitter"/></a>
</div>
<br/>
<!-- Ezoic - Sidebar middle - sidebar_middle -->
<div id="ezoic-pub-ad-placeholder-104">
</div>
<!-- End Ezoic - Sidebar middle - sidebar_middle -->
</div>
</div><div class='widget LinkList' data-version='1' id='LinkList2'>
<h2>Editor's Picks</h2>
<div class='widget-content'>
<ul>
<li><a href='https://www.linuxuprising.com/2020/04/top-things-to-do-after-installing.html'>Top Things To Do After Installing Ubuntu 20.04 Focal Fossa To Make The Most Of It</a></li>
<li><a href='https://www.linuxuprising.com/2020/03/opensnitch-linux-application-firewall.html'>OpenSnitch Linux Application Firewall Fork With Improvements And Bug Fixes</a></li>
<li><a href='https://www.linuxuprising.com/2020/01/4-tools-to-record-your-linux-desktop.html'>5 Tools To Record Your Linux Desktop (Screencast) In 2020</a></li>
<li><a href='https://www.linuxuprising.com/2020/01/how-to-boot-to-console-text-mode-in.html'>How To Boot To Console (Text) Mode Using Debian / Ubuntu, Fedora, Arch Linux / Manjaro And More</a></li>
<li><a href='https://www.linuxuprising.com/2019/11/ffmpeg-extract-audio-from-video-in.html'>FFmpeg: Extract Audio From Video In Original Format Or Converting It To MP3 Or Ogg Vorbis</a></li>
<li><a href='https://www.linuxuprising.com/2018/06/how-to-install-davinci-resolve-15-in.html'>How To Install DaVinci Resolve 16.2 In Ubuntu, Linux Mint Or Debian (Generate DEB Package)</a></li>
<li><a href='https://www.linuxuprising.com/2018/12/how-to-change-grub-boot-order-or.html'>How To Change The GRUB Boot Order Or Default Boot Entry In Ubuntu, Linux Mint, Debian, Or Fedora With Grub Customizer</a></li>
<li><a href='https://www.linuxuprising.com/2019/06/new-oracle-java-11-installer-for-ubuntu.html'>New Oracle Java 11 Installer For Ubuntu Or Linux Mint (Using Local Oracle Java .tar.gz)</a></li>
<li><a href='https://www.linuxuprising.com/2018/07/how-to-fix-could-not-get-lock.html'>How To Fix `Could not get lock /var/lib/dpkg/lock - open (11 Resource temporarily unavailable)` Errors</a></li>
<li><a href='https://www.linuxuprising.com/2018/07/how-to-mount-onedrive-in-linux-using.html'>How To Mount OneDrive In Linux Using Rclone (Supports Business And Personal Accounts)</a></li>
</ul>
</div>
</div><div class='widget HTML' data-version='2' id='HTML5'>
<div class='widget-content'>
<!-- Ezoic - Sidebar bottom - sidebar_bottom -->
<div id="ezoic-pub-ad-placeholder-106"></div>
<!-- End Ezoic - Sidebar bottom - sidebar_bottom -->
</div>
</div><div class='widget HTML' data-version='1' id='HTML6'>
<script type='text/javascript'>
var disqus_shortname = 'linuxuprising';
var disqus_blogger_current_url = "https://www.linuxuprising.com/2021/02/free-and-open-source-rts-game-0-ad.html";
var disqus_title = "Free And Open Source RTS Game 0 A.D. Alpha 24 Xšayāršā Released - Linux Uprising Blog";
if (!disqus_blogger_current_url.length) {
disqus_blogger_current_url = "https://www.linuxuprising.com/2021/02/free-and-open-source-rts-game-0-ad.html";
}
var disqus_blogger_homepage_url = "https://www.linuxuprising.com/";
var disqus_blogger_canonical_homepage_url = "https://www.linuxuprising.com/";
</script>
<script>
var disqus_loaded = false;
function load_disqus( disqus_shortname ) {
  // Prepare the trigger and target

  var is_disqus_empty = document.getElementById('disqus_empty'),
      disqus_target   = document.getElementById('disqus_thread_load_on_scroll'),
      disqus_embed    = document.createElement('script'),
      disqus_hook     = (document.getElementsByTagName('head')[0] || document.getElementsByTagName('body')[0]);

  // Load script asynchronously only when the trigger and target exist
  if( disqus_target && is_disqus_empty ) {
    disqus_loaded = true;
    disqus_embed.type = 'text/javascript';
    disqus_embed.async = true;
    disqus_embed.src = '//' + disqus_shortname + '.disqus.com/blogger_item.js';
    disqus_hook.appendChild(disqus_embed);
    is_disqus_empty.remove();
  }
}

window.addEventListener('scroll', function(e) {
  var currentScroll = document.scrollingElement.scrollTop;
  var disqus_target = document.getElementById('disqus_thread_load_on_scroll');

  if( currentScroll > disqus_target.getBoundingClientRect().top - 150 ) {
    if (disqus_loaded==false) {
      load_disqus('linuxuprising');
    };
  }
}, false);
</script>
</div></div>
</div>
<div class='clear'></div>
</div>
<!-- end content-wrapper -->
<div class='clear'></div><!-- Footer wrapper -->
<div id='footer-wrapper'>
<div id='footer'>
<div class='footer-sections row' id='footer-sections'>
<div class='sect-left section' id='footer-sec1' name='Widget 1'><div class='widget LinkList' data-version='1' id='LinkList1'>
<h2>Linux Uprising</h2>
<div class='widget-content'>
<ul>
<li><a href='https://www.linuxuprising.com/p/about.html'>About</a></li>
<li><a href='https://www.linuxuprising.com/p/privacy-policy.html'>Privacy Policy</a></li>
<li><a href='https://www.linuxuprising.com/p/terms-of-use.html'>Terms of Service</a></li>
<li><a href='https://www.linuxuprising.com/p/cookie-policy.html'>Cookie Information</a></li>
<li><a href='https://www.linuxuprising.com/?ez_force_cookie_consent=1'>Cookie Settings</a></li>
</ul>
</div>
</div></div>
<div class='sect-left section' id='footer-sec2' name='Widget 2'><div class='widget FollowByEmail' data-version='1' id='FollowByEmail1'>
<h2 class='title'>Follow by Email</h2>
<div class='widget-content'>
<div class='follow-by-email-inner'>
<form action='https://feedburner.google.com/fb/a/mailverify' method='post' onsubmit='window.open("https://feedburner.google.com/fb/a/mailverify?uri=LinuxUprising", "popupwindow", "scrollbars=yes,width=550,height=520"); return true' target='popupwindow'>
<table width='100%'>
<tr>
<td>
<label for='email'><input aria-label='email' class='follow-by-email-address' id='email' name='email' placeholder='Email address...' type='text'/></label>
</td>
<td width='64px'>
<input class='follow-by-email-submit' type='submit' value='Submit'/>
</td>
</tr>
</table>
<input name='uri' type='hidden' value='LinuxUprising'/>
<input name='loc' type='hidden' value='en_US'/>
</form>
</div>
</div>
<span class='item-control blog-admin'>
</span>
</div></div>
<div class='sect-left section' id='footer-sec3' name='Widget 3'><div class='widget BlogArchive' data-version='1' id='BlogArchive2'>
<h2>Blog Archive</h2>
<div class='widget-content'>
<div id='ArchiveList'>
<div id='BlogArchive2_ArchiveList'>
<label aria-label='archive-menu' for='BlogArchive2_ArchiveMenu'>
<select id='BlogArchive2_ArchiveMenu'>
<option value=''>Blog Archive</option>
<option value='https://www.linuxuprising.com/2021/02/'>February 2021 (21)</option>
<option value='https://www.linuxuprising.com/2021/01/'>January 2021 (11)</option>
<option value='https://www.linuxuprising.com/2020/12/'>December 2020 (10)</option>
<option value='https://www.linuxuprising.com/2020/11/'>November 2020 (12)</option>
<option value='https://www.linuxuprising.com/2020/10/'>October 2020 (13)</option>
<option value='https://www.linuxuprising.com/2020/09/'>September 2020 (6)</option>
<option value='https://www.linuxuprising.com/2020/07/'>July 2020 (8)</option>
<option value='https://www.linuxuprising.com/2020/06/'>June 2020 (8)</option>
<option value='https://www.linuxuprising.com/2020/05/'>May 2020 (7)</option>
<option value='https://www.linuxuprising.com/2020/04/'>April 2020 (13)</option>
<option value='https://www.linuxuprising.com/2020/03/'>March 2020 (12)</option>
<option value='https://www.linuxuprising.com/2020/02/'>February 2020 (14)</option>
<option value='https://www.linuxuprising.com/2020/01/'>January 2020 (13)</option>
<option value='https://www.linuxuprising.com/2019/12/'>December 2019 (14)</option>
<option value='https://www.linuxuprising.com/2019/11/'>November 2019 (18)</option>
<option value='https://www.linuxuprising.com/2019/10/'>October 2019 (13)</option>
<option value='https://www.linuxuprising.com/2019/09/'>September 2019 (17)</option>
<option value='https://www.linuxuprising.com/2019/08/'>August 2019 (11)</option>
<option value='https://www.linuxuprising.com/2019/07/'>July 2019 (22)</option>
<option value='https://www.linuxuprising.com/2019/06/'>June 2019 (18)</option>
<option value='https://www.linuxuprising.com/2019/05/'>May 2019 (19)</option>
<option value='https://www.linuxuprising.com/2019/04/'>April 2019 (20)</option>
<option value='https://www.linuxuprising.com/2019/03/'>March 2019 (16)</option>
<option value='https://www.linuxuprising.com/2019/02/'>February 2019 (17)</option>
<option value='https://www.linuxuprising.com/2019/01/'>January 2019 (21)</option>
<option value='https://www.linuxuprising.com/2018/12/'>December 2018 (15)</option>
<option value='https://www.linuxuprising.com/2018/11/'>November 2018 (24)</option>
<option value='https://www.linuxuprising.com/2018/10/'>October 2018 (22)</option>
<option value='https://www.linuxuprising.com/2018/09/'>September 2018 (15)</option>
<option value='https://www.linuxuprising.com/2018/08/'>August 2018 (27)</option>
<option value='https://www.linuxuprising.com/2018/07/'>July 2018 (26)</option>
<option value='https://www.linuxuprising.com/2018/06/'>June 2018 (21)</option>
<option value='https://www.linuxuprising.com/2018/05/'>May 2018 (31)</option>
<option value='https://www.linuxuprising.com/2018/04/'>April 2018 (25)</option>
<option value='https://www.linuxuprising.com/2018/03/'>March 2018 (1)</option>
</select>
</label>
</div>
</div>
</div>
</div></div>
</div>
</div>
<div class='clear'></div>
<div class='footer-wrapper'>
<div class='footer-sec row'>
<!-- Footer Social -->
<div class='social-footer section' id='social-footer' name='Social Footer'><div class='widget LinkList' data-version='1' id='LinkList20'>
<div class='widget-content'>
<ul>
<li><a class='rss' href='https://feeds.feedburner.com/LinuxUprising' rel='noreferrer' target='_blank' title='rss'></a></li>
<li><a class='friendica' href='https://libranet.de/profile/linuxuprising' rel='noreferrer' target='_blank' title='friendica'></a></li>
<li><a class='twitter' href='https://twitter.com/linuxuprising' rel='noreferrer' target='_blank' title='twitter'></a></li>
<li><a class='telegram' href='https://t.me/LinuxUprising' rel='noreferrer' target='_blank' title='telegram'></a></li>
<li><a class='facebook' href='https://www.facebook.com/LinuxUprising/' rel='noreferrer' target='_blank' title='facebook'></a></li>
<li><a class='reddit' href='https://www.reddit.com/r/LinuxUprising/' rel='noreferrer' target='_blank' title='reddit'></a></li>
</ul>
</div>
</div></div>
<!-- Footer Copyright -->
<div class='copyright'>
License: <a href='https://creativecommons.org/licenses/by-sa/4.0/' rel='license nofollow noreferrer' target='_blank'>Creative Commons Attribution 4.0 International License</a>
<a href='https://www.linuxuprising.com'>Linux Uprising</a>. <br/>The registered trademark Linux&#174; is used pursuant to a sublicense from the Linux Foundation, the exclusive licensee of Linus Torvalds, owner of the mark on a world&#173;wide basis.
</div>
</div>
</div>
</div>
</div>
<script type='text/javascript'>
if (!('IntersectionObserver' in window)) {
    var script = document.createElement("script");
    script.src = "https://cdn.jsdelivr.net/npm/intersection-observer@0.7.0/intersection-observer.js";
    document.getElementsByTagName('head')[0].appendChild(script);
}
</script>
<script type='text/javascript'>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</script>
<script type='text/javascript'>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</script>
<script type='text/javascript'>    
//<![CDATA[

$(document).ready((function() {
    $('#post-article').find('pre.cssterm').each((function() {
        $(this).attr('title','Triple click to select a complete line!');
    }));
}));


// Lazyload
            (function(a){a.fn.lazyload=function(b){var c={threshold:0,failurelimit:0,event:"scroll",effect:"show",container:window};if(b){a.extend(c,b)}var d=this;if("scroll"==c.event){a(c.container).bind("scroll",function(b){var e=0;d.each(function(){if(a.abovethetop(this,c)||a.leftofbegin(this,c)){}else if(!a.belowthefold(this,c)&&!a.rightoffold(this,c)){a(this).trigger("appear")}else{if(e++>c.failurelimit){return false}}});var f=a.grep(d,function(a){return!a.loaded});d=a(f)})}this.each(function(){var b=this;if(undefined==a(b).attr("original")){a(b).attr("original",a(b).attr("src"))}if("scroll"!=c.event||undefined==a(b).attr("src")||c.placeholder==a(b).attr("src")||a.abovethetop(b,c)||a.leftofbegin(b,c)||a.belowthefold(b,c)||a.rightoffold(b,c)){if(c.placeholder){a(b).attr("src",c.placeholder)}else{a(b).removeAttr("src")}b.loaded=false}else{b.loaded=true}a(b).one("appear",function(){if(!this.loaded){a("<img />").bind("load",function(){a(b).hide().attr("src",a(b).attr("original"))[c.effect](c.effectspeed);b.loaded=true}).attr("src",a(b).attr("original"))}});if("scroll"!=c.event){a(b).bind(c.event,function(c){if(!b.loaded){a(b).trigger("appear")}})}});a(c.container).trigger(c.event);return this};a.belowthefold=function(b,c){if(c.container===undefined||c.container===window){var d=a(window).height()+a(window).scrollTop()}else{var d=a(c.container).offset().top+a(c.container).height()}return d<=a(b).offset().top-c.threshold};a.rightoffold=function(b,c){if(c.container===undefined||c.container===window){var d=a(window).width()+a(window).scrollLeft()}else{var d=a(c.container).offset().left+a(c.container).width()}return d<=a(b).offset().left-c.threshold};a.abovethetop=function(b,c){if(c.container===undefined||c.container===window){var d=a(window).scrollTop()}else{var d=a(c.container).offset().top}return d>=a(b).offset().top+c.threshold+a(b).height()};a.leftofbegin=function(b,c){if(c.container===undefined||c.container===window){var d=a(window).scrollLeft()}else{var d=a(c.container).offset().left}return d>=a(b).offset().left+c.threshold+a(b).width()};a.extend(a.expr[":"],{"below-the-fold":"$.belowthefold(a, {threshold : 0, container: window})","above-the-fold":"!$.belowthefold(a, {threshold : 0, container: window})","right-of-fold":"$.rightoffold(a, {threshold : 0, container: window})","left-of-fold":"!$.rightoffold(a, {threshold : 0, container: window})"})})(jQuery);$(function(){$("img").lazyload({placeholder:"https://1.bp.blogspot.com/-zfTgNA4ZsX0/XR0aQA2GyiI/AAAAAAAADAA/JOjs9ZVsMvA7aIt4bXkH5AqiJK_xkIDUwCLcBGAs/s1600-rw/pixel.gif",effect:"fadeIn",threshold:"1"})});

var RelatedPosts = $("#related-posts")

RelatedPosts.each((function() {
    var g = $(this).html();
    var title = $("#entry-title").text().trim();
    $.ajax({
        url: "/feeds/posts/default/-/" + g + "?alt=json-in-script&max-results=" + related_number,
        type: 'get',
        cache: true,
        dataType: "jsonp",
        success: function(data) {
            var posturl = "";
            var htmlcode = '<div class="related"><ul>';
            for (var i = 0; i < data.feed.entry.length; i++) {
              var s = data.feed.entry[i].title.$t.trim();
              if (s !== title) {
                for (var j = 0; j < data.feed.entry[i].link.length; j++) {
                    if (data.feed.entry[i].link[j].rel == "alternate") {
                            posturl = data.feed.entry[i].link[j].href;
                            break
                    }
                }

                var posttitle = data.feed.entry[i].title.$t;

                if (!data.feed.entry[i].media$thumbnail) {
                    var thumb = '<a title="' + posttitle +'" class="related-img" href="' + posturl + '"' + 'data-bg="url(' + no_image_url + ')" />'                 
                } else {
                    var src = data.feed.entry[i].media$thumbnail.url.split(/s72.*?\//).join("s320-rw/");
                    var thumb = '<a title="' + posttitle +'" class="related-img" href="' + posturl + '"' + 'data-bg="url(' + src + ')" />'                
                }

                htmlcode += '<li><div class="related-thumb">' + thumb + '</div><h3 class="related-title"><a href="' + posturl + '">' + posttitle + '</a></h3></li>'
            }
            }
            htmlcode += '</ul></div><div class="clear"/>';
            RelatedPosts.html(htmlcode);
            LL.update();

        }
    })
}));


//]]>
</script>
<div class='back-to-top'>
<a href='#' id='back-to-top' title='back to top'>
<i class='fa fa-long-arrow-up'></i>
</a>
</div>

<script type='text/javascript' style='display:none;' async>
__ez.queue.addFile('edmonton.php', '/detroitchicago/edmonton.webp?a=a&cb=0&shcb=34', true, ['/detroitchicago/minneapolis.js'], true, false, false, false);
__ez.queue.addFile('jellyfish.php', '/porpoiseant/jellyfish.webp?a=a&cb=0&shcb=34', false, [], true, false, false, false);
</script>

<script>var _audins_dom="linuxuprising_com",_audins_did=131660;__ez.queue.addDelayFunc("audins.js","__ez.script.add", "//go.ezoic.net/detroitchicago/audins.js?cb=192-0");</script><noscript><div style="display:none;"><img src="//pixel.quantserve.com/pixel/p-31iz6hfFutd16.gif?labels=Domain.linuxuprising_com,DomainId.131660" border="0" height="1" width="1" alt="Quantcast"/></div></noscript>
<script type="text/javascript" data-cfasync="false"></script></body>
</html>