<!DOCTYPE html>
<html dir='ltr' lang='en-US' xmlns='http://www.w3.org/1999/xhtml' xmlns:b='http://www.google.com/2005/gml/b' xmlns:data='http://www.google.com/2005/gml/data' xmlns:expr='http://www.google.com/2005/gml/expr'>
<head><meta charset='utf-8'/>
<script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>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</script><script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>__ez.pel=function(){var u=[],i="/porpoiseant/army.gif";function t(e,i,t,_,d,o,n){if(__ez.dot.isDefined(e)&&0!=__ez.dot.isAnyDefined(e.getSlotElementId,e.ElementId)){var r=parseInt(__ez.dot.getTargeting(e,"ap")),a=__ez.dot.getSlotIID(e),s=__ez.dot.getAdUnit(e),p=parseInt(__ez.dot.getTargeting(e,"compid")),z=0,f=0,g=function(e){if("undefined"==typeof _ezim_d)return!1;var i=__ez.dot.getAdUnitPath(e).split("/").pop();if("object"==typeof _ezim_d&&_ezim_d.hasOwnProperty(i))return _ezim_d[i];for(var t in _ezim_d)if(t.split("/").pop()===i)return _ezim_d[t];return!1}(e);"object"==typeof g&&(void 0!==g.creative_id&&(f=g.creative_id),void 0!==g.line_item_id&&(z=g.line_item_id)),__ez.dot.isDefined(a,s)&&__ez.dot.isValid(i)&&u.push({type:"impression",impression_id:a,domain_id:__ez.dot.getDID(),unit:s,t_epoch:__ez.dot.getEpoch(0),revenue:t,est_revenue:_,ad_position:r,ad_size:"",bid_floor_filled:d,bid_floor_prev:o,stat_source_id:n,country_code:__ez.dot.getCC(),pageview_id:__ez.dot.getPageviewId(),comp_id:p,line_item_id:z,creative_id:f,data:__ez.dot.dataToStr(i)})}}function _(){if(void 0===document.visibilityState||"prerender"!==document.visibilityState){if(__ez.dot.isDefined(u)&&0<u.length){var e=__ez.dot.getURL(i)+"?orig="+(!0===__ez.template.isOrig?1:0)+"&sts="+btoa(JSON.stringify(u));void 0!==window.isAmp&&isAmp&&void 0!==window._ezaq&&_ezaq.hasOwnProperty("domain_id")&&(e+="&visit_uuid="+_ezaq.visit_uuid),(new Image).src=e}u=[]}}return{Add:t,AddAndFire:function(e,i){t(e,i,0,0,0,0,0),_()},AddById:function(e,i){var t=e.split("/");if(__ez.dot.isDefined(e)&&3===t.length&&__ez.dot.isValid(i)){var _=t[0],d=t[2];u.push({type:"impression",impression_id:d,domain_id:__ez.dot.getDID(),unit:_,t_epoch:__ez.dot.getEpoch(0),pageview_id:__ez.dot.getPageviewId(),data:__ez.dot.dataToStr(i)})}},Fire:_,GetPixels:function(){return u}}}();var EzoicPixel=function(){this.pixels=[],this.pixelUrl="/ezoic/e.gif",("undefined"!=typeof ezJsu&&!0===ezJsu||"undefined"!=typeof _ez_sa&&!0===_ez_sa||void 0!==window.isAmp&&!0===isAmp||"undefined"!=typeof ezWp&&!0===ezWp)&&(this.pixelUrl="//g.ezoic.net"+this.pixelUrl),this.tEpoch=0,"undefined"!=typeof _ezaq&&_ezaq.hasOwnProperty("t_epoch")&&(this.tEpoch=_ezaq.t_epoch)},EzoicPixelData=function(e,i){this.name=e,this.val=i};EzoicPixel.prototype={constructor:EzoicPixel,AddAndFireImpPixel:function(e,i){this.AddImpPixel(e,i,0,0,0,0,0),this.FirePixels()},AddAndFirePVPixel:function(e,i){this.AddPVPixel(e,i),this.FirePixels()},AddImpPixel:function(e,i,t,n,o,a,d){if(0!=__ez.dot.isDefined(e)&&0!=__ez.dot.isAnyDefined(e.getSlotElementId,e.ElementId)){var s=parseInt(__ez.dot.getTargeting(e,"ap")),r=__ez.dot.getSizes(e)[0],_=r.l.toString()+"x"+r.j.toString(),p="0",l="XX";"undefined"!=typeof _ezaq&&_ezaq.hasOwnProperty("domain_id")&&(p=_ezaq.domain_id.toString()),"undefined"!=typeof _ezaq&&_ezaq.hasOwnProperty("country")&&(l=_ezaq.country);var h=__ez.dot.getSlotIID(e),c=__ez.dot.getSlotElementId(e);__ez.dot.isDefined(h,c)&&this.validateData(i)&&(i=this.convertDataToStr(i),this.pixels.push({type:"impression",impression_id:h,domain_id:p,unit:c,t_epoch:this.tEpoch,revenue:t,est_revenue:n,ad_position:s,ad_size:_,bid_floor_filled:o,bid_floor_prev:a,stat_source_id:d,country_code:l,data:i}))}},AddImpPixelById:function(e,i){var t="0";"undefined"!=typeof _ezaq&&_ezaq.hasOwnProperty("domain_id")&&(t=_ezaq.domain_id.toString());var n=e.split("/");if(__ez.dot.isDefined(e)&&3===n.length&&this.validateData(i)){var o=n[0],a=n[2];i=this.convertDataToStr(i),this.pixels.push({type:"impression",impression_id:a,domain_id:t,unit:o,t_epoch:this.tEpoch,data:i})}},AddPVPixel:function(e,i){var t="0";"undefined"!=typeof _ezaq&&_ezaq.hasOwnProperty("domain_id")&&(t=_ezaq.domain_id.toString()),__ez.dot.isDefined(e)&&this.validateData(i)&&(i=this.convertDataToStr(i),this.pixels.push({type:"pageview",pageview_id:e,domain_id:t,t_epoch:this.tEpoch,data:i}))},FirePixels:function(){void 0!==document.visibilityState&&"prerender"===document.visibilityState||(__ez.dot.isDefined(this.pixels)&&0<this.pixels.length&&((new Image).src=this.pixelUrl+"?orig="+(!0===__ez.template.isOrig?1:0)+"&pixels="+encodeURIComponent(JSON.stringify(this.pixels))),this.pixels=[])},NewData:function(e,i){return new EzoicPixelData(e,i)},convertDataToStr:function(e){if(void 0===e)return[];try{for(var i in e)e[i].val=e[i].val+""}catch(e){}return e},validateData:function(e){for(var i=0;i<e.length;i++)if(e[i]instanceof EzoicPixelData==!1)return console.error("Invalid pixelData. ",e[i]),!1;return!0}};</script>
<script data-ezscrex="false" data-cfasync="false">(function(){if("function"===typeof window.CustomEvent)return!1;window.CustomEvent=function(c,a){a=a||{bubbles:!1,cancelable:!1,detail:null};var b=document.createEvent("CustomEvent");b.initCustomEvent(c,a.bubbles,a.cancelable,a.detail);return b}})();</script><script data-ezscrex="false" data-cfasync="false">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</script>

<meta content='en-us' http-equiv='content-language'/>
<meta content='IE=edge' http-equiv='X-UA-Compatible'/>
<meta content='width=device-width,initial-scale=1.0' name='viewport'/>
<meta content='#f2132d' name='theme-color'/>
<meta content='#f2132d' name='msapplication-TileColor'/>
<meta content='#f2132d' name='msapplication-navbutton-color'/>
<link href='https://3.bp.blogspot.com/-_Rvl0I-6PsE/WxqOMWBSvFI/AAAAAAAAAr0/YVpbw6VxjTE0cs2FIG3JGGrzfelqF1AXQCLcBGAs/s1600/apple-icon-180x180.png' rel='apple-touch-icon' sizes='180x180'/>
<link href='https://4.bp.blogspot.com/-C3SXpMZFwoM/WxqOMWPcqBI/AAAAAAAAAr4/q3BlIVZd9BIycvFtwpwee9ho2axmuey1wCLcBGAs/s1600/android-icon-192x192.png' rel='icon' sizes='192x192' type='image/png'/>
<link href='https://1.bp.blogspot.com/-Rt0ksgLeHY8/XfJ5aMpjzZI/AAAAAAAADts/utsNBkpMNgoN82UZoo9EjfGponnDWZLIACLcBGAsYHQ/s1600/favicon-large_32x32.png' rel='icon' sizes='32x32' type='image/png'/>
<meta content='text/html; charset=UTF-8' http-equiv='Content-Type'/>
<!-- Chrome, Firefox OS and Opera -->
<meta content='' name='theme-color'/>
<!-- Windows Phone -->
<meta content='' name='msapplication-navbutton-color'/>
<meta content='blogger' name='generator'/>
<link href='https://www.linuxuprising.com/favicon.ico' rel='icon' type='image/x-icon'/>
<link href='https://www.linuxuprising.com/2020/01/bandwhich-shows-whats-taking-up-your.html' rel='canonical'/>
<link rel="alternate" type="application/atom+xml" title="Linux Uprising Blog - Atom" href="https://www.linuxuprising.com/feeds/posts/default" />
<link rel="alternate" type="application/rss+xml" title="Linux Uprising Blog - RSS" href="https://www.linuxuprising.com/feeds/posts/default?alt=rss" />
<link rel="service.post" type="application/atom+xml" title="Linux Uprising Blog - Atom" href="https://www.blogger.com/feeds/852161773840707483/posts/default" />

<link rel="alternate" type="application/atom+xml" title="Linux Uprising Blog - Atom" href="https://www.linuxuprising.com/feeds/6798698476520966096/comments/default" />
<!--Can't find substitution for tag [blog.ieCssRetrofitLinks]-->
<link href='https://1.bp.blogspot.com/-rMasFjcRUEY/XibqyZFMnMI/AAAAAAAAD1M/Xq79HXCy-F45VqUJrHvr2G2aSY5hvvTygCLcBGAsYHQ/s640/bandwhich.png' rel='image_src'/>
<meta content='bandwhich is a relatively new terminal bandwidth utilization tool for Linux, *BSD and macOS, written in Rust. It shows the current network utilization by process, connection and remote IP/hostname.' name='description'/>
<meta content='https://www.linuxuprising.com/2020/01/bandwhich-shows-whats-taking-up-your.html' property='og:url'/>
<meta content='bandwhich Shows What&#39;s Taking Up Your Network Bandwidth On Linux And macOS' property='og:title'/>
<meta content='bandwhich is a relatively new terminal bandwidth utilization tool for Linux, *BSD and macOS, written in Rust. It shows the current network utilization by process, connection and remote IP/hostname.' property='og:description'/>
<meta content='https://1.bp.blogspot.com/-rMasFjcRUEY/XibqyZFMnMI/AAAAAAAAD1M/Xq79HXCy-F45VqUJrHvr2G2aSY5hvvTygCLcBGAsYHQ/w1200-h630-p-k-no-nu/bandwhich.png' property='og:image'/>
<!--[if IE]> <script> (function() { var html5 = ("abbr,article,aside,audio,canvas,datalist,details," + "figure,footer,header,hgroup,mark,menu,meter,nav,output," + "progress,section,time,video").split(','); for (var i = 0; i < html5.length; i++) { document.createElement(html5[i]); } try { document.execCommand('BackgroundImageCache', false, true); } catch(e) {} })(); </script> <![endif]-->
<link href='https://fonts.gstatic.com' rel='dns-prefetch'/>
<link crossorigin='anonymous' href='https://fonts.gstatic.com' rel='preconnect'/>
<link href='https://cdn.jsdelivr.net' rel='dns-prefetch'/>
<link crossorigin='anonymous' href='https://cdn.jsdelivr.net' rel='preconnect'/>
<link crossorigin='crossorigin' href='https://fonts.googleapis.com' rel='preconnect'/>
<link crossorigin='crossorigin' href='https://ajax.googleapis.com' rel='preconnect'/>
<link crossorigin='crossorigin' href='https://www.google-analytics.com' rel='preconnect'/>
<link crossorigin='crossorigin' href='https://ssl.google-analytics.com' rel='preconnect'/>
<link crossorigin='crossorigin' href='https://apis.google.com' rel='preconnect'/>
<link crossorigin='crossorigin' href='https://googleads.g.doubleclick.net' rel='preconnect'/>
<link crossorigin='crossorigin' href='https://cdn.jsdelivr.net' rel='preconnect'/>
<link crossorigin='crossorigin' href='https://lh3.googleusercontent.com' rel='preconnect'/>
<link crossorigin='crossorigin' href='https://fonts.gstatic.com' rel='preconnect'/>
<link crossorigin='crossorigin' href='https://adservice.google.com' rel='preconnect'/>
<link crossorigin='crossorigin' href='https://www.googletagservices.com' rel='preconnect'/>
<link crossorigin='crossorigin' href='https://tpc.googlesyndication.com' rel='preconnect'/>
<link crossorigin='crossorigin' href='https://partner.googleadservices.com' rel='preconnect'/>
<link crossorigin='crossorigin' href='https://static.quantcast.mgr.consensu.org' rel='preconnect'/>
<link crossorigin='crossorigin' href='https://quantcast.mgr.consensu.org' rel='preconnect'/>
<link crossorigin='crossorigin' href='https://vendorlist.consensu.org' rel='preconnect'/>
<link crossorigin='crossorigin' href='https://audit.quantcast.mgr.consensu.org' rel='preconnect'/>
<link crossorigin='crossorigin' href='https://cdnjs.cloudflare.com' rel='preconnect'/>
<link crossorigin='crossorigin' href='https://1.bp.blogspot.com' rel='preconnect'/>
<link crossorigin='crossorigin' href='https://2.bp.blogspot.com' rel='preconnect'/>
<link crossorigin='crossorigin' href='https://3.bp.blogspot.com' rel='preconnect'/>
<link crossorigin='crossorigin' href='https://4.bp.blogspot.com' rel='preconnect'/>
<link crossorigin='crossorigin' href='https://ib.adnxs.com' rel='preconnect'/>
<link crossorigin='crossorigin' href='https://bidder.criteo.com' rel='preconnect'/>
<link crossorigin='crossorigin' href='https://g.ezoic.net' rel='preconnect'/>
<link href='//linuxuprising.disqus.com' rel='preconnect'/>
<link href='//disqus.com' rel='dns-prefetch'/>
<link href='//c.disquscdn.com' rel='dns-prefetch'/>
<link href='//referrer.disqus.com' rel='dns-prefetch'/>
<link href='//juggler.services.disqus.com' rel='dns-prefetch'/>
<meta content='https://www.facebook.com/LinuxUprising' property='article:publisher'/>
<meta content='3F3C1DB7847EE7E64E8A2F6CDC5A5F10' name='msvalidate.01'/>
<meta content='de18aa7b281bff4c' name='yandex-verification'/>
<title>
bandwhich Shows What's Taking Up Your Network Bandwidth On Linux And macOS - Linux Uprising Blog
</title>
<!-- Description and Keywords (start) -->
<meta content='en_US' property='og:locale'/>
<!-- Description and Keywords (end) -->
<meta content='article' property='og:type'/>
<meta content='Linux Uprising Blog' property='og:site_name'/>
<meta content='https://www.linuxuprising.com/' name='twitter:domain'/>
<meta content='bandwhich Shows What&#39;s Taking Up Your Network Bandwidth On Linux And macOS' name='twitter:title'/>
<meta content='summary_large_image' name='twitter:card'/>
<meta content='https://1.bp.blogspot.com/-rMasFjcRUEY/XibqyZFMnMI/AAAAAAAAD1M/Xq79HXCy-F45VqUJrHvr2G2aSY5hvvTygCLcBGAsYHQ/s640/bandwhich.png' name='twitter:image'/>
<meta content='bandwhich is a relatively new terminal bandwidth utilization tool for Linux, *BSD and macOS, written in Rust. It shows the current network utilization by process, connection and remote IP/hostname.' name='twitter:description'/>
<!-- Social Media meta tag need customer customization -->
<meta content='572203406470374' property='fb:app_id'/>
<meta content='841352899' property='fb:admins'/>
<meta content='@linuxuprising' name='twitter:site'/>
<meta content='@linuxuprising' name='twitter:creator'/>
<!-- Quantcast Choice. Consent Manager Tag -->
<script async='true' type='text/javascript'>
    var elem = document.createElement('script');
    elem.src = 'https://quantcast.mgr.consensu.org/cmp.js';
    elem.async = true;
    elem.type = "text/javascript";
    var scpt = document.getElementsByTagName('script')[0];
    scpt.parentNode.insertBefore(elem, scpt);
    (function() {
    var gdprAppliesGlobally = false;
    function addFrame() {
        if (!window.frames['__cmpLocator']) {
        if (document.body) {
            var body = document.body,
                iframe = document.createElement('iframe');
            iframe.style = 'display:none';
            iframe.name = '__cmpLocator';
            body.appendChild(iframe);
        } else {
            // In the case where this stub is located in the head,
            // this allows us to inject the iframe more quickly than
            // relying on DOMContentLoaded or other events.
            setTimeout(addFrame, 5);
        }
        }
    }
    addFrame();
    function cmpMsgHandler(event) {
        var msgIsString = typeof event.data === "string";
        var json;
        if(msgIsString) {
        json = event.data.indexOf("__cmpCall") != -1 ? JSON.parse(event.data) : {};
        } else {
        json = event.data;
        }
        if (json.__cmpCall) {
        var i = json.__cmpCall;
        window.__cmp(i.command, i.parameter, function(retValue, success) {
            var returnMsg = {"__cmpReturn": {
            "returnValue": retValue,
            "success": success,
            "callId": i.callId
            }};
            event.source.postMessage(msgIsString ?
            JSON.stringify(returnMsg) : returnMsg, '*');
        });
        }
    }
    window.__cmp = function (c) {
        var b = arguments;
        if (!b.length) {
        return __cmp.a;
        }
        else if (b[0] === 'ping') {
        b[2]({"gdprAppliesGlobally": gdprAppliesGlobally,
            "cmpLoaded": false}, true);
        } else if (c == '__cmp')
        return false;
        else {
        if (typeof __cmp.a === 'undefined') {
            __cmp.a = [];
        }
        __cmp.a.push([].slice.apply(b));
        }
    }
    window.__cmp.gdprAppliesGlobally = gdprAppliesGlobally;
    window.__cmp.msgHandler = cmpMsgHandler;
    if (window.addEventListener) {
        window.addEventListener('message', cmpMsgHandler, false);
    }
    else {
        window.attachEvent('onmessage', cmpMsgHandler);
    }
    })();
    window.__cmp('init', {
        'Language': 'en',
    'Initial Screen Reject Button Text': 'I do not accept',
    'Initial Screen Accept Button Text': 'I accept',
    'Purpose Screen Body Text': 'You can set your consent preferences and determine how you want your data to be used based on the purposes below. You may set your preferences for us independently from those of third-party partners. Each purpose has a description so that you know how we and partners use your data.',
    'Vendor Screen Body Text': 'You can set consent preferences for each individual third-party company below. Expand each company list item to see what purposes they use data for to help make your choices. In some cases, companies may disclose that they use your data without asking for your consent, based on their legitimate interests. You can click on their privacy policies for more information and to opt out.',
    'Vendor Screen Accept All Button Text': 'Accept all',
    'Vendor Screen Reject All Button Text': 'Reject all',
    'Initial Screen Body Text': 'We and our partners use technology such as cookies on our site to personalise content and ads, provide social media features, and analyse our traffic. Click below to consent to the use of this technology across the web. You can change your mind and change your consent choices at anytime by returning to this site.',
    'Initial Screen Body Text Option': 1,
    'Publisher Name': 'Linux Uprising',
    'Publisher Logo': 'https://1.bp.blogspot.com/-OQO0AVdTMzg/XUQKnqI4K1I/AAAAAAAADHM/Oy6NjuOQYgMzts8ad4ub85ZMEoF2iZjSQCLcBGAs/s1600/LO_logo.png',
    'Default Value for Toggles': 'on',
    'Initial Screen Title Text': 'We use cookies',
    'Purpose Screen Title Text': 'We use cookies',
    'Vendor Screen Title Text': 'We use cookies', 
    'Display Persistent Consent Link': false,
    'Min Days Between UI Displays': 60,
    'Publisher Purpose IDs': [5],
    'Consent Scope': 'service',
    //'UI Layout': 'banner',    
    'No Option': false,
    });
</script>
<!-- &#39;Display Persistent Consent Link&#39;: false, -->
<!-- End Quantcast Choice. Consent Manager Tag -->
<!-- Disable default blogger Cookie Choice-->
<script type='text/javascript'>
    cookieChoices = {};
</script>
<!-- Set personalized or not for Adsense based on cookie consent info -->
<script type='text/javascript'>

var checkUserConsent;

// fetch google personalization consent information
__cmp('getGooglePersonalization', function(consent, isSuccess) {

// do we have a cookie? 
if(!isSuccess) 
 return;

// check for given consent
if(consent.googlePersonalizationData.consentValue) {
  //
  // You have consent from the user: 
  // add your code here to call google&#8217;s admanager or adsense 
  //

  //(adsbygoogle=window.adsbygoogle||[]).requestNonPersonalizedAds=0;
  checkUserConsent = 'YES';

} else {
  // 
  // No consent for personalized ads from the user:
  // either no call to google&#8217;s admanger / adsense or
  // call admanager and adsense using the appropriate 
  // method to set &#8216;requestNonPersonalizedAds&#8217; accordingly.
  //

  //(adsbygoogle=window.adsbygoogle||[]).requestNonPersonalizedAds=1;
  checkUserConsent = 'NO';

}
});
</script>
<!-- Google Analytics -->
<script type='text/javascript'>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');
  ga('create', 'UA-116578392-1', 'auto');
  if (checkUserConsent == 'NO') {
     ga('set', 'allowAdFeatures', false);
 }
  ga('set', 'anonymizeIp', true);
  ga('send', 'pageview');
</script>
<style id='page-skin-1' type='text/css'>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</style>
<style id='template-skin-1' type='text/css'><!--
/*------Layout (No Edit)----------*/
body#layout .row {width: 900px;}
body#layout #outer-wrapper{padding:0;width:900px}
body#layout .section h4{color:#333!important}
body#layout .theme-opt{overflow:hidden;     display: block!important;}
body#layout #option{overflow:hidden; display:block}
body#layout #option h4{font-size:16px;padding:4px 0 7px}
body#layout #option .widget{float:left;width:20%}
body#layout #option .widget.locked-widget .widget-content{background-color: #ff7575 !important;
border-color: #840000 !important;
color: #fff !important;}
body#layout #option .widget.locked-widget .widget-content a.editlink{color:#fff!important;border:1px solid;border-radius:2px;padding:2px 5px}
body#layout #topnav,body#layout .tm-head{height:auto}
body#layout .tm-menu{margin:0;width:70%}
body#layout .social-area{margin:0;width:30%}
body#layout .header-content,body#layout #header-blog{height:160px}
body#layout .header-logo{float:left;width:30%;margin:0;padding:0}
body#layout .header-ads{width:70%;margin:0}
body#layout .header-menu li.home-child{display:none}
body#layout .header-search,body#layout .m-rec{display:none}
body#layout .header-menu{float:left;width:100%;margin:4px 0 0;padding:0}
body#layout #content-wrapper{margin:0 auto}
body#layout .feat-layout .widget-content,body#layout .feat-layout h2.title,body#layout #ads-blog{display:block}
body#layout #main-wrapper{float:left;width:70%;margin:0;padding:0}
body#layout #ads-post10{display:block}
body#layout .sidebar-wrapper{float:right;width:30%;margin:0;padding:0}
body#layout #footer-wrapper{overflow:hidden}
body#layout .sect-left{width:28.3%;float:left}
body#layout #social-footer{width:30%;float:right}
/*------Layout (end)----------*/
--></style>
<style type='text/css'>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</style>
<noscript>
<style>
        #HTML1, #HTML2, #HTML3, #adsense-top-horiz {display:none;}
    </style>
</noscript>
<script type='text/javascript'> 
//<![CDATA[
var text_month = [, "Jan", "Feb", "Mar", "Apr", "May", "Jun", "Jul", "Aug", "Sept", "Oct", "Nov", "Dec"];
var no_image_url = "https://1.bp.blogspot.com/-dUVHHKr63sw/WrjkLAm4OkI/AAAAAAAAABU/SNBN1gIB8E0vLNWf41AGwudNCH1Q9hYYwCLcBGAs/s1600-r/nothumb.jpg";
var feat1_number = 3;
var related_number = 4;
//]]>
</script>
<script>
        (function () {
            var done = false;
            var script = document.createElement("script"),
            head = document.getElementsByTagName("head")[0] || document.documentElement;
            script.src = 'https://ajax.googleapis.com/ajax/libs/webfont/1.6.26/webfont.js';
            script.async = true;
            script.onload = script.onreadystatechange = function() {
                if ( ! done && ( ! this.readyState || this.readyState === "loaded" || this.readyState === "complete" ) ) {
                    done = true;
                    WebFont.load({
                        google: {
                            families: ['Ubuntu:300,300i,500,700&display=swap']
                        }
                    });
                    script.onload = script.onreadystatechange = null;
                }
            };
            head.insertBefore(script, head.firstChild);
        })();
    </script>
<noscript><link href='https://fonts.googleapis.com/css?family=Ubuntu:300,300i,500,700&display=swap' rel='stylesheet'/></noscript>
<script type='text/javascript'>
!function(e,n,t){"use strict";var o="https://cdn.jsdelivr.net/npm/fork-awesome@1.1.3/css/fork-awesome.min.css",r="__3perf_googleFonts_dcfa3";function c(e){(n.head||n.body).appendChild(e)}function a(){var e=n.createElement("link");e.href=o,e.rel="stylesheet",c(e)}function f(e){if(!n.getElementById(r)){var t=n.createElement("style");t.id=r,c(t)}n.getElementById(r).innerHTML=e}e.FontFace&&e.FontFace.prototype.hasOwnProperty("display")?(t[r]&&f(t[r]),fetch(o).then(function(e){return e.text()}).then(function(e){return e.replace(/@font-face{/g,"@font-face{font-display:swap;")}).then(function(e){return e.replace(/\.\.\/fonts\//g,"https:\/\/cdn\.jsdelivr\.net\/npm\/fork-awesome@1\.1\.3\/fonts\/")}).then(function(e){return t[r]=e}).then(f).catch(a)):a()}(window,document,localStorage);
</script>
<noscript><link href='https://cdn.jsdelivr.net/npm/fork-awesome@1.1.3/css/fork-awesome.min.css' rel='stylesheet'/></noscript>

<!--<link href='https://www.blogger.com/dyn-css/authorization.css?targetBlogID=852161773840707483&amp;zx=d04ca743-ee2d-423b-aa81-225206862da9' media='none' onload='if(media!=&#39;all&#39;)media=&#39;all&#39;' rel='stylesheet'/><noscript><link href='https://www.blogger.com/dyn-css/authorization.css?targetBlogID=852161773840707483&amp;zx=d04ca743-ee2d-423b-aa81-225206862da9' rel='stylesheet'/></noscript>

</head>-->
<script data-ezscrex="false" data-cfasync="false" type="text/javascript">window.google_analytics_uacct = "UA-124339592-32";</script>
<script data-ezscrex="false" data-cfasync="false" type="text/javascript">
var _gaq = _gaq || [];
_gaq.push(['e._setAccount', 'UA-124339592-32']);
_gaq.push(['f._setAccount', 'UA-38339005-1']);
_gaq.push(['e._setDomainName', 'linuxuprising.com']);
_gaq.push(['f._setDomainName', 'linuxuprising.com']);
_gaq.push(['e._setCustomVar',1,'template','old_site_gc',3]);
_gaq.push(['e._setCustomVar',2,'t','126',3]);
_gaq.push(['e._setCustomVar',3,'rid','0',2]);
_gaq.push(['e._setCustomVar',4,'bra','mod71',3]);
_gaq.push(['e._setAllowAnchor',true]);
_gaq.push(['e._setSiteSpeedSampleRate', 10]);
_gaq.push(['f._setCustomVar',1,'template','old_site_gc',3]);
_gaq.push(['f._setCustomVar',2,'domain','linuxuprising.com',3]);
_gaq.push(['f._setSiteSpeedSampleRate', 20]);
_gaq.push(['e._trackPageview']);
_gaq.push(['f._trackPageview']);


(function() {
 var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
 ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
 var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
})();
</script>
<script type="text/javascript">var ezouid = "1";</script><base href="https://www.linuxuprising.com/2020/01/bandwhich-shows-whats-taking-up-your.html"><script type='text/javascript'>
var ezoTemplate = 'old_site_gc';
if(typeof ezouid == 'undefined')
{
    var ezouid = 'none';
}
var ezoFormfactor = '1';
var ezo_elements_to_check = Array();
</script><!-- START EZHEAD -->
<script data-ezscrex="false" type='text/javascript'>
var soc_app_id = '0';
var did = 131660;
var ezdomain = 'linuxuprising.com';
var ezoicSearchable = 1;
</script>
<!--{jquery}-->
<!-- END EZHEAD -->
<script data-ezscrex="false" type="text/javascript" data-cfasync="false">var _ezaq = {"ad_cache_level":0,"city":"Ashburn","country":"US","days_since_last_visit":-1,"domain_id":131660,"engaged_time_visit":0,"ezcache_level":0,"forensiq_score":-1,"form_factor_id":1,"framework_id":1,"is_return_visitor":false,"is_sitespeed":0,"last_page_load":"","last_pageview_id":"","lt_cache_level":0,"metro_code":511,"page_ad_positions":"","page_view_count":0,"page_view_id":"68d55cfc-f7c6-4dbf-62e1-6b79d4864e51","position_selection_id":0,"postal_code":"20149","pv_event_count":0,"response_time_orig":58,"serverid":"34.230.35.85:21891","state":"VA","t_epoch":1579851070,"template_id":126,"time_on_site_visit":0,"url":"https://www.linuxuprising.com/2020/01/bandwhich-shows-whats-taking-up-your.html","user_id":0,"word_count":1191,"worst_bad_word_level":0};var _ezExtraQueries = "&ez_orig=1";</script><script data-ezscrex='false' data-cfasync='false' type="text/javascript" src="/detroitchicago/rochester.js?cb=188-0&v=8" async></script>
<script data-ezscrex='false' data-pagespeed-no-defer data-cfasync='false'>
function create_ezolpl() {
    var d = new Date();
    d.setTime(d.getTime() + (365*24*60*60*1000));
    var expires = "expires="+d.toUTCString();
    __ez.ck.setByCat("ezux_lpl_131660=" + new Date().getTime() + "|68d55cfc-f7c6-4dbf-62e1-6b79d4864e51; " + expires, 3);
}
function attach_ezolpl() {
    if(window.attachEvent) {
        window.attachEvent('onload', create_ezolpl);
    } else {
        if(window.onload) {
            var curronload = window.onload;
            var newonload = function(evt) {
                curronload(evt);
                create_ezolpl();
            };
            window.onload = newonload;
        } else {
            window.onload = create_ezolpl;
        }
    }
}
attach_ezolpl();
</script></head>

    <body class='item'>
<div class='theme-opt' style='display:none'>
<div class='option section' id='option' name='Theme Option'><div class='widget HTML' data-version='1' id='HTML103'>

<script type='text/javascript'> 
          //<![CDATA[
          var recentposts_number = 5;
          //]]>
         </script>
         
</div><div class='widget HTML' data-version='1' id='HTML104'>
<script type='text/javascript'> 
          //<![CDATA[
          var randomposts_number = 4;
          //]]>
         </script>
</div><div class='widget HTML' data-version='1' id='HTML105'>

         <script type='text/javascript'>
          var postperpage=12;
         </script>
         
</div><div class='widget HTML' data-version='1' id='HTML106'>
</div><div class='widget HTML' data-version='1' id='HTML851'>
<script src='https://ajax.googleapis.com/ajax/libs/jquery/2.2.4/jquery.min.js' type='text/javascript'></script>
<script type='text/javascript'> 
            //<![CDATA[

            // Plugin: Sticky jQuery ~ BY: https://stickyjs.com
            (function(e){var t={topSpacing:0,bottomSpacing:0,className:"is-sticky",wrapperClassName:"sticky-wrapper",center:false,getWidthFrom:"",responsiveWidth:false},n=e(window),r=e(document),i=[],s=n.height(),o=function(){var t=n.scrollTop(),o=r.height(),u=o-s,a=t>u?u-t:0;for(var f=0;f<i.length;f++){var l=i[f],c=l.stickyWrapper.offset().top,h=c-l.topSpacing-a;if(t<=h){if(l.currentTop!==null){l.stickyElement.css("width","").css("position","").css("top","");l.stickyElement.trigger("sticky-end",[l]).parent().removeClass(l.className);l.currentTop=null}}else{var p=o-l.stickyElement.outerHeight()-l.topSpacing-l.bottomSpacing-t-a;if(p<0){p=p+l.topSpacing}else{p=l.topSpacing}if(l.currentTop!=p){l.stickyElement.css("width",l.stickyElement.width()).css("position","fixed").css("top",p);if(typeof l.getWidthFrom!=="undefined"){l.stickyElement.css("width",e(l.getWidthFrom).width())}l.stickyElement.trigger("sticky-start",[l]).parent().addClass(l.className);l.currentTop=p}}}},u=function(){s=n.height();for(var t=0;t<i.length;t++){var r=i[t];if(typeof r.getWidthFrom!=="undefined"&&r.responsiveWidth===true){r.stickyElement.css("width",e(r.getWidthFrom).width())}}},a={init:function(n){var r=e.extend({},t,n);return this.each((function(){var n=e(this);var s=n.attr("id");var o=s?s+"-"+t.wrapperClassName:t.wrapperClassName;var u=e("<div></div>").attr("id",s+"-sticky-wrapper").addClass(r.wrapperClassName);n.wrapAll(u);if(r.center){n.parent().css({width:n.outerWidth(),marginLeft:"auto",marginRight:"auto"})}if(n.css("float")=="right"){n.css({"float":"none"}).parent().css({"float":"right"})}var a=n.parent();a.css("height",n.outerHeight());i.push({topSpacing:r.topSpacing,bottomSpacing:r.bottomSpacing,stickyElement:n,currentTop:null,stickyWrapper:a,className:r.className,getWidthFrom:r.getWidthFrom,responsiveWidth:r.responsiveWidth})}))},update:o,unstick:function(t){return this.each((function(){var t=e(this);var n=-1;for(var r=0;r<i.length;r++){if(i[r].stickyElement.get(0)==t.get(0)){n=r}}if(n!=-1){i.splice(n,1);t.unwrap();t.removeAttr("style")}}))}};if(window.addEventListener){window.addEventListener("scroll",o,false);window.addEventListener("resize",u,false)}else if(window.attachEvent){window.attachEvent("onscroll",o);window.attachEvent("onresize",u)}e.fn.sticky=function(t){if(a[t]){return a[t].apply(this,Array.prototype.slice.call(arguments,1))}else if(typeof t==="object"||!t){return a.init.apply(this,arguments)}else{e.error("Method "+t+" does not exist on jQuery.sticky")}};e.fn.unstick=function(t){if(a[t]){return a[t].apply(this,Array.prototype.slice.call(arguments,1))}else if(typeof t==="object"||!t){return a.unstick.apply(this,arguments)}else{e.error("Method "+t+" does not exist on jQuery.sticky")}};e((function(){setTimeout(o,0)}))})(jQuery);
            //]]>
          </script>
          <script type='text/javascript'> 
            //<![CDATA[
              $(document).ready(function(){$("#header-navigation").sticky({topSpacing:0});});
            //]]>
          </script>
        </div></div>
</div>

<div id="pages-wrap" class="item">

<div id='outer-wrapper'>
<div id='topnav'>
<div class='tm-head row'>
<div class='tm-menu'>
<div class='menu1 section' id='menu1' name='Top Navigation'><div class='widget LinkList' data-version='1' id='LinkList210'>
<div class='widget-content'>
<ul id='nav1'>
<li><a href='https://www.linuxuprising.com/p/about.html'>About</a></li>
<li><a href='https://www.reddit.com/r/LinuxUprising/' rel='noreferrer' target='_blank'>Submit A Tip</a></li>
</ul>
</div>
</div></div>
</div>
<!-- Top Social -->
<div class='social-area'>
<div class='social-top section' id='social-top' name='Social Top'><div class='widget LinkList' data-version='1' id='LinkList50'>
<div class='widget-content'>
<ul>
<li><a class='rss' href='https://feeds.feedburner.com/LinuxUprising' rel='noreferrer' target='_blank' title='rss'></a></li>
<li><a class='friendica' href='https://libranet.de/profile/linuxuprising' rel='noreferrer' target='_blank' title='friendica'></a></li>
<li><a class='twitter' href='https://twitter.com/linuxuprising' rel='noreferrer' target='_blank' title='twitter'></a></li>
<li><a class='telegram' href='https://t.me/LinuxUprising' rel='noreferrer' target='_blank' title='telegram'></a></li>
<li><a class='facebook' href='https://www.facebook.com/LinuxUprising/' rel='noreferrer' target='_blank' title='facebook'></a></li>
<li><a class='reddit' href='https://www.reddit.com/r/LinuxUprising/' rel='noreferrer' target='_blank' title='reddit'></a></li>
</ul>
</div>
</div></div>
</div>
</div>
</div>
<div id='header-blog'>
<div class='header-content row'>
<div class='header-logo'>
<div class='section' id='logo_blog' name='Logo'><div class='widget Header' data-version='1' id='Header1'>
<div id='header-inner'>
<h2 class='logo'>
<a href='https://www.linuxuprising.com/' style='display: block'>
<img alt='Linux Uprising Blog' height='23px; ' id='Header1_headerimg' src='https://cdn.rawgit.com/logix2/6fb43ed0a1979f24c50857fadc6de3ac/raw/24571f5df3fa6fadeeb0937ffd40ea38c380075f/logo2.svg' style='display: block' width='455px; '/>
</a>
<span class='alt-logo'>Linux Uprising blog</span>
</h2>
</div>
</div></div>
</div>
<!-- <div class='header-ads'> <b:section id='ads-content' maxwidgets='1' name='Ads 728x90' showaddelement='yes'> <b:widget id='HTML1' locked='false' title='' type='HTML'> <b:includable id='main'> <b:if cond='data:title != &quot;&quot;'> <h2 class='title'><data:title/></h2> </b:if> <div class='widget-content'> <data:content/> </div> </b:includable> </b:widget> </b:section> </div> -->
</div>
</div>
<nav class='row' id='header-navigation'>
<div class='nav-wrapper'>
<div class='nav-menu'>
<div class='header-search'>
<ul>
<li>
<a class='search' id='search'>
<form action='/search/max-results=12' method='get'>
<input id='s' name='q' placeholder='Type and hit enter...' type='text'/>
</form>
</a>
</li>
</ul>
</div>
<div class='header-menu'>
<ul>
<li class='home-child'><a href='https://www.linuxuprising.com/'>Home</a></li>
</ul>
<div class='menu section' id='menu' name='Main Menu'><div class='widget LinkList' data-version='1' id='LinkList110'>
<div class='widget-content'>
<ul id='nav' itemscope='' itemtype='https://schema.org/SiteNavigationElement'>
<li itemprop='name'><a href='https://www.linuxuprising.com/search/label/news?max-results=12' itemprop='url'>News</a></li>
<li itemprop='name'><a href='https://www.linuxuprising.com/search/label/apps?max-results=12' itemprop='url'>Applications</a></li>
<li itemprop='name'><a href='https://www.linuxuprising.com/search/label/how-to?max-results=12' itemprop='url'>How To</a></li>
<li itemprop='name'><a href='https://www.linuxuprising.com/search/label/tweaks?max-results=12' itemprop='url'>Tweaks</a></li>
<li itemprop='name'><a href='https://www.linuxuprising.com/search/label/customization?max-results=12' itemprop='url'>Themes & More</a></li>
<li itemprop='name'><a href='https://www.linuxuprising.com/search/label/console?max-results=12' itemprop='url'>Console</a></li>
</ul>
</div>
</div></div>
</div>
</div>
</div>
</nav>
<div class='clear'></div>
<div class='row' id='content-wrapper'>
<div id='main-wrapper'>
<div id='ads-blog'>
<div class='home-ad no-items section' id='ads-home' name='Ads Home/Post (728x90)'>
</div>
</div>
<div class='main section' id='main' name='Main Wrapper'><div class='widget Blog' data-version='1' id='Blog1'>
<div class='blog-posts hfeed'>
<div class='post-outer' id='post-outer'>
<div class='post' id='post-article'>

    <div itemprop='blogPost' itemscope='itemscope' itemtype='https://schema.org/Article'>
            <meta content='data:post.link : data:post.url' itemType='https://schema.org/WebPage' itemid='' itemprop='mainEntityOfPage' itemscope='itemscope'/>
<div itemprop='publisher' itemscope='itemscope' itemtype='https://schema.org/Organization'>
<div itemprop='logo' itemscope='itemscope' itemtype='https://schema.org/ImageObject'>
<meta content='https://4.bp.blogspot.com/-OlFvIO7s2mM/WrzEk1hCVZI/AAAAAAAAAE0/H4meMs7XreskNd_mTgVtNREkBX08-O1CACK4BGAYYCw/s590/LUR_logo1.png' itemprop='url'/>
<meta content='455' itemprop='width'/>
<meta content='48' itemprop='height'/>
</div>
<meta content='Linux Uprising Blog' itemprop='name'/>
</div>
<meta content='https://1.bp.blogspot.com/-rMasFjcRUEY/XibqyZFMnMI/AAAAAAAAD1M/Xq79HXCy-F45VqUJrHvr2G2aSY5hvvTygCLcBGAsYHQ/s640/bandwhich.png' itemprop='image'/>
<div class='post-header'>
<div id='adsense-top-horiz'>
<div id='ezoic-pub-ad-placeholder-103'>
<ins class='adsbygoogle responsive_1' data-ad-client='ca-pub-1997822342415050' data-ad-slot='5867515603' style='display:inline-block;'></ins>
<script async='async' src='//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js'></script>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
<script>
if (window.innerWidth < 1000) {
     (adsbygoogle = window.adsbygoogle || []).push({
          google_ad_client: "ca-pub-1997822342415050",
          enable_page_level_ads: true
     });
}    
</script>
</div>
</div>
<div class='post-head'><h1 class='post-title entry-title' id='entry-title' itemprop='name headline'>
bandwhich Shows What's Taking Up Your Network Bandwidth On Linux And macOS
</h1></div>
<div class='post-meta'>
<span class='post-author vcard'>
<i class='fa fa-user'></i>
<span class='fn' itemprop='author' itemscope='itemscope' itemtype='https://schema.org/Person'>
<meta content='https://www.blogger.com/profile/03026963810377267607' itemprop='url'/>
<a class='g-profile' href='https://www.blogger.com/profile/03026963810377267607' rel='author' title='Logix'>
<span itemprop='name'>Logix</span>
</a>
</span>
</span>
<span class='post-timestamp'>
<i class='fa fa-clock-o'></i>
<meta content='https://www.linuxuprising.com/2020/01/bandwhich-shows-whats-taking-up-your.html' itemprop='url'/>
          Updated on <a class='timestamp-link' href='https://www.linuxuprising.com/2020/01/bandwhich-shows-whats-taking-up-your.html' rel='bookmark' title='permanent link'><time class='updated timeago' datetime='2020-01-23T09:43:47Z' title='2020-01-23T09:43:47Z'><span id='updatedateinfo'>2020-01-23T09:43:47Z</span></time></a>
<script>
            var dates = "2020-01-23T09:43:47Z"
            var dateu = new Date(dates);
            var months = ["January","February","March","April","May","June","July","August","September","October","November","December"];
            document.getElementById("updatedateinfo").innerHTML = months[dateu.getMonth()] + " " + dateu.getDate() + ", " + dateu.getFullYear();
        </script>
<meta content='2020-01-23T09:43:47Z' itemprop='dateModified'/>
<meta content='2020-01-21T12:23:00Z' itemprop='datePublished'/>
</span>
<span class='label-head'>
<i class='fa fa-folder-open-o'></i>
<a href='https://www.linuxuprising.com/search/label/console?max-results=12' rel='tag'>console</a>,
<a href='https://www.linuxuprising.com/search/label/network?max-results=12' rel='tag'>network</a>
</span>
</div>
<div class='ads-posting'>
<div id='ezoic-pub-ad-placeholder-107'></div>
</div>
</div>
<article>
<div class='post-body entry-content' id='post-body-6798698476520966096' itemprop='articleBody'>
<meta content=' bandwhich  is a relatively new terminal bandwidth utilization tool for Linux, *BSD and macOS, written in Rust. It shows the current network...' name='twitter:description'/>
<div class="separator" style="clear: both; text-align: center;"><a href="https://1.bp.blogspot.com/-rMasFjcRUEY/XibqyZFMnMI/AAAAAAAAD1M/Xq79HXCy-F45VqUJrHvr2G2aSY5hvvTygCLcBGAsYHQ/s1600/bandwhich.png" imageanchor="1" style="margin-left: 1em; margin-right: 1em;"><img alt="bandwhich network bandwidth utilization tool for Linux and macOS" border="0" data-original-height="744" data-original-width="1155" height="412" src="https://1.bp.blogspot.com/-rMasFjcRUEY/XibqyZFMnMI/AAAAAAAAD1M/Xq79HXCy-F45VqUJrHvr2G2aSY5hvvTygCLcBGAsYHQ/s640/bandwhich.png" title="bandwhich network bandwidth utilization tool for Linux and macOS" width="640" /></a></div><br />
<b><a href="https://github.com/imsnif/bandwhich" target="_blank">bandwhich</a> is a relatively new terminal bandwidth utilization tool for Linux, *BSD and macOS, written in Rust. It shows the current network utilization by process, connection and remote IP/hostname.</b><br />
<a name='more'></a><br />
This tool's main purpose is to show what is taking up your bandwidth. It was originally called "what", but its name was changed to bandwhich about 3 weeks ago.<br />
<br />
bandwhich is able to show the current network utilization by process, connection and remote IP/hostname by sniffing a given network interface and recording the IP packet size, cross-referencing it with the <span class="codeblock2"><code>/proc</code></span> filesystem on Linux and <span class="codeblock2"><code>lsof</code></span> on macOS. Also, the tool attempts to resolve the IP addresses to their host names in the background, using reverse DNS "on a best effort basis"; this can be disabled using the <span class="codeblock2"><code>-n / --no-resolve</code></span> option.<br />
<br />
By default, bandwhich runs in interactive mode and it has 3 panes that show: network utilization by process name, utilization by connection, and utilization by remote address. Because bandwhich has a responsive terminal user interface, the terminal window in which you run bandwhich must be large enough for these 3 panes to be displayed - depending on the window width and/or height, only one or two of these panes may be shown.<br />
<br />
<table align="center" cellpadding="0" cellspacing="0" class="tr-caption-container" style="margin-left: auto; margin-right: auto; text-align: center;"><tbody>
<tr><td style="text-align: center;"><a href="https://1.bp.blogspot.com/-wu73KJ94-e8/XibsoJNR92I/AAAAAAAAD1Y/2r7V6bVCr_oGfmogYXKMHSjlxJWWZbxBQCLcBGAsYHQ/s1600/bandwhich-smaller-window.png" imageanchor="1" style="margin-left: auto; margin-right: auto;"><img alt="bandwhich network bandwidth utilization tool" border="0" data-original-height="708" data-original-width="741" height="610" src="https://1.bp.blogspot.com/-wu73KJ94-e8/XibsoJNR92I/AAAAAAAAD1Y/2r7V6bVCr_oGfmogYXKMHSjlxJWWZbxBQCLcBGAsYHQ/s640/bandwhich-smaller-window.png" title="bandwhich network bandwidth utilization tool" width="640" /></a></td></tr>
<tr><td class="tr-caption" style="text-align: center;">bandwhich has a responsive terminal user interface</td></tr>
</tbody></table><br />
If you only want to display one of these panes, bandwhich has an option for that - run it with <span class="codeblock2"><code>-a / --addresses</code></span> to only show the addresses table, <span class="codeblock2"><code>-c / connections</code></span> to only show the network connections table, or run it using <span class="codeblock2"><code>-p / --processes</code></span> to only show the processes table. <br />
<br />
The feature that allows selecting which panes / tables to show from the command line was added very recently, along with support for IPv6, and VPN traffic sniffing on Mac. Support for WireGuard interfaces was also added fairly recently, as well as a small but useful feature that allows pausing the UI from updating by pressing the <span class="codeblock2"><code>SPACE</code></span> key (this is only for the interactive mode - it doesn't work with the raw mode).<br />
<br />
<table align="center" cellpadding="0" cellspacing="0" class="tr-caption-container" style="margin-left: auto; margin-right: auto; text-align: center;"><tbody>
<tr><td style="text-align: center;"><a href="https://1.bp.blogspot.com/-wnmqtnpQ968/XibsyiNU6jI/AAAAAAAAD1c/X8k_2z27tEc-zPG4-TmyC06UKmfBFDBtQCLcBGAsYHQ/s1600/bandwhich-raw-grep.png" imageanchor="1" style="margin-left: auto; margin-right: auto;"><img alt="bandwhich raw mode" border="0" data-original-height="690" data-original-width="1056" height="418" src="https://1.bp.blogspot.com/-wnmqtnpQ968/XibsyiNU6jI/AAAAAAAAD1c/X8k_2z27tEc-zPG4-TmyC06UKmfBFDBtQCLcBGAsYHQ/s640/bandwhich-raw-grep.png" title="bandwhich raw mode" width="640" /></a></td></tr>
<tr><td class="tr-caption" style="text-align: center;">bandwhich running in raw mode, filtering results for "rclone" (<span class="codeblock2"><code>bandwhich --raw | grep rclone</code></span>)</td></tr>
</tbody></table><br />
Besides the interactive mode, bandwhich also has a raw mode (to use it run bandwhich with the <span class="codeblock2"><code>-r / --raw</code></span> option) that produces machine friendly output. This mode automatically scrolls the raw output without removing any previous lines. It would be useful if this would show a regular timestamp in the form of %H:%M:%S, but maybe such a feature will be added in a future release.<br />
<br />
<b>Related: <a href="https://www.linuxuprising.com/2019/04/analyze-network-traffic-with-termshark.html">Analyze Network Traffic With Termshark, A Terminal UI For TShark (Wireshark)</a></b><br />
<br />
It's also worth noting that by default, bandwhich shows the bandwidth utilization for all available (active) network interfaces. In case you want to specify a particular network interface to listen on, use the <span class="codeblock2"><code>-i / --interface</code></span> option followed by the network interface name, e.g. eth0, enp4s0, or whatever the interface is called.<br />
<br />
There are quite a few tools that can show the network bandwidth utilization on the command line, including iftop, nethogs, and others. bandwhich is similar in some aspects, but it also does things differently.<br />
<br />
For example iftop, which displays bandwidth usage on an interface by host, doesn't show the process that's utilizing the bandwidth. nethogs on the other hand, a command line tool that groups bandwidth per process (it shows the PID, user, program, interface and the sent/received per PID), is a lot more similar in what information it shows compared to bandwhich, but nethogs lacks a raw output mode which can be useful in various cases. Also, nethogs doesn't show individual connections. The way the information is presented also differs, and I personally quite like the bandwhich terminal user interface.<br />
<br />
Anyway, I'm not here to preach but only to inform. Use the tool that you like the most and that's best suited for what you need.<br />
<br />
<h2>Install bandwhich</h2><br />
<div style="text-align: center;"><a href="https://github.com/imsnif/bandwhich#installation" rel="noopener" target="_blank"><input class="install" title="Install bandwhich" type="button" value="Install bandwhich" /></a></div><br />
The bandwhich project page linked above has installation instructions for Arch Linux, Nix/NixOS, Void Linux, Fedora (Copr), and macOS. There are also instructions for installing bandwhich using Cargo, the Rust package manager, that should work on any Linux distribution. The application does not work on Microsoft Windows, at least for now.<br />
<br />
The easiest way to install bandwhich on a Linux distribution for which there are no packages available, is to download the precompiled binary from the <a href="https://github.com/imsnif/bandwhich/releases" rel="nofollow" target="_blank">bandwhich releases tab</a>, and then extract the archive so you have the bandwhich executable ready to use. You'll probably want to install this somewhere in your <span class="codeblock2"><code>$PATH</code></span>, for example <span class="codeblock2"><code>/usr/local/bin</code></span> - you can install it there using (run this command in the folder where you have extracted the bandwhich binary):<br />
<br />
<pre class="cssterm"><code>sudo install bandwhich /usr/local/bin</code></pre><br />
It's important to note that since bandwhich sniffs network packets, it requires root privileges. Run it with <span class="codeblock2"><code>sudo</code></span> on both MacOS and Linux, or for Linux only you can give the bandwhich binary the required privileges so it doesn't require running with sudo, by using:<br />
<br />
<pre class="cssterm"><code>sudo setcap cap_sys_ptrace,cap_dac_read_search,cap_net_raw,cap_net_admin+ep `which bandwhich`</code></pre>
</div>
</article>
<div style='clear:both'></div>
<div class='post-footer'>
<div class='share-box'>
<h8 class='share-title'>Share This:</h8>
<div class='share-art'>
<a class='fac-art' href='https://www.facebook.com/sharer.php?u=https://www.linuxuprising.com/2020/01/bandwhich-shows-whats-taking-up-your.html&title=bandwhich Shows What&#39;s Taking Up Your Network Bandwidth On Linux And macOS' onclick='window.open(this.href, &#39;windowName&#39;, &#39;width=600, height=400, left=24, top=24, scrollbars, resizable&#39;); return false;' rel='nofollow noreferrer' target='_blank' title='Facebook'><i class='fa fa-facebook'></i><span class='resp_del'> Facebook</span></a>
<a class='twi-art' href='https://twitter.com/share?url=https://www.linuxuprising.com/2020/01/bandwhich-shows-whats-taking-up-your.html&title=bandwhich Shows What&#39;s Taking Up Your Network Bandwidth On Linux And macOS' onclick='window.open(this.href, &#39;windowName&#39;, &#39;width=600, height=400, left=24, top=24, scrollbars, resizable&#39;); return false;' rel='nofollow noreferrer' target='_blank' title='Twitter'><i class='fa fa-twitter'></i><span class='resp_del2'> Twitter</span></a>
<a class='dis-art' href='https://sharetodiaspora.github.io/?url=https://www.linuxuprising.com/2020/01/bandwhich-shows-whats-taking-up-your.html&title=bandwhich Shows What&#39;s Taking Up Your Network Bandwidth On Linux And macOS' onclick='window.open(this.href, &#39;windowName&#39;, &#39;width=770, height=500, left=24, top=24, scrollbars, resizable&#39;); return false;' rel='nofollow noreferrer' target='_blank' title='Diaspora'><i class='fa fa-diaspora'></i><span class='resp_del3'> Diaspora</span></a>
<a class='redd-art' href='https://www.reddit.com/submit?url=https://www.linuxuprising.com/2020/01/bandwhich-shows-whats-taking-up-your.html&title=bandwhich Shows What&#39;s Taking Up Your Network Bandwidth On Linux And macOS' onclick='window.open(this.href, &#39;windowName&#39;); return false;' rel='nofollow noreferrer' target='_blank' title='Reddit'><i class='fa fa-reddit-alien'></i><span class='resp_del4'> Reddit</span></a>
<a class='tel-art' href='https://telegram.me/share/url?text=bandwhich Shows What&#39;s Taking Up Your Network Bandwidth On Linux And macOS&tags=&url=https://www.linuxuprising.com/2020/01/bandwhich-shows-whats-taking-up-your.html' onclick='window.open(this.href, &#39;windowName&#39;, &#39;width=600, height=400, left=24, top=24, scrollbars, resizable&#39;); return false;' rel='nofollow noreferrer' target='_blank' title='Telegram'><i class='fa fa-telegram'></i><span class='resp_del5'> Telegram</span></a>
<a class='wat-art' data-action='share/whatsapp/share' href='whatsapp://send?text=bandwhich Shows What&#39;s Taking Up Your Network Bandwidth On Linux And macOS https://www.linuxuprising.com/2020/01/bandwhich-shows-whats-taking-up-your.html' onclick='window.open(this.href, &#39;windowName&#39;, &#39;width=600, height=400, left=24, top=24, scrollbars, resizable&#39;); return false;' rel='nofollow noreferrer' target='_blank' title='WhatsApp'><i class='fa fa-whatsapp'></i><span class='resp_del6'> WhatsApp</span></a>
</div>
</div>
<div style='clear:both'></div>
<div class='ads-post'>
<a name='ads-post-in'></a>
</div>
<div id='related-posts'>
network
</div>
<div class='under-related'>
<div id='ezoic-pub-ad-placeholder-105'></div>
</div>
<div class='clear'></div>
<div class='comment-notif-box'>Please post civil and on-topic comments. <a href='https://www.linuxuprising.com/p/commenting-guidelines.html' rel='nofollow'>Commenting guidelines</a>.</div>
</div>
<div id='disqus_thread_load_on_scroll'>
<div id='disqus_empty' style='display: none'>Empty</div>
</div>

      </div>
    
</div>
<div class='comments' id='comments'>
<a name='comments'></a>
<div id='backlinks-container'>
<div id='Blog1_backlinks-container'>
</div>
</div>
</div>
</div>
</div>
<div class='post-feeds'>
</div>
</div></div>
<div id='ads-post10'>
<div class='no-items section' id='ads-post-468' name='ADS Inner Footer 728x90'>
</div>
</div>
</div>
<div class='sidebar-wrapper' id='sidebar-wrapper'>
<div class='sidebar section' id='sidebar' name='Sidebar Right'><div class='widget HTML' data-version='1' id='HTML1'>
<div class='widget-content'>
<div class="imagehere"><!-- Top Right Sidebar 300x250 -->
<!-- Ezoic - 300x250 top right - sidebar -->
<div id="ezoic-pub-ad-placeholder-102">            
<ins class="adsbygoogle"
     style="display:inline-block;width:300px;height:250px"
     data-ad-client="ca-pub-1997822342415050"
     data-ad-slot="8358301820"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
<!-- End Ezoic - 300x250 top right - sidebar -->
</div>

<script type="text/javascript">
//<![CDATA[
$(window).load(function(){null==document.getElementsByTagName("iframe").item(ga.length-1)&&$("div.imagehere").html("<a href='https://www.linuxuprising.com/2019/04/join-uprising.html' rel='nofollow noopener'><img src='https://4.bp.blogspot.com/-RM33YT7JTCw/XOVA0YwyKxI/AAAAAAAACyo/lA22C-cphP87WD39N4_9SJ-qG5b21IORgCLcBGAs/s1600/join-the-uprising.png' alt='Join the Uprising'/></a><br/>")});
//]]> 
</script>
</div>
</div><div class='widget HTML' data-version='1' id='HTML2'>
<h2 class='title'>Recent Posts</h2>
<div id='RecentPosts'>
<div class='widget-content'>
recentposts
</div>
</div>
</div><div class='widget HTML' data-version='1' id='HTML3'>
<div class='widget-content'>
<div style="margin:0 auto;">
<a target="_blank" rel="noopener nofollow" href="https://t.me/LinuxUprising"><img src="https://1.bp.blogspot.com/-fCC0RyOv2Ts/XcVRcqh6LxI/AAAAAAAADhQ/v-meoJy6TnUe9642hYTzRM1a9q1VQ7seQCLcBGAsYHQ/s1600/telegram-320.png" alt="Join us on Telegram" title="Join us on Telegram"/></a>
</div>
<br/>
<div style="margin:0 auto;">
<a target="_blank" rel="noopener nofollow" href="https://twitter.com/LinuxUprising"><img src="https://1.bp.blogspot.com/-LKFL-Vu_G8w/XfJ0DAfbXcI/AAAAAAAADtc/9nhpwKOKez4EOawDSsDVQe_le3D0Gu-1gCLcBGAsYHQ/s320/twitter.png" alt="follow us on twitter" title="follow us on twitter"/></a>
</div>
<br/>
<!-- Ezoic - Sidebar middle - sidebar_middle -->
<div id="ezoic-pub-ad-placeholder-104">
            <!-- Sidebar right 300x600 -->
<ins class="adsbygoogle"
     style="display:inline-block;width:300px;height:600px"
     data-ad-client="ca-pub-1997822342415050"
     data-ad-slot="6174183113"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
<!-- End Ezoic - Sidebar middle - sidebar_middle -->
</div>
</div><div class='widget LinkList' data-version='1' id='LinkList2'>
<h2>Editor's Picks</h2>
<div class='widget-content'>
<ul>
<li><a href='https://www.linuxuprising.com/2019/11/ffmpeg-extract-audio-from-video-in.html'>FFmpeg: Extract Audio From Video In Original Format Or Converting It To MP3 Or Ogg Vorbis</a></li>
<li><a href='https://www.linuxuprising.com/2019/10/3-ways-of-installing-tor-browser-on.html'>3 Ways Of Installing Tor Browser On Linux (Ubuntu, Fedora, openSUSE, Etc.)</a></li>
<li><a href='https://www.linuxuprising.com/2019/09/fix-username-is-not-in-sudoers-file.html'>Fix 'Username Is Not In The Sudoers File. This Incident Will Be Reported' On Debian</a></li>
<li><a href='https://www.linuxuprising.com/2019/09/install-oracle-java-13-on-ubuntu-linux.html'>Install Oracle Java 13 On Ubuntu, Linux Mint Or Debian From APT PPA Repository</a></li>
<li><a href='https://www.linuxuprising.com/2019/11/how-to-bind-mouse-buttons-to-keyboard.html'>How To Bind Mouse Buttons To Keyboard Keys Or Commands (Linux Using X11)</a></li>
<li><a href='https://www.linuxuprising.com/2019/03/create-persistent-storage-live-usb-with.html'>Create A Persistent Storage Live USB With Ubuntu, Linux Mint Or Debian (UEFI, >4GB Persistence Support)</a></li>
<li><a href='https://www.linuxuprising.com/2018/06/how-to-install-davinci-resolve-15-in.html'>How To Install DaVinci Resolve 16 Or 16.1 In Ubuntu, Linux Mint Or Debian (Generate DEB Package)</a></li>
<li><a href='https://www.linuxuprising.com/2018/12/how-to-change-grub-boot-order-or.html'>How To Change The GRUB Boot Order Or Default Boot Entry In Ubuntu, Linux Mint, Debian, Or Fedora With Grub Customizer</a></li>
<li><a href='https://www.linuxuprising.com/2019/06/new-oracle-java-11-installer-for-ubuntu.html'>New Oracle Java 11 Installer For Ubuntu Or Linux Mint (Using Local Oracle Java .tar.gz)</a></li>
<li><a href='https://www.linuxuprising.com/2018/07/how-to-fix-could-not-get-lock.html'>How To Fix 'Could not get lock /var/lib/dpkg/lock - open (11 Resource temporarily unavailable)' Errors</a></li>
<li><a href='https://www.linuxuprising.com/2018/07/how-to-mount-onedrive-in-linux-using.html'>How To Mount OneDrive In Linux Using Rclone (Supports Business And Personal Accounts)</a></li>
</ul>
</div>
</div><div class='widget HTML' data-version='2' id='HTML5'>
<div class='widget-content'>
<!-- Ezoic - Sidebar bottom - sidebar_bottom -->
<div id="ezoic-pub-ad-placeholder-106"></div>
<!-- End Ezoic - Sidebar bottom - sidebar_bottom -->
</div>
</div><div class='widget HTML' data-version='1' id='HTML6'>
<script type='text/javascript'>
var disqus_shortname = 'linuxuprising';
var disqus_blogger_current_url = "https://www.linuxuprising.com/2020/01/bandwhich-shows-whats-taking-up-your.html";
var disqus_title = "bandwhich Shows What's Taking Up Your Network Bandwidth On Linux And macOS - Linux Uprising Blog";
if (!disqus_blogger_current_url.length) {
disqus_blogger_current_url = "https://www.linuxuprising.com/2020/01/bandwhich-shows-whats-taking-up-your.html";
}
var disqus_blogger_homepage_url = "https://www.linuxuprising.com/";
var disqus_blogger_canonical_homepage_url = "https://www.linuxuprising.com/";
</script>
<script>
var disqus_loaded = false;
function load_disqus( disqus_shortname ) {
  // Prepare the trigger and target

  var is_disqus_empty = document.getElementById('disqus_empty'),
      disqus_target   = document.getElementById('disqus_thread_load_on_scroll'),
      disqus_embed    = document.createElement('script'),
      disqus_hook     = (document.getElementsByTagName('head')[0] || document.getElementsByTagName('body')[0]);

  // Load script asynchronously only when the trigger and target exist
  if( disqus_target && is_disqus_empty ) {
    disqus_loaded = true;
    disqus_embed.type = 'text/javascript';
    disqus_embed.async = true;
    disqus_embed.src = '//' + disqus_shortname + '.disqus.com/blogger_item.js';
    disqus_hook.appendChild(disqus_embed);
    is_disqus_empty.remove();
  }
}

window.addEventListener('scroll', function(e) {
  var currentScroll = document.scrollingElement.scrollTop;
  var disqus_target = document.getElementById('disqus_thread_load_on_scroll');

  if( currentScroll > disqus_target.getBoundingClientRect().top - 150 ) {
    if (disqus_loaded==false) {
      load_disqus('linuxuprising');
    };
  }
}, false);
</script>
</div></div>
</div>
<div class='clear'></div>
</div>
<!-- end content-wrapper -->
<div class='clear'></div><!-- Footer wrapper -->
<div id='footer-wrapper'>
<div id='footer'>
<div class='footer-sections row' id='footer-sections'>
<div class='sect-left section' id='footer-sec1' name='Widget 1'><div class='widget LinkList' data-version='1' id='LinkList1'>
<h2>Linux Uprising</h2>
<div class='widget-content'>
<ul>
<li><a href='https://www.linuxuprising.com/p/about.html'>About</a></li>
<li><a href='https://www.linuxuprising.com/p/privacy-policy.html'>Privacy Policy</a></li>
<li><a href='https://www.linuxuprising.com/p/terms-of-use.html'>Terms of Service</a></li>
<li><a href='https://www.linuxuprising.com/p/cookie-policy.html'>Cookie Information</a></li>
<li><a href='https://www.linuxuprising.com/p/privacy-policy.html'>Privacy Policy</a></li>
</ul>
</div>
</div><div class='widget HTML' data-version='2' id='HTML47'>
<div class='widget-content'>
<a class="change-consent" onclick="window.__cmp('displayConsentUi');">Cookie Settings</a>
</div>
</div></div>
<div class='sect-left section' id='footer-sec2' name='Widget 2'><div class='widget FollowByEmail' data-version='1' id='FollowByEmail1'>
<h2 class='title'>Follow by Email</h2>
<div class='widget-content'>
<div class='follow-by-email-inner'>
<form action='https://feedburner.google.com/fb/a/mailverify' method='post' onsubmit='window.open("https://feedburner.google.com/fb/a/mailverify?uri=LinuxUprising", "popupwindow", "scrollbars=yes,width=550,height=520"); return true' target='popupwindow'>
<table width='100%'>
<tr>
<td>
<label for='email'><input aria-label='email' class='follow-by-email-address' id='email' name='email' placeholder='Email address...' type='text'/></label>
</td>
<td width='64px'>
<input class='follow-by-email-submit' type='submit' value='Submit'/>
</td>
</tr>
</table>
<input name='uri' type='hidden' value='LinuxUprising'/>
<input name='loc' type='hidden' value='en_US'/>
</form>
</div>
</div>
<span class='item-control blog-admin'>
</span>
</div></div>
<div class='sect-left section' id='footer-sec3' name='Widget 3'><div class='widget BlogArchive' data-version='1' id='BlogArchive2'>
<h2>Blog Archive</h2>
<div class='widget-content'>
<div id='ArchiveList'>
<div id='BlogArchive2_ArchiveList'>
<label aria-label='archive-menu' for='BlogArchive2_ArchiveMenu'>
<select id='BlogArchive2_ArchiveMenu'>
<option value=''>Blog Archive</option>
<option value='https://www.linuxuprising.com/2020/01/'>January 2020 (8)</option>
<option value='https://www.linuxuprising.com/2019/12/'>December 2019 (14)</option>
<option value='https://www.linuxuprising.com/2019/11/'>November 2019 (18)</option>
<option value='https://www.linuxuprising.com/2019/10/'>October 2019 (13)</option>
<option value='https://www.linuxuprising.com/2019/09/'>September 2019 (17)</option>
<option value='https://www.linuxuprising.com/2019/08/'>August 2019 (11)</option>
<option value='https://www.linuxuprising.com/2019/07/'>July 2019 (22)</option>
<option value='https://www.linuxuprising.com/2019/06/'>June 2019 (18)</option>
<option value='https://www.linuxuprising.com/2019/05/'>May 2019 (19)</option>
<option value='https://www.linuxuprising.com/2019/04/'>April 2019 (20)</option>
<option value='https://www.linuxuprising.com/2019/03/'>March 2019 (16)</option>
<option value='https://www.linuxuprising.com/2019/02/'>February 2019 (17)</option>
<option value='https://www.linuxuprising.com/2019/01/'>January 2019 (21)</option>
<option value='https://www.linuxuprising.com/2018/12/'>December 2018 (15)</option>
<option value='https://www.linuxuprising.com/2018/11/'>November 2018 (24)</option>
<option value='https://www.linuxuprising.com/2018/10/'>October 2018 (22)</option>
<option value='https://www.linuxuprising.com/2018/09/'>September 2018 (15)</option>
<option value='https://www.linuxuprising.com/2018/08/'>August 2018 (27)</option>
<option value='https://www.linuxuprising.com/2018/07/'>July 2018 (26)</option>
<option value='https://www.linuxuprising.com/2018/06/'>June 2018 (21)</option>
<option value='https://www.linuxuprising.com/2018/05/'>May 2018 (31)</option>
<option value='https://www.linuxuprising.com/2018/04/'>April 2018 (25)</option>
<option value='https://www.linuxuprising.com/2018/03/'>March 2018 (1)</option>
</select>
</label>
</div>
</div>
</div>
</div></div>
</div>
</div>
<div class='clear'></div>
<div class='footer-wrapper'>
<div class='footer-sec row'>
<!-- Footer Social -->
<div class='social-footer section' id='social-footer' name='Social Footer'><div class='widget LinkList' data-version='1' id='LinkList20'>
<div class='widget-content'>
<ul>
<li><a class='rss' href='https://feeds.feedburner.com/LinuxUprising' rel='noreferrer' target='_blank' title='rss'></a></li>
<li><a class='friendica' href='https://libranet.de/profile/linuxuprising' rel='noreferrer' target='_blank' title='friendica'></a></li>
<li><a class='twitter' href='https://twitter.com/linuxuprising' rel='noreferrer' target='_blank' title='twitter'></a></li>
<li><a class='telegram' href='https://t.me/LinuxUprising' rel='noreferrer' target='_blank' title='telegram'></a></li>
<li><a class='facebook' href='https://www.facebook.com/LinuxUprising/' rel='noreferrer' target='_blank' title='facebook'></a></li>
<li><a class='reddit' href='https://www.reddit.com/r/LinuxUprising/' rel='noreferrer' target='_blank' title='reddit'></a></li>
</ul>
</div>
</div></div>
<!-- Footer Copyright -->
<div class='copyright'>
License: <a href='https://creativecommons.org/licenses/by-nc/4.0/' rel='license nofollow noreferrer' target='_blank'>CC BY-NC 4.0</a>
<a href='https://www.linuxuprising.com'>Linux Uprising</a>. <br/>The registered trademark Linux&#174; is used pursuant to a sublicense from the Linux Foundation, the exclusive licensee of Linus Torvalds, owner of the mark on a world&#173;wide basis.
</div>
</div>
</div>
</div>
</div>
<script type='text/javascript'>
if (!('IntersectionObserver' in window)) {
    var script = document.createElement("script");
    script.src = "https://cdn.jsdelivr.net/npm/intersection-observer@0.7.0/intersection-observer.js";
    document.getElementsByTagName('head')[0].appendChild(script);
}
</script>
<script src='https://cdnjs.cloudflare.com/ajax/libs/vanilla-lazyload/12.3.0/lazyload.min.js'></script>
<script type='text/javascript'>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</script>
<script type='text/javascript'>    
//<![CDATA[

$(document).ready((function() {
    $('pre.cssterm','#post-article').each((function() {
        $(this).attr('title','Triple click to select a complete line!');
    }));
}));

// Lazyload
            (function(a){a.fn.lazyload=function(b){var c={threshold:0,failurelimit:0,event:"scroll",effect:"show",container:window};if(b){a.extend(c,b)}var d=this;if("scroll"==c.event){a(c.container).bind("scroll",function(b){var e=0;d.each(function(){if(a.abovethetop(this,c)||a.leftofbegin(this,c)){}else if(!a.belowthefold(this,c)&&!a.rightoffold(this,c)){a(this).trigger("appear")}else{if(e++>c.failurelimit){return false}}});var f=a.grep(d,function(a){return!a.loaded});d=a(f)})}this.each(function(){var b=this;if(undefined==a(b).attr("original")){a(b).attr("original",a(b).attr("src"))}if("scroll"!=c.event||undefined==a(b).attr("src")||c.placeholder==a(b).attr("src")||a.abovethetop(b,c)||a.leftofbegin(b,c)||a.belowthefold(b,c)||a.rightoffold(b,c)){if(c.placeholder){a(b).attr("src",c.placeholder)}else{a(b).removeAttr("src")}b.loaded=false}else{b.loaded=true}a(b).one("appear",function(){if(!this.loaded){a("<img />").bind("load",function(){a(b).hide().attr("src",a(b).attr("original"))[c.effect](c.effectspeed);b.loaded=true}).attr("src",a(b).attr("original"))}});if("scroll"!=c.event){a(b).bind(c.event,function(c){if(!b.loaded){a(b).trigger("appear")}})}});a(c.container).trigger(c.event);return this};a.belowthefold=function(b,c){if(c.container===undefined||c.container===window){var d=a(window).height()+a(window).scrollTop()}else{var d=a(c.container).offset().top+a(c.container).height()}return d<=a(b).offset().top-c.threshold};a.rightoffold=function(b,c){if(c.container===undefined||c.container===window){var d=a(window).width()+a(window).scrollLeft()}else{var d=a(c.container).offset().left+a(c.container).width()}return d<=a(b).offset().left-c.threshold};a.abovethetop=function(b,c){if(c.container===undefined||c.container===window){var d=a(window).scrollTop()}else{var d=a(c.container).offset().top}return d>=a(b).offset().top+c.threshold+a(b).height()};a.leftofbegin=function(b,c){if(c.container===undefined||c.container===window){var d=a(window).scrollLeft()}else{var d=a(c.container).offset().left}return d>=a(b).offset().left+c.threshold+a(b).width()};a.extend(a.expr[":"],{"below-the-fold":"$.belowthefold(a, {threshold : 0, container: window})","above-the-fold":"!$.belowthefold(a, {threshold : 0, container: window})","right-of-fold":"$.rightoffold(a, {threshold : 0, container: window})","left-of-fold":"!$.rightoffold(a, {threshold : 0, container: window})"})})(jQuery);$(function(){$("img").lazyload({placeholder:"https://1.bp.blogspot.com/-zfTgNA4ZsX0/XR0aQA2GyiI/AAAAAAAADAA/JOjs9ZVsMvA7aIt4bXkH5AqiJK_xkIDUwCLcBGAs/s1600/pixel.gif",effect:"fadeIn",threshold:"1"})});

$("#related-posts").each((function() {
    var g = $(this).html();
    var title = $("#entry-title").text().trim();
    $.ajax({
        url: "/feeds/posts/default/-/" + g + "?alt=json-in-script&max-results=" + related_number,
        type: 'get',
        cache: true,
        dataType: "jsonp",
        success: function(data) {
            var posturl = "";
            var htmlcode = '<div class="related"><ul>';
            for (var i = 0; i < data.feed.entry.length; i++) {
              var s = data.feed.entry[i].title.$t.trim();
              if (s !== title) {
                for (var j = 0; j < data.feed.entry[i].link.length; j++) {
                    if (data.feed.entry[i].link[j].rel == "alternate") {
                            posturl = data.feed.entry[i].link[j].href;
                            break
                    }
                }

                var posttitle = data.feed.entry[i].title.$t;

                if (!data.feed.entry[i].media$thumbnail) {
                    var thumb = '<a title="' + posttitle +'" class="related-img" href="' + posturl + '"' + 'data-bg="url(' + no_image_url + ')" />'                 
                } else {
                    var src = data.feed.entry[i].media$thumbnail.url.split(/s72-c/).join("s320");
                    var thumb = '<a title="' + posttitle +'" class="related-img" href="' + posturl + '"' + 'data-bg="url(' + src + ')" />'                
                }

                htmlcode += '<li><div class="related-thumb">' + thumb + '</div><h3 class="related-title"><a href="' + posturl + '">' + posttitle + '</a></h3></li>'
            }
            }
            htmlcode += '</ul></div><div class="clear"/>';
            $("#related-posts").html(htmlcode);
            LL.update();

        }
    })
}));


//]]>
</script>
<div class='back-to-top'>
<a href='#' id='back-to-top' title='back to top'>
<i class='fa fa-long-arrow-up'></i>
</a>
</div>

<script type="text/javascript" src="https://www.blogger.com/static/v1/widgets/2094335208-widgets.js"></script>
<script type='text/javascript'>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</script>
<script type='text/javascript' style='display:none;' async>
__ez.queue.addFile('edmonton.php', '/detroitchicago/edmonton.webp?a=a&cb=0&shcb=32', true, [], true, false, false, false);
__ez.queue.addFile('jellyfish.php', '/porpoiseant/jellyfish.webp?a=a&cb=0&shcb=32', false, [], true, false, false, false);
</script>

<script>var _audins_dom="linuxuprising_com",_audins_did=131660;__ez.queue.addDelayFunc("audins.js","__ez.script.add", "//go.ezoic.net/detroitchicago/audins.js?cb=188-0");</script><noscript><div style="display:none;"><img src="//pixel.quantserve.com/pixel/p-31iz6hfFutd16.gif?labels=Domain.linuxuprising_com,DomainId.131660" border="0" height="1" width="1" alt="Quantcast"/></div></noscript><noscript><img src="https://sb.scorecardresearch.com/p?c1=2&c2=20015427&cv=2.0&cj=1"/></noscript>
<script type='text/javascript' data-cfasync='false'>(function(){function b(e,c){for(var d=0;d<c.length;d++){var f=c[d];if(0==f.complete||"undefined"!=typeof f.readyState&&4>f.readyState){var g=f.getAttribute("src")||f.currentSrc;"undefined"!=typeof f.readyState&&0==f.readyState?f.addEventListener("loadstart",function(h){var k=h.getAttribute("src")||h.currentSrc;window.ezorqs(h,k)}):(g=f.getAttribute("src")||f.currentSrc,window.ezorqs(f,g));f.addEventListener("load",function(h){var k=h.currentTarget.getAttribute("src")||h.srcElement.currentSrc;window.ezorqe(h,
	k)});f.addEventListener("loadeddata",function(h){var k=h.currentTarget.getAttribute("src")||h.srcElement.currentSrc;window.ezorqe(h,k)});f.addEventListener("error",function(h){var k=h.currentTarget.getAttribute("src")||h.srcElement.currentSrc;window.ezorqe(h,k)})}}}function a(e){for(var c=0;c<document.styleSheets.length;c++)if(document.styleSheets[c].href==e)return!0;return!1}b("img",document.querySelectorAll("img"));b("video",document.querySelectorAll("video"));b("audio",document.querySelectorAll("audio"));
	(function(e){for(var c=0;c<e.length;c++){var d=e[c];if(("preload"==d.getAttribute("rel")||"stylesheet"==d.getAttribute("rel"))&&null!=d.getAttribute("href")&&a(d.getAttribute("href"))){window.ezorqs(d,d.getAttribute("href"));var f=document.createElement("img");f.onerror=function(g){"undefined"!=typeof g.path&&"undefined"!=typeof g.path[0].currentSrc?window.ezorqe(d,g.path[0].currentSrc):"undefined"!=typeof g.srcElement&&"undefined"!=typeof g.srcElement.href&&window.ezorqe(d,g.srcElement.href)};f.src=
	d.getAttribute("href")}}})(document.querySelectorAll("link"));"undefined"!=typeof window.__ez.ssaf&&-1<window.__ez.ssaf.indexOf(16)&&"undefined"!==typeof window.__ez.sshsdef&&!1===window.__ez.sshsdef&&Element.prototype.addEventListener&&("function"==typeof window.onload&&(window.addEventListener("load",window.onload),window.onload=null),"function"==typeof document.onload&&(document.addEventListener.addEventListener("load",document.onload),document.onload=null))})();</script></body>
</html>