<!DOCTYPE html>
<html dir='ltr' lang='en-US' xmlns='http://www.w3.org/1999/xhtml' xmlns:b='http://www.google.com/2005/gml/b' xmlns:data='http://www.google.com/2005/gml/data' xmlns:expr='http://www.google.com/2005/gml/expr'>
<head>
<meta charset='utf-8'/>
<meta content='en-us' http-equiv='content-language'/>
<meta content='IE=edge' http-equiv='X-UA-Compatible'/>
<meta content='width=device-width,initial-scale=1.0' name='viewport'/>
<meta content='#f2132d' name='theme-color'/>
<meta content='#f2132d' name='msapplication-TileColor'/>
<link href='https://3.bp.blogspot.com/-_Rvl0I-6PsE/WxqOMWBSvFI/AAAAAAAAAr0/YVpbw6VxjTE0cs2FIG3JGGrzfelqF1AXQCLcBGAs/s1600/apple-icon-180x180.png' rel='apple-touch-icon' sizes='180x180'/>
<link href='https://4.bp.blogspot.com/-C3SXpMZFwoM/WxqOMWPcqBI/AAAAAAAAAr4/q3BlIVZd9BIycvFtwpwee9ho2axmuey1wCLcBGAs/s1600/android-icon-192x192.png' rel='icon' sizes='192x192' type='image/png'/>
<link href='https://fonts.gstatic.com' rel='dns-prefetch'/>
<link crossorigin='anonymous' href='https://fonts.gstatic.com' rel='preconnect'/>
<link as='fetch' crossorigin='anonymous' href='https://fonts.googleapis.com/css?family=Ubuntu:300,300i,400,500,700' rel='preload'/>
<link href='https://cdn.jsdelivr.net' rel='dns-prefetch'/>
<link crossorigin='anonymous' href='https://cdn.jsdelivr.net' rel='preconnect'/>
<link as='fetch' crossorigin='anonymous' href='https://cdn.jsdelivr.net/npm/fork-awesome@1.1.3/css/fork-awesome.min.css' rel='preload'/>
<link crossorigin='crossorigin' href='https://fonts.googleapis.com' rel='preconnect'/>
<link crossorigin='crossorigin' href='https://ajax.googleapis.com' rel='preconnect'/>
<link crossorigin='crossorigin' href='https://apis.google.com' rel='preconnect'/>
<link crossorigin='crossorigin' href='https://cdn.jsdelivr.net' rel='preconnect'/>
<link crossorigin='crossorigin' href='https://lh3.googleusercontent.com' rel='preconnect'/>
<link crossorigin='crossorigin' href='https://fonts.gstatic.com' rel='preconnect'/>
<link crossorigin='crossorigin' href='https://adservice.google.com' rel='preconnect'/>
<link href='//linuxuprising.disqus.com' rel='preconnect'/>
<link href='//disqus.com' rel='dns-prefetch'/>
<link href='//c.disquscdn.com' rel='dns-prefetch'/>
<link href='//referrer.disqus.com' rel='dns-prefetch'/>
<link href='//juggler.services.disqus.com' rel='dns-prefetch'/>
<meta content='text/html; charset=UTF-8' http-equiv='Content-Type'/>
<!-- Chrome, Firefox OS and Opera -->
<meta content='' name='theme-color'/>
<!-- Windows Phone -->
<meta content='' name='msapplication-navbutton-color'/>
<meta content='blogger' name='generator'/>
<link href='https://www.linuxuprising.com/favicon.ico' rel='icon' type='image/x-icon'/>
<link href='https://www.linuxuprising.com/2019/07/rclonetray-easily-mount-rclone-remotes.html' rel='canonical'/>
<link rel="alternate" type="application/atom+xml" title="Linux Uprising Blog - Atom" href="https://www.linuxuprising.com/feeds/posts/default" />
<link rel="alternate" type="application/rss+xml" title="Linux Uprising Blog - RSS" href="https://www.linuxuprising.com/feeds/posts/default?alt=rss" />
<link rel="service.post" type="application/atom+xml" title="Linux Uprising Blog - Atom" href="https://www.blogger.com/feeds/852161773840707483/posts/default" />

<link rel="alternate" type="application/atom+xml" title="Linux Uprising Blog - Atom" href="https://www.linuxuprising.com/feeds/2980370474628936728/comments/default" />
<!--Can't find substitution for tag [blog.ieCssRetrofitLinks]-->
<link href='https://1.bp.blogspot.com/-jnAyCx9vh-o/XS33JinfIZI/AAAAAAAADDU/39vv7aGwDKMl2O1aeMJV8cofz7VNXINygCLcBGAs/s640/rclonetray.png' rel='image_src'/>
<meta content='RcloneTray is a GUI for Rclone, the "rsync for cloud storage" command line tool, which runs on Windows, Mac and Linux. Using this Electron tray application, you&#39;ll be able to quickly mount Rclone remotes, open the mount location using your default file manager, and perform other operations.' name='description'/>
<meta content='https://www.linuxuprising.com/2019/07/rclonetray-easily-mount-rclone-remotes.html' property='og:url'/>
<meta content='RcloneTray: Easily Mount Rclone Remotes On Demand Using A GUI' property='og:title'/>
<meta content='RcloneTray is a GUI for Rclone, the &quot;rsync for cloud storage&quot; command line tool, which runs on Windows, Mac and Linux. Using this Electron tray application, you&#39;ll be able to quickly mount Rclone remotes, open the mount location using your default file manager, and perform other operations.' property='og:description'/>
<meta content='https://1.bp.blogspot.com/-jnAyCx9vh-o/XS33JinfIZI/AAAAAAAADDU/39vv7aGwDKMl2O1aeMJV8cofz7VNXINygCLcBGAs/w1200-h630-p-k-no-nu/rclonetray.png' property='og:image'/>
<!--[if IE]> <script> (function() { var html5 = ("abbr,article,aside,audio,canvas,datalist,details," + "figure,footer,header,hgroup,mark,menu,meter,nav,output," + "progress,section,time,video").split(','); for (var i = 0; i < html5.length; i++) { document.createElement(html5[i]); } try { document.execCommand('BackgroundImageCache', false, true); } catch(e) {} })(); </script> <![endif]-->
<meta content='https://www.facebook.com/LinuxUprising' property='article:publisher'/>
<meta content='3F3C1DB7847EE7E64E8A2F6CDC5A5F10' name='msvalidate.01'/>
<meta content='de18aa7b281bff4c' name='yandex-verification'/>
<title>
RcloneTray: Easily Mount Rclone Remotes On Demand Using A GUI - Linux Uprising Blog
</title>
<!-- Description and Keywords (start) -->
<meta content='en_US' property='og:locale'/>
<!-- Description and Keywords (end) -->
<meta content='article' property='og:type'/>
<meta content='Linux Uprising Blog' property='og:site_name'/>
<meta content='https://www.linuxuprising.com/' name='twitter:domain'/>
<meta content='RcloneTray: Easily Mount Rclone Remotes On Demand Using A GUI' name='twitter:title'/>
<meta content='summary_large_image' name='twitter:card'/>
<meta content='https://1.bp.blogspot.com/-jnAyCx9vh-o/XS33JinfIZI/AAAAAAAADDU/39vv7aGwDKMl2O1aeMJV8cofz7VNXINygCLcBGAs/s640/rclonetray.png' name='twitter:image'/>
<meta content='RcloneTray is a GUI for Rclone, the "rsync for cloud storage" command line tool, which runs on Windows, Mac and Linux. Using this Electron tray application, you&#39;ll be able to quickly mount Rclone remotes, open the mount location using your default file manager, and perform other operations.' name='twitter:description'/>
<!-- Social Media meta tag need customer customization -->
<meta content='572203406470374' property='fb:app_id'/>
<meta content='841352899' property='fb:admins'/>
<meta content='@linuxuprising' name='twitter:site'/>
<meta content='@linuxuprising' name='twitter:creator'/>
<style id='page-skin-1' type='text/css'>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</style>
<style id='template-skin-1' type='text/css'><!--
/*------Layout (No Edit)----------*/
body#layout .row {width: 900px;}
body#layout #outer-wrapper{padding:0;width:900px}
body#layout .section h4{color:#333!important}
body#layout .theme-opt{overflow:hidden;     display: block!important;}
body#layout #option{overflow:hidden; display:block}
body#layout #option h4{font-size:16px;padding:4px 0 7px}
body#layout #option .widget{float:left;width:20%}
body#layout #option .widget.locked-widget .widget-content{background-color: #ff7575 !important;
border-color: #840000 !important;
color: #fff !important;}
body#layout #option .widget.locked-widget .widget-content a.editlink{color:#fff!important;border:1px solid;border-radius:2px;padding:2px 5px}
body#layout #topnav,body#layout .tm-head{height:auto}
body#layout .tm-menu{margin:0;width:70%}
body#layout .social-area{margin:0;width:30%}
body#layout .header-content,body#layout #header-blog{height:160px}
body#layout .header-logo{float:left;width:30%;margin:0;padding:0}
body#layout .header-ads{width:70%;margin:0}
body#layout .header-menu li.home-child{display:none}
body#layout .header-search,body#layout .m-rec{display:none}
body#layout .header-menu{float:left;width:100%;margin:4px 0 0;padding:0}
body#layout #content-wrapper{margin:0 auto}
body#layout .feat-layout .widget-content,body#layout .feat-layout h2.title,body#layout #ads-blog{display:block}
body#layout #main-wrapper{float:left;width:70%;margin:0;padding:0}
body#layout #ads-post10{display:block}
body#layout .sidebar-wrapper{float:right;width:30%;margin:0;padding:0}
body#layout #footer-wrapper{overflow:hidden}
body#layout .sect-left{width:28.3%;float:left}
body#layout #social-footer{width:30%;float:right}
/*------Layout (end)----------*/
--></style>
<style type='text/css'>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</style>
<script async='async' src='//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js'></script>
<script>
if (window.innerWidth < 1000) {
     (adsbygoogle = window.adsbygoogle || []).push({
          google_ad_client: "ca-pub-1997822342415050",
          enable_page_level_ads: true
     });
}    
</script>
<script type='text/javascript'> 
//<![CDATA[
var text_month = [, "Jan", "Feb", "Mar", "Apr", "May", "Jun", "Jul", "Aug", "Sept", "Oct", "Nov", "Dec"];
var no_image_url = "https://1.bp.blogspot.com/-dUVHHKr63sw/WrjkLAm4OkI/AAAAAAAAABU/SNBN1gIB8E0vLNWf41AGwudNCH1Q9hYYwCLcBGAs/s1600-r/nothumb.jpg";
var feat1_number = 3;
var related_number = 4;
//]]>
</script>
<!-- Google Analytics -->
<script type='text/javascript'>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');
  ga('create', 'UA-116578392-1', 'auto');
  ga('require', 'displayfeatures');
  ga('set', 'anonymizeIp', true);
  ga('send', 'pageview');
</script>
<script type='text/javascript'>
function getCookie(name) {
    var nameEQ = name + "=";
    var ca = document.cookie.split(';');
    for(var i=0;i < ca.length;i++) {
        var c = ca[i];
        while (c.charAt(0)==' ') c = c.substring(1,c.length);
        if (c.indexOf(nameEQ) == 0) return c.substring(nameEQ.length,c.length);
    }
    return null;
}    
var x = getCookie('displayCookieNotice');
if (x) {
    (adsbygoogle=window.adsbygoogle||[]).requestNonPersonalizedAds=0;
}
</script>
<!-- START Custom EU Cookies Notice -->
<script type='text/javascript'> 
  cookieOptions = { 
    msg: "This site is hosted on Google Blogger and uses cookies from Google to deliver its services, to serve and personalize ads, and to analyze traffic. Your IP address and user-agent are shared with Google along with performance and security metrics to ensure quality of service, generate usage statistics, and to detect and address abuse.", 
    close: "Ok", 
    learn: "Learn More" }; 
</script>
<!-- END Custom EU Cookies Notice -->
<script>
        (function () {
            var done = false;
            var script = document.createElement("script"),
            head = document.getElementsByTagName("head")[0] || document.documentElement;
            script.src = 'https://ajax.googleapis.com/ajax/libs/webfont/1.6.26/webfont.js';
            script.async = true;
            script.onload = script.onreadystatechange = function() {
                if ( ! done && ( ! this.readyState || this.readyState === "loaded" || this.readyState === "complete" ) ) {
                    done = true;
                    WebFont.load({
                        google: {
                            families: ['Ubuntu:300,300i,500,700&display=swap']
                        }
                    });
                    script.onload = script.onreadystatechange = null;
                }
            };
            head.insertBefore(script, head.firstChild);
        })();
    </script>
<noscript><link href='https://fonts.googleapis.com/css?family=Ubuntu:300,300i,500,700&display=swap' rel='stylesheet'/></noscript>
<link href='https://www.blogger.com/dyn-css/authorization.css?targetBlogID=852161773840707483&amp;zx=21e85f25-8872-4460-98b0-0d397fb48f22' media='none' onload='if(media!=&#39;all&#39;)media=&#39;all&#39;' rel='stylesheet'/><noscript><link href='https://www.blogger.com/dyn-css/authorization.css?targetBlogID=852161773840707483&amp;zx=21e85f25-8872-4460-98b0-0d397fb48f22' rel='stylesheet'/></noscript>

</head>
<body class='item'>
<div class='theme-opt' style='display:none'>
<div class='option section' id='option' name='Theme Option'><div class='widget HTML' data-version='1' id='HTML103'>

<script type='text/javascript'> 
          //<![CDATA[
          var recentposts_number = 5;
          //]]>
         </script>
         
</div><div class='widget HTML' data-version='1' id='HTML104'>
<script type='text/javascript'> 
          //<![CDATA[
          var randomposts_number = 4;
          //]]>
         </script>
</div><div class='widget HTML' data-version='1' id='HTML105'>

         <script type='text/javascript'>
          var postperpage=12;
         </script>
         
</div><div class='widget HTML' data-version='1' id='HTML106'>
</div><div class='widget HTML' data-version='1' id='HTML851'>
<script src='https://ajax.googleapis.com/ajax/libs/jquery/2.2.4/jquery.min.js' type='text/javascript'></script>
<script type='text/javascript'> 
            //<![CDATA[

            // Plugin: Sticky jQuery ~ BY: https://stickyjs.com
            (function(e){var t={topSpacing:0,bottomSpacing:0,className:"is-sticky",wrapperClassName:"sticky-wrapper",center:false,getWidthFrom:"",responsiveWidth:false},n=e(window),r=e(document),i=[],s=n.height(),o=function(){var t=n.scrollTop(),o=r.height(),u=o-s,a=t>u?u-t:0;for(var f=0;f<i.length;f++){var l=i[f],c=l.stickyWrapper.offset().top,h=c-l.topSpacing-a;if(t<=h){if(l.currentTop!==null){l.stickyElement.css("width","").css("position","").css("top","");l.stickyElement.trigger("sticky-end",[l]).parent().removeClass(l.className);l.currentTop=null}}else{var p=o-l.stickyElement.outerHeight()-l.topSpacing-l.bottomSpacing-t-a;if(p<0){p=p+l.topSpacing}else{p=l.topSpacing}if(l.currentTop!=p){l.stickyElement.css("width",l.stickyElement.width()).css("position","fixed").css("top",p);if(typeof l.getWidthFrom!=="undefined"){l.stickyElement.css("width",e(l.getWidthFrom).width())}l.stickyElement.trigger("sticky-start",[l]).parent().addClass(l.className);l.currentTop=p}}}},u=function(){s=n.height();for(var t=0;t<i.length;t++){var r=i[t];if(typeof r.getWidthFrom!=="undefined"&&r.responsiveWidth===true){r.stickyElement.css("width",e(r.getWidthFrom).width())}}},a={init:function(n){var r=e.extend({},t,n);return this.each((function(){var n=e(this);var s=n.attr("id");var o=s?s+"-"+t.wrapperClassName:t.wrapperClassName;var u=e("<div></div>").attr("id",s+"-sticky-wrapper").addClass(r.wrapperClassName);n.wrapAll(u);if(r.center){n.parent().css({width:n.outerWidth(),marginLeft:"auto",marginRight:"auto"})}if(n.css("float")=="right"){n.css({"float":"none"}).parent().css({"float":"right"})}var a=n.parent();a.css("height",n.outerHeight());i.push({topSpacing:r.topSpacing,bottomSpacing:r.bottomSpacing,stickyElement:n,currentTop:null,stickyWrapper:a,className:r.className,getWidthFrom:r.getWidthFrom,responsiveWidth:r.responsiveWidth})}))},update:o,unstick:function(t){return this.each((function(){var t=e(this);var n=-1;for(var r=0;r<i.length;r++){if(i[r].stickyElement.get(0)==t.get(0)){n=r}}if(n!=-1){i.splice(n,1);t.unwrap();t.removeAttr("style")}}))}};if(window.addEventListener){window.addEventListener("scroll",o,false);window.addEventListener("resize",u,false)}else if(window.attachEvent){window.attachEvent("onscroll",o);window.attachEvent("onresize",u)}e.fn.sticky=function(t){if(a[t]){return a[t].apply(this,Array.prototype.slice.call(arguments,1))}else if(typeof t==="object"||!t){return a.init.apply(this,arguments)}else{e.error("Method "+t+" does not exist on jQuery.sticky")}};e.fn.unstick=function(t){if(a[t]){return a[t].apply(this,Array.prototype.slice.call(arguments,1))}else if(typeof t==="object"||!t){return a.unstick.apply(this,arguments)}else{e.error("Method "+t+" does not exist on jQuery.sticky")}};e((function(){setTimeout(o,0)}))})(jQuery);
            //]]>
          </script>
          <script type='text/javascript'> 
            //<![CDATA[
              $(document).ready(function(){$("#header-navigation").sticky({topSpacing:0});});
            //]]>
          </script>
        </div></div>
</div>

<div id="pages-wrap" class="item">

<div id='outer-wrapper'>
<div id='topnav'>
<div class='tm-head row'>
<div class='tm-menu'>
<div class='menu1 section' id='menu1' name='Top Navigation'><div class='widget LinkList' data-version='1' id='LinkList210'>
<div class='widget-content'>
<ul id='nav1'>
<li><a href='https://www.linuxuprising.com/p/about.html'>About</a></li>
<li><a href='https://www.linuxuprising.com/p/contact.html'>Contact</a></li>
<li><a href='https://www.reddit.com/r/LinuxUprising/' rel='noreferrer' target='_blank'>Submit A Tip</a></li>
</ul>
</div>
</div></div>
</div>
<!-- Top Social -->
<div class='social-area'>
<div class='social-top section' id='social-top' name='Social Top'><div class='widget LinkList' data-version='1' id='LinkList50'>
<div class='widget-content'>
<ul>
<li><a class='rss' href='https://feeds.feedburner.com/LinuxUprising' rel='noreferrer' target='_blank' title='rss'></a></li>
<li><a class='friendica' href='https://libranet.de/profile/linuxuprising' rel='noreferrer' target='_blank' title='friendica'></a></li>
<li><a class='twitter' href='https://twitter.com/linuxuprising' rel='noreferrer' target='_blank' title='twitter'></a></li>
<li><a class='telegram' href='https://t.me/LinuxUprising' rel='noreferrer' target='_blank' title='telegram'></a></li>
<li><a class='facebook' href='https://www.facebook.com/LinuxUprising/' rel='noreferrer' target='_blank' title='facebook'></a></li>
<li><a class='reddit' href='https://www.reddit.com/r/LinuxUprising/' rel='noreferrer' target='_blank' title='reddit'></a></li>
</ul>
</div>
</div></div>
</div>
</div>
</div>
<div id='header-blog'>
<div class='header-content row'>
<div class='header-logo'>
<div class='section' id='logo_blog' name='Logo'><div class='widget Header' data-version='1' id='Header1'>
<div id='header-inner'>
<h2 class='logo'>
<a href='https://www.linuxuprising.com/' style='display: block'>
<img alt='Linux Uprising Blog' height='23px; ' id='Header1_headerimg' src='https://cdn.rawgit.com/logix2/6fb43ed0a1979f24c50857fadc6de3ac/raw/24571f5df3fa6fadeeb0937ffd40ea38c380075f/logo2.svg' style='display: block' width='455px; '/>
</a>
<span class='alt-logo'>Linux Uprising blog</span>
</h2>
</div>
</div></div>
</div>
<!-- <div class='header-ads'> <b:section id='ads-content' maxwidgets='1' name='Ads 728x90' showaddelement='yes'> <b:widget id='HTML1' locked='false' title='' type='HTML'> <b:includable id='main'> <b:if cond='data:title != &quot;&quot;'> <h2 class='title'><data:title/></h2> </b:if> <div class='widget-content'> <data:content/> </div> </b:includable> </b:widget> </b:section> </div> -->
</div>
</div>
<nav class='row' id='header-navigation'>
<div class='nav-wrapper'>
<div class='nav-menu'>
<div class='header-search'>
<ul>
<li>
<a class='search' id='search'>
<form action='/search/max-results=12' method='get'>
<input id='s' name='q' placeholder='Type and hit enter...' type='text'/>
</form>
</a>
</li>
</ul>
</div>
<div class='header-menu'>
<ul>
<li class='home-child'><a href='https://www.linuxuprising.com/'>Home</a></li>
</ul>
<div class='menu section' id='menu' name='Main Menu'><div class='widget LinkList' data-version='1' id='LinkList110'>
<div class='widget-content'>
<ul id='nav' itemscope='' itemtype='https://schema.org/SiteNavigationElement'>
<li itemprop='name'><a href='https://www.linuxuprising.com/search/label/news?max-results=12' itemprop='url'>News</a></li>
<li itemprop='name'><a href='https://www.linuxuprising.com/search/label/apps?max-results=12' itemprop='url'>Applications</a></li>
<li itemprop='name'><a href='https://www.linuxuprising.com/search/label/how-to?max-results=12' itemprop='url'>How To</a></li>
<li itemprop='name'><a href='https://www.linuxuprising.com/search/label/tweaks?max-results=12' itemprop='url'>Tweaks</a></li>
<li itemprop='name'><a href='https://www.linuxuprising.com/search/label/customization?max-results=12' itemprop='url'>Themes & More</a></li>
<li itemprop='name'><a href='https://www.linuxuprising.com/search/label/console?max-results=12' itemprop='url'>Console</a></li>
</ul>
</div>
</div></div>
</div>
</div>
</div>
</nav>
<div class='clear'></div>
<div class='row' id='content-wrapper'>
<div id='main-wrapper'>
<div id='ads-blog'>
<div class='home-ad no-items section' id='ads-home' name='Ads Home/Post (728x90)'>
</div>
</div>
<div class='main section' id='main' name='Main Wrapper'><div class='widget Blog' data-version='1' id='Blog1'>
<div class='blog-posts hfeed'>
<div class='post-outer' id='post-outer'>
<div class='post' id='post-article'>

    <div itemprop='blogPost' itemscope='itemscope' itemtype='https://schema.org/Article'>
            <meta content='data:post.link : data:post.url' itemType='https://schema.org/WebPage' itemid='' itemprop='mainEntityOfPage' itemscope='itemscope'/>
<div itemprop='publisher' itemscope='itemscope' itemtype='https://schema.org/Organization'>
<div itemprop='logo' itemscope='itemscope' itemtype='https://schema.org/ImageObject'>
<meta content='https://4.bp.blogspot.com/-OlFvIO7s2mM/WrzEk1hCVZI/AAAAAAAAAE0/H4meMs7XreskNd_mTgVtNREkBX08-O1CACK4BGAYYCw/s590/LUR_logo1.png' itemprop='url'/>
<meta content='455' itemprop='width'/>
<meta content='48' itemprop='height'/>
</div>
<meta content='Linux Uprising Blog' itemprop='name'/>
</div>
<meta content='https://1.bp.blogspot.com/-jnAyCx9vh-o/XS33JinfIZI/AAAAAAAADDU/39vv7aGwDKMl2O1aeMJV8cofz7VNXINygCLcBGAs/s640/rclonetray.png' itemprop='image'/>
<div class='post-header'>
<ins class='adsbygoogle responsive_1' data-ad-client='ca-pub-1997822342415050' data-ad-slot='5867515603' style='display:inline-block;'></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
<br/><br/>
<div class='post-head'><h1 class='post-title entry-title' id='entry-title' itemprop='name headline'>
RcloneTray: Easily Mount Rclone Remotes On Demand Using A GUI
</h1></div>
<div class='post-meta'>
<span class='post-author vcard'>
<i class='fa fa-user'></i>
<span class='fn' itemprop='author' itemscope='itemscope' itemtype='https://schema.org/Person'>
<meta content='https://www.blogger.com/profile/03026963810377267607' itemprop='url'/>
<a class='g-profile' href='https://www.blogger.com/profile/03026963810377267607' rel='author' title='Logix'>
<span itemprop='name'>Logix</span>
</a>
</span>
</span>
<span class='post-timestamp'>
<i class='fa fa-clock-o'></i>
<meta content='https://www.linuxuprising.com/2019/07/rclonetray-easily-mount-rclone-remotes.html' itemprop='url'/>
          Updated on <a class='timestamp-link' href='https://www.linuxuprising.com/2019/07/rclonetray-easily-mount-rclone-remotes.html' rel='bookmark' title='permanent link'><time class='updated timeago' datetime='2019-07-16T17:20:55Z' title='2019-07-16T17:20:55Z'><span id='updatedateinfo'>2019-07-16T17:20:55Z</span></time></a>
<script>
            var dates = "2019-07-16T17:20:55Z"
            var dateu = new Date(dates);
            var months = ["January","February","March","April","May","June","July","August","September","October","November","December"];
            document.getElementById("updatedateinfo").innerHTML = months[dateu.getMonth()] + " " + dateu.getDate() + ", " + dateu.getFullYear();
        </script>
<meta content='2019-07-16T17:20:55Z' itemprop='dateModified'/>
<meta content='2019-07-16T18:17:00+01:00' itemprop='datePublished'/>
</span>
<span class='label-head'>
<i class='fa fa-folder-open-o'></i>
<a href='https://www.linuxuprising.com/search/label/apps?max-results=12' rel='tag'>apps</a>,
<a href='https://www.linuxuprising.com/search/label/cloud?max-results=12' rel='tag'>cloud</a>,
<a href='https://www.linuxuprising.com/search/label/rclone?max-results=12' rel='tag'>rclone</a>
</span>
</div>
<div class='ads-posting'>
<a name='ad-post'></a>
</div>
</div>
<article>
<div class='post-body entry-content' id='post-body-2980370474628936728' itemprop='articleBody'>
<meta content=' RcloneTray  is a GUI for Rclone , the &quot;rsync for cloud storage&quot; command line tool, which runs on Windows, Mac and Linux. Using th...' name='twitter:description'/>
<div class="separator" style="clear: both; text-align: center;"><a href="https://1.bp.blogspot.com/-jnAyCx9vh-o/XS33JinfIZI/AAAAAAAADDU/39vv7aGwDKMl2O1aeMJV8cofz7VNXINygCLcBGAs/s1600/rclonetray.png" imageanchor="1" style="margin-left: 1em; margin-right: 1em;"><img alt="RcloneTray" border="0" data-original-height="629" data-original-width="1034" height="388" src="https://1.bp.blogspot.com/-jnAyCx9vh-o/XS33JinfIZI/AAAAAAAADDU/39vv7aGwDKMl2O1aeMJV8cofz7VNXINygCLcBGAs/s640/rclonetray.png" title="RcloneTray" width="640" /></a></div><br />
<b><a href="https://github.com/dimitrov-adrian/RcloneTray" target="_blank">RcloneTray</a> is a GUI for <a href="https://rclone.org/" target="_blank">Rclone</a>, the "rsync for cloud storage" command line tool, which runs on Windows, Mac and Linux. Using this Electron tray application, you'll be able to quickly mount Rclone remotes, open the mount location using your default file manager, and perform other operations.</b><br />
<br />
Rclone can synchronize files from your filesystem from/to cloud storage services like Google Drive, Microsoft OneDrive, Nextcloud, Yandex Disk, Dropbox, Amazon Drive and S3, Mega, pCloud, and others (and having WebDAV, FTP and SFTP support), as well as directly between cloud storage services. It also supports mounting these cloud storage services so you can access your files using desktop applications.<br />
<br />
RcloneTray lists all your Rclone remotes in its tray menu, each remote having a separate submenu that varies with each storage service. <br />
<a name='more'></a><br />
<b>You have the option of mounting any remote you've previously configured using Rclone, from the RcloneTray menu</b>, be it some cloud storage provider, WebDAV, SFTP, etc., as well as opening it using your default file manager. For some remotes (Google Drive and Dropbox for example) though, it may say "Open in Finder" even though it's running on Linux; this is just a display bug and it does open the location using your default Linux file manager. To indicate when a remote is mounted, the circle shown to the left of the remote name fills up.<br />
<br />
<b>On some remotes</b> (this option is available for Google Drive and Dropbox remotes, but not for OneDrive for example) <b>you also have the option of downloading the whole remote contents to your filesystem for offline use, and uploading all the files copied to the folder mapped to the remote cloud storage server</b>.<br />
<br />
From the RcloneTray menu <b>you also get quick access to Rclone's ncdu </b>(not to be confused with <a href="https://dev.yorhel.nl/ncdu" target="_blank">ncdu</a> itself, this is only for rclone)<b>, an interactive, text-based user interface for the console, which allows the navigation of a remote</b>, showing the used space. This command line tool is missing quite a few features right now, but it's still quite useful already. To enable the Console Browser option (this is how Rclone's ncdu is shown in the RcloneTray menu), you'll need to open the RcloneTray settings, go to the NCDU tab and enable it from there.<br />
<br />
<b>Other RcloneTray features:</b><br />
<br />
<ul><li><b>Option to create a new "bookmark" (this is called "remote" in Rclone) which lists all available providers, and then shows all the options available for that provider. You may also use this to edit existing remotes/providers</b></li>
<li><b>Optional serving via HTTP, FTP, Restic and WebDAV (needs to be enabled in the RcloneTray preferences). This seems broken in RcloneTray when using recent rclone versions (bug reported)</b></li>
<li><b>Comes with bundled Rclone binary, and it uses this by default, but it has an option to disable the bundled Rclone and use the system one. You can <a href="https://rclone.org/downloads/" target="_blank">download Rclone</a> from its website</b></li>
<li><b>Specify custom Rclone configuration file path and args</b></li>
</ul><br />
<table align="center" cellpadding="0" cellspacing="0" class="tr-caption-container" style="margin-left: auto; margin-right: auto; text-align: center;"><tbody>
<tr><td style="text-align: center;"><a href="https://1.bp.blogspot.com/-EmXtB5psq_8/XS33vF9BhTI/AAAAAAAADDc/YkIgPTUp9DMPFE5ZaK3e21vmNTRP5OdUwCLcBGAs/s1600/rclone-tray-add-new-service.png" imageanchor="1" style="margin-left: auto; margin-right: auto;"><img border="0" data-original-height="713" data-original-width="665" height="640" src="https://1.bp.blogspot.com/-EmXtB5psq_8/XS33vF9BhTI/AAAAAAAADDc/YkIgPTUp9DMPFE5ZaK3e21vmNTRP5OdUwCLcBGAs/s640/rclone-tray-add-new-service.png" width="595" /></a></td></tr>
<tr><td class="tr-caption" style="text-align: center;">The RcloneTray "Create new Bookmark" dialog, which can also be used to edit an existing "bookmark" (called "remote" in Rclone)</td></tr>
</tbody></table><br />
<br />
I personally find it easier to add a new remote to Rclone from the command line (run <span class="codeblock2"><code>rclone config</code></span> in a console and follow the setup wizard - for example see how to <a href="https://www.linuxuprising.com/2018/07/how-to-mount-onedrive-in-linux-using.html">configure and mount Microsoft OneDrive using Rclone</a>) than using the RcloneTray option to add a new bookmark. What's more, the authorization link did not open automatically in my web browser when I tried to setup a new remote/provider using the RcloneTray new bookmark option.<br />
<br />
RcloneTray was created as a free alternative to <a href="https://mountainduck.io/" target="_blank">Mountain Duck</a>, a tray application for mounting your server or cloud storage as a disk in Finder on macOS and File Explorer on Windows, using <a href="https://cyberduck.io/" target="_blank">Cyberduck</a> for the synchronization work. RcloneTray is free and open source software, and it does allow mounting cloud storages easily from a tray menu not only on Windows and macOS, but also on Linux, but it lacks some important Mountain Duck features. This includes synchronizing files to your local disk when opened, select which files and folders to have offline (RcloneTray allows downloading all files only), file manager integration, and more.<br />
<br />
This should be obvious, but I guess I should still mention it - to work, RcloneTray needs a working system tray. On Gnome Shell you can use the <a href="https://extensions.gnome.org/extension/615/appindicator-support/" target="_blank">AppIndicator Support</a> extension (installed and enabled by default on Ubuntu).<br />
<br />
<h2>Download and usage</h2><br />
<br />
<div style="text-align: center;"><a href="https://github.com/dimitrov-adrian/RcloneTray/releases" rel="noopener" target="_blank"><input class="install" title="Download RcloneTray for Windows, Mac or Linux" type="button" value="Download RcloneTray" /></a></div><br />
<b>The downloads page has RcloneTray binaries for Windows, Mac and Linux (AppImage and DEB). </b>Users running Debian, Ubuntu, Linux Mint, Pop!_OS or any other Linux distribution based on Debian or Ubuntu should use the DEB package. <br />
<br />
To run the RcloneTray AppImage binary you'll need to make it executable: <span class="codeblock2"><code>right click -&gt; Properties -&gt; Permissions -&gt; Allow executing file as program</code></span> (or similar; this depends on your file manager). Now if your desktop environment / file manager allows it, double click the <span class="codeblock2"><code>rclonetray-1.0.0-x86_64.AppImage</code></span> file to run it. On desktop environments which don't allow double clicking AppImage files to run them, open a terminal and drag'n'drop the <span class="codeblock2"><code>rclonetray-1.0.0-x86_64.AppImage</code></span> file onto the terminal window, then press <span class="codeblock2"><code>Enter</code></span>. You may also type <span class="codeblock2"><code>./rclonetray-1.0.0-x86_64.AppImage</code></span> from the folder where the AppImage is located in.<br />
<br />
<table align="center" cellpadding="0" cellspacing="0" class="tr-caption-container" style="margin-left: auto; margin-right: auto; text-align: center;"><tbody>
<tr><td style="text-align: center;"><a href="https://1.bp.blogspot.com/-23ggPgeZWe8/XS35sWL9H9I/AAAAAAAADDo/QaPQuwuWrJMDSDx7spH6cGVk1FLxwrwMQCLcBGAs/s1600/rclonetray-directory-mapping.png" imageanchor="1" style="margin-left: auto; margin-right: auto;"><img border="0" data-original-height="406" data-original-width="668" src="https://1.bp.blogspot.com/-23ggPgeZWe8/XS35sWL9H9I/AAAAAAAADDo/QaPQuwuWrJMDSDx7spH6cGVk1FLxwrwMQCLcBGAs/s1600/rclonetray-directory-mapping.png" /></a></td></tr>
<tr><td class="tr-caption" style="text-align: center;">Mapping a local directory to a remote host</td></tr>
</tbody></table><br />
<b>As soon as you start RcloneTray it should show your existing remotes (OneDrive, Google Drive, etc.) in its menu, but to be able to mount them, make sure they have a local directory mapping.</b> You can check / add this from RcloneTray: <span class="codeblock2"><code>remote submenu -&gt; Edit -&gt; Mappings -&gt; Local Path</code></span> (remember to click <span class="codeblock2"><code>Save</code></span> after mapping a local path to a remote).<br />
<br />
It should be noted that the option to run RcloneTray to startup doesn't seem to work on Linux. On my Ubuntu 19.04 desktop, the option of launching the application on startup failed to launch the app (or even get the option to remain enabled) using both the DEB and AppImage binaries (and this is expected for the AppImage but not for the DEB package). It's still possible to add it to your startup applications.<br />
<br />
Add it to startup on desktops that have a Startup Applications tool (or equivalent) by using the following as command for the package installed as DEB: <span class="codeblock2"><code>/opt/RcloneTray/rclonetray</code></span>, and the exact path to the binary (including the filename) if you're using the AppImage.<br />
<br />
You can also add it to startup manually, by creating a file called <span class="codeblock2"><code>rclonetray.desktop</code></span> in <span class="codeblock2"><code>~/.config/autostart/</code></span> with the following contents:<br />
<br />
<pre class="codeblocktall"><code>[Desktop Entry]
Type=Application
Exec=PATH-TO-EXECUTABLE
Hidden=false
NoDisplay=false
X-GNOME-Autostart-enabled=true
Name=Rclone Tray</code></pre><br />
Replacing <span class="codeblock2"><code>PATH-TO-EXECUTABLE</code></span> with the path to the RcloneTray executable (<span class="codeblock2"><code>/opt/RcloneTray/rclonetray</code></span> if installed from DEB, or wherever you've saved the AppImage if that's what you want to use).
</div>
</article>
<div style='clear:both'></div>
<div class='post-footer'>
<div class='share-box'>
<h8 class='share-title'>Share This:</h8>
<div class='share-art'>
<a class='fac-art' href='https://www.facebook.com/sharer.php?u=https://www.linuxuprising.com/2019/07/rclonetray-easily-mount-rclone-remotes.html&title=RcloneTray: Easily Mount Rclone Remotes On Demand Using A GUI' onclick='window.open(this.href, &#39;windowName&#39;, &#39;width=600, height=400, left=24, top=24, scrollbars, resizable&#39;); return false;' rel='nofollow noreferrer' target='_blank' title='Facebppl'><i class='fa fa-facebook'></i><span class='resp_del'> Facebook</span></a>
<a class='twi-art' href='https://twitter.com/share?url=https://www.linuxuprising.com/2019/07/rclonetray-easily-mount-rclone-remotes.html&title=RcloneTray: Easily Mount Rclone Remotes On Demand Using A GUI' onclick='window.open(this.href, &#39;windowName&#39;, &#39;width=600, height=400, left=24, top=24, scrollbars, resizable&#39;); return false;' rel='nofollow noreferrer' target='_blank' title='Twitter'><i class='fa fa-twitter'></i><span class='resp_del2'> Twitter</span></a>
<a class='dis-art' href='https://sharetodiaspora.github.io/?url=https://www.linuxuprising.com/2019/07/rclonetray-easily-mount-rclone-remotes.html&title=RcloneTray: Easily Mount Rclone Remotes On Demand Using A GUI' onclick='window.open(this.href, &#39;windowName&#39;, &#39;width=770, height=500, left=24, top=24, scrollbars, resizable&#39;); return false;' rel='nofollow noreferrer' target='_blank' title='Diaspora'><i class='fa fa-diaspora'></i><span class='resp_del3'> Diaspora</span></a>
<a class='redd-art' href='https://www.reddit.com/submit?url=https://www.linuxuprising.com/2019/07/rclonetray-easily-mount-rclone-remotes.html&title=RcloneTray: Easily Mount Rclone Remotes On Demand Using A GUI' onclick='window.open(this.href, &#39;windowName&#39;); return false;' rel='nofollow noreferrer' target='_blank' title='Reddit'><i class='fa fa-reddit-alien'></i><span class='resp_del4'> Reddit</span></a>
<a class='tel-art' href='https://telegram.me/share/url?text=RcloneTray: Easily Mount Rclone Remotes On Demand Using A GUI&tags=&url=https://www.linuxuprising.com/2019/07/rclonetray-easily-mount-rclone-remotes.html' onclick='window.open(this.href, &#39;windowName&#39;, &#39;width=600, height=400, left=24, top=24, scrollbars, resizable&#39;); return false;' rel='nofollow noreferrer' target='_blank' title='Telegram'><i class='fa fa-telegram'></i><span class='resp_del5'> Telegram</span></a>
<a class='wat-art' data-action='share/whatsapp/share' href='whatsapp://send?text=RcloneTray: Easily Mount Rclone Remotes On Demand Using A GUI https://www.linuxuprising.com/2019/07/rclonetray-easily-mount-rclone-remotes.html' onclick='window.open(this.href, &#39;windowName&#39;, &#39;width=600, height=400, left=24, top=24, scrollbars, resizable&#39;); return false;' rel='nofollow noreferrer' target='_blank' title='WhatsApp'><i class='fa fa-whatsapp'></i><span class='resp_del6'> WhatsApp</span></a>
</div>
</div>
<div style='clear:both'></div>
<div class='ads-post'>
<a name='ads-post-in'></a>
</div>
<div id='related-posts'>
rclone
</div>
<div class='clear'></div>
<div class='comment-notif-box'>Please post civil and on-topic comments. <a href='https://www.linuxuprising.com/p/commenting-guidelines.html' rel='nofollow' target='_blank'>Commenting guidelines</a>.</div>
</div>
<div id='disqus_thread_load_on_scroll'>
<div id='disqus_empty' style='display: none'>Empty</div>
</div>

      </div>
    
</div>
<div class='comments' id='comments'>
<a name='comments'></a>
<div id='backlinks-container'>
<div id='Blog1_backlinks-container'>
</div>
</div>
</div>
</div>
</div>
<div class='post-feeds'>
</div>
</div></div>
<div id='ads-post10'>
<div class='no-items section' id='ads-post-468' name='ADS Inner Footer 728x90'>
</div>
</div>
</div>
<div class='sidebar-wrapper' id='sidebar-wrapper'>
<div class='sidebar section' id='sidebar' name='Sidebar Right'><div class='widget HTML' data-version='1' id='HTML6'>
<script type='text/javascript'>
var disqus_shortname = 'linuxuprising';
var disqus_blogger_current_url = "https://www.linuxuprising.com/2019/07/rclonetray-easily-mount-rclone-remotes.html";
var disqus_title = "RcloneTray: Easily Mount Rclone Remotes On Demand Using A GUI - Linux Uprising Blog"; 
if (!disqus_blogger_current_url.length) {
disqus_blogger_current_url = "https://www.linuxuprising.com/2019/07/rclonetray-easily-mount-rclone-remotes.html";
}
var disqus_blogger_homepage_url = "https://www.linuxuprising.com/";
var disqus_blogger_canonical_homepage_url = "https://www.linuxuprising.com/";
</script>
<script>
var disqus_loaded = false;
function load_disqus( disqus_shortname ) {
  // Prepare the trigger and target

  var is_disqus_empty = document.getElementById('disqus_empty'),
      disqus_target   = document.getElementById('disqus_thread_load_on_scroll'),
      disqus_embed    = document.createElement('script'),
      disqus_hook     = (document.getElementsByTagName('head')[0] || document.getElementsByTagName('body')[0]);

  // Load script asynchronously only when the trigger and target exist
  if( disqus_target && is_disqus_empty ) {
    disqus_loaded = true;
    disqus_embed.type = 'text/javascript';
    disqus_embed.async = true;
    disqus_embed.src = '//' + disqus_shortname + '.disqus.com/blogger_item.js';
    disqus_hook.appendChild(disqus_embed);
    is_disqus_empty.remove();
  }
}

window.addEventListener('scroll', function(e) {
  var currentScroll = document.scrollingElement.scrollTop;
  var disqus_target = document.getElementById('disqus_thread_load_on_scroll');

  if( currentScroll > disqus_target.getBoundingClientRect().top - 150 ) {
    if (disqus_loaded==false) {
      load_disqus('linuxuprising');
    };
  }
}, false);

(function($){
    setInterval(() => {
        $.each($('iframe'), (arr,x) => {
            let src = $(x).attr('src');
            if (src && src.match(/(ads-iframe)|(disqusads)/gi)) {
                $(x).remove();
            }
        });
    }, 300);
})(jQuery);
</script>
</div><div class='widget HTML' data-version='1' id='HTML1'>
<div class='widget-content'>
<div class="imagehere"><!-- Top Right Sidebar 300x250 -->
<ins class="adsbygoogle"
     style="display:inline-block;width:300px;height:250px"
     data-ad-client="ca-pub-1997822342415050"
     data-ad-slot="8358301820"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div>

<script type="text/javascript">
//<![CDATA[
$(window).load(function(){null==document.getElementsByTagName("iframe").item(ga.length-1)&&$("div.imagehere").html("<a href='https://www.linuxuprising.com/2019/04/join-uprising.html' rel='nofollow noopener'><img src='https://4.bp.blogspot.com/-RM33YT7JTCw/XOVA0YwyKxI/AAAAAAAACyo/lA22C-cphP87WD39N4_9SJ-qG5b21IORgCLcBGAs/s1600/join-the-uprising.png' alt='Join the Uprising'/></a><br/>")});
//]]> 
</script>
</div>
</div><div class='widget HTML' data-version='1' id='HTML2'>
<h2 class='title'>Recent Posts</h2>
<div id='RecentPosts'>
<div class='widget-content'>
recentposts
</div>
</div>
</div><div class='widget HTML' data-version='1' id='HTML3'>
<div class='widget-content'>
<!-- Sidebar right 300x600 -->
<ins class="adsbygoogle"
     style="display:inline-block;width:300px;height:600px"
     data-ad-client="ca-pub-1997822342415050"
     data-ad-slot="6174183113"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
</div><div class='widget ContactForm' data-version='1' id='ContactForm1'>
</div><div class='widget LinkList' data-version='1' id='LinkList2'>
<h2>Editor's Picks</h2>
<div class='widget-content'>
<ul>
<li><a href='https://www.linuxuprising.com/2018/07/anbox-how-to-install-google-play-store.html'>Anbox: How To Install Google Play Store And Enable ARM (libhoudini) Support, The Easy Way</a></li>
<li><a href='https://www.linuxuprising.com/2018/07/how-to-mount-onedrive-in-linux-using.html'>How To Mount OneDrive In Linux Using Rclone (Supports Business And Personal Accounts)</a></li>
<li><a href='https://www.linuxuprising.com/2018/06/how-to-install-davinci-resolve-15-in.html'>How To Install DaVinci Resolve 16 Or 15 In Ubuntu, Linux Mint Or Debian (Generate DEB Package)</a></li>
<li><a href='https://www.linuxuprising.com/2019/03/control-android-devices-from-your.html'>Control Android Devices From A Desktop With scrcpy (Ubuntu, Fedora, Debian, Linux Mint Installation)</a></li>
<li><a href='https://www.linuxuprising.com/2019/02/how-to-create-fillable-pdf-forms-with.html'>How To Create Fillable PDF Forms With LibreOffice Writer</a></li>
<li><a href='https://www.linuxuprising.com/2018/10/how-to-encrypt-usb-drive-with-veracrypt.html'>How To Encrypt An USB Drive With VeraCrypt (Compatible With Windows, macOS and Linux)</a></li>
<li><a href='https://www.linuxuprising.com/2018/11/how-to-use-dropbox-on-non-ext4.html'>How To Use Dropbox On Non-Ext4 Filesystems (Btrfs, Ext3, XFS, ZFS, Etc.) On Linux</a></li>
<li><a href='https://www.linuxuprising.com/2018/12/pdfarranger-merge-split-rotate-crop-or.html'>PDFArranger: Merge, Split, Rotate, Crop Or Rearrange PDF Documents (PDF-Shuffler Fork)</a></li>
<li><a href='https://www.linuxuprising.com/2019/03/how-to-install-oracle-java-12-jdk-12-in.html'>How To Install Oracle Java 12 (JDK 12) In Ubuntu, Linux Mint Or Debian (Using PPA)</a></li>
<li><a href='https://www.linuxuprising.com/2019/03/create-persistent-storage-live-usb-with.html'>Create A Persistent Storage Live USB With Ubuntu, Linux Mint Or Debian (UEFI, >4GB Persistance Support)</a></li>
</ul>
</div>
</div></div>
</div>
<div class='clear'></div>
</div>
<!-- end content-wrapper -->
<div class='clear'></div><!-- Footer wrapper -->
<div id='footer-wrapper'>
<div id='footer'>
<div class='footer-sections row' id='footer-sections'>
<div class='sect-left section' id='footer-sec1' name='Widget 1'><div class='widget LinkList' data-version='1' id='LinkList1'>
<h2>Linux Uprising</h2>
<div class='widget-content'>
<ul>
<li><a href='https://www.linuxuprising.com/p/contact.html'>Contact</a></li>
<li><a href='https://www.linuxuprising.com/p/about.html'>About</a></li>
<li><a href='https://www.linuxuprising.com/p/terms-of-use.html'>Terms of Service</a></li>
<li><a href='https://www.linuxuprising.com/p/cookie-policy.html'>Cookie Information</a></li>
<li><a href='https://www.linuxuprising.com/p/privacy-policy.html'>Privacy Policy</a></li>
</ul>
</div>
</div></div>
<div class='sect-left section' id='footer-sec2' name='Widget 2'><div class='widget FollowByEmail' data-version='1' id='FollowByEmail1'>
<h2 class='title'>Follow by Email</h2>
<div class='widget-content'>
<div class='follow-by-email-inner'>
<form action='https://feedburner.google.com/fb/a/mailverify' method='post' onsubmit='window.open("https://feedburner.google.com/fb/a/mailverify?uri=LinuxUprising", "popupwindow", "scrollbars=yes,width=550,height=520"); return true' target='popupwindow'>
<table width='100%'>
<tr>
<td>
<label for='email'><input aria-label='email' class='follow-by-email-address' id='email' name='email' placeholder='Email address...' type='text'/></label>
</td>
<td width='64px'>
<input class='follow-by-email-submit' type='submit' value='Submit'/>
</td>
</tr>
</table>
<input name='uri' type='hidden' value='LinuxUprising'/>
<input name='loc' type='hidden' value='en_US'/>
</form>
</div>
</div>
<span class='item-control blog-admin'>
</span>
</div></div>
<div class='sect-left section' id='footer-sec3' name='Widget 3'><div class='widget BlogArchive' data-version='1' id='BlogArchive2'>
<h2>Blog Archive</h2>
<div class='widget-content'>
<div id='ArchiveList'>
<div id='BlogArchive2_ArchiveList'>
<label aria-label='archive-menu' for='BlogArchive2_ArchiveMenu'>
<select id='BlogArchive2_ArchiveMenu'>
<option value=''>Blog Archive</option>
<option value='https://www.linuxuprising.com/2019/07/'>July 2019 (12)</option>
<option value='https://www.linuxuprising.com/2019/06/'>June 2019 (18)</option>
<option value='https://www.linuxuprising.com/2019/05/'>May 2019 (19)</option>
<option value='https://www.linuxuprising.com/2019/04/'>April 2019 (20)</option>
<option value='https://www.linuxuprising.com/2019/03/'>March 2019 (16)</option>
<option value='https://www.linuxuprising.com/2019/02/'>February 2019 (17)</option>
<option value='https://www.linuxuprising.com/2019/01/'>January 2019 (21)</option>
<option value='https://www.linuxuprising.com/2018/12/'>December 2018 (15)</option>
<option value='https://www.linuxuprising.com/2018/11/'>November 2018 (24)</option>
<option value='https://www.linuxuprising.com/2018/10/'>October 2018 (22)</option>
<option value='https://www.linuxuprising.com/2018/09/'>September 2018 (15)</option>
<option value='https://www.linuxuprising.com/2018/08/'>August 2018 (27)</option>
<option value='https://www.linuxuprising.com/2018/07/'>July 2018 (26)</option>
<option value='https://www.linuxuprising.com/2018/06/'>June 2018 (21)</option>
<option value='https://www.linuxuprising.com/2018/05/'>May 2018 (31)</option>
<option value='https://www.linuxuprising.com/2018/04/'>April 2018 (25)</option>
<option value='https://www.linuxuprising.com/2018/03/'>March 2018 (1)</option>
</select>
</label>
</div>
</div>
</div>
</div></div>
</div>
</div>
<div class='clear'></div>
<div class='footer-wrapper'>
<div class='footer-sec row'>
<!-- Footer Social -->
<div class='social-footer section' id='social-footer' name='Social Footer'><div class='widget LinkList' data-version='1' id='LinkList20'>
<div class='widget-content'>
<ul>
<li><a class='rss' href='https://feeds.feedburner.com/LinuxUprising' rel='noreferrer' target='_blank' title='rss'></a></li>
<li><a class='friendica' href='https://libranet.de/profile/linuxuprising' rel='noreferrer' target='_blank' title='friendica'></a></li>
<li><a class='twitter' href='https://twitter.com/linuxuprising' rel='noreferrer' target='_blank' title='twitter'></a></li>
<li><a class='telegram' href='https://t.me/LinuxUprising' rel='noreferrer' target='_blank' title='telegram'></a></li>
<li><a class='facebook' href='https://www.facebook.com/LinuxUprising/' rel='noreferrer' target='_blank' title='facebook'></a></li>
<li><a class='reddit' href='https://www.reddit.com/r/LinuxUprising/' rel='noreferrer' target='_blank' title='reddit'></a></li>
</ul>
</div>
</div></div>
<!-- Footer Copyright -->
<div class='copyright'>
License: <a href='https://creativecommons.org/licenses/by-nc/4.0/' rel='license nofollow noreferrer' target='_blank'>CC BY-NC 4.0</a>
<a href='https://www.linuxuprising.com'>Linux Uprising</a>. <br/>The registered trademark Linux&#174; is used pursuant to a sublicense from the Linux Foundation, the exclusive licensee of Linus Torvalds, owner of the mark on a world&#173;wide basis.
</div>
</div>
</div>
</div>
<script type='text/javascript'>    
//<![CDATA[

$(document).ready((function() {
    $('pre.cssterm','#post-article').each((function() {
        $(this).attr('title','Triple click to select a complete line!');
    }));
}));

            // Lazyload
            (function(a){a.fn.lazyload=function(b){var c={threshold:0,failurelimit:0,event:"scroll",effect:"show",container:window};if(b){a.extend(c,b)}var d=this;if("scroll"==c.event){a(c.container).bind("scroll",function(b){var e=0;d.each(function(){if(a.abovethetop(this,c)||a.leftofbegin(this,c)){}else if(!a.belowthefold(this,c)&&!a.rightoffold(this,c)){a(this).trigger("appear")}else{if(e++>c.failurelimit){return false}}});var f=a.grep(d,function(a){return!a.loaded});d=a(f)})}this.each(function(){var b=this;if(undefined==a(b).attr("original")){a(b).attr("original",a(b).attr("src"))}if("scroll"!=c.event||undefined==a(b).attr("src")||c.placeholder==a(b).attr("src")||a.abovethetop(b,c)||a.leftofbegin(b,c)||a.belowthefold(b,c)||a.rightoffold(b,c)){if(c.placeholder){a(b).attr("src",c.placeholder)}else{a(b).removeAttr("src")}b.loaded=false}else{b.loaded=true}a(b).one("appear",function(){if(!this.loaded){a("<img />").bind("load",function(){a(b).hide().attr("src",a(b).attr("original"))[c.effect](c.effectspeed);b.loaded=true}).attr("src",a(b).attr("original"))}});if("scroll"!=c.event){a(b).bind(c.event,function(c){if(!b.loaded){a(b).trigger("appear")}})}});a(c.container).trigger(c.event);return this};a.belowthefold=function(b,c){if(c.container===undefined||c.container===window){var d=a(window).height()+a(window).scrollTop()}else{var d=a(c.container).offset().top+a(c.container).height()}return d<=a(b).offset().top-c.threshold};a.rightoffold=function(b,c){if(c.container===undefined||c.container===window){var d=a(window).width()+a(window).scrollLeft()}else{var d=a(c.container).offset().left+a(c.container).width()}return d<=a(b).offset().left-c.threshold};a.abovethetop=function(b,c){if(c.container===undefined||c.container===window){var d=a(window).scrollTop()}else{var d=a(c.container).offset().top}return d>=a(b).offset().top+c.threshold+a(b).height()};a.leftofbegin=function(b,c){if(c.container===undefined||c.container===window){var d=a(window).scrollLeft()}else{var d=a(c.container).offset().left}return d>=a(b).offset().left+c.threshold+a(b).width()};a.extend(a.expr[":"],{"below-the-fold":"$.belowthefold(a, {threshold : 0, container: window})","above-the-fold":"!$.belowthefold(a, {threshold : 0, container: window})","right-of-fold":"$.rightoffold(a, {threshold : 0, container: window})","left-of-fold":"!$.rightoffold(a, {threshold : 0, container: window})"})})(jQuery);$(function(){$("img").lazyload({placeholder:"https://1.bp.blogspot.com/-zfTgNA4ZsX0/XR0aQA2GyiI/AAAAAAAADAA/JOjs9ZVsMvA7aIt4bXkH5AqiJK_xkIDUwCLcBGAs/s1600/pixel.gif",effect:"fadeIn",threshold:"-50"})});

$("#related-posts").each((function() {
    var g = $(this).html();
    var title = $("#entry-title").text().trim();
    $.ajax({
        url: "/feeds/posts/default/-/" + g + "?alt=json-in-script&max-results=" + related_number,
        type: 'get',
        cache: true,
        dataType: "jsonp",
        success: function(data) {
            var posturl = "";
            var htmlcode = '<div class="related"><ul>';
            for (var i = 0; i < data.feed.entry.length; i++) {
              var s = data.feed.entry[i].title.$t.trim();
              if (s !== title) {
                for (var j = 0; j < data.feed.entry[i].link.length; j++) {
                    if (data.feed.entry[i].link[j].rel == "alternate") {
                            posturl = data.feed.entry[i].link[j].href;
                            break
                    }
                }

                var posttitle = data.feed.entry[i].title.$t;

                if (!data.feed.entry[i].media$thumbnail) {
                    var thumb = '<a title="' + posttitle +'" class="related-img" href="' + posturl + '" style="background:url(' + no_image_url + ') no-repeat center center;background-size: cover"/>'                
                } else {
                    var src = data.feed.entry[i].media$thumbnail.url.split(/s72-c/).join("s320");
                    var thumb = '<a title="' + posttitle +'" class="related-img" href="' + posturl + '" style="background:url(' + src + ') no-repeat center center;background-size: cover"/>'                
                }

                htmlcode += '<li><div class="related-thumb">' + thumb + '</div><h3 class="related-title"><a href="' + posturl + '">' + posttitle + '</a></h3></li>'
            }
            }
            htmlcode += '</ul></div><div class="clear"/>';
            $("#related-posts").html(htmlcode);


        }
    })
}));

//]]>
</script>
<script type='text/javascript'>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</script>
</div>
<script type='text/javascript'>
!function(e,n,t){"use strict";var o="https://cdn.jsdelivr.net/npm/fork-awesome@1.1.3/css/fork-awesome.min.css",r="__3perf_googleFonts_dcfa3";function c(e){(n.head||n.body).appendChild(e)}function a(){var e=n.createElement("link");e.href=o,e.rel="stylesheet",c(e)}function f(e){if(!n.getElementById(r)){var t=n.createElement("style");t.id=r,c(t)}n.getElementById(r).innerHTML=e}e.FontFace&&e.FontFace.prototype.hasOwnProperty("display")?(t[r]&&f(t[r]),fetch(o).then(function(e){return e.text()}).then(function(e){return e.replace(/@font-face{/g,"@font-face{font-display:swap;")}).then(function(e){return e.replace(/\.\.\/fonts\//g,"https:\/\/cdn\.jsdelivr\.net\/npm\/fork-awesome@1\.1\.3\/fonts\/")}).then(function(e){return t[r]=e}).then(f).catch(a)):a()}(window,document,localStorage);
</script>
<noscript><link href='https://cdn.jsdelivr.net/npm/fork-awesome@1.1.3/css/fork-awesome.min.css' rel='stylesheet'/></noscript>
<div class='back-to-top'>
<a href='#' id='back-to-top' title='back to top'>
<i class='fa fa-long-arrow-up'></i>
</a>
</div>

<script type="text/javascript" src="https://www.blogger.com/static/v1/widgets/1501421786-widgets.js"></script>
<script type='text/javascript'>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</script>
</body>
</html>