<!DOCTYPE html>
<html dir='ltr' lang='en-US' xmlns='http://www.w3.org/1999/xhtml' xmlns:b='http://www.google.com/2005/gml/b' xmlns:data='http://www.google.com/2005/gml/data' xmlns:expr='http://www.google.com/2005/gml/expr'>
<head><!--[if IE]><script type="text/javascript" src="https://www.blogger.com/static/v1/jsbin/3382421118-ieretrofit.js"></script> <![endif]-->
<meta charset='utf-8'/>
<meta content='en-us' http-equiv='content-language'/>
<meta content='IE=edge' http-equiv='X-UA-Compatible'/>
<meta content='width=device-width,initial-scale=1.0,minimum-scale=1.0,maximum-scale=1.0' name='viewport'/>
<meta content='#f2132d' name='theme-color'/>
<meta content='#f2132d' name='msapplication-TileColor'/>
<link href='https://3.bp.blogspot.com/-_Rvl0I-6PsE/WxqOMWBSvFI/AAAAAAAAAr0/YVpbw6VxjTE0cs2FIG3JGGrzfelqF1AXQCLcBGAs/s1600/apple-icon-180x180.png' rel='apple-touch-icon' sizes='180x180'/>
<link href='https://4.bp.blogspot.com/-C3SXpMZFwoM/WxqOMWPcqBI/AAAAAAAAAr4/q3BlIVZd9BIycvFtwpwee9ho2axmuey1wCLcBGAs/s1600/android-icon-192x192.png' rel='icon' sizes='192x192' type='image/png'/>
<link crossorigin='crossorigin' href='https://www.gstatic.com' rel='preconnect'/>
<link crossorigin='crossorigin' href='https://fonts.googleapis.com' rel='preconnect'/>
<link crossorigin='crossorigin' href='https://ajax.googleapis.com' rel='preconnect'/>
<link crossorigin='crossorigin' href='https://apis.google.com' rel='preconnect'/>
<link crossorigin='crossorigin' href='https://cdn.jsdelivr.net' rel='preconnect'/>
<link crossorigin='crossorigin' href='https://lh3.googleusercontent.com' rel='preconnect'/>
<link crossorigin='crossorigin' href='https://fonts.gstatic.com' rel='preconnect'/>
<meta content='text/html; charset=UTF-8' http-equiv='Content-Type'/>
<meta content='blogger' name='generator'/>
<link href='https://www.linuxuprising.com/favicon.ico' rel='icon' type='image/x-icon'/>
<link href='https://www.linuxuprising.com/2019/02/run-or-raise-application-windows-on.html' rel='canonical'/>
<link rel="alternate" type="application/atom+xml" title="Linux Uprising Blog - Atom" href="https://www.linuxuprising.com/feeds/posts/default" />
<link rel="alternate" type="application/rss+xml" title="Linux Uprising Blog - RSS" href="https://www.linuxuprising.com/feeds/posts/default?alt=rss" />
<link rel="service.post" type="application/atom+xml" title="Linux Uprising Blog - Atom" href="https://www.blogger.com/feeds/852161773840707483/posts/default" />

<link rel="alternate" type="application/atom+xml" title="Linux Uprising Blog - Atom" href="https://www.linuxuprising.com/feeds/887518511597864171/comments/default" />
<!--[if IE]><script type="text/javascript" src="https://www.blogger.com/static/v1/jsbin/864213505-ieretrofit.js"></script>
<![endif]-->
<link href='https://2.bp.blogspot.com/-nzijBlCm9cY/XGq1Ns7X0cI/AAAAAAAACTc/tuD_auOJhxEAs5iTf1nqg0zs8rhXRt8qQCLcBGAs/s640/jumpapp-firefox.png' rel='image_src'/>
<meta content='Run application, focus (raise) its window or cycle through its open windows using a single keyboard shortcut in Linux with jumpapp.' name='description'/>
<meta content='https://www.linuxuprising.com/2019/02/run-or-raise-application-windows-on.html' property='og:url'/>
<meta content='Run Or Raise Application Windows On Linux (X11) Using A Single Keyboard Shortcut With jumpapp' property='og:title'/>
<meta content='Run application, focus (raise) its window or cycle through its open windows using a single keyboard shortcut in Linux with jumpapp.' property='og:description'/>
<meta content='https://2.bp.blogspot.com/-nzijBlCm9cY/XGq1Ns7X0cI/AAAAAAAACTc/tuD_auOJhxEAs5iTf1nqg0zs8rhXRt8qQCLcBGAs/w1200-h630-p-k-no-nu/jumpapp-firefox.png' property='og:image'/>
<!--[if IE]> <script> (function() { var html5 = ("abbr,article,aside,audio,canvas,datalist,details," + "figure,footer,header,hgroup,mark,menu,meter,nav,output," + "progress,section,time,video").split(','); for (var i = 0; i < html5.length; i++) { document.createElement(html5[i]); } try { document.execCommand('BackgroundImageCache', false, true); } catch(e) {} })(); </script> <![endif]-->
<meta content='width=device-width, initial-scale=1, maximum-scale=1' name='viewport'/>
<link href='https://plus.google.com/+LinuxUprising' rel='publisher'/>
<meta content='https://www.facebook.com/LinuxUprising' property='article:publisher'/>
<meta content='3F3C1DB7847EE7E64E8A2F6CDC5A5F10' name='msvalidate.01'/>
<meta content='de18aa7b281bff4c' name='yandex-verification'/>
<title>
Run Or Raise Application Windows On Linux (X11) Using A Single Keyboard Shortcut With jumpapp - Linux Uprising Blog
</title>
<!-- Description and Keywords (start) -->
<meta content='en_US' property='og:locale'/>
<!-- Description and Keywords (end) -->
<meta content='article' property='og:type'/>
<meta content='Linux Uprising Blog' property='og:site_name'/>
<meta content='https://www.linuxuprising.com/' name='twitter:domain'/>
<meta content='Run Or Raise Application Windows On Linux (X11) Using A Single Keyboard Shortcut With jumpapp' name='twitter:title'/>
<meta content='summary_large_image' name='twitter:card'/>
<meta content='https://2.bp.blogspot.com/-nzijBlCm9cY/XGq1Ns7X0cI/AAAAAAAACTc/tuD_auOJhxEAs5iTf1nqg0zs8rhXRt8qQCLcBGAs/s640/jumpapp-firefox.png' name='twitter:image'/>
<meta content='Run application, focus (raise) its window or cycle through its open windows using a single keyboard shortcut in Linux with jumpapp.' name='twitter:description'/>
<!-- Social Media meta tag need customer customization -->
<meta content='572203406470374' property='fb:app_id'/>
<meta content='841352899' property='fb:admins'/>
<meta content='@linuxuprising' name='twitter:site'/>
<meta content='@linuxuprising' name='twitter:creator'/>
<style id='page-skin-1' type='text/css'>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</style>
<style id='template-skin-1' type='text/css'><!--
/*------Layout (No Edit)----------*/
body#layout .row {width: 900px;}
body#layout #outer-wrapper{padding:0;width:900px}
body#layout .section h4{color:#333!important}
body#layout .theme-opt{overflow:hidden;     display: block!important;}
body#layout #option{overflow:hidden; display:block}
body#layout #option h4{font-size:16px;padding:4px 0 7px}
body#layout #option .widget{float:left;width:20%}
body#layout #option .widget.locked-widget .widget-content{background-color: #ff7575 !important;
border-color: #840000 !important;
color: #fff !important;}
body#layout #option .widget.locked-widget .widget-content a.editlink{color:#fff!important;border:1px solid;border-radius:2px;padding:2px 5px}
body#layout #topnav,body#layout .tm-head{height:auto}
body#layout .tm-menu{margin:0;width:70%}
body#layout .social-area{margin:0;width:30%}
body#layout .header-content,body#layout #header-blog{height:160px}
body#layout .header-logo{float:left;width:30%;margin:0;padding:0}
body#layout .header-ads{width:70%;margin:0}
body#layout .header-menu li.home-child{display:none}
body#layout .header-search,body#layout .m-rec{display:none}
body#layout .header-menu{float:left;width:100%;margin:4px 0 0;padding:0}
body#layout #content-wrapper{margin:0 auto}
body#layout .feat-layout .widget-content,body#layout .feat-layout h2.title,body#layout #ads-blog{display:block}
body#layout #main-wrapper{float:left;width:70%;margin:0;padding:0}
body#layout #ads-post10{display:block}
body#layout .sidebar-wrapper{float:right;width:30%;margin:0;padding:0}
body#layout #footer-wrapper{overflow:hidden}
body#layout .sect-left{width:28.3%;float:left}
body#layout #social-footer{width:30%;float:right}
/*------Layout (end)----------*/
--></style>
<style type='text/css'>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</style>
<script async='async' src='//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js'></script>
<script>
if (window.innerWidth < 1000) {
     (adsbygoogle = window.adsbygoogle || []).push({
          google_ad_client: "ca-pub-1997822342415050",
          enable_page_level_ads: true
     });
}    
</script>
<script src='https://ajax.googleapis.com/ajax/libs/jquery/2.2.4/jquery.min.js' type='text/javascript'></script>
<script type='text/javascript'>
//<![CDATA[
$(document).ready(function() {
    var dimension = 150;
    $('#PopularPosts1,#PopularPosts2,#PopularPosts3').find('img').each(function(n, image) {
        var image = $(image);
        image.attr({
            src: image.attr('src').replace(/s72-c/, 's' + dimension)
        })
    })
});

//]]>
</script>
<script type='text/javascript'> 
//<![CDATA[
var text_month = [, "Jan", "Feb", "Mar", "Apr", "May", "Jun", "Jul", "Aug", "Sept", "Oct", "Nov", "Dec"];
var no_image_url = "https://1.bp.blogspot.com/-dUVHHKr63sw/WrjkLAm4OkI/AAAAAAAAABU/SNBN1gIB8E0vLNWf41AGwudNCH1Q9hYYwCLcBGAs/s1600-r/nothumb.jpg";
var feat1_number = 3;
var related_number = 3;

// Plugin: Sticky jQuery ~ BY: https://stickyjs.com
(function(e){var t={topSpacing:0,bottomSpacing:0,className:"is-sticky",wrapperClassName:"sticky-wrapper",center:false,getWidthFrom:"",responsiveWidth:false},n=e(window),r=e(document),i=[],s=n.height(),o=function(){var t=n.scrollTop(),o=r.height(),u=o-s,a=t>u?u-t:0;for(var f=0;f<i.length;f++){var l=i[f],c=l.stickyWrapper.offset().top,h=c-l.topSpacing-a;if(t<=h){if(l.currentTop!==null){l.stickyElement.css("width","").css("position","").css("top","");l.stickyElement.trigger("sticky-end",[l]).parent().removeClass(l.className);l.currentTop=null}}else{var p=o-l.stickyElement.outerHeight()-l.topSpacing-l.bottomSpacing-t-a;if(p<0){p=p+l.topSpacing}else{p=l.topSpacing}if(l.currentTop!=p){l.stickyElement.css("width",l.stickyElement.width()).css("position","fixed").css("top",p);if(typeof l.getWidthFrom!=="undefined"){l.stickyElement.css("width",e(l.getWidthFrom).width())}l.stickyElement.trigger("sticky-start",[l]).parent().addClass(l.className);l.currentTop=p}}}},u=function(){s=n.height();for(var t=0;t<i.length;t++){var r=i[t];if(typeof r.getWidthFrom!=="undefined"&&r.responsiveWidth===true){r.stickyElement.css("width",e(r.getWidthFrom).width())}}},a={init:function(n){var r=e.extend({},t,n);return this.each(function(){var n=e(this);var s=n.attr("id");var o=s?s+"-"+t.wrapperClassName:t.wrapperClassName;var u=e("<div></div>").attr("id",s+"-sticky-wrapper").addClass(r.wrapperClassName);n.wrapAll(u);if(r.center){n.parent().css({width:n.outerWidth(),marginLeft:"auto",marginRight:"auto"})}if(n.css("float")=="right"){n.css({"float":"none"}).parent().css({"float":"right"})}var a=n.parent();a.css("height",n.outerHeight());i.push({topSpacing:r.topSpacing,bottomSpacing:r.bottomSpacing,stickyElement:n,currentTop:null,stickyWrapper:a,className:r.className,getWidthFrom:r.getWidthFrom,responsiveWidth:r.responsiveWidth})})},update:o,unstick:function(t){return this.each(function(){var t=e(this);var n=-1;for(var r=0;r<i.length;r++){if(i[r].stickyElement.get(0)==t.get(0)){n=r}}if(n!=-1){i.splice(n,1);t.unwrap();t.removeAttr("style")}})}};if(window.addEventListener){window.addEventListener("scroll",o,false);window.addEventListener("resize",u,false)}else if(window.attachEvent){window.attachEvent("onscroll",o);window.attachEvent("onresize",u)}e.fn.sticky=function(t){if(a[t]){return a[t].apply(this,Array.prototype.slice.call(arguments,1))}else if(typeof t==="object"||!t){return a.init.apply(this,arguments)}else{e.error("Method "+t+" does not exist on jQuery.sticky")}};e.fn.unstick=function(t){if(a[t]){return a[t].apply(this,Array.prototype.slice.call(arguments,1))}else if(typeof t==="object"||!t){return a.unstick.apply(this,arguments)}else{e.error("Method "+t+" does not exist on jQuery.sticky")}};e(function(){setTimeout(o,0)})})(jQuery);
//]]>
</script>
<!-- Google Analytics -->
<script type='text/javascript'>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');
  ga('create', 'UA-116578392-1', 'auto');
  ga('require', 'displayfeatures');
  ga('set', 'anonymizeIp', true);
  ga('send', 'pageview');
</script>
<script>
  WebFontConfig = {
    google: {
      families: ['Ubuntu:300,300i,400,500,700']
      }
    };
   (function(d) {
      var wf = d.createElement('script'), s = d.scripts[0];
      wf.src = 'https://ajax.googleapis.com/ajax/libs/webfont/1.6.26/webfont.js';
      wf.async = true;
      s.parentNode.insertBefore(wf, s);
   })(document);  
</script>
<script type='text/javascript'>
function getCookie(name) {
    var nameEQ = name + "=";
    var ca = document.cookie.split(';');
    for(var i=0;i < ca.length;i++) {
        var c = ca[i];
        while (c.charAt(0)==' ') c = c.substring(1,c.length);
        if (c.indexOf(nameEQ) == 0) return c.substring(nameEQ.length,c.length);
    }
    return null;
}    
var x = getCookie('displayCookieNotice');
if (x) {
    (adsbygoogle=window.adsbygoogle||[]).requestNonPersonalizedAds=0;
}
</script>
<!-- START Custom EU Cookies Notice -->
<script type='text/javascript'> 
  cookieOptions = { 
    msg: "This site is hosted on Google Blogger and uses cookies from Google to deliver its services, to serve and personalize ads, and to analyze traffic. Your IP address and user-agent are shared with Google along with performance and security metrics to ensure quality of service, generate usage statistics, and to detect and address abuse.", 
    close: "Ok", 
    learn: "Learn More" }; 
</script>
<!-- END Custom EU Cookies Notice -->
<link href='https://www.blogger.com/dyn-css/authorization.css?targetBlogID=852161773840707483&amp;zx=c0f82f5e-0ab4-4394-9e31-432b7ecb0a63' media='none' onload='if(media!=&#39;all&#39;)media=&#39;all&#39;' rel='stylesheet'/><noscript><link href='https://www.blogger.com/dyn-css/authorization.css?targetBlogID=852161773840707483&amp;zx=c0f82f5e-0ab4-4394-9e31-432b7ecb0a63' rel='stylesheet'/></noscript>

</head>
<body class='item'>
<div class='theme-opt' style='display:none'>
<div class='option section' id='option' name='Theme Option'><div class='widget HTML' data-version='1' id='HTML103'>

<script type='text/javascript'> 
          //<![CDATA[
          var recentposts_number = 5;
          //]]>
         </script>
         
</div><div class='widget HTML' data-version='1' id='HTML104'>
<script type='text/javascript'> 
          //<![CDATA[
          var randomposts_number = 4;
          //]]>
         </script>
</div><div class='widget HTML' data-version='1' id='HTML105'>

         <script type='text/javascript'>
          var postperpage=10;
         </script>
         
</div><div class='widget HTML' data-version='1' id='HTML106'>

         <script type='text/javascript'>
//<![CDATA[
$(window).bind("load",function(){$('.Label a,.postags a,.m-rec h2 a,.breadcrumbs span a,.label-head a,.feat-title h2 a').each(function(){var labelPage=$(this).attr('href');$(this).attr('href',labelPage+'?&max-results=8')})});
 //]]>
</script>
         
</div><div class='widget HTML' data-version='1' id='HTML851'>
<script type='text/javascript'> 
            //<![CDATA[
            // Plugin: Sticky jQuery ~ BY: https://stickyjs.com
            (function(e){var t={topSpacing:0,bottomSpacing:0,className:"is-sticky",wrapperClassName:"sticky-wrapper",center:false,getWidthFrom:"",responsiveWidth:false},n=e(window),r=e(document),i=[],s=n.height(),o=function(){var t=n.scrollTop(),o=r.height(),u=o-s,a=t>u?u-t:0;for(var f=0;f<i.length;f++){var l=i[f],c=l.stickyWrapper.offset().top,h=c-l.topSpacing-a;if(t<=h){if(l.currentTop!==null){l.stickyElement.css("width","").css("position","").css("top","");l.stickyElement.trigger("sticky-end",[l]).parent().removeClass(l.className);l.currentTop=null}}else{var p=o-l.stickyElement.outerHeight()-l.topSpacing-l.bottomSpacing-t-a;if(p<0){p=p+l.topSpacing}else{p=l.topSpacing}if(l.currentTop!=p){l.stickyElement.css("width",l.stickyElement.width()).css("position","fixed").css("top",p);if(typeof l.getWidthFrom!=="undefined"){l.stickyElement.css("width",e(l.getWidthFrom).width())}l.stickyElement.trigger("sticky-start",[l]).parent().addClass(l.className);l.currentTop=p}}}},u=function(){s=n.height();for(var t=0;t<i.length;t++){var r=i[t];if(typeof r.getWidthFrom!=="undefined"&&r.responsiveWidth===true){r.stickyElement.css("width",e(r.getWidthFrom).width())}}},a={init:function(n){var r=e.extend({},t,n);return this.each(function(){var n=e(this);var s=n.attr("id");var o=s?s+"-"+t.wrapperClassName:t.wrapperClassName;var u=e("<div></div>").attr("id",s+"-sticky-wrapper").addClass(r.wrapperClassName);n.wrapAll(u);if(r.center){n.parent().css({width:n.outerWidth(),marginLeft:"auto",marginRight:"auto"})}if(n.css("float")=="right"){n.css({"float":"none"}).parent().css({"float":"right"})}var a=n.parent();a.css("height",n.outerHeight());i.push({topSpacing:r.topSpacing,bottomSpacing:r.bottomSpacing,stickyElement:n,currentTop:null,stickyWrapper:a,className:r.className,getWidthFrom:r.getWidthFrom,responsiveWidth:r.responsiveWidth})})},update:o,unstick:function(t){return this.each(function(){var t=e(this);var n=-1;for(var r=0;r<i.length;r++){if(i[r].stickyElement.get(0)==t.get(0)){n=r}}if(n!=-1){i.splice(n,1);t.unwrap();t.removeAttr("style")}})}};if(window.addEventListener){window.addEventListener("scroll",o,false);window.addEventListener("resize",u,false)}else if(window.attachEvent){window.attachEvent("onscroll",o);window.attachEvent("onresize",u)}e.fn.sticky=function(t){if(a[t]){return a[t].apply(this,Array.prototype.slice.call(arguments,1))}else if(typeof t==="object"||!t){return a.init.apply(this,arguments)}else{e.error("Method "+t+" does not exist on jQuery.sticky")}};e.fn.unstick=function(t){if(a[t]){return a[t].apply(this,Array.prototype.slice.call(arguments,1))}else if(typeof t==="object"||!t){return a.unstick.apply(this,arguments)}else{e.error("Method "+t+" does not exist on jQuery.sticky")}};e(function(){setTimeout(o,0)})})(jQuery);
            //]]>
          </script>
          <script type='text/javascript'> 
            //<![CDATA[
            var stickyWork = "yes";
            var FstickyWork = stickyWork.replace(/(\r\n|\n|\r)/gm," ");
            if ( FstickyWork === "yes" ) {
              $(document).ready(function(){$("#header-navigation").sticky({topSpacing:0});});
            }
            //]]>
          </script>
        </div></div>
</div>

<div id="pages-wrap" class="item">

<div id='outer-wrapper'>
<div id='topnav'>
<div class='tm-head row'>
<div class='tm-menu'>
<div class='menu1 section' id='menu1' name='Top Navigation'><div class='widget LinkList' data-version='1' id='LinkList210'>
<div class='widget-content'>
<ul id='nav1'>
<li><a href='https://www.linuxuprising.com/p/about.html'>About</a></li>
<li><a href='https://www.linuxuprising.com/p/contact.html'>Contact</a></li>
<li><a href='https://www.reddit.com/r/LinuxUprising/' rel='noreferrer' target='_blank'>Submit A Tip</a></li>
</ul>
</div>
</div></div>
</div>
<!-- Top Social -->
<div class='social-area'>
<div class='social-top section' id='social-top' name='Social Top'><div class='widget LinkList' data-version='1' id='LinkList50'>
<div class='widget-content'>
<ul>
<li><a class='rss' href='https://feeds.feedburner.com/LinuxUprising' rel='noreferrer' target='_blank' title='rss'></a></li>
<li><a class='friendica' href='https://libranet.de/profile/linuxuprising' rel='noreferrer' target='_blank' title='friendica'></a></li>
<li><a class='twitter' href='https://twitter.com/linuxuprising' rel='noreferrer' target='_blank' title='twitter'></a></li>
<li><a class='facebook' href='https://www.facebook.com/LinuxUprising/' rel='noreferrer' target='_blank' title='facebook'></a></li>
<li><a class='reddit' href='https://www.reddit.com/r/LinuxUprising/' rel='noreferrer' target='_blank' title='reddit'></a></li>
</ul>
</div>
</div></div>
</div>
</div>
</div>
<div id='header-blog'>
<div class='header-content row'>
<div class='header-logo'>
<div class='section' id='logo_blog' name='Logo'><div class='widget Header' data-version='1' id='Header1'>
<div id='header-inner'>
<h2 class='logo'>
<a href='https://www.linuxuprising.com/' style='display: block'>
<img alt='Linux Uprising Blog' height='23px; ' id='Header1_headerimg' src='https://cdn.rawgit.com/logix2/6fb43ed0a1979f24c50857fadc6de3ac/raw/24571f5df3fa6fadeeb0937ffd40ea38c380075f/logo2.svg' style='display: block' width='455px; '/>
</a>
<span class='alt-logo'>Linux Uprising blog</span>
</h2>
</div>
</div></div>
</div>
<!-- <div class='header-ads'> <b:section id='ads-content' maxwidgets='1' name='Ads 728x90' showaddelement='yes'> <b:widget id='HTML1' locked='false' title='' type='HTML'> <b:includable id='main'> <b:if cond='data:title != &quot;&quot;'> <h2 class='title'><data:title/></h2> </b:if> <div class='widget-content'> <data:content/> </div> </b:includable> </b:widget> </b:section> </div> -->
</div>
</div>
<nav class='row' id='header-navigation'>
<div class='nav-wrapper'>
<div class='nav-menu'>
<div class='header-search'>
<li>
<a class='search'>
<form action='/search/max-results=10' method='get'>
<input id='s' name='q' placeholder='Type and hit enter...' type='text'/>
</form>
</a>
</li>
</div>
<div class='header-menu'>
<li class='home-child'><a href='https://www.linuxuprising.com/'>Home</a></li>
<div class='menu section' id='menu' name='Main Menu'><div class='widget LinkList' data-version='1' id='LinkList110'>
<div class='widget-content'>
<ul id='nav' itemscope='' itemtype='https://schema.org/SiteNavigationElement'>
<li itemprop='name'><a href='https://www.linuxuprising.com/search/label/news?max-results=10' itemprop='url'>News</a></li>
<li itemprop='name'><a href='https://www.linuxuprising.com/search/label/apps?max-results=10' itemprop='url'>Applications</a></li>
<li itemprop='name'><a href='https://www.linuxuprising.com/search/label/how-to?max-results=10' itemprop='url'>How To</a></li>
<li itemprop='name'><a href='https://www.linuxuprising.com/search/label/tweaks?max-results=10' itemprop='url'>Tweaks</a></li>
<li itemprop='name'><a href='https://www.linuxuprising.com/search/label/customization?max-results=10' itemprop='url'>Themes & More</a></li>
<li itemprop='name'><a href='https://www.linuxuprising.com/search/label/console?max-results=10' itemprop='url'>Console</a></li>
</ul>
<script type='text/javascript'> 
            //<![CDATA[
            $("#LinkList110").each(function(){var e="<ul id='nav'><li><ul id='sub-menu'>";$("#LinkList110 li").each(function(){var t=$(this).text(),n=t.substr(0,1),r=t.substr(1);"_"==n?(n=$(this).find("a").attr("href"),e+='<li><a href="'+n+'">'+r+"</a></li>"):(n=$(this).find("a").attr("href"),e+='</ul></li><li><a href="'+n+'">'+t+"</a><ul id='sub-menu'>")});e+="</ul></li></ul>";$(this).html(e);$("#LinkList110 ul").each(function(){var e=$(this);if(e.html().replace(/\s|&nbsp;/g,"").length==0)e.remove()});$("#LinkList110 li").each(function(){var e=$(this);if(e.html().replace(/\s|&nbsp;/g,"").length==0)e.remove()})});
            //]]>
            </script>
</div>
</div></div>
</div>
</div>
</div>
</nav>
<div class='clear'></div>
<div class='row' id='content-wrapper'>
<div id='main-wrapper'>
<div id='ads-blog'>
<div class='home-ad no-items section' id='ads-home' name='Ads Home/Post (728x90)'>
</div>
</div>
<div class='main section' id='main' name='Main Wrapper'><div class='widget Blog' data-version='1' id='Blog1'>
<div class='blog-posts hfeed'>
<div class='post-outer'>
<div class='post'>

    <div itemprop='blogPost' itemscope='itemscope' itemtype='https://schema.org/Article'>
            <meta content='data:post.link : data:post.url' itemType='https://schema.org/WebPage' itemid='' itemprop='mainEntityOfPage' itemscope='itemscope'/>
<div itemprop='publisher' itemscope='itemscope' itemtype='https://schema.org/Organization'>
<div itemprop='logo' itemscope='itemscope' itemtype='https://schema.org/ImageObject'>
<meta content='https://4.bp.blogspot.com/-OlFvIO7s2mM/WrzEk1hCVZI/AAAAAAAAAE0/H4meMs7XreskNd_mTgVtNREkBX08-O1CACK4BGAYYCw/s590/LUR_logo1.png' itemprop='url'/>
<meta content='455' itemprop='width'/>
<meta content='48' itemprop='height'/>
</div>
<meta content='Linux Uprising Blog' itemprop='name'/>
</div>
<meta content='https://2.bp.blogspot.com/-nzijBlCm9cY/XGq1Ns7X0cI/AAAAAAAACTc/tuD_auOJhxEAs5iTf1nqg0zs8rhXRt8qQCLcBGAs/s640/jumpapp-firefox.png' itemprop='image'/>
<div class='post-header'>
<ins class='adsbygoogle' data-ad-client='ca-pub-1997822342415050' style='display:inline-block;width:728px;height:90px'>
</ins>
<script>
    if (window.innerWidth > 1151) {
      mySlotId = '9211084306';
    } else {
      mySlotId = '5867515603';
    }
    (adsbygoogle = window.adsbygoogle || []).push({
      params: { google_ad_slot: mySlotId }
    });
</script>
<br/><br/>
<div class='post-head'><h1 class='post-title entry-title' itemprop='name headline'>
Run Or Raise Application Windows On Linux (X11) Using A Single Keyboard Shortcut With jumpapp
</h1></div>
<div class='post-meta'>
<span class='post-author vcard'>
<i class='fa fa-user'></i>
<span class='fn' itemprop='author' itemscope='itemscope' itemtype='https://schema.org/Person'>
<meta content='https://www.blogger.com/profile/03026963810377267607' itemprop='url'/>
<a class='g-profile' href='https://www.blogger.com/profile/03026963810377267607' rel='author' title='Logix'>
<span itemprop='name'>Logix</span>
</a>
</span>
</span>
<span class='post-timestamp'>
<i class='fa fa-clock-o'></i>
<meta content='https://www.linuxuprising.com/2019/02/run-or-raise-application-windows-on.html' itemprop='url'/>
          Updated on <a class='timestamp-link' href='https://www.linuxuprising.com/2019/02/run-or-raise-application-windows-on.html' rel='bookmark' title='permanent link'><time class='updated timeago' datetime='2019-02-19T17:01:17Z' title='2019-02-19T17:01:17Z'><span id='updatedateinfo'>2019-02-19T17:01:17Z</span></time></a>
<script>
            var dates = "2019-02-19T17:01:17Z"
            var dateu = new Date(dates);
            var months = ["January","February","March","April","May","June","July","August","September","October","November","December"];
            document.getElementById("updatedateinfo").innerHTML = months[dateu.getMonth()] + " " + dateu.getDate() + ", " + dateu.getFullYear();
        </script>
<meta content='2019-02-19T17:01:17Z' itemprop='dateModified'/>
<meta content='2019-02-18T14:18:00Z' itemprop='datePublished'/>
</span>
<span class='label-head'>
<i class='fa fa-folder-open-o'></i>
<a href='https://www.linuxuprising.com/search/label/apps' rel='tag'>apps</a>,
<a href='https://www.linuxuprising.com/search/label/tweaks' rel='tag'>tweaks</a>,
<a href='https://www.linuxuprising.com/search/label/usability' rel='tag'>usability</a>
</span>
</div>
<div class='ads-posting'>
<a name='ad-post'></a>
</div>
</div>
<article>
<div class='post-body entry-content' id='post-body-887518511597864171' itemprop='articleBody'>
<meta content='jumpapp  is a very fast way of switching between applications or application windows, for X11 Linux desktops.   Using jumpapp you can create...' name='twitter:description'/>
<b><a href="https://github.com/mkropat/jumpapp" rel="noopener" target="_blank">jumpapp</a> is a very fast way of switching between applications or application windows, for X11 Linux desktops.</b><br />
<br />
<b>Using jumpapp you can create a single keyboard shortcut that will launch an application if it's not already running, or focus the application window if it's already running. If there is more than one application window open, pressing the keyboard shortcut repeatedly cycles through all the application windows.</b><br />
<br />
This way you have frequently used applications one keyboard shortcut away, no matter if they are already running or not, on which workspace they are on, etc.<br />
<br />
<div class="separator" style="clear: both; text-align: center;"><a href="https://2.bp.blogspot.com/-nzijBlCm9cY/XGq1Ns7X0cI/AAAAAAAACTc/tuD_auOJhxEAs5iTf1nqg0zs8rhXRt8qQCLcBGAs/s1600/jumpapp-firefox.png" imageanchor="1" style="margin-left: 1em; margin-right: 1em;"><img alt="jumpapp firefox" border="0" data-original-height="777" data-original-width="1041" height="476" src="https://2.bp.blogspot.com/-nzijBlCm9cY/XGq1Ns7X0cI/AAAAAAAACTc/tuD_auOJhxEAs5iTf1nqg0zs8rhXRt8qQCLcBGAs/s640/jumpapp-firefox.png" title="jumpapp firefox" width="640" /></a></div><a name='more'></a><br />
The run-or-raise application switcher makes use of <a href="http://tripie.sweb.cz/utils/wmctrl/" rel="noopener" target="_blank">wmctrl</a>, a command line program that can be used to interact with X Window managers that are compatible with the EWMH/NetWM specification.<br />
<br />
The jumpapp page says that the program was built for the Gnome desktop environment, but "there's a good chance though that it'll work on any window manager supported by wmctrl".&nbsp;wmctrl supports Metacity, KWin, Enlightenment, Fluxbox, Openbox, Xfce, Window Maker, and others.<br />
<br />
While to use jumpapp, all you have to do is assign a keyboard shortcut to <span class="codeblock2"><code>jumpapp application-executable</code></span>, for example <span class="codeblock2"><code>jumpapp chromium-browser</code></span>, <span class="codeblock2"><code>jumpapp firefox</code></span>, and so on, the tool offers some advanced options too. You can specify jumpapp to cycle through open windows in reverse order (<span class="codeblock2"><code>-r</code></span>), always launch COMMAND when ARGs are passed (<span class="codeblock2"><code>-p</code></span>), specify the window using WM_CLASS (<span class="codeblock2"><code>-c</code></span>) or window title (<span class="codeblock2"><code>-t</code></span>) instead of COMMAND, and more.<br />
<br />
You can see all the jumpapp options by running <span class="codeblock2"><code>jumpapp</code></span> without any arguments:<br />
<br />
<pre class="cssterm"><code>$ jumpapp
Usage: jumpapp [OPTION]... COMMAND [ARG]...

Jump to (focus) the first open window for an application, if it's running.
Otherwise, launch COMMAND (with opitonal ARGs) to start the application.

Options:
  -r -- cycle through windows in reverse order
  -f -- force COMMAND to launch if process found but no windows found
  -n -- do not fork into background when launching COMMAND
  -p -- always launch COMMAND when ARGs passed
        (see Argument Passthrough in man page)
  -L -- list matching windows for COMMAND and quit
  -t NAME -- process window has to have NAME as the window title
  -c NAME -- find window using NAME as WM_CLASS (instead of COMMAND)
  -i NAME -- find process using NAME as the command name (instead of COMMAND)
  -w -- only find the applications in the current workspace
  -C -- center cursor when raising application</code></pre><br />
There's also a new option (<span class="codeblock2"><code>-R</code></span>) that has not yet been released (it's not available in the latest release, but it was added in Git), which allows bringing the application to the current workspace when raising the window, instead of switching to the workspace that the application is currently on.<br />
<br />
<h2>Installing and using jumpapp</h2><br />
<div style="text-align: center;"><a href="https://github.com/mkropat/jumpapp/releases" rel="noopener" target="_blank"><input class="install" title="Download jumpapp" type="button" value="Download jumpapp" /></a></div><br />
jumpapp is available for download as a RPM, DEB or as a generic archive that can be installed on any Linux distribution. There are <a href="https://github.com/mkropat/jumpapp#installation" rel="noopener" target="_blank">instructions</a> for how to install the latest version from Git as well.<br />
<br />
To use jumpapp, you'll need to assign a keyboard shortcut for the <span class="codeblock2"><code>jumpapp application-executable</code></span> (use the application executable name instead of "application-executable) command, for each application you want to use with it. For example, use <span class="codeblock2"><code>jumpapp firefox</code></span> for Firefox, <span class="codeblock2"><code>jumpapp chromium-browser</code></span> for Chromium web browser, etc.<br />
<br />
To assign a keyboard shortcut to a command in Gnome, open <span class="codeblock2"><code>System settings</code></span>, go to <span class="codeblock2"><code>Devices -&gt; Keyboard</code></span>, scroll down to <span class="codeblock2"><code>Custom Shortcuts</code></span>, click the <span class="codeblock2"><code>+</code></span> button, and add a new command (<span class="codeblock2"><code>jumpapp application-executable</code></span>). Then assign a keyboard shortcut to this command.<br />
<br />
In case the desktop environment you're using doesn't have a way of biding keyboard shortcuts to commands, you can use XBindKeys as explained <a href="https://github.com/mkropat/jumpapp#xbindkeys" rel="noopener" target="_blank">here</a>.
</div>
</article>
<div style='clear:both'></div>
<div class='post-footer'>
<div class='share-box'>
<h8 class='share-title'>Share This:</h8>
<div class='share-art'>
<a class='fac-art' href='https://www.facebook.com/sharer.php?u=https://www.linuxuprising.com/2019/02/run-or-raise-application-windows-on.html&title=Run Or Raise Application Windows On Linux (X11) Using A Single Keyboard Shortcut With jumpapp' onclick='window.open(this.href, &#39;windowName&#39;, &#39;width=600, height=400, left=24, top=24, scrollbars, resizable&#39;); return false;' rel='nofollow noreferrer' target='_blank'><i class='fa fa-facebook'></i><span class='resp_del'> Facebook</span></a>
<a class='twi-art' href='https://twitter.com/share?url=https://www.linuxuprising.com/2019/02/run-or-raise-application-windows-on.html&title=Run Or Raise Application Windows On Linux (X11) Using A Single Keyboard Shortcut With jumpapp' onclick='window.open(this.href, &#39;windowName&#39;, &#39;width=600, height=400, left=24, top=24, scrollbars, resizable&#39;); return false;' rel='nofollow noreferrer' target='_blank'><i class='fa fa-twitter'></i><span class='resp_del2'> Twitter</span></a>
<a class='dis-art' href='https://sharetodiaspora.github.io/?url=https://www.linuxuprising.com/2019/02/run-or-raise-application-windows-on.html&title=Run Or Raise Application Windows On Linux (X11) Using A Single Keyboard Shortcut With jumpapp' onclick='window.open(this.href, &#39;windowName&#39;, &#39;width=770, height=500, left=24, top=24, scrollbars, resizable&#39;); return false;' rel='nofollow noreferrer' target='_blank'><i class='fa fa-diaspora'></i><span class='resp_del3'> Diaspora</span></a>
<a class='redd-art' href='https://www.reddit.com/submit?url=https://www.linuxuprising.com/2019/02/run-or-raise-application-windows-on.html&title=Run Or Raise Application Windows On Linux (X11) Using A Single Keyboard Shortcut With jumpapp' onclick='window.open(this.href, &#39;windowName&#39;); return false;' rel='nofollow noreferrer' target='_blank'><i class='fa fa-reddit-alien'></i><span class='resp_del4'> Reddit</span></a>
<a class='tel-art' href='https://telegram.me/share/url?url=https://www.linuxuprising.com/2019/02/run-or-raise-application-windows-on.html&tags=&bodytext=jumpapp  is a very fast way of switching between applications or application windows, for X11 Linux desktops.   Using jumpapp you can create...&text=Run Or Raise Application Windows On Linux (X11) Using A Single Keyboard Shortcut With jumpapp' onclick='window.open(this.href, &#39;windowName&#39;, &#39;width=600, height=400, left=24, top=24, scrollbars, resizable&#39;); return false;' rel='nofollow noreferrer' target='_blank'><i class='fa fa-telegram'></i><span class='resp_del5'> Telegram</span></a>
<a class='wat-art' data-action='share/whatsapp/share' href='whatsapp://send?text=Run Or Raise Application Windows On Linux (X11) Using A Single Keyboard Shortcut With jumpapp https://www.linuxuprising.com/2019/02/run-or-raise-application-windows-on.html' onclick='window.open(this.href, &#39;windowName&#39;, &#39;width=600, height=400, left=24, top=24, scrollbars, resizable&#39;); return false;' rel='nofollow noreferrer' target='_blank'><i class='fa fa-whatsapp'></i><span class='resp_del6'> WhatsApp</span></a>
</div>
</div>
<div style='clear:both'></div>
<div class='ads-post'>
<a name='ads-post-in'></a>
</div>
<div id='related-posts'>
usability
</div>
<div class='clear'></div>
<ul class='post-nav'>
<li class='next'>
<a class='newer-link' href='https://www.linuxuprising.com/2019/02/all-in-one-messaging-application-franz.html' id='Blog1_blog-pager-newer-link' rel='next'></a>
</li>
<li class='previous'>
<a class='older-link' href='https://www.linuxuprising.com/2019/02/how-to-install-ubuntu-18042-lts.html' id='Blog1_blog-pager-older-link' rel='previous'></a>
</li>
</ul>
<div class='comment-notif-box'>Please post civil and on-topic comments. <a href='https://www.linuxuprising.com/p/commenting-guidelines.html' rel='nofollow' target='_blank'>Commenting guidelines</a>.</div>
</div>

      </div>
    
</div>
<div class='comments' id='comments'>
<a name='comments'></a>
<h4>No comments:</h4>
<div id='Blog1_comments-block-wrapper'>
<dl class='avatar-comment-indent' id='comments-block'>
</dl>
</div>
<p class='comment-footer'>
<div class='comment-form'>
<a name='comment-form'></a>
<p>
</p>
<a href='https://www.blogger.com/comment-iframe.g?blogID=852161773840707483&postID=887518511597864171' id='comment-editor-src'></a>
<iframe allowtransparency='true' class='blogger-iframe-colorize blogger-comment-from-post' frameborder='0' height='410' id='comment-editor' name='comment-editor' src='' width='100%'></iframe>
<!--Can't find substitution for tag [post.friendConnectJs]-->
<script src='https://www.blogger.com/static/v1/jsbin/55386745-comment_from_post_iframe.js' type='text/javascript'></script>
<script type='text/javascript'>
      BLOG_CMT_createIframe('https://www.blogger.com/rpc_relay.html');
    </script>
</div>
</p>
<div id='backlinks-container'>
<div id='Blog1_backlinks-container'>
</div>
</div>
</div>
</div>
</div>
<div class='post-feeds'>
<div class='feed-links'>
Subscribe to:
<a class='feed-link' href='https://www.linuxuprising.com/feeds/887518511597864171/comments/default' target='_blank' type='application/atom+xml'>
Post Comments
                      (
                      Atom
                      )
                    </a>
</div>
</div>
</div></div>
<div id='ads-post10'>
<div class='no-items section' id='ads-post-468' name='ADS Inner Footer 728x90'>
</div>
</div>
</div>
<div class='sidebar-wrapper'>
<div class='sidebar section' id='sidebar' name='Sidebar Right'><div class='widget HTML' data-version='1' id='HTML1'>
<div class='widget-content'>
<div class="imagehere"><!-- Top Right Sidebar 300x250 -->
<ins class="adsbygoogle"
     style="display:inline-block;width:300px;height:250px"
     data-ad-client="ca-pub-1997822342415050"
     data-ad-slot="8358301820"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div>

<script type="text/javascript">
//<![CDATA[
$(window).load(function(){null==document.getElementsByTagName("iframe").item(ga.length-1)&&$("div.imagehere").html("<div style='text-align:center'><a href='https://amzn.to/2Qyew5i' target='_blank' rel='nofollow noopener'><img src='https://3.bp.blogspot.com/-zWPgBNpIKn8/XBOiILjFb-I/AAAAAAAACDg/qWl3jhp--CcOcHxyc9Y9YSmXvgq_LO6IQCLcBGAs/s1600/chromecast-logo-small.png' alt='Chromecast 3rd gen'/></a><br/></div>")});
//]]> 
</script>
</div>
</div><div class='widget HTML' data-version='1' id='HTML2'>
<h2 class='title'>Recent Posts</h2>
<div id='RecentPosts'>
<div class='widget-content'>
recentposts
</div>
</div>
</div><div class='widget HTML' data-version='1' id='HTML3'>
<div class='widget-content'>
<!-- Sidebar right 300x600 -->
<ins class="adsbygoogle"
     style="display:inline-block;width:300px;height:600px"
     data-ad-client="ca-pub-1997822342415050"
     data-ad-slot="6174183113"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
</div><div class='widget PopularPosts' data-version='1' id='PopularPosts2'>
<h2>Popular This Week</h2>
<div class='widget-content popular-posts'>
<ul>
<li>
<div class='item-thumbnail-only'>
<div class='item-thumbnail'>
<a href='https://www.linuxuprising.com/2019/02/nautilus-exif-pdf-and-audio-metadata.html' target='_blank'>
<img alt='Nautilus Exif, PDF And Audio Metadata Tag Columns Extension For Ubuntu' border='0' height='72' src='https://3.bp.blogspot.com/-DtgTcLxDaPI/XGK6qmEK4jI/AAAAAAAACRM/FQTSV0D2EfchaEZOyhsJcCyGt2TrOpiJgCLcBGAs/s72-c/nautilus-media-columns.png' width='72'/>
</a>
</div>
<div class='item-title'><a href='https://www.linuxuprising.com/2019/02/nautilus-exif-pdf-and-audio-metadata.html'>Nautilus Exif, PDF And Audio Metadata Tag Columns Extension For Ubuntu</a></div>
</div>
<div style='clear: both;'></div>
</li>
<li>
<div class='item-thumbnail-only'>
<div class='item-thumbnail'>
<a href='https://www.linuxuprising.com/2018/10/encrypted-evernote-alternative-turtl.html' target='_blank'>
<img alt='Encrypted Evernote Alternative Turtl v0.7 Includes Rewritten Server, New Spaces Feature' border='0' height='72' src='https://4.bp.blogspot.com/-q25oTcBgCTw/W73RTWTIOVI/AAAAAAAABmY/ij4jsbmTGQoNcLw8YFUhjIRWXF9cPHIGACLcBGAs/s72-c/turtl-desktop-application.png' width='72'/>
</a>
</div>
<div class='item-title'><a href='https://www.linuxuprising.com/2018/10/encrypted-evernote-alternative-turtl.html'>Encrypted Evernote Alternative Turtl v0.7 Includes Rewritten Server, New Spaces Feature</a></div>
</div>
<div style='clear: both;'></div>
</li>
<li>
<div class='item-thumbnail-only'>
<div class='item-thumbnail'>
<a href='https://www.linuxuprising.com/2019/02/run-or-raise-application-windows-on.html' target='_blank'>
<img alt='Run Or Raise Application Windows On Linux (X11) Using A Single Keyboard Shortcut With jumpapp' border='0' height='72' src='https://2.bp.blogspot.com/-nzijBlCm9cY/XGq1Ns7X0cI/AAAAAAAACTc/tuD_auOJhxEAs5iTf1nqg0zs8rhXRt8qQCLcBGAs/s72-c/jumpapp-firefox.png' width='72'/>
</a>
</div>
<div class='item-title'><a href='https://www.linuxuprising.com/2019/02/run-or-raise-application-windows-on.html'>Run Or Raise Application Windows On Linux (X11) Using A Single Keyboard Shortcut With jumpapp</a></div>
</div>
<div style='clear: both;'></div>
</li>
</ul>
</div>
</div><div class='widget ContactForm' data-version='1' id='ContactForm1'>
<h2 class='title'>Contact Form</h2>
<div class='contact-form-widget'>
<div class='form'>
<form name='contact-form'>
<p></p>
Name
<br/>
<input class='contact-form-name' id='ContactForm1_contact-form-name' name='name' size='30' type='text' value=''/>
<p></p>
Email
<span style='font-weight: bolder;'>*</span>
<br/>
<input class='contact-form-email' id='ContactForm1_contact-form-email' name='email' size='30' type='text' value=''/>
<p></p>
Message
<span style='font-weight: bolder;'>*</span>
<br/>
<textarea class='contact-form-email-message' cols='25' id='ContactForm1_contact-form-email-message' name='email-message' rows='5'></textarea>
<p></p>
<input class='contact-form-button contact-form-button-submit' id='ContactForm1_contact-form-submit' type='button' value='Send'/>
<p></p>
<div style='text-align: center; max-width: 222px; width: 100%'>
<p class='contact-form-error-message' id='ContactForm1_contact-form-error-message'></p>
<p class='contact-form-success-message' id='ContactForm1_contact-form-success-message'></p>
</div>
</form>
</div>
</div>
</div><div class='widget LinkList' data-version='1' id='LinkList2'>
<h2>Editor's Picks</h2>
<div class='widget-content'>
<ul>
<li><a href='https://www.linuxuprising.com/2018/06/cryptomator-secures-your-cloud-storage.html'>Cryptomator Secures Your Cloud Storage Data (Open Source, Multi-Platform Client-Side Encryption Tool)</a></li>
<li><a href='https://www.linuxuprising.com/2018/07/bootiso-easy-iso-to-bootable-usb-drive.html'>bootiso: Easy ISO To Bootable USB Drive From The Command Line</a></li>
<li><a href='https://www.linuxuprising.com/2018/05/bitwarden-secure-open-source-password.html'>Bitwarden: The Secure, Open Source Password Manager You're Looking For</a></li>
<li><a href='https://www.linuxuprising.com/2018/04/top-things-to-do-after-installing.html'>Top Things To Do After Installing Ubuntu 18.04 Bionic Beaver To Make It Your Own</a></li>
<li><a href='https://www.linuxuprising.com/2018/04/integrate-your-android-phone-with-gnome.html'>Integrate Your Android Phone With Gnome Shell Without KDE Dependencies With GSConnect</a></li>
<li><a href='https://www.linuxuprising.com/2018/10/how-to-install-oracle-java-11-in-ubuntu.html'>How To Install Oracle Java 11 In Ubuntu, Linux Mint Or Debian (From PPA Repository)</a></li>
</ul>
</div>
</div>
</div>
</div>
<div class='clear'></div>
</div>
<!-- end content-wrapper -->
<div class='clear'></div><!-- Footer wrapper -->
<div id='footer-wrapper'>
<div id='footer'>
<div class='footer-sections row'>
<div class='sect-left section' id='footer-sec1' name='Widget 1'><div class='widget LinkList' data-version='1' id='LinkList1'>
<h2>Linux Uprising</h2>
<div class='widget-content'>
<ul>
<li><a href='https://www.linuxuprising.com/p/contact.html'>Contact</a></li>
<li><a href='https://www.linuxuprising.com/p/about.html'>About</a></li>
<li><a href='https://www.linuxuprising.com/p/terms-of-use.html'>Terms of Service</a></li>
<li><a href='https://www.linuxuprising.com/p/cookie-policy.html'>Cookie Information</a></li>
<li><a href='https://www.linuxuprising.com/p/privacy-policy.html'>Privacy Policy</a></li>
</ul>
</div>
</div></div>
<div class='sect-left section' id='footer-sec2' name='Widget 2'><div class='widget FollowByEmail' data-version='1' id='FollowByEmail1'>
<h2 class='title'>Follow by Email</h2>
<div class='widget-content'>
<div class='follow-by-email-inner'>
<form action='https://feedburner.google.com/fb/a/mailverify' method='post' onsubmit='window.open("https://feedburner.google.com/fb/a/mailverify?uri=LinuxUprising", "popupwindow", "scrollbars=yes,width=550,height=520"); return true' target='popupwindow'>
<table width='100%'>
<tr>
<td>
<input class='follow-by-email-address' name='email' placeholder='Email address...' type='text'/>
</td>
<td width='64px'>
<input class='follow-by-email-submit' type='submit' value='Submit'/>
</td>
</tr>
</table>
<input name='uri' type='hidden' value='LinuxUprising'/>
<input name='loc' type='hidden' value='en_US'/>
</form>
</div>
</div>
<span class='item-control blog-admin'>
</span>
</div></div>
<div class='sect-left section' id='footer-sec3' name='Widget 3'><div class='widget BlogArchive' data-version='1' id='BlogArchive2'>
<h2>Blog Archive</h2>
<div class='widget-content'>
<div id='ArchiveList'>
<div id='BlogArchive2_ArchiveList'>
<select id='BlogArchive2_ArchiveMenu'>
<option value=''>Blog Archive</option>
<option value='https://www.linuxuprising.com/2019/02/'>February 2019 (11)</option>
<option value='https://www.linuxuprising.com/2019/01/'>January 2019 (21)</option>
<option value='https://www.linuxuprising.com/2018/12/'>December 2018 (15)</option>
<option value='https://www.linuxuprising.com/2018/11/'>November 2018 (24)</option>
<option value='https://www.linuxuprising.com/2018/10/'>October 2018 (22)</option>
<option value='https://www.linuxuprising.com/2018/09/'>September 2018 (15)</option>
<option value='https://www.linuxuprising.com/2018/08/'>August 2018 (27)</option>
<option value='https://www.linuxuprising.com/2018/07/'>July 2018 (26)</option>
<option value='https://www.linuxuprising.com/2018/06/'>June 2018 (21)</option>
<option value='https://www.linuxuprising.com/2018/05/'>May 2018 (31)</option>
<option value='https://www.linuxuprising.com/2018/04/'>April 2018 (25)</option>
<option value='https://www.linuxuprising.com/2018/03/'>March 2018 (1)</option>
</select>
</div>
</div>
</div>
</div></div>
</div>
</div>
<div class='clear'></div>
<div class='footer-wrapper'>
<div class='footer-sec row'>
<!-- Footer Social -->
<div class='social-footer section' id='social-footer' name='Social Footer'><div class='widget LinkList' data-version='1' id='LinkList20'>
<div class='widget-content'>
<ul>
<li><a class='rss' href='https://feeds.feedburner.com/LinuxUprising' rel='noreferrer' target='_blank' title='rss'></a></li>
<li><a class='friendica' href='https://libranet.de/profile/linuxuprising' rel='noreferrer' target='_blank' title='friendica'></a></li>
<li><a class='twitter' href='https://twitter.com/linuxuprising' rel='noreferrer' target='_blank' title='twitter'></a></li>
<li><a class='facebook' href='https://www.facebook.com/LinuxUprising/' rel='noreferrer' target='_blank' title='facebook'></a></li>
<li><a class='reddit' href='https://www.reddit.com/r/LinuxUprising/' rel='noreferrer' target='_blank' title='reddit'></a></li>
</ul>
</div>
</div></div>
<!-- Footer Copyright -->
<div class='copyright'>
License: <a href='https://creativecommons.org/licenses/by-nc/4.0/' rel='license nofollow noreferrer' target='_blank'><img alt='Creative Commons License' src='https://2.bp.blogspot.com/-Rhy820PBJuo/W1By3G0kprI/AAAAAAAABOQ/Mm8Nu4jfO0svAY0mqEzPl9MyaI9rgndUwCLcBGAs/s1600/license.png' style='margin-bottom:-3px;'/></a>
<a href='https://www.linuxuprising.com'>Linux Uprising</a>. <br/>The registered trademark Linux&#174; is used pursuant to a sublicense from the Linux Foundation, the exclusive licensee of Linus Torvalds, owner of the mark on a world&#173;wide basis.
</div>
</div>
</div>
</div>
<script type='text/javascript'>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</script>
<script type='text/javascript'>
    (function() {
        var css = document.createElement('link');
        css.href = '//cdn.jsdelivr.net/npm/fork-awesome@1.1.3/css/fork-awesome.min.css';
        css.rel = 'stylesheet';
        css.type = 'text/css';
        document.getElementsByTagName('head')[0].appendChild(css);
    })();
</script>
</div>
<div class='back-to-top'>
<a href='#' id='back-to-top' title='back to top'>
<i class='fa fa-long-arrow-up'></i>
</a>
</div>

<script type="text/javascript" src="https://www.blogger.com/static/v1/widgets/3915142185-widgets.js"></script>
<script type='text/javascript'>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</script>
</body>
</html>